Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

"boot0:error" when trying to boot from HDD

3 posts in this topic

Recommended Posts

hey guys,
I have a dell XPS L421X with windows 7 (legacy BIOS no UEFI)
I followed this guide pretty much exactly
and did a manual patch for the MBR found here to allow me to dual boot windows 7 and OSX on the same hard drive (different partitions). I did the install with myHack as outlined in in the guide and I'm using the supplied config files for chameleon bootloader.
Everything went well with the install and it works fantastic except I cant get Chameleon to load without the USB. 
When I try, all I get is "boot0:error" none of the extra junk that is commonly seen, strictly "boot0:error" and nothing more
I've tried the fix for 4k sectors and the other common fix outlined on MacBreaker: http://www.macbreaker.com/2012/02/hackintosh-boot0-error.html
both are of no avail to me. The only way I can get to windows is if I boot off the "Recovery" partition by using chameleon on the USB stick.
Intel Core i7-3687U @ 2.10GHz
Ivy Bridge Chipset
Intel HM77 Southbridge
RAM : 4GB DDR3-1333 (1X4) (Changed for a 8GB module)
Video : NVIDIA GeForce 630M, Intel HD Graphics
WDC [blue] WD5000LPVX-7 500GB
For more specs than you need to know see here:
with that said, any feedback would be greatly appreciated! Thanks guys

Share this post

Link to post
Share on other sites

Your bootloader makes problems ...

Share this post

Link to post
Share on other sites

I have had luck using the myFix option in myHack to fix boot0 errors.  I have never tried it on a hard drive with both windows and OSX installed.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.