Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Help me to install Mac OS X 10.8 on ASUS N56JR

5 posts in this topic

Recommended Posts

Hi all! I made this new thread to get helped trought the installation of Mac Os X 10.8 (iNiresh) on my laptop. Here's some specs:


Asus N56JR-4023p

Intel Core i7 4700HQ

8 GB of ram

750GB hdd

Nvidia Geforce GTX760M (2gb vram)

Atheros Wireless Chip (with bluetooth)


Notes: I have Secure Boot enabled and UEFI bootloader. I Installed Windows 8.1. 


I'd like to triple boot Ubuntu 13.10-Mac Os X 10.8-Windows 8.1.... without losing windows data! 


Can you help me? Or just link me to some guides? Thanks!

Share this post

Link to post
Share on other sites

the page you linked is related to Mac Os X 10.9 (mavericks) but i'd like to install 10.8 since i already have Niresh OS X dvd. You helped me some months ago to install it on another laptop. Can you help me again, with my new laptop? 


I don't need Nvidia GTX working, just Intel HD graphics 4000!

Share this post

Link to post
Share on other sites



the problem  related  in that topic is the same ..


but if u install the system .. the hd 4000 is u minor problem..


so install the system.. and after we talk about the pos installation


good hack

Share this post

Link to post
Share on other sites

I too have n56jr. I have managed to install 10.9.0 (and upgrade to 10.9.2) but only with chameleon not with clover uefi. Also, I use a patched Haswell kernel. To boot the installer I had to delete all NV*.kext from the /S/L/E of the install usb.


Got working: touch pad, ehernet/Apple store (RealtekRTL8111), keyboard,audio (VoodooHDA),display in VGA mode (i had to remove all AppleIntelHD3/4/5*.kext  and NV*.kext to be able to boot).


Not working: AirPort (got Intel Dual Band Wireless-N 7260 buried somewhere deep in the laptop chassis), Intel Graphics HD 4600M (and of course GeForce GTX 760M).


What has to be done:

1. Boot and install OS X with Clover UEFI (I want a dual boot laptop). So far, clover fails at loading graphics - seams like it is trying lo load NVidia kexts no matter what is in config.plist. I have tried to create a DSDT of n56jr using all available tools and methods but the extracted ACPI file fails to compile (there is a sequence of zeros in the file).

2. Enable integrated graphics HD 4600M (80860416) as stated above i cannot patch it in DSDT only tried boot option IGPlatformID.


Any guru help will be appreciated.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.