Jump to content
distro

The pursuit for the fastest virtual machine

1 post in this topic

Recommended Posts

I recently embarked on a mission to set up the fastest virtual machine possible (OS X Mavericks running on Windows 8.1). I think I'm almost there.

 

Note: This is not at all about hardware. My mission is simply to remove all bottlenecks.

 

Background

 

I wanted a Hackintosh. But I have a Dell Latitude E4310 with a BCM4313, a WiFi card which is not compatible with OS X, so I set out to run the OS in a virtual machine

 

Software

I'm using VMware Workstation 10, though Player 6 will probably also work, running on Windows 8.1 x64

 

Hardware

Dell Latitude E4310, with Intel i5 processor and Intel HD Graphics (1st generation). 4GB RAM. 150GB WD Scorpio Black 7200RPM.

 

Initial bottlenecks & issues

  • Disk
  • Graphics
  • Network
  • RAM

Bottlenecks removed

  • Disk
  • Network

Bottlenecks almost removed

  • Graphics
  • RAM

 

Process

 

Hardware & host

First off, disk. Using a virtual disk was probably the largest bottleneck in the initial setup, so I knew I had to find another way. After some searching, this has been completely solved. Here's how.

 

  1. Create a partition on the hard drive. Mine is 38GB.
  2. Add this physical partition to the VM
  3. Edit the VMDK file. Remove all extent descriptions except the correct partition. Remove all of the UUID stuff. At the top, change createType to "fullDevice".

    Here's my VMDK file:
    # Disk DescriptorFile
    version=1
    encoding="windows-1252"
    CID=4752fba3
    parentCID=ffffffff
    isNativeSnapshot="no"
    createType="fullDevice"
    
    # Extent description
    RW 79687680 FLAT "\\.\PhysicalDrive0" 211916800
    
    # The Disk Data Base 
    #DDB
    
    ddb.adapterType = "ide"
    ddb.geometry.biosCylinders = "1024"
    ddb.geometry.biosHeads = "255"
    ddb.geometry.biosSectors = "63"
    ddb.geometry.cylinders = "16383"
    ddb.geometry.heads = "16"
    ddb.geometry.sectors = "63"
    ddb.longContentID = "00ccb28b97ee4e6bd3d16fec4752fba3"
    ddb.toolsVersion = "9409"
    ddb.uuid = "60 00 C2 93 91 9e 74 ec-87 2e a4 eb c3 51 f9 db"
    ddb.virtualHWVersion = "10"

Network was easier. I use NAT since Bridged didn't always work for me. There shouldn't be any issues here.

 

RAM shouldn't be too much of an issue. Just don't run anything other than VMware. I run my VM with 2.5GB, and it seems to work okay (I can run Chrome with a few tabs while running Activity Monitor, iTerm2, and Sublime Text).

 

Software & Guest

Time for graphics. Install the latest VMware tools and the awesome VMsvga2 driver (http://sourceforge.net/projects/vmsvga2/). Big thanks to Zenith432 for that! Set the vram size to 128MB.

 

However, VMware imposes a 128MB limit for vram. I'm trying to find a way around this. Zenith says that VMsvga allocates more video memory when needed, but OS X doesn't recognize this. Graphics performance is still a bit laggy.

 

 

This is meant to be a discussion thread. Post your suggestions!

 

Cheers,

Alfred

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ayeshch
      Me (and many other people) experience eye-ache from new Macbooks (and windows machines).
       
      I have spent two years of trial-and-error and found that installing macOS Mavericks on my MacBook (pro 13 late 2013, Intel Iris 1536 MB) resolves the issue of eye ache completely. (it is believed that newer systems use harsher version of temporal dithering that causes of a certain group of indivisuals eye aches).

      I cannot stay at Mavericks because of software support and security issues, so the only thing is an issue now:

      How can I take drivers from Mavericks and install them on Catalina? (I tried replacing .kext in /System/Library/Extensions with old files but it didn't work).

      It would be so great if possible!

      Thank you
    • By tlac
      Simple steps to create macOS Installer for Vmware on Linux or Windows
       
      This guide describes how you can create a Vmware image (vmdk) for installing macOS in Vmware. Most tutorials about this topic require an ISO installer file that was typically created in macOS or you have to download some preinstalled image file from unknown source. None of them are ideal. But if you follow the steps below, you will not need to access macOS and will use official and trusted sources.
       
      First of all download gibMacOS from here and set up
      https://github.com/corpnewt/gibMacOS
        Run the script to download the full macOS installer:
      on Linux: gibMacOS.command on Windows: gibMacOS.bat  
      Install qemu-img converter

      on Linux (Debian or Ubuntu):
      install qemu-tools package

      on Windows use this installer:
      https://qemu.weilnetz.de/w64/
      when you run the installer, it is enough to select the "tools" and "dll library".
       
      Convert the downloaded BaseSystem.dmg to Vmware image
      run the following commmand in that directory where BaseSystem.dmg was downloaded (somewhere here: gibMacOS-master/macOS Downloads/publicrelease/061-44387 - 10.15.3 macOS Catalina)
      on Linux:
      qemu-img convert -O vmdk -o compat6 BaseSystem.dmg recovery.vmdk on Windows:
      c:\"Program Files"\qemu\qemu-img convert -O vmdk -o compat6 BaseSystem.dmg recovery.vmdk  
      Use the previously created image to install macOS in Vmware
       
      I assume you have a patched and working Vmware already. If not, find another guide but in nutshell:
      - confirm the VT-x is supported on your Intel machine (if you are on AMD you may not able to virtualize macOS or you need to do more work)
      - install VMware Workstation or VMware Workstation Player (free for non-commercial use)
      - use an unlocker to patch the Vmware to support macOS guest
       currently this works well: https://github.com/BDisp/unlocker/
       
      So when you are here you have a patched Vmware and a Vmware image (recovery.vmdk).
      Run Vmware and create a new virtual machine by choosing macOS guest. But add another hard disk as well with selecting to use an existing virtual disk. Browse the recovery.vmdk. You will get a warning about the image is not in the latest format but choose to keep the existing format.
      After you installed the macOS, install the vmware tools as well.
       
      Tested on Windows 10 with macOS Catalina 10.15.3 in Vmware 15.5 Player
       
      Comments are welcome.
       
    • By Kaku
      Greetings!
       
      So I managed to get a Catalina 10.15 vm up and running in ESXi 6.7u2.
      When I try to install Catalina updates, however, it goes to the Apple logo, status bar moving ever so slightly, reboots again and this time hangs on the Apple logo.  To fix this, I either remove or disable "Mac OS" as an option in the bootloader. Is there a way to get these updates to install? 
       
      In the meantime...
       
      I instead of restarting Catalina after choosing to update it, I shutdown the guest.  After a restart it SEEMED to update with the time duration countdown.
       
      Prior to this I did run disk utility and checked Untitled and Untitled-Data for errors (I don't think it found any).
       
      So I just logged back onto the VM and the version is still 10.15 and NOT 10.15.2 as hoped. So weird.
       
      Any ideas?
       
    • By Giuseppe Biondo
      Running macOS Catalina in Windows10 with VMware 15.5
      The system runs perfectly with only one very important problem: the display type.
      In my PC is installed an Asus RX580 4GB but the virtual machine runs with a graphic card of 128MB of GPU ram.
      The resolution is OK, but graphic tasks are very slow.
      VMware Tools are installed.
      How can I fix this issue?
×