Jump to content
InsanelyMac Forum
ACDindia

[HELP!] Intel HD4000 OS X 10.9.2 detected but no QE/QC

Recommended Posts

Hello Guys!

 

I have ran into a weird situation here.

 

My DELL 7720 SE laptop had some power problem on the motherboard (as told by the service center guys) which made my system unbootable.

They replaced the motherboard.

 

I brought it home and obviously, tried installing OSX using the Time Machine Backup. It restored correctly.

Used all the same files/ config as earlier but the system couldn't boot up.

 

It boots in safe mode, but no QE/QC.

When I delete the Intel HD4000 Kexts and SNBGraphics etc kexts, the system boots up, again w/o QE/QC!!!     :(

 

Now, what in the world has gone wrong??

I have updated the BIOS to the latest A16.

 

Is the new motherboard different than the earlier one?

Basically, Intel HD4000 is not working.......

 

I am trying get it work on OS X 10.9.2

 

I tried latest Chameleon Bootloader with DSDT=Null and tried all IntelCapriFB=1-11 EnableDualLink=Yes/No, GraphicsEnabler=Yes/No SkipNvidiaGfx=Yes..

 

All except one gave me Black Screen...

IntelCapriFB=4 was the best one as the Intel Graphics was detected correctly with 1024Mb VRAM...but No QE/QC..

 

The graphics is obviously crappy without QE/QC...

 

I checked the loaded KEXTS and found that AGPM is not loading.. FramebufferCapri and HD4000 kexts are loading with IntelCapriFB=4....

 

Also, clover Bootloader is not able to find my Mac volume, yes, i have the HFS related driver in CLover... tried both Vbox and HFSPlus...!!!!!

So using chameleon on the USB as I have windows in UEFI mode with GPT partitioning.

 

The older DSDT worked flawlessly (thanks to Lejenk)

Somehow the same DSDT has stopped working after the swapping of motherboard.....

 
System has Intel HD Graphics 4000 and NVIDIA GT650M in optimus..
CPU is 3rd Gen Intel Core i7 3630QM..
HDD is 1TB partitioned as GPT... with windows 8 installed in UEFI mode...

 

Please help!

Share this post


Link to post
Share on other sites
Advertisement

Hi!

 

The Intel HD 4000 Kext is loading...

Index Refs Address            Size       Wired      Name (Version) <Linked Against>
    1   62 0xffffff7f807e0000 0x8d80     0x8d80     com.apple.kpi.bsd (13.1.0)
    2    6 0xffffff7f80b22000 0x28c0     0x28c0     com.apple.kpi.dsep (13.1.0)
    3   88 0xffffff7f807a9000 0x1dfb0    0x1dfb0    com.apple.kpi.iokit (13.1.0)
    4   93 0xffffff7f807c7000 0xbf40     0xbf40     com.apple.kpi.libkern (13.1.0)
    5   81 0xffffff7f807a6000 0x2d10     0x2d10     com.apple.kpi.mach (13.1.0)
    6   37 0xffffff7f807d3000 0x7d90     0x7d90     com.apple.kpi.private (13.1.0)
    7   55 0xffffff7f807db000 0x48e0     0x48e0     com.apple.kpi.unsupported (13.1.0)
    8    2 0xffffff7f80b28000 0x47000    0x47000    com.apple.kec.corecrypto (1.0) <7 6 5 4 3 1>
    9    0 0xffffff7f80c79000 0xb000     0xb000     com.apple.kec.pthread (1) <7 6 5 4 1>
   10   16 0xffffff7f80c84000 0x9000     0x9000     com.apple.iokit.IOACPIFamily (1.4) <7 6 4 3>
   11   21 0xffffff7f808bb000 0x2f000    0x2f000    com.apple.iokit.IOPCIFamily (2.9) <7 6 5 4 3>
   12    2 0xffffff7f81b15000 0x5c000    0x5c000    com.apple.driver.AppleACPIPlatform (1.3.5) <11 10 7 6 5 4 3>
   13    1 0xffffff7f80e14000 0xb000     0xb000     com.apple.driver.AppleFDEKeyStore (28.30) <8 7 6 5 4 3 1>
   14    1 0xffffff7f810d7000 0x11000    0x11000    com.apple.iokit.IOReportFamily (23) <5 4 3>
   15   11 0xffffff7f807e9000 0x2d000    0x2d000    com.apple.iokit.IOStorageFamily (1.9) <7 6 5 4 3 1>
   16    0 0xffffff7f811b1000 0x1e000    0x1e000    com.apple.driver.DiskImages (371.1) <15 7 6 5 4 3 1>
   17    0 0xffffff7f81845000 0x14000    0x14000    com.apple.driver.AppleKeyStore (2) <8 7 6 5 4 3 1>
   18    0 0xffffff7f819f1000 0x29000    0x29000    com.apple.driver.AppleIntelCPUPowerManagement (196.0.0) <7 6 5 4 3 1>
   19    0 0xffffff7f80b25000 0x3000     0x3000     com.apple.security.TMSafetyNet (7) <7 6 5 4 2 1>
   20    2 0xffffff7f80bc6000 0x5000     0x5000     com.apple.kext.AppleMatch (1.0.0d1) <4 1>
   21    1 0xffffff7f80bcb000 0x14000    0x14000    com.apple.security.sandbox (278.11) <20 7 6 5 4 3 2 1>
   22    0 0xffffff7f80bdf000 0x7000     0x7000     com.apple.security.quarantine (3) <21 20 7 6 5 4 2 1>
   23    0 0xffffff7f81b90000 0x8000     0x8000     com.apple.nke.applicationfirewall (153) <7 6 5 4 3 1>
   24    0 0xffffff7f819ec000 0x3000     0x3000     com.apple.driver.AppleIntelCPUPowerManagementClient (216.0.0) <7 6 5 4 3 1>
   25    0 0xffffff7f81ae9000 0x3000     0x3000     com.apple.driver.AppleAPIC (1.7) <4 3>
   26    0 0xffffff7f81749000 0x4000     0x4000     com.apple.driver.AppleSMBIOS (2.1) <7 4 3>
   27    0 0xffffff7f81a41000 0x3000     0x3000     com.apple.driver.AppleHPET (1.8) <10 7 5 4 3>
   28    0 0xffffff7f817de000 0x3000     0x3000     com.apple.AppleACPIPS2Nub (1.6.1) <10 7 4 3>
   29    5 0xffffff7f80e1f000 0x85000    0x85000    com.apple.iokit.IOHIDFamily (2.0.0) <13 7 6 5 4 3 2 1>
   30    0 0xffffff7f81b7a000 0x4000     0x4000     com.apple.driver.AppleACPIButtons (1.3.5) <29 12 10 7 6 5 4 3 1>
   31    0 0xffffff7f80c8d000 0x7000     0x7000     com.apple.driver.AppleRTC (1111) <10 5 4 3 1>
   32    2 0xffffff7f81069000 0x4000     0x4000     com.apple.iokit.IOSMBusFamily (1.1) <5 4 3>
   33    0 0xffffff7f81b71000 0x6000     0x6000     com.apple.driver.AppleACPIEC (1.3.5) <32 12 10 5 4 3>
   34    0 0xffffff7f81b81000 0x8000     0x8000     com.apple.driver.AppleACPIBatteryManager (1.0.15) <10 5 4 3 1>
   35    0 0xffffff7f813c8000 0xd000     0xd000     org.netkas.FakeSMC (1111) <10 7 5 4 3>
   36    0 0xffffff7f817e4000 0x9000     0x9000     com.apple.driver.ApplePS2Controller (2.0.0) <5 4 3>
   37    1 0xffffff7f81ac4000 0x5000     0x5000     com.apple.driver.AppleEFIRuntime (2.0) <7 6 5 4 3>
   38    0 0xffffff7f81ac9000 0xa000     0xa000     com.apple.driver.AppleEFINVRAM (2.0) <37 7 6 5 4 3>
   39   11 0xffffff7f80be7000 0x6d000    0x6d000    com.apple.iokit.IOUSBFamily (675.4.0) <11 7 5 4 3 1>
   40    0 0xffffff7f813ad000 0x1b000    0x1b000    net.osx86.kexts.GenericUSBXHCI (1.2.7) <39 11 7 5 4 3>
   41    0 0xffffff7f80f31000 0x18000    0x18000    com.apple.driver.AppleUSBEHCI (660.4.0) <39 11 7 5 4 3 1>
   42    3 0xffffff7f8134f000 0x19000    0x19000    com.apple.iokit.IOAHCIFamily (2.6.5) <5 4 3 1>
   43    0 0xffffff7f81aee000 0x1a000    0x1a000    com.apple.driver.AppleAHCIPort (3.0.0) <42 11 5 4 3 1>
   44    0 0xffffff7f80c54000 0x1e000    0x1e000    com.LaCie.driver.PXHCD (1111) <39 11 7 5 4 3>
   45    0 0xffffff7f80eb4000 0x1d000    0x1d000    com.apple.driver.AppleUSBXHCI (670.4.0) <39 11 7 5 4 3 1>
   46    2 0xffffff7f80dbc000 0x34000    0x34000    com.apple.iokit.IONetworkingFamily (3.2) <7 6 5 4 3 1>
   47    0 0xffffff7f81137000 0x1d000    0x1d000    com.apple.driver.AppleRTL8169Ethernet (1.1.4a5) <46 11 5 4 3 1>
   48    0 0xffffff7f80e11000 0x3000     0x3000     com.apple.iokit.IOUSBUserClient (660.4.2) <39 7 5 4 3 1>
   49    0 0xffffff7f80f12000 0x18000    0x18000    com.apple.driver.AppleUSBHub (666.4.0) <39 5 4 3 1>
   50    0 0xffffff7f814bd000 0x9000     0x9000     com.apple.BootCache (35) <7 6 5 4 3 1>
   51    0 0xffffff7f81ab5000 0x4000     0x4000     com.apple.AppleFSCompression.AppleFSCompressionTypeZlib (1.0.0d1) <6 4 3 2 1>
   52    0 0xffffff7f81abb000 0x3000     0x3000     com.apple.AppleFSCompression.AppleFSCompressionTypeDataless (1.0.0d1) <7 6 4 3 2 1>
   53    0 0xffffff7f81ac0000 0x2000     0x2000     com.apple.driver.AppleFileSystemDriver (3.0.1) <15 4 3>
   54    0 0xffffff7f81375000 0x18000    0x18000    com.apple.iokit.IOAHCIBlockStorage (2.5.1) <42 15 6 5 4 3 1>
   55    5 0xffffff7f80879000 0x31000    0x31000    com.apple.iokit.IOSCSIArchitectureModelFamily (3.6.6) <5 4 3 1>
   56    0 0xffffff7f81368000 0xd000     0xd000     com.apple.iokit.IOAHCISerialATAPI (2.6.1) <55 42 5 4 3 1>
   57    0 0xffffff7f815f4000 0x3000     0x3000     com.apple.driver.XsanFilter (404) <15 5 4 3 1>
   58    0 0xffffff7f817d9000 0x5000     0x5000     com.apple.driver.ApplePS2Keyboard (2.0.0) <29 5 4 3>
   59    0 0xffffff7f817cc000 0x8000     0x8000     com.apple.driver.ApplePS2Trackpad (2.0.0) <29 5 4 3>
   60    0 0xffffff7f817d4000 0x5000     0x5000     com.apple.driver.ApplePS2Mouse (2.0.0) <29 5 4 3>
   61    0 0xffffff7f81083000 0x7000     0x7000     com.apple.iokit.SCSITaskUserClient (3.6.6) <55 15 5 4 3 1>
   62    3 0xffffff7f8108e000 0x11000    0x11000    com.apple.iokit.IOCDStorageFamily (1.7.1) <15 5 4 3 1>
   63    2 0xffffff7f8109f000 0xe000     0xe000     com.apple.iokit.IODVDStorageFamily (1.7.1) <62 15 5 4 3 1>
   64    1 0xffffff7f810ad000 0xc000     0xc000     com.apple.iokit.IOBDStorageFamily (1.7) <63 62 15 5 4 3 1>
   65    0 0xffffff7f810b9000 0x1e000    0x1e000    com.apple.iokit.IOSCSIMultimediaCommandsDevice (3.6.6) <64 63 62 55 15 5 4 3 1>
   66    0 0xffffff7f80ead000 0x7000     0x7000     com.apple.driver.AppleUSBComposite (656.4.1) <39 4 3 1>
   67    0 0xffffff7f80dfd000 0x14000    0x14000    com.apple.iokit.IOUSBMassStorageClass (3.6.0) <55 39 15 5 4 3 1>
   68    0 0xffffff7f80cdf000 0x18000    0x18000    com.apple.iokit.IOSCSIBlockCommandsDevice (3.6.6) <55 15 5 4 3 1>
   69    0 0xffffff7f81860000 0x8000     0x8000     com.apple.driver.AppleIntelMCEReporter (104) <7 6 5 4 3>
   70    0 0xffffff7f81a1d000 0x3000     0x3000     com.apple.driver.AppleHWAccess (1) <7 5 4 3>
   71    2 0xffffff7f8110b000 0x15000    0x15000    com.apple.driver.AppleSMC (3.1.8) <10 7 5 4 3 1>
   72    0 0xffffff7f813d5000 0x5000     0x5000     com.apple.Dont_Steal_Mac_OS_X (7.0.0) <71 7 4 3 1>
   73    0 0xffffff7f8126e000 0xad000    0xad000    com.apple.iokit.IOBluetoothFamily (4.2.3f10) <39 14 7 5 4 3 1>
   74    6 0xffffff7f8115e000 0x43000    0x43000    com.apple.iokit.IOGraphicsFamily (2.4.1) <11 7 5 4 3 1>
   75    1 0xffffff7f81055000 0x14000    0x14000    com.apple.iokit.IOSurface (91) <7 5 4 3 1>
   76    0 0xffffff7f80df0000 0x7000     0x7000     com.apple.iokit.IOUserEthernet (1.0.0d1) <46 6 5 4 3 1>
   77    4 0xffffff7f810e8000 0xa000     0xa000     com.apple.driver.IOPlatformPluginFamily (5.7.0d10) <10 7 6 5 4 3>
   78    0 0xffffff7f8183d000 0x3000     0x3000     com.apple.driver.AppleLPC (1.7.0) <77 11 5 4 3>
   79    1 0xffffff7f81977000 0x6000     0x6000     com.apple.AppleGraphicsDeviceControl (3.4.35) <7 6 5 4 3 1>
   80    2 0xffffff7f81894000 0x72000    0x72000    com.apple.iokit.IOAcceleratorFamily2 (98.14) <74 11 7 6 5 4 3 1>
   81    0 0xffffff7f8197d000 0x58000    0x58000    com.apple.driver.AppleIntelFramebufferCapri (8.2.4) <80 79 74 11 10 7 6 5 4 3 1>
   82    0 0xffffff7f81746000 0x3000     0x3000     com.apple.driver.AppleSMBusPCI (1.0.12d1) <11 5 4 3>
   83    0 0xffffff7f811a1000 0x10000    0x10000    com.apple.iokit.IONDRVSupport (2.4.1) <74 11 7 5 4 3>
   84    0 0xffffff7f810f2000 0x3000     0x3000     com.apple.driver.AppleSMCPDRC (1.0.0) <77 11 6 4 3>
   85    1 0xffffff7f81a76000 0xf000     0xf000     com.apple.iokit.IOHDAFamily (2.3.0f2) <5 4 3 1>
   86    0 0xffffff7f81a85000 0x16000    0x16000    com.apple.driver.AppleHDAController (2.3.0f2) <85 74 11 6 5 4 3 1>
   87    1 0xffffff7f810f7000 0x14000    0x14000    com.apple.driver.IOPlatformPluginLegacy (1.0.0) <77 10 7 6 5 4 3>
   88    0 0xffffff7f81120000 0x10000    0x10000    com.apple.driver.ACPI_SMC_PlatformPlugin (1.0.0) <87 77 71 11 10 7 6 5 4 3>
   89    0 0xffffff7f80ca7000 0x4000     0x4000     com.evosx86.driver.lspcidrv (1111) <4 3>
   90    0 0xffffff7f81906000 0x4c000    0x4c000    com.apple.driver.AppleIntelHD4000Graphics (8.2.4) <80 75 74 11 7 5 4 3 1>
   91    1 0xffffff7f817f3000 0x11000    0x11000    com.apple.driver.AppleSMBusController (1.0.11d1) <32 11 10 5 4 3>
   92    0 0xffffff7f81804000 0xd000     0xd000     com.apple.driver.AppleMCCSControl (1.1.12) <91 74 11 10 7 5 4 3 1>
   93    0 0xffffff7f8124d000 0x1d000    0x1d000    com.apple.iokit.IOBluetoothHostControllerUSBTransport (4.2.3f10) <39 11 10 7 5 4 3 1>
   94    0 0xffffff7f80ea4000 0x9000     0x9000     com.apple.iokit.IOUSBHIDDriver (660.4.0) <39 29 5 4 3 1>
   95    1 0xffffff7f80b6f000 0x5000     0x5000     com.apple.kext.triggers (1.0) <7 6 5 4 3 1>
   96    0 0xffffff7f814c8000 0x9000     0x9000     com.apple.filesystems.autofs (3.0) <95 7 6 5 4 3 1>
   97    0 0xffffff7f81bad000 0x17000    0x17000    com.tuxera.filesystems.tufsfs.fusefs_txantfs (2013.3.14) <7 5 4 3 1>
   98    1 0xffffff7f81072000 0x11000    0x11000    com.apple.iokit.IOSerialFamily (10.0.7) <7 6 5 4 3 1>
   99    0 0xffffff7f8123d000 0xa000     0xa000     com.apple.iokit.IOBluetoothSerialManager (4.2.3f10) <98 7 5 4 3 1>
  100    1 0xffffff7f80c97000 0xe000     0xe000     com.apple.filesystems.msdosfs (1.9) <7 5 4 1>

pokenguyen checked my IOReg, and suggested that my laptop is missing Intel Management Engine Interface (IMEI).... The motherboard was swapped by DELL service center... so probably the motherboard is faulty... I am looking for a reason to complain about it to the service center guys.... can't say that I am installing Hack MAC.... :P :P

 

Do you know any app that utilizes this device and can return me with a error that the device is not found...? :P

Share this post


Link to post
Share on other sites

I checked for drivers on the DELL website.. They do not have a Intel Management Engine Interface (IMEI) driver for my laptop!!!!

Is it possible that a laptop lacks that device??

 

Can OS X work without that device??

Share this post


Link to post
Share on other sites

Try patching your dsdt with this (use MacIASL):

into device label IMEI parent_label PCI0 remove_entry;
into device label PCI0 insert
begin
Device (IMEI)\n
{\n
    Name (_ADR, 0x00160000)\n
    Method (_DSM, 4, NotSerialized)\n                
    {\n
        If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n
        Return (Package()\n
        {\n
            "device-id", Buffer() { 0x3A, 0x1E, 0x00, 0x00 },\n
            "name", "pci8086,1e3a",\n
        })\n
    }\n
}\n
end;

Share this post


Link to post
Share on other sites

Run DPCIManager, take a screenshot of PCI List tab.

 

Hi!

 

I added your provided patch for IMEI in the DSDT which worked earlier for me...

 

I removed Chameleon argument "IntelCapriFB=4 GraphicsEnabler=Yes"..

 

The system doesn't boot up.. It gets stuck at

 

DRMStatus Error: iTunes/Apple Store Content Access Problem. Content playback may be disabled on this computer. You can continue to use the machine, but you should contact an Apple support representative. ErrorCode: 8877652"

 

I tried with "IntelCapriFB=4 GraphicsEnabler=Yes" with the same result...

 

Finally booted with -x parameter.....

 

Attaching the DPCIManager screenshot..

 

PCI_List_Screen.tiff

 

 

Also, I am attaching my new IOReg after using the DSDT

 

MacBookPro_DSDT_Patch.ioreg.zip

 

Thank you for your help!!!

 

Share this post


Link to post
Share on other sites

Thanks!!

but, NVIDIA Optimus is already disabled in the DSDT.....

 

have no luck yet!!! don't know where I am going wrong..!! Probably that IMEI device is the root cause of this.....

Share this post


Link to post
Share on other sites

Hi ACD,

Just played the quiz to get here, gues what i passed...
Anyway i have the same problem as you, for the H7 series chipset we shoulden't need a imei, I get the same message about the "DRMStatus".
My idea was to try different ports on my notebook to see what will happen, wel if i counter anything i let you know.

Share this post


Link to post
Share on other sites

Hey bro!

Thank you for that ray of hope...

 

I really hope that you get through this problem and both of us could have a working Hackintosh.

 

Waiting eagerly. :)

Share this post


Link to post
Share on other sites

Update:

I installed OS X 10.8 which worked with the same DSDT... Then I gladly updated it to 10.8.5.. But to my dismay, the same problem surfaced!!!

I decided to update one by one... So that I could know which version of OS X stops working..

It worked till 10.8.2.. I had Intel HD Graphics 4000 with 512MB VRAM and QE/QC... Only thing was my ISB 3.0 wasn't working... But I can't use 10.8.2 as many softwares are not supported on it... At least Maverics is required!!

I searched for the IMEI device problem... What I have learned is that it becomes mandatory for the hybrid systems... Like 6 series chip on 7 series board.. But mine is both 7 Series...

Please someone help!! :'( :'(

Share this post


Link to post
Share on other sites

I am having the same problem with an HP Probook 4340s which is missing the Intel Management Engine Interface (for some reason).

 

Unless I boot with -x I get the : DRMStatus Error: iTunes/Apple Store Content Access Problem. Content playback may be disabled on this computer. You can continue to use the machine, but you should contact an Apple support representative. ErrorCode: 8877652...

 

Do you think it is possible to use the 10.8.2 accelerators for our HD4000?

Share this post


Link to post
Share on other sites

I am having the same problem with an HP Probook 4340s which is missing the Intel Management Engine Interface (for some reason).

 

Unless I boot with -x I get the : DRMStatus Error: iTunes/Apple Store Content Access Problem. Content playback may be disabled on this computer. You can continue to use the machine, but you should contact an Apple support representative. ErrorCode: 8877652...

 

Do you think it is possible to use the 10.8.2 accelerators for our HD4000?

 

 

IMEI can be fixed by Clover bootloader. See intructions to it.

 

 

Thanks for the replies!!!

 

Currently, after upgrading to 10.10, my QE/QC is working with Device ID injection in Clover... running 10.10.1.

The new issue is that it stops working after one restart. The workaround is that I enable "GenerateCStates" and "GeneratePStates", it starts working!

Then again after a restart, it stops working... Then I disable "GenerateCStates" and "GeneratePStates", it starts working!

I have to keep alternating this to keep it working..

It is funny and weird! :/

Does anyone have a clue??

 

I am using custom DSDT and SSDT.

Share this post


Link to post
Share on other sites

Hi, I had same problem.

Fortunately, there is workable solution! Skipping a part of the procedure of AppleMEClientController.
on-the-fly patch for Clove. Replaces 488983980000004885C00F840203000048 with 488983980000004831C00F840203000048 for AppleIntelFramebufferCapri:

<dict>
<key>Comment</key>
<string>Disable Intel MEI check</string>
<key>Find</key>
<data>
SImDmAAAAEiFwA+EAgMAAEg=
</data>
<key>Name</key>
<string>AppleIntelFramebufferCapri</string>
<key>Replace</key>
<data>
SImDmAAAAEgxwA+EAgMAAEg=
</data>
</dict>

post-1202318-0-15227900-1439185102_thumb.png

 

Before patch: https://goo.gl/photos/T1S4TAxkreofeD3UA

Share this post


Link to post
Share on other sites

Hi, I had same problem.

 

Fortunately, there is workable solution! Skipping a part of the procedure of AppleMEClientController.

on-the-fly patch for Clove. Replaces 488983980000004885C00F840203000048 with 488983980000004831C00F840203000048 for AppleIntelFramebufferCapri:

<dict>
<key>Comment</key>
<string>Disable Intel MEI check</string>
<key>Find</key>
<data>
SImDmAAAAEiFwA+EAgMAAEg=
</data>
<key>Name</key>
<string>AppleIntelFramebufferCapri</string>
<key>Replace</key>
<data>
SImDmAAAAEgxwA+EAgMAAEg=
</data>
</dict>

attachicon.gifSnímek obrazovky 2015-08-07 v 19.09.33.png

 

Before patch: https://goo.gl/photos/T1S4TAxkreofeD3UA

 

Hi gynekolog!

First of all, thank you for your post. I have been struggling with this for so many months now.

 

I will surely give it a shot and revert back to you! :):D

 

Thanking you again!

Share this post


Link to post
Share on other sites

Hi, I had same problem.

 

Fortunately, there is workable solution! Skipping a part of the procedure of AppleMEClientController.

on-the-fly patch for Clove. Replaces 488983980000004885C00F840203000048 with 488983980000004831C00F840203000048 for AppleIntelFramebufferCapri:

<dict>
<key>Comment</key>
<string>Disable Intel MEI check</string>
<key>Find</key>
<data>
SImDmAAAAEiFwA+EAgMAAEg=
</data>
<key>Name</key>
<string>AppleIntelFramebufferCapri</string>
<key>Replace</key>
<data>
SImDmAAAAEgxwA+EAgMAAEg=
</data>
</dict>

attachicon.gifSnímek obrazovky 2015-08-07 v 19.09.33.png

 

Before patch: https://goo.gl/photos/T1S4TAxkreofeD3UA

 

 

My Dear Friend Gynekolog!

 

You da real MVP!

Thank you very much!!

The issue has vanished..!

 

Also, I have upgraded to El Capitan.. It's running even smoother.

TuxeraNTFS and Paragon (Pre-release 10.11 compatible) both have failed to detect the NTFS partitions!

 

Anyways, I will be looking into that matter.. Thank you once again! :):D

Share this post


Link to post
Share on other sites

I installed macOS Sierra using Pokenguyen's yosemite guide. My Dell E5430 also does not have IMEI. I tried both pokenguyen imei dsdt and gynekolog clover path but nothing seems to fix my problem. Please tell me solution. It haunts me during El Capitan days.


Hi, I had same problem.

Fortunately, there is workable solution! Skipping a part of the procedure of AppleMEClientController.
on-the-fly patch for Clove. Replaces 488983980000004885C00F840203000048 with 488983980000004831C00F840203000048 for AppleIntelFramebufferCapri:

<dict>
<key>Comment</key>
<string>Disable Intel MEI check</string>
<key>Find</key>
<data>
SImDmAAAAEiFwA+EAgMAAEg=
</data>
<key>Name</key>
<string>AppleIntelFramebufferCapri</string>
<key>Replace</key>
<data>
SImDmAAAAEgxwA+EAgMAAEg=
</data>
</dict>

attachicon.gifSnímek obrazovky 2015-08-07 v 19.09.33.png

 

Before patch: https://goo.gl/photos/T1S4TAxkreofeD3UA

 

Hi, I had same problem.

Fortunately, there is workable solution! Skipping a part of the procedure of AppleMEClientController.
on-the-fly patch for Clove. Replaces 488983980000004885C00F840203000048 with 488983980000004831C00F840203000048 for AppleIntelFramebufferCapri:

<dict>
<key>Comment</key>
<string>Disable Intel MEI check</string>
<key>Find</key>
<data>
SImDmAAAAEiFwA+EAgMAAEg=
</data>
<key>Name</key>
<string>AppleIntelFramebufferCapri</string>
<key>Replace</key>
<data>
SImDmAAAAEgxwA+EAgMAAEg=
</data>
</dict>

attachicon.gifSnímek obrazovky 2015-08-07 v 19.09.33.png

 

Before patch: https://goo.gl/photos/T1S4TAxkreofeD3UA

I installed macOS Sierra using Pokenguyen's yosemite guide. My Dell E5430 also does not have IMEI. I tried both pokenguyen imei dsdt and gynekolog clover path but nothing seems to fix my problem. Please tell me solution. It haunts me during El Capitan days.

Share this post


Link to post
Share on other sites

I installed macOS Sierra using Pokenguyen's yosemite guide. My Dell E5430 also does not have IMEI. I tried both pokenguyen imei dsdt and gynekolog clover path but nothing seems to fix my problem. Please tell me solution. It haunts me during El Capitan days.

 

I installed macOS Sierra using Pokenguyen's yosemite guide. My Dell E5430 also does not have IMEI. I tried both pokenguyen imei dsdt and gynekolog clover path but nothing seems to fix my problem. Please tell me solution. It haunts me during El Capitan days.

Try this (tested on GA-Z77X-UD5H with me_clean'ed Aptio UEFI running 10.12.3):

<key>Comment</key>
<string>Skip Intel ME Check</string>
<key>Disabled</key>
<false/>
<key>Name</key>
<string>com.apple.driver.AppleIntelFramebufferCapri</string>
<key>Find</key>
<data>SYmEJJgAAABIhcAPhFkDAAA=</data>
<key>Replace</key>
<data>SYmEJJgAAABIMcAPhFkDAAA=</data>

Share this post


Link to post
Share on other sites

 

Try this (tested on GA-Z77X-UD5H with me_clean'ed Aptio UEFI running 10.12.3):

				<key>Comment</key>
				<string>Skip Intel ME Check</string>
				<key>Disabled</key>
				<false/>
				<key>Name</key>
				<string>com.apple.driver.AppleIntelFramebufferCapri</string>
				<key>Find</key>
				<data>D4RZAwAA</data>
				<key>Replace</key>
				<data>D4UAAAAA</data>

I am running Mac OS 10.12.2. It does not work first. Then after running windows then mac it works. I don't know whether it really fixed or not because it still say DRM Status blah blah

However, here is my darwin dump (https://www.dropbox.com/s/nrw583ws13rpyc4/darwinDump.zip?dl=0) and config.plist (https://www.dropbox.com/s/bwb8goq8ykxrrja/config.plist?dl=0) file for examination.

My Chipset is HM77 https://ark.intel.com/products/64339/Mobile-Intel-HM77-Express-Chipset. It clearly states no IMEI.

Share this post


Link to post
Share on other sites

Your chipset has absolutely nothing to do with the presence of ME. ALL Intel chipsets since the Core2 era have ME included; your ME firmware is probably just corrupt (which is why it isn't showing up). If you want to properly fix ME, reflash the ME firmware.

 

Edit: Not sure if any patch is even needed; I can still boot macOS with QE/CI with the ME disabled (there is a ~20 second hang though).

Share this post


Link to post
Share on other sites

Your chipset has absolutely nothing to do with the presence of ME. ALL Intel chipsets since the Core2 era have ME included; your ME firmware is probably just corrupt (which is why it isn't showing up). If you want to properly fix ME, reflash the ME firmware.

 

Edit: Not sure if any patch is even needed; I can still boot macOS with QE/CI with the ME disabled (there is a ~20 second hang though).

On the intel link I provided earlier, they said this chipset does not have intel Mei. If it is not IMEI's issue then what is the cause of this issue. Sometimes, qe/ci work other time not. Maybe you are right that it is not due to imei otherwise it should never work(not even single time). But, the question is how to fix this issue. I am happy to provide any thing you need. Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×