Jump to content
Aigors

[GUIDA] Integrare Ozmosis nel bios UEFI

166 posts in this topic

Recommended Posts

Advertisement

No!che è successo?

Sofi sp8

 

Boh qualcosa è andato storto : al boot non vede ne le porte usb ne la ram inserita.

Mi va bene che faccio una sostituzione con Amazon ma vorrei pararmi il culo per il futuro, prendermi un programmatore e vivere felice.

 

Cosa dovrei sapere per programmare il bios della nostra mobo? hai mica fatto una guida ? :)

Share this post


Link to post
Share on other sites

Azz, mi spiace, puoi pero' provare a fare il bios flashback.

prendi una chiavetta usb, meglio se di piccolo taglio, formattala fat32, copiaci sopra il bios e rinominalo in Z97IPLUS.CAP, collega l'alimentatore alla piastra, non accenderla, metti la chiavetta usb che hai preparato nella porta usb2 in basso, per capirci le porte usb2 sono quelle che sono nere all interno, se guardi la "culatta" che ti danno insieme alla mobo vedrai che tale porta e' marchiata in verde e c'e' scritto bios flashback, una volta inserita la chiavetta, tieni premuto il reset per 5 secondi, se sei fortunato parte la procedura di flashback se la chiavetta ha un led di stato vedrai l'operazione tramite il lampeggio del led, dovrebbe durare circa un paio di minuti.

In bocca al lupo.

La procedura di programmazione del bios non la faccio perche' e' intuitiva e varia da programmatore a programmatore.

Share this post


Link to post
Share on other sites

Azz, mi spiace, puoi pero' provare a fare il bios flashback.

prendi una chiavetta usb, meglio se di piccolo taglio, formattala fat32, copiaci sopra il bios e rinominalo in Z97IPLUS.CAP, collega l'alimentatore alla piastra, non accenderla, metti la chiavetta usb che hai preparato nella porta usb2 in basso, per capirci le porte usb2 sono quelle che sono nere all interno, se guardi la "culatta" che ti danno insieme alla mobo vedrai che tale porta e' marchiata in verde e c'e' scritto bios flashback, una volta inserita la chiavetta, tieni premuto il reset per 5 secondi, se sei fortunato parte la procedura di flashback se la chiavetta ha un led di stato vedrai l'operazione tramite il lampeggio del led, dovrebbe durare circa un paio di minuti.

In bocca al lupo.

La procedura di programmazione del bios non la faccio perche' e' intuitiva e varia da programmatore a programmatore.

 

 

AZZ ha funzionato, ci avevo provato 20 volte ma non lo avevo rinominato giusto come hai detto tu!!!!

 

Senti,

 

però tu hai fatto di sicuro qualche modifica al tuo bios, perchè ne ho fatto uno pulito proprio adesso mettendo dentro solo questi files :

 

|188|OzmosisDefaults|99F2839C-57C3-411E-ABC3-ADE5267D960D|00DA7A19|000128|FRFM|

|189|HfsPlus |4CF484CD-135F-4FDC-BAFB-1AA104B48D36|00DA7B41|006174|DRVR|

|190|PartitionDxe |1FA1F39E-FEFF-4AAE-BD7B-38A070A3B609|00DADCB5|002E68|DRVR|

|191|SmcEmulatorKext|DADE1001-1B31-4FE4-8557-26FCEFC78275|00DCF5D8|021710|FRFM|

|192|Ozmosis |AAE65279-0761-41D1-BA13-4A3C1383603F|00DF0CE8|01CDC4|DRVR|

|193|DisablerKext |DADE1002-1B31-4FE4-8557-26FCEFC78275|00E0DAAC|002B6B|FRFM|

 

ma osx non parte : rimane schermata nera con la barra di avanzamento a metà.

Allora mi sono fatto il mio Defaults.plist e messo nella cartella Kext2Ffs\Ffs\Efi\Compress e convertito. Il file poi lo ho rinominato in OzmosisDefaults e sostituito con quello di defaults.

 

Ottengo sempre la schermata nera con la mela bianca e la barra di avanzamento che si blocca a metà.

 

La cosa strana è che io gli ho messo il "-v" nel plist eppure non se lo fila manco per sogno.

 

E' per questo che ti chiedo se hai fatto qualche cosa di strano nel tuo bios perchè a parità di mobo e file la mia non va :(

 

 

Quello che ho fatto è giusto no? creare il Defaults.plist e convertire in OzmosisDefaultsCompress.ffs ed inserirlo come al solito?

Share this post


Link to post
Share on other sites

Scusami se leggo solo ora, dunque, se leggi il readme del bios QUO nuovo vedrai che per resettare le impostazioni che scrive il bios stesso in nvram devi premere 4 tasti insieme, ossia winlogo+alt+p+r in questo modo ozmosis cancella la nvram e legge il file OzmosisDefaults.ffs direttamente dal bios, in questo modo dovrebbe prenderti anche il -v

Che scheda grafica stai usando? una pci-E o quella a bordo del processore? 
In quest'ultimo caso in funzione del tipo di scheda ( Intel Graphics HD4000 o 4600,la 4400 non e' compatibile ) devi fare il corretto DSDT e modificare il file OzmosisDefaults.plist aggiungendo il corretto AAPL-ID relativo alla tua scheda.
Se invece usi una scheda PCI-E sempre in funzione del tipo di scheda occorre aggiungere delle chiavi dentro al file plist.
Per una radeon, devi vedere che tipo di framebuffer devi passargli, per una nvidia, dipende dal modello e dal sistema operativo.
Se usi maverick le nvidia vengono riconosciute OOB ( Out Of Box ) se invece stai usando Yosemite, per l'installazione devi disabilitare l'uso del driver nvidia del sistema operativo, poi, una volta terminata l'installazione, devi scaricarti il web-driver ed usare questo.
Una volta scaricato il driver e installatolo, spegni la macchina, riabilita il driver nvidia e dovrebbe funzionare tutto.
A maggior ragione se usi una 970 con Yosemite.

Share this post


Link to post
Share on other sites

Anyone know in what way 'NTFS-asus.efi' is used?

 

Thanks

Not in deep, i suppose it's' used to read ntfs disk, for what i know it's enough filesystem from quo bios.

Share this post


Link to post
Share on other sites

Buonasera tutti, una volta inserito nel bios i vari pezzi, la parte che riguarda l'ozmosisdefault non mi è chiara, dove piazzarlo? O i vari kext base da aggiungere, smc, vga etc. Poi nel file dato sul forum tedesco come capire cosa c'è e cosa manca. Conviene caricarlo cosi e inserire a mano i dati in nvram? Grazie

Share this post


Link to post
Share on other sites

Buonasera tutti, una volta inserito nel bios i vari pezzi, la parte che riguarda l'ozmosisdefault non mi è chiara, dove piazzarlo? O i vari kext base da aggiungere, smc, vga etc. Poi nel file dato sul forum tedesco come capire cosa c'è e cosa manca. Conviene caricarlo cosi e inserire a mano i dati in nvram? Grazie

Se usi il tool UefiTool di Coderush, vedrai che il file Defaults.plist e' presente nel bios che hai fatto, devi estrarne il body, modificarlo e reinserirlo, sono al lavoro e non posso fartelo vedere,se arrivo a casa ad un orario ragionevole ti faccio vedere come fare.

Share this post


Link to post
Share on other sites

Ciao e grazie per l'ottima guida.

Sto provando a modificare il bios della gigabyte z68x-ud3h-b3.

Ad oggi Ozmosis è arrivato alla versione 1479, che da quello che leggo in giro è l'unica in grado di avviare El Capitan, senza ricorrere ad ulteriori accorgimenti (come ad es. creare un ibrido Ozmosis-Clover).

 

Tuttavia, anche se ho spazio nel bios, non appena provo ad inserire il modulo ozmosis.ffs, MMtool mi dice "unable to getting firmware information".

 

Per la cronaca, in rete si trova un bios già pronto, ma con la versione 894m, che va bene per Yosemite, ma non per El Capitan.

 

Qualcuno mi può dare una mano?

 

Grazie

Share this post


Link to post
Share on other sites

Ho compresso il modulo core_dxe ed ho liberato parecchio spazio, tanto da fa entrare tutti i moduli ozmosis.

Tuttavia quando provo ad inserire quello principale (ozmosis) non solo MMtool mi dice "unable to getting firmware information", ma tutto il bios si incasina e non posso fare altre operazioni, senza ottenere lo stesso messaggio d'errore.

Share this post


Link to post
Share on other sites

Ciao a tutti, qualcuno è riuscito ad abilitare l'audio HDMI con scheda video integrata HD4600 e Ozmosis?

Personalmente non sono mai riuscito a far andare l HDMI ozmosis o meno, ma sospetto che sia piu' un mio problema :D 

A quanto ho letto e per quanto ne so, nessuno che usa ozmosis ha mai postato tale problema.

Share this post


Link to post
Share on other sites

Salve ragazzi,

 

parto col presupposto che entro domani probabilmente farò il mio "primo" Hackintosh e nel frattempo mi stavo informando e sono capitato a leggere a proposito di questo "Ozmosis".

Se ho ben capito, utilizzando questo tool e quindi flashando una versione modificata del proprio UEFI sulla propria MoBo, ci si può risparmiare di utilizzare un Bootloader come Clover, giusto? Ciò quali vantaggi reali apporterebbe in generale? Potrei installare OSX ed aggiornarlo alle versioni successive senza fare alcuna modifica al suo installer come invece attualmente viene fatto?

 

Un'altra curiosità, ma una volta flashate queste modifiche, il pannello di controllo UEFI originale della propria Motherboard continua ad esserci?

 

Qualcuno, inoltre, saprebbe dirmi se tutto ciò è possibile con la mia scheda madre? Nel mio caso si tratta di una MSI H170 GAMING M3

 

P.S: aggiungo che io punterei ad installare Sierra sul mio computer.

Share this post


Link to post
Share on other sites

Ti consiglio di usare clover... puoi aggiornare osx senza fare alcuna modifica all'installer

Dove hai letto che solo ozmosis rende possibile aggiornare senza problemi?

Share this post


Link to post
Share on other sites

Ti consiglio di usare clover... puoi aggiornare osx senza fare alcuna modifica all'installer

Dove hai letto che solo ozmosis rende possibile aggiornare senza problemi?

 

Avevo tentato di dedurre in base a ciò che ho letto, evidentemente sbagliando XD

 

Ma allora usare Ozmosis quali benefici comporta?

Share this post


Link to post
Share on other sites

Hai una sorta di vero mac, ma basta qualche cambiamento che son dolori, con clover ogni modifica può essere fatta con dsdt o ssdt. Inoltre ozmosis tocchi il bios a livello hardware se non hai doppio chip bios sono dolori

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Salve a tutti, mi domandavo se Ozmosis risulta essere compatibile con chipset Intel Z170 o superiore/equivalente, qualcuno ha qualche info al riguardo?

Non ho problemi a ripristinare il firmware da un dump valido eventualmente (flasher SPI + clip Pomona SOIC-8)

 

ENG

 

Hi guys, I was wondering if Ozmosis is compatible with Intel Z170 chipset, does anybody have some info about it?

I don't have any problems of recovering the firmware from a valid dump (SPI flasher + Pomona clip SOIC-8)

Share this post


Link to post
Share on other sites

Salve a tutti, mi domandavo se Ozmosis risulta essere compatibile con chipset Intel Z170 o superiore/equivalente, qualcuno ha qualche info al riguardo?

Non ho problemi a ripristinare il firmware da un dump valido eventualmente (flasher SPI + clip Pomona SOIC-8)

Si,funziona,occhio che se hai una mobo gigabyte con dual BIOS,potresti incontrare delle difficoltà con la clips.

Il dump lo puoi ottenere direttamente dalla tua mobo

 

Inviato dal mio ONE A2003 utilizzando Tapatalk

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×