Jump to content
About Just Joined group Read more... ×
Slice

AmdCPUMonitor and HWSensors 3.3.1

110 posts in this topic

Recommended Posts

I made new kext as an addition to HWSensors v3.3.

Compatibility with OS 10.6 - 10.10

Currently it show only CPU temperature. May be later I make voltage and frequencies. Voluntaries welcomed.

 

I am not sure with kozlek's project compatibility. Test with precations.

(kozlek's version is not newer. It is a branch with own enumeration)

 

Manual testing without installation:

sudo -s
chown -R root:wheel ~/Downloads/AmdCPUMonitor.kext
chmod -R 755 ~/Downloads/AmdCPUMonitor.kext
kextutil -v ~/Downloads/AmdCPUMonitor.kext

This kext v1.0 attachicon.gifAmdCPUMonitor.kext.zip

Other files in the project (don't install all of them! For example you don't need IntelCPUMonitor)

attachicon.gifFakeSMC_plugins_746.zip

 

New FakeSMC with Illumination version in System Profiler and no warnings in kernel.log

attachicon.gifFakeSMC.kext_Illumination.zip

Minimum set includes FakeSMC+HWInfo

 

 

Recommended installation (I have no installer so I propose you will use Terminal.app)

sudo -s
cp -r -v ~/Downloads/HWSensors/AmdCPUMonitor.kext /System/Library/Extensions/

and so on for all kexts that will have a sense for you

ACPIMonitor.kext     - for devices in DSDT. Only for advanced users!
AmdCPUMonitor.kext   - temperature for AMD CPU
Andigilog.kext       - for andigilog chip. Found on some Intel motherboard
AnalogDevices.kext   - for chips like ADT7470-7475
F718x.kext           - for Fintek chip
FakeSMC.kext         - obligatory for any Hackintosh
GeforceSensor.kext   - for new NVidia Geforce cards
HWInfo.kext          - if you use Clover bootloader
ICHSMBus.kext        - an addition for Andigilog.kext
IntelCPUMonitor.kext - temperature, voltage and frequencies for Intel CPU up to Haswell
ITEIT87x.kext        - for ITE chip, found on most Gigabyte motherboards
NuvotonNCT677x.kext  - for Nuvotone chip, found on new ASUS motherboards
NVClockX.kext        - for old NVidia cards
PC8739x.kext         - for NSC chip, found on Dell Inspiron only
RadeonMonitor.kext   - for Radeon videocard HD4000+
W836x.kext           - for Winbond chips found on old ASUS motherboards
X3100.kext           - for Intel X3100 (GM965 chip) 

Monitor application to be used

attachicon.gifHWMonitor.app_731.zip

 

New version andigilog.kext supports EMC6D103 chip.

 

 

Advantages: 

- no spam in system.log

- CPU usage only 0.1%

- no panics

- supported wide range of chips.

 

Sources are available here

https://www.assembla.com/code/fakesmc/subversion/nodes/738/HWSensors

Hey can u re upload all the files u shared here, I am not able to download from here for some reason,. Thanks

Share this post


Link to post
Share on other sites
Advertisement

So I tried to install it but installation fails due to some error. But I can still see new HWMonitorSMC app installed. But it show only Hard disk temp nothing else. More over Now I have started to freez during restart and my external hdd is now being recognized as Read Only.

How do I uninstall it now?

Share this post


Link to post
Share on other sites

the link does not work

 

I made new kext as an addition to HWSensors v3.3.

Compatibility with OS 10.6 - 10.10

Currently it show only CPU temperature. May be later I make voltage and frequencies. Voluntaries welcomed.

 

I am not sure with kozlek's project compatibility. Test with precations.

(kozlek's version is not newer. It is a branch with own enumeration)

 

Manual testing without installation:

sudo -s
chown -R root:wheel ~/Downloads/AmdCPUMonitor.kext
chmod -R 755 ~/Downloads/AmdCPUMonitor.kext
kextutil -v ~/Downloads/AmdCPUMonitor.kext

This kext v1.0 attachicon.gifAmdCPUMonitor.kext.zip

Other files in the project (don't install all of them! For example you don't need IntelCPUMonitor)

attachicon.gifFakeSMC_plugins_746.zip

 

New FakeSMC with Illumination version in System Profiler and no warnings in kernel.log

attachicon.gifFakeSMC.kext_Illumination.zip

Minimum set includes FakeSMC+HWInfo

 

 

Recommended installation (I have no installer so I propose you will use Terminal.app)

sudo -s
cp -r -v ~/Downloads/HWSensors/AmdCPUMonitor.kext /System/Library/Extensions/

and so on for all kexts that will have a sense for you

ACPIMonitor.kext     - for devices in DSDT. Only for advanced users!
AmdCPUMonitor.kext   - temperature for AMD CPU
Andigilog.kext       - for andigilog chip. Found on some Intel motherboard
AnalogDevices.kext   - for chips like ADT7470-7475
F718x.kext           - for Fintek chip
FakeSMC.kext         - obligatory for any Hackintosh
GeforceSensor.kext   - for new NVidia Geforce cards
HWInfo.kext          - if you use Clover bootloader
ICHSMBus.kext        - an addition for Andigilog.kext
IntelCPUMonitor.kext - temperature, voltage and frequencies for Intel CPU up to Haswell
ITEIT87x.kext        - for ITE chip, found on most Gigabyte motherboards
NuvotonNCT677x.kext  - for Nuvotone chip, found on new ASUS motherboards
NVClockX.kext        - for old NVidia cards
PC8739x.kext         - for NSC chip, found on Dell Inspiron only
RadeonMonitor.kext   - for Radeon videocard HD4000+
W836x.kext           - for Winbond chips found on old ASUS motherboards
X3100.kext           - for Intel X3100 (GM965 chip) 

Monitor application to be used

attachicon.gifHWMonitor.app_731.zip

 

New version andigilog.kext supports EMC6D103 chip.

 

 

Advantages: 

- no spam in system.log

- CPU usage only 0.1%

- no panics

- supported wide range of chips.

 

Sources are available here

https://www.assembla.com/code/fakesmc/subversion/nodes/738/HWSensors

Share this post


Link to post
Share on other sites

:)

 

but temperature is false :D

 

Same thing...

 

This is my speedfan log from windows:

Win9x:NO  64Bit:YES  GiveIO:NO  SpeedFan:YESI/O properly initialized
Linked ISA BUS at $0290
Linked ATI SBx00 SMBUS at $0B00
Linked ISA BUS at $0CCB
SB7xx/8xx PM2 found on ISA at $CCB
Found nVidia GeForce GT 610
Linked nVidiaI2C0 SMBUS at $3D403E3F
Linked nVidiaI2C1 SMBUS at $3D403637
Linked nVidiaI2C2 SMBUS at $3D405051
Scanning ISA BUS at $0290...
IT8712F(J) found on ISA at $290
Scanning AtiIgp SMBus at $0B00...
Scanning ISA BUS at $0CCB...
Scanning I2CNVidia SMBus at $3D403E3F...
Scanning I2CNVidia SMBus at $3D403637...
Scanning I2CNVidia SMBus at $3D405051...
Found Hitachi HTS543232A7A384 on AdvSMART
Found WDC WD5000AAKX-083CA1 on AdvSMART
ATK0110 (MB=M5A78L-M-LX3) found on ACPI
End of detection

 

Used these kexts:

 

ACPIMonitor.kext - for devices in DSDT. Only for advanced users!

AmdCPUMonitor.kext - temperature for AMD CPU

Andigilog.kext - for andigilog chip. Found on some Intel motherboard

AnalogDevices.kext - for chips like ADT7470-7475

F718x.kext - for Fintek chip

FakeSMC.kext - obligatory for any Hackintosh

GeforceSensor.kext - for new NVidia Geforce cards

HWInfo.kext - if you use Clover bootloader

ICHSMBus.kext - an addition for Andigilog.kext

IntelCPUMonitor.kext - temperature, voltage and frequencies for Intel CPU up to Haswell

ITEIT87x.kext - for ITE chip, found on most Gigabyte motherboards

NuvotonNCT677x.kext - for Nuvotone chip, found on new ASUS motherboards

NVClockX.kext - for old NVidia cards

PC8739x.kext - for NSC chip, found on Dell Inspiron only

RadeonMonitor.kext - for Radeon videocard HD4000+

W836x.kext - for Winbond chips found on old ASUS motherboards

X3100.kext - for Intel X3100 (GM965 chip) 

 

 

 

It's just a little report. Maybe I should use some other kexts, I'm not sure.

p.s. my hardware you can see at my signature...

post-1484325-0-59148300-1444477422.png

Share this post


Link to post
Share on other sites

The drivers that are not suitable for your hardware, you have to remove from Fakesmc.kext/ ... /plugin/ folders. Or add missing drivers in the pluging folder. you need to test.

Share this post


Link to post
Share on other sites

The drivers that are not suitable for your hardware, you have to remove from Fakesmc.kext/ ... /plugin/ folders. Or add missing drivers in the pluging folder. you need to test.

 

Ok, I'll try in a free time.)

Share this post


Link to post
Share on other sites

Alright I've tried - same result, I had even delete all drivers and left only fakesmc.kext and amdcpumonitor.kext in Contents/Plugins.

edit: I think it's not compatible with my type of CPU, the driver should be updated for compatibility. But it's ok, for now will be enough GPU sensor.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By kokozaurs
      Hi all,
       
      I'm using ESXI 7.0b (did use 6.7 to try but with no difference).
       
      Right now on Catalina but I can't seem to try to get GPU (RX580) working properly.
       
      I pass it through to the VM(tried with windows before with no problems) and it appeared just as pci-device with no name.
       
      After that, I've applied whatevergreen + lilu kexts and it does properly recognize it under system report however that's all there is. It's listed at GFX0. See attached images.
       
      No hardware acceleration. Monitor also not turning on using either DP/HDMI. 
       
      Since it is being passed through to the VM, it seems that the problem is not on ESXi side but on macOS side. 
       
      Has anyone has been able to pass through an AMD GPU to ESXI VM? Can anyone suggest some pointers as to where I could find some solutions to this problem?
       
      Thanks! 
       
       



    • By b2550
      Currently my install is 100% working except that so far I have only been able to get one of my 1080p monitors working with a MiniDP to HDMI cable. I currently am getting a second MiniDP to HDMI cable but for now I am stuck with a DVI to HDMI cable.

      The monitor that is working is plugged in via the MiniDP to HDMI. The monitor that isn't working is using the DVI cable. However I also tried switching it to HDMI to HDMI which had the same result. The monitor wakes up but it's black. However for whatever reason, both monitors are still recognized in system preferences and hackintool.

      I know all my cables are good and work because I updated from an install of El Capitan (which I still have on it's original SSD just in case this install fails) as well as a Windows install. Both monitors worked fine on El Capitan for literally years. El Capitan is just too old now and I need to update to keep up with software updates.

      Problem reporting files should provide needed info about how I've configured this install. Build is in my signature.
      debug_22725.zip
    • By autantpourmoi
      I'm an happy user of a x99 built hackintosch since 6/7 years using it mainly for photoshop and fcpx ... Using new camera with better resolution and video in ProResRaw , my built start to struggle a bit 
      I'm thinking of making a new built and seeking for advices for this new built that I want evolutive and last at least as long as my previous built 
      I'll use a SSD M2 forth Generation so I need at least 2 to 3 SSD M2 PCI x4 slots
      then which proc to use , I was thinking about the AMD Ryzen 9 3900xt or the Intel I9 10900k ( don't have the money for AMD threadripper ) if you have better idea I'm really open to it as long as you explain it to me 
      then which chipset should I use:
      for Intel  , should I go to Z490 or X299 or W480
      For AMD , I think I have only the choice of X570
      I always used Gigabyte motherboard so it will be naturally my first choice but again I'm open to any suggestion
      I need at least usb 3,1 Gen 2 and TB3 is not necessary but an option and can be add later on with a PCI Card I think
      So I'll be pleased o read your opinion and the choices that you'll do for the purpose of this built 
      thanks in advance 
       
       
    • By asheenlevrai
      Hi
       
      I recently built my 1st ryzentosh.
      I also used Opencore (0.6.1) for the 1st time and followed the install guides on Dortania.
       
      Now I need to map my USB ports and apparently it's not achieved the same way on AMD platforms compared to what I was "used to" on Intel platforms.
       
      The guide on Dortania is a bit confusing to me since there is information that is not clearly labelled as "for Intel" or "for AMD" and I thus don't understand very well what I should and shouldn't do.
       
      Can anyone give me advice or point towards as comprehensive tutorial intended for AMD-based builds.
       
      Thank you very much in advance for your help.
       
      Best,
      -a-
    • By Johnnycale
      Hi everybody. I'm stuck here and after a few days I'm really not able to boot.
      My setup is the following:
       
      CPU AMD Ryzen 9 3900x
      GPU Aorus RX 5700 XT
      MOTHERBOARD AsRock x570m Pro4
      SSD 1 Corsair MP600 1TB
      SSD 2 Gigabyte Aorus NVMe 1TB
      RAM Crucial Ballistix 2x32GB
      WIFI BCM94360CD

      Error message from Bios attached to this thread.

      Thanks to anyone willing to help me. I've tried different open core versions, adding and removing a lot of kexts, keeping essentials ACPIs, setting as true or false different .plist settings that I saw resolving similar issues as mine but nothing seems to work.
      opencore-2020-09-07-214007.txt
×