Jump to content

Upgrade Core2 Duo to Xeon X5460 Quad=no graphics


11 posts in this topic

Recommended Posts


I just upgraded my cpu from a 3.16 GHz Core 2 Duo to a Xeon X5460 3.16 GHz Quad Core by doing the 771 to 775 mod. My mobo is a Gigabyte GA-P31-3GS with a paltry 2 Gigs of DDR2 SDRAM 666MHz. I'm running a dual boot system with OSX Lion 10.7.5 and Windows XP SP3. The problem I'm having is that my EVGA Geforce 9800GT 512 MB shows just a black and grey screen with a few white boxes (like a test pattern) after boot-up. Booting with -v revealed a problem with NVEnabler and someone (from the site that cannot be named) suggested making a custom DSDT which I did and was able to boot (using the old Core2 Duo) with Graphics Enabler=No and eliminating NVEnabler from S/L/E.


However, using the Xeon X5460 I get the same black and grey screen. I am able to boot with the Xeon if I disable the DSDT, use GE=Yes and with PCIRoot=0 but then I only get 1024x768 resolution and, of course, no acceleration.


What makes this so fustrating is it boots up perfectly with Windows XP! Anybody have any ideas?


Thanks in advance!


Oops. I forgot to mention that when I go to System Info it correctly identifies the Quad Core CPU as a Xeon X5460. And I also noticed that when I successfully booted with the Xeon (again DSDT off, use GE=Yes and with PCIRoot=0) Temperature Monitor no longer was able to read any CPU temps-only temp for my HDD.

Link to comment
Share on other sites

All aboard!!! The GA-P31-S3G is now leaving on Track 1 direct to Harpertown!!


I finally found success in swapping out the IOPCIFAMILY and AppleACPIPlatform kext from my SL Retail DVD as detailed by Douggle here in this thread




I noticed his error log was almost exactly the same as mine http://pastebin.com/3aZ8kuwV and later he mentions that when he disabled NVEnabler his System would hang at the NVDANV50.hal kext. Exactly like mine. Although, why the Quad Core needed this rollback is still a mystery. I'm wondering if this problem would have simply gone  away with an upgrade to ML or Mavericks? Anyone?


I haven't been able to drive my system in anger just yet as I only have the stock Core2 Duo fan but everything seems to be working. I even have Dual Monitor support and hot swapping.


I installed the latest HWSensors Binaries and now I have CPU monitoring capabilities although the Heatsink and Main Logic board temps show a continuous 126 C and 73C. (This seems to be a bug and has been reported by other posters as well). Also it seems that Temperature Monitor has some limited capabilities with the installation of the HWSensors kexts because now it too shows all cpu temps and the erroneous Heatsink and Main Logic board temps but no voltage or fan speeds.


Thanks again. And thanks Douggle!

Link to comment
Share on other sites

That you have to boot with DSDT=no suggests to me that you should re-extract your DSDT with the Xeon CPU installed, and patch it again.


DSDT is fixed-function but its contents will change when enabling CPU features in the BIOS, or installing a CPU that supports different features, installing more RAM etc.


Deliberately setting PCIRoot incorrectly will prevent EthernetBuiltIn and GraphicsEnabler from working. Possibly other things as well once OS X is running, not sure, I've never tried it, it's not my idea of a fun time :D


PCIRoot=0 is the Chameleon default and therefore there's no need to specify 0 - unless your real PCIRoot is 1 and you're doing it deliberately to prevent GraphicsEnabler from working. In which case GraphicsEnabler=n should be enough...so what you're doing there doesn't really make any sense, unless you're trying to prevent things from working correctly.


On Gigabyte boards the PCI Root is historically 1. Look for a pinned topic in the DSDT section called "tequila fix" or something like that for more information.

Link to comment
Share on other sites

Thanks for the reply


And sorry,


I should have included more specific (and useful) info in my post.  Everything is working fine with my DSDT injected, GraphicsEnabler=No and PciRoot set to the defaults ( i.e. no input specified in Chameleon) and NVEnabler.kext removed from S/L/E*.


Thanks again


*Although I suspect that NVEnabler would probably work now with the SL kext mod I have not tried it.


Link to comment
Share on other sites

How can it be working if you have GraphicsEnabler=n and no NVEnabler.kext? You must be injecting via DSDT then?


The 9800 GT should work just fine with GraphicsEnabler=y, as long as you're using a not completely antique Chameleon build.


Of course to test that, you'd have to completely remove the DSDT code for it first.


There must be a better way to get it running than swapping those kernel extensions...

Link to comment
Share on other sites

Yes but that's complicated and has no advantages. Also, to generate one, instead if just running gfxutil, people will use EFI Studio or OSX86Tools, and then be tempted to click other "interesting" stuff which will inevitably break everything. These antiquated and obsolete tools lead users down the narrow, dark path of how things were done in 2008. We still occasionally have people posting that they have "enabled Quartz" or corrupted "About this Mac" with OSX86Tools.


GraphicsEnabler=y is by far the easiest method to get an nvidia card going.

  • Like 1
Link to comment
Share on other sites

  • 7 months later...

I know I'm coming in rather late to this discussion, but I'm hoping you guys are still listening to this thread because I need some help!

I just recently bought a Gigabyte GA-G41M Combo Rev 1.4 motherboard. I put my C2D E6750 in and she POSTed right away. I tested the board thoroughly with Windows 7 and 8.1, without any issues what so ever. I even tried the Win10 preview and all was good, BUT, the reason I bought this board was to turn it into a Quad core Xeon hackintosh. This is where my issues lie and where I need some help/advice.

Below is a link to the motherboards info web page and the current specs of my system.....

Gigabyte GA-G41M Combo Rev 1.4 mobo
Intel Xeon E5450 3.0GHz Quad core CPU (80 watt E0 stepping) (I did the socket 771 to 775 mod)
4GB Patriot 1066MHz DDR2 Memory
Testing with an: Nvidia GeForce 8800GTS 640MB and a 8400gs 256MB and an evga GTX 260
430 W Corsair PSU
WD 400GB H/D
Operating Systems Tested: Win 7 x64 / 8.1 x64 / 10x64 / Mac OS X 10.9.2 / 10.9.5

(OS X was tested using the xxx-beast method as well as My-Hack. I had issues with myhack so I stuck with xxx-beast)

My old hackintosh used all of the above components except the mobo and xeon and it worked very well, except my old mobo apparently does not fully support the Xeon. It caused some odd behavior like temp readings were falsley off the chart. And from what I've been told, there is no way to add the newer microcodes to the intel BIOS

(intel DG31PR)

I added the newest microcodes to the gigabyte motherboards BIOS. everything worked perfectly and the Xeon was recognized. This is what I see on the screen after POST.

Award Modular BIOS v6.00PG
Copyright © 1984-2010, Award Software, Inc.

G41M-Combo F4

Main Processor : Intel ® Xeon ® CPU E5450 @ 3.00GHz (333x9)
CPUID : 001067A Patch ID : 0A0B
Memory Test : 4029MB OK + 66M Shared

When I have the Xeon CPU installed, I either get a full screen of artifacts when using the nvidia cards or the screen blanks out and the computer freezes.

The built in video shows up fine, all be it at a resolution of 1024 x 768 only.
When I have the Core 2 Duo installed, there are no artifacts and all video cards run properly with QE/CI (grapahics acceleration) at the monitors native res of 1680x1050.

Can anyone think of a reason why this would happen with the Xeon installed? (Note: the same thing happened when I had the Xeon installed in the DG31PR motherboard)


This is what I did to get OS X installed.....

In my BIOS i had to set the internal video (intel x4500) to always ebabled and first device to onboard video.

I had to boot from the USB using -v -x cpus=1

installed Mavericks 10.9.5

rebooted using the same boot flags as above


Mavericks booted properly, so I created a dsdt using MaciASL and a patch from olarila and used xxxxx-beast to install drivers with user-dsdt mode.

shutdown the PC and installed the 8400GS video card and tried to boot from just it by shutting off the internal video.

If I boot with no bootflags, the video blanks out. If I add GraphicsEnablr=Yes, I get a very quick memory error on boot and the PC freezes up completely.

If I use npci=0x2000 or 0x3000, the computer will boot, but when the video is finally initialized, nothing can be seen but colourful bits and blocks of white/black/green/blue and red. Artifacts everywhere!


I was able to get clear video from the nvidia cards, but to do it I had to have both internal and external video enabled at the same time and boot with flags -v npci=0x2000.

I would boot from the internal and as soon as mavericks was fully booted, the nvidia card would activate. The issue here though is that the desktop shows up in a small square box centered in the middle of the monitor. When I try to change resolutions, it flickers but the size of the desktop refuses to fill the entire screen.

Also, I am unable to get a stable OS without using cpus=1, which totally defeats the purpose of having a xeon quad core cpu!

The only time this setup has worked without much of any issue what so ever, was when I had my C2D cpu installed.


Any and all help would be greatly appreciated!

Link to comment
Share on other sites

UPDATE: Just for kicks and giggles, I grabbed the Ati Radeon HD 4350 from my home theater pc and installed it. With npci=0x2000 it booted right into mavericks, however there appears to be no built in support for this card so I'm at 1024x768. There are tutorials on how to get it to work, but seeing as this card belongs to another system, I'm not going to go to the effort. Another odd issue I'm having is that if I want the system to run stable, I still have to use cpus=1, which is very frustrating.



Link to comment
Share on other sites

UPDATE: Just for kicks and giggles, I grabbed the Ati Radeon HD 4350 from my home theater pc and installed it. With npci=0x2000 it booted right into mavericks, however there appears to be no built in support for this card so I'm at 1024x768. There are tutorials on how to get it to work, but seeing as this card belongs to another system, I'm not going to go to the effort. Another odd issue I'm having is that if I want the system to run stable, I still have to use cpus=1, which is very frustrating.




Link to comment
Share on other sites

Thanks husaber!


Someone from another forum sent me a link to a modded TSCSync file which make everything come together. I am currently running Yosemite with all 4 cores working properly. And sleep works perfectly as well!!!


Take care!

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...