Jump to content

22 posts in this topic

Recommended Posts

Hello people from OSx86

 

I have this computer wich have Windows 8.1 installed on it, and I want to dual boot with OS X Mavericks, here is the specs:

 

Intel Core i5 2400

MB Asus P8H67

8GB RAM

320 HDD 1TB HDD

GeForce GTX 460 SC 1GB

 

I've been looking around YouTube, Google and many other places for tutorials for dual booting those operating systems, but all of them say that I must install first the OS X, then Windows on it. But I have a lot of files and settings on my Windows partition, and I don't want to lose them.

Is there a way to install OS X on my PC without formatting my Windows?

Share this post


Link to post
Share on other sites
Advertisement

this not true, if you have win installed, make a Partition to Mac os in FAT32, then make a USBinstaller with app Pandora "section downloads", now boot with the USBInstaller and when you have the screen to chose your disk to install, open Utilities/Disk utility and format the Partition Fat to  format Mac os HFS+, then install the system.When finish reboot go to desktop Mac os and install the chameleon boot loader/reboot and bingo, dual boot :yes: win/mac

Share this post


Link to post
Share on other sites

The reason why they say to install OSX first is b/c installing OSX requires your BIOS be set to AHCI mode, and could potentially make your Windows drive not readable switching from IDE mode. I'm not sure if this can happen b/c I've always installed OSX first. Also it is best to install Windows on separate hard drive from OSX; Windows is MBR and OSX is GPT. With the specs you have I believe your system is capable of dual booting, you just need a few tweaks to your motherboard BIOS to get started and of course necessary prerequisite files.

Share this post


Link to post
Share on other sites

of course, if when install the Ruindows you have installed in IDE Mode , that I not think, then  you need set  Sata to AHCI to install MAC , but if you have installed win in Sata AHCI Mode, no problem to install Mac to second Partition.


here a Guide , is for ML, but the same for Mavericks, take a look:http://www.osx86.net/topic/13590-guide-how-to-dual-boot-windows-7-mountain-lion-with-chameleon-boot-loader/

Share this post


Link to post
Share on other sites

Hello guys, I've got trouble here.

I made a partition on my Hdd, and formatted using Disk Utility from Os X installer, but When I'm almost there, the installer says that my disk must be on GUID partition table in order to continue.

But When I took a look about it, it said that I must do a complete format on my Hdd.

What now?

Share this post


Link to post
Share on other sites

It seems like you have an mbr formatted hard drive....you will need to patch your installer USB in order to complete the install -see here.

 

As others have mentioned, the "safest" option is to install OSX on its own hard drive that is formatted as full GPT (as was designed by Apple).  The Windows drive can be temporarily disconnected to ensure nothing is accidently done to it while installing OSX.

 

It is also important that your Windows is running in AHCI mode (you can convert from IDE to AHCI mode safely by following this microsoft guide) so you can easily switch between Windows & OSX.

 

@Frank Moolah, UEFI Windows X64 & newer can be installed with OSX on GPT drives with Clover bootloader.....and live very happily together but that's another story :).

Share this post


Link to post
Share on other sites

well, here a tip to solve it, you can   install the  System  to  USB Stick or a External HD Partitioned in GUID and format HFS+, then you  can clone  with  C.C.C. the external disk to your Disk/Partition in your machine, easy  :yes:

Share this post


Link to post
Share on other sites

Hello again. I wanna thank you guys for the help. I installed OS X in my HDD using the tip @fusion71au sent here, and i could get back to windows to tell all of this with the tutorial sent by @iFIRE

 

But, there are things that I still need help, like: To boot on my Mac, I must type "GraphicsEnabler=Yes" or my monitor goes no sinal, and "-x" every time, because he gets stuck at the spinning color circle. I've readed about this one, but it says that I must disable VT-D in my bios, but this option does not exist in there, Just the Vt-x, and even disabling this one, it still gets stuck. And also some drivers are missing, like the ethernet, sound and graphics card, because my screen resolution dosen't appear in there (1280x1024). And I want to know how to make my Windows partition as the default when dual boot screen appears, because my dad still does not deal so good with Mac.

 

How can I fix those things?

 

Share this post


Link to post
Share on other sites

After installing chameleon to your hard drive, you can copy over the /Extra folder from your installer USB to your hard drive and use Chameleon wizard to tweak your org.chameleon.boot.plist and SMBIOS.plist.

 

eg

 

post-846696-0-00902600-1392449739_thumb.png

 

  • GraphicsEnabler=Yes to org.chameleon.boot.plist---->to always enable chameleon graphics injection at boot
  • dart=0 to disable Vt-d
  • default partition=hd(x,y)---->to set the default partition to boot (for Windows, this is the System reserved partition and most likely hd(0,1) in your case - see post by Gringo Vermelho for more detailed explanation).

 

Have a look at beta992's installation guide for ML for some pointers to your post install - even though he uses Clover instead of Chameleon as bootloader, his dsdt and the kexts used are still applicable to your machine (a properly patched DSDT is important for a fully functional hack to enable power management, shutdown, sleep, USB etc ---->place in /Extra folder).

 

As a minimum, you need to install FakeSMC.kext in your /System/Library/Extensions folder of your hard drive with kext utility or kext wizard.

 

Note he also needed to patch AppleIntelCPUPowerManagement.kext or mod his BIOS to get speedstep & power management working (until then, need NullCPUPowerManagement.kext in S/L/E - see this post by artur-pt and PimentelX86).

 

To find kexts for non functional devices, you can run System Info App (needs internet connection to access its database but can run also in windows & linux) and determine which kexts are available for your hardware - post by Cassio.

 

If you want to dual boot using the Windows Bootloader to chainload Chameleon

This is for your dad so he still thinks it is a Windows machine :)If you use this method, don't set default partition in org.chameleon.boot.plist to boot Windows first because in this case, you want chameleon to choose OSX.

 

To dual boot with OSX using the Windows bootloader, you can install EasyBCD in Windows (link to download  http://www.softpedia...s/EasyBCD.shtml ).

1. Restore the Windows bootloader to the mbr and bootsector as shown in this guide

2. Create an OSX entry in the Windows boot menu,

  • Open EasyBCD and click "Add New Entry" button on left
  • Click on the "Mac" tab under "Operating Systems", change the name to whatever you like eg "OSX Mavericks" and then select "MBR" for mode and click "Add Entry"
  • Click on the "Edit Boot Menu" button on the left and tick which OS you want to boot by default.  The timeout option can be changed to say 3 seconds to allow reasonable time to choose which OS to boot (if different to default).  Finally click "Save Settings"

When you reboot the computer, selecting the OSX entry from the Windows bootloader should now chainload chameleon and you should now be able to boot OSX as per normal.

Share this post


Link to post
Share on other sites

Hey people, I'm back.

So, I followed those steps above, but there are things that I still need help (again):

After installing and configuring Chamaleon, I got new problems here, that when I try to boot on OS X through Chamaleon on HDD, it just restarts, forcing me to boot on Mac using my USB.

Ethernet driver is working fine, video is partially working, I couldn't install a driver for him, and the same for the audio. Also, EasyBCD worked too, but I still need video, audio and boot working appropriately.

What can I do?

Share this post


Link to post
Share on other sites

@franco

 

Can you upload the contents of your /Extra folder on the hard drive and list the kexts you have installed in /System/Library/Extensions?

 

Need to know exactly what boot options you are using and when the reboot is happening ie is it before you reach the Chameleon GUI or afterwards?  Make sure you enable at least verbose output during boot -v.

 

If you used EasyBCD to install Windows Bootloader to the MBR and bootsector, did you make sure you removed the default partition=hd(0,1) from org.chameleon.boot.plist?  This is necessary because when we choose the OSX entry from the Windows boot loader, we want chameleon to choose the OSX partition, not point back to the Windows partition and bootloader---->will create an endless loop!

 

When you select to boot OSX from the Windows boot loader, do you see Chameleon's spinning underscore, followed by the GUI?

If so, press the <Tab> key immediately and you should see a list of your partitions ---> choose your OSX partition and boot with the following options

 

-v -f GraphicsEnabler=Yes PCIRoot=1

 

If you are able to boot the Mavericks partition successfully from your installer USB, it should be a simple matter to boot it with Chameleon on your hard drive with the same boot settings.....

 

Audio: Your motherboard uses Realtek ALC887 --->use patched AppleHDA.kext with HDAEnabler1.kext from Toleda

Video:  Did you set Graphics Mode to 1280x1024x32 in your org.chameleon.boot.plist?  Maybe try NVidia Retail OSX drivers if that doesn't work?

Share this post


Link to post
Share on other sites

Hey guys! So, again, I followed the steps above from @fusion71au and now, audio is working fine!  :lol:
To fix the boot problem, I had to change the OS X setting in EasyBCD from "EFI (Default)" to "MBR". Now it boots with all my settings  :)
But... I've tried installing the Nvidia Retail OS X drivers on my system, but I got this message on the image.

 

http://imageshack.com/a/img513/9803/ubqb.png

 

What can I do now about this?

Share this post


Link to post
Share on other sites

change smbios to MacPro3,1/reboot, this change is only to install the kexts, then return to your smbios model

Share this post


Link to post
Share on other sites

you have adjust your resulution in Preferences System ? like this ? or try set to your org.boot.plist GraphicsEnabler=Yes ,  or  to No, have you repaired permissions/rebuild caches with Kext Wizard and reboot ?

 

post-333439-0-43796000-1392559931_thumb.png

 

 

post-333439-0-75838000-1392560043_thumb.png

Share this post


Link to post
Share on other sites

UPDATE: I finally could adjust my resolution!

To do that, I downloaded a program called 'SwitchResX', which helped me selecting my AOC monitor's native resolution. Take a look:

 

ksua.png

 

Thank you guys for everything  :D now this is working like a charm ;). Problem solved.

Share this post


Link to post
Share on other sites

I have installed Windows and Mavericks (with MBR patch) too but i have problem.. I have installed chameleon bootloader on partition of Mavericks but when I start my pc it autamatically boot with Windows, i can enter in Mavericks only with the usb installare.. What should i do?

Share this post


Link to post
Share on other sites

@fedemengofede,

 

If you installed Windows after Mavericks, it probably installed its own bootloader over Chameleon in the MBR.  You can install EasyBCD and create an OSX entry in the Windows boot menu as I stated in post #9.  Selecting the OSX entry from the Windows bootloader will then chainload Chameleon on the HFS partition---->boot OSX.

 

Alternatively, you can re-install Chameleon on the hard drive and use it to dual boot OSX/Windows from the MBR.

Share this post


Link to post
Share on other sites

I will try with easybcd cause I have just tried to reinstall Chameleon but it doesn't work, maybe because I made some mistake.. I have installerò Chameleon in tue osx partition, today i try with easybcd

Share this post


Link to post
Share on other sites

1. In my laptop

 

I want to dual boot windows 8.1 and mavericks in my Lenovo Ideapad y510p.

Processor : i5 / VGA : NVidia 755 & Intel 4600

I want step by step guide if possible.

Thanks in advance.

Sorry, because I don't know of what further details would be required. 

 

2. My desktop

 

I have installed windows 7 and mavericks in dual boot.

Everything is working fine except these

1. I have to force boot the hard disk, otherwise no bootable device found error is generated.

2. Resolutions can not be set.

 

 

Please help me!

Huge thanks in advance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By notacone
      These are the Original iMac17,1 Firmware 0105_B20 ACPI Tables.
      They have been extracted from the firmware file provided in 10.12.4 update, so they are clean and unloaded.
      All tables are available in hex cut/new file/paste order so they are untouched and unloaded.
      I believe these files can serve to better study Skylake architecture implementation in Sierra.
      10.12.4-10.12.6 : IM171_0105_B20-10.12.4.firmware update ACPI Tables.zip
      10.13.0+ : IM171_0110_B00 10.13.0GM ACPI Tables.zip
    • By frankiee
      Hi there, time for my first guide after asking so many things
       
      Updated for newer Clover versions and with additional instructions for more apps: gdisk and RU.
       
      So what may be overlooked sometimes in the whole boot loader discussion is the ability of UEFI to do more than just loading an OS. This is why I see ".efi" files as "apps" because in fact they just are, built on a special kind of API: UEFI. So, you can actually do stuff like editing, diagnosing, testing certain stuff at the lowest possible system level without booting to any OS.
       
      DISCLAIMER: Use this guide at your own risk! For educational purposes only! Should do not any harm, but remember you are dealing with rather low level stuff. But at least for me everything went flawless.
       
      Prerequisites:
      Working clover installation Clover Configurator or some app to edit the config.plist  
      1) Memtest
       
      This is how to install the UEFI version of Memtest with Clover:
      Download memtest, I used this link: Image for creating boot-able USB Drive Open the archive by double clicking on it. Mount the file memtest86-usb.img within by double clicking again. Now, you should see a folder named EFI in this volume, containing a folder BOOT. Open it. The files containing it are the actual app, in 32 and 64 bit versions. Think in almost all cases we want to use the 64 bit version. Now, mount your EFI partition, using Clover configurator. Create a folder named MemTest86 in the EFI folder on your main drive. Copy all files in the EFI/BOOT folder from the mounted image to your newly created folder. That ends the basic setup! Now, we add the correct Menu entry to the clover boot menu, so that we can actually start this app.
       
      Get into clover configurator, open your standard config.plist from your boot drive and go to the GUI section. Under "Custom Entries", add an entry like this:
       

       
      Please note while the path you enter is not case sensitive, you must make sure you use the backslash "\" for entering paths, and not a slash. So basically what we do is tell clover where it can find the app, give it a name, and tell clover it is a "Windows" app. Note: with older Clover versions we had to set this to "Linux", but for now "Windows" is the setting that works.
       
      If you prefer to do a manual config, add this entry to your config.plist, under GUI/Custom/Entries:
      <dict> <key>CustomLogo</key> <true/> <key>Disabled</key> <false/> <key>FullTitle</key> <string>MemTest86</string> <key>Hidden</key> <false/> <key>Ignore</key> <false/> <key>Image</key> <string>\EFI\CLOVER\themes\Icons\os_mint.png</string> <key>Path</key> <string>\EFI\MemTest86\BOOTX64.efi</string> <key>Type</key> <string>Windows</string> <key>VolumeType</key> <string>Internal</string> </dict> Now, save and reboot and you should see the newly created entry. Note that I also used a custom Icon - this is optional - in case you don't you will just see a generic windows icon instead:
       

       
      And this is how it looks like:
       

       

       
      PS: also noticeably faster and you get also more features with this version than with the older version, for example it does now write a log file. For more Information, see: http://www.passmark.com/forum/showthread.php?4315-Memtest86-Version-5-Beta-%28Pure-UEFI%29
       
       
      2) gdisk
       
      Another app you can use is the UEFI version of gdisk (aka GPT fdisk), which you can use to edit and change your partitions.
       
      Warning! Install and use this app at your own risk! If you do something wrong here you might nuke your drive(s), so only use that if you know what you are doing.
       
      This is how to do it (even easier):
      Download here: https://sourceforge.net/projects/gptfdisk/files/gptfdisk/1.0.1/gdisk-binaries/gdisk-efi-1.0.1.zip/download Mount your EFI partition Unzip the file and copy the resulting folder to your EFI Folder, so your path goes like this "/Volumes/EFI/EFI/gdisk-efi" Get into clover configurator, open your standard config.plist from your boot drive and go to the GUI section. Add an entry like this:  
      If you prefer to do a manual config, add this entry to your config.plist, under GUI/Custom/Entries:
      <dict> <key>CustomLogo</key> <false/> <key>Disabled</key> <false/> <key>FullTitle</key> <string>GDisk</string> <key>Hidden</key> <false/> <key>Ignore</key> <false/> <key>Image</key> <string></string> <key>Path</key> <string>\EFI\gdisk-efi\gdisk_x64.efi</string> <key>Type</key> <string>Windows</string> <key>VolumeType</key> <string>Internal</string> </dict> When everything went OK you should see this after selecting the respective entry in Clover:
       

       
       
      3) RU
       
      I recently found one more app that might be interesting to some, and thats "Read Universal" or in short "RU". This is a tool that enables you to debug your BIOS and read (and modify!) every imaginable data, including UEFI variables, ACPI Tables etc.
       
      Warning, again! I think blindly messing around with this app is even more dangerous, but on the other hand it gives you access to a lot of potentially interesting stuff.
      Download here: http://ruexe.blogspot.de/ The next steps are basically the same as above so make a folder in your EFI partition, copy the .EFI files and make another custom entry in your config.plist Here are some screens:
       

       

       

       
       
      So this is what you also can do with UEFI and clover. I am curious which other useful applications might exist!
       
      Anybody who knows, maybe post it here?
    • By Soeren_DK
      Hi there.
      I'm new to this site but not totally new to hack. I've had a hack since 10.4 and the latest version I ran was 10.9, not totally fixed but it worked to what I needed. Now I want to make the machine run as good as it can. I can see there has been a lot of changes/upgrades/new solutions since I installed my hack and I have a hard time to catch up.  
      I've been able to boot and install macOSX and now I need the POST installation.
      I tried to install the clover EFI boot loader with these settings:
       
      and found the DSDT.aml and SSDT-0.aml from HERE
      found the apfs.efi
      and placed it in EFI -> EFI -> CLOVER -> driver64
      and these kext in here:

       
       
      But when I boot it up this is the first bootscreen I have. No partions, no mouse control, no nothing.

      if I exit clover this screen appear.

      and now everything works. 
       
      What is wrong?
      Cheers
      Soren
×