Jump to content

Attempting Mavericks in Samsung NP550P5C

14 posts in this topic

Recommended Posts



i'm trying to install mavericks on my samsung np550p5c-s051n



I'm trying to install mac from very long time. This is first time creating forum for help otherwise i was just following others forums. 


i've tried #####, vanilla install but still no luck. So need little help.



problems i'm facing


#####: For ##### i'm following takeawaydave's forum, here is the link:




but got this error: 


system nanotime after this screen stuck and nothing happened. almost try every bootflags but still no luck.



Vanilla Installion: 


so i was trying one of Guide provided by insanelymac here is the link:





By this method still no luck. Errors errors errors.



Another attemp:


Then i do more digging. and do vanilla and takeawaydave's files combined to make hackintosh.


These are the steps i've taken:


First mount my installesd.dmg and basesystem.dmg


then restore basesystem.dmg to usb


Then del packeges link and replace it with installesd.dmg packeges folder


copy mach_kernel to usb root provided by insanelymac forum(link provided earlier)


then install chameleon boot-loader to my usb create extra folder and put smbios.plist for macbookpro9,1 and org.chameleon.boot.plist from takeawaydave's forums


i also copy his laptop dsdt.aml bcoz most of configurations of our laptops are same and kext provided by him in his forums


then something great happened. my usb get to mavericks installer without any flag graphics looks not proper but i've tried installing


everything is going great but got an error when 2 mins left.



So now here i am. please help me with this.

Laptop Full Model Name: NP550P5C-S05IN


Processor: Core i7 (3rd Gen) 3630QM 2.4 GHz with Turbo Boost Upto 3.4 GHz Cache 6 MB
MEMORY: 2* Corsair DDR3 4 GB Laptop RAM (CMSO4GX3M1A1333C9) (Total 8gb)
STORAGE: Samsung Electronics 840 EVO-Series 250GB
Screen Size 15.6 inch
Resolution 1600 x 900 Pixel
Graphic Processor: Intel HD4000 with NVIDIA GeForce GT 650M 2GB DDR3 (Optimus Technology)
Wireless WAN: Intel Centrino Advanced-N 6235

Share this post

Link to post
Share on other sites

Ok, make a Vanilla USBInstaller with the app DiskMaker x , google it, put DiskMaker x and  your app Mavericks in folder Applications of your Virtual Machine Mountain LION 10.8, run the app DiskMaker x ,   then make your USBInstaller, when you have the USBInstaller ok ,  send me PM and I make a folder Extra to your Hardware.


Share this post

Link to post
Share on other sites

Ok, here a Extra folder to your hardware, unzip and copy to root of your USBInstaller, then boot and install, report back







Edit: sory, I forget, Install Chameleon boot loader to your USB, install all default as marked

Share this post

Link to post
Share on other sites

I've tried both ways. Boot flags are not working. Same restarting problem.


Then I've tried to remove mach_kernel and try to boot with mach_kernel/ flag here I am unable to add /

Share this post

Link to post
Share on other sites

open the org.boot.plist and quit DeviceProperties, delete this string, and delete all Graphics kexts from your USBinstaller and try again, go to the chat and we talk about it, where you remove the kernel ? the flag need a space, not this mach_kernel/  the corect form is mach_kernel /, respect the space in the boot flags or not work



try this flag        cpus=1 -x -f -v GraphicsEnabler=No PCIRootUID=0 npci=0x3000

Share this post

Link to post
Share on other sites



I've tried hack install as you mentioned in chat.

Successfully install in USB

Successfully boot and install in my laptop.


But after this I'm unable to boot my HDR even my USB installer.


Getting error while booting my USB installer



Error : still waiting for root device.

Share this post

Link to post
Share on other sites

ok, try this kexts, put to Extra/Extensions from your UBSInstaller, then boot with this flag          -f -v GraphicsEnabler=No PCIRootUID=0 npci=0x3000





Still waiting.zip

Share this post

Link to post
Share on other sites

Problem I'm facing is, successfully install mavericks to my hdd.


But when restart system is unable to find my hdd.


Then If I try to boot from USB then it shows waiting for root device.


If I format my hdd partitions with Linux live CDs then same USB boot up and ready to install mavericks.



So any suggestions.?

Share this post

Link to post
Share on other sites



Need more little help properly installed mavericks by following boot flag


-x -f -v GraphicsEnabler=No PCIRootUID=1 npci=0x2000


Now Able to boot my Mac installed partition with same boot flags


Now please help me to do proper post installion.


Thanks in advance.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Install Clover in USB stick UEFI mode https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace Folder CLOVER INSTALLATION.zip   --Install System and boot with USB STICK! --Install Clover in UEFI mode and replace with my folder  Mavericks / Yosemite CLOVER Mavericks-Yosemite.zip El Capitan / Sierra CLOVER El Capitan-Sierra.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches! If you need DSDT edit... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generate in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609    --DSDT My DSDT DSDT.Asus Z97M-PLUS.zip   Patches  -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -EHCx -DARWIN -LPC -XHCI -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -HDMI -ALS0 -SHUTDOWN -LAN -PNLF --SSDT Generate your SSDT Power Management, use ssdtPRGen Piker-Alpha https://github.com/Piker-Alpha run in terminal curl -o ~/ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/Beta/ssdtPRGen.sh chmod +x ~/ssdtPRGen.sh sudo ~/ssdtPRGen.sh ssdtPRGen.command.zip
      --SSDT i74790K
      SSDT.i7 4790K.zip
      Clear NVRAM, Purge and Kextcache Olarila.command.zip   stock coolerand Rio 40º    --FakeSMC http://www.hwsensors.com/releases --Audio http://www.insanelymac.com/forum/topic/314406-voodoohda-289/ --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/304235-intelmausiethernetkext-for-intel-onboard-lan/   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
    • By GiorgioHeins
      Hello everybody, it’s been a long long time since my last post here on this forum, I’m having a lot of issues trying to activate my graphic card, the system recognizes the graphic card but there’s not full acceleration, clearly shows up its name as Intel graphics HD 3000 with only 4 MB of video ram.
      I would like to know how I could fix this problem or a least any suggestion about it. The reason I came to this site one more time is because I have no clue how to edit or patch a DSDt.aml file, I have clover bootloader and still  (seems to be easy but not for me LOL) so I don’t want to ruin the system once again.
      My configuration is
      OS macOS High Sierra 10.13
      SAMSUNG series 3 NP300E5C-A0US
      INTEL CORE i3 - 2370M 2.4 GHz
      WiFi ATHEROS AR5B95
      MEMORY 6 GB DDR3
      Wifi works *** Sound Works ***Ethernet Works*** 
      Battery indicators and trackpad gestures are not working yet.
      Thank you guys in advance, I’ll keep myself reading and searching for any kind of solution for my laptop..
      See attachment

    • By zeg66
      Please help me with this 10.9.5 system. Motherboard: Gigabyte 965p-s3 rev3.3, gpu: Ati Radeon HD6450 (dvi/hdmi/vga). 
      Using any of the 3 ports on the 6450 (dvi, hdmi, vga), I see all the white letters on black background during boot but when they complete and it's time for the graphics to start I get a black screen and sometimes a restart after that. Using Clover 4411. Is there any way to get past this?
    • By zeg66
      Could you please help me enable the VGA port on the GT710 in 10.9.5 13F34 ? 
      It is currently booting fine through its HDMI port, web driver 334.0103f01 and config.plist arguments checked: Verbose (-v), npci=0x2000, dart=0, nvda_drv=1
      The nvidia GT710 works fine through its VGA port and web drivers on a friend's Mac Pro 3,1
      I must soon return this borrowed HDMI monitor, mine only has a VGA port so I'd appreciate your input.