Jump to content
Whit3Spirit

Disabling NVIDIA Optimus card on all laptops

345 posts in this topic

Recommended Posts

Dear Mr Rehabman,

 

I request a small favour on my DSDT. I am attaching them for you to review. The problem is Nvidia graphic card disabled but I lost restart facility. Every time I need to shut down. Please help me to over come this problem.

Try calling _ON from begining of _PTS, and _OFF from end of _WAK (before the Return).

Share this post


Link to post
Share on other sites
Advertisement

Try calling _ON from begining of _PTS, and _OFF from end of _WAK (before the Return).

Thanks for instant reply. I am not that much well versed with programming. Please, if you dont mind, can you update on my DSDT. Sorry for bothering you. 

 

Thanks in advance.

 

I tried to follow your instructions, Compiler returned 2 errors

 

" 5440, 4065, Object not found or not accessible from scope (^PEG0.PEGP._ON) 

 

 

5578, 4065, Object not found or not accessible from scope (^PEG0.PEGP._OFF)".

 

I added " External (\_SB_.PCI0.PEG0.PEGP._ON, MethodObj) "

Share this post


Link to post
Share on other sites

Thanks for instant reply. I am not that much well versed with programming. Please, if you dont mind, can you update on my DSDT. Sorry for bothering you. 

 

Thanks in advance.

 

I tried to follow your instructions, Compiler returned 2 errors

 

" 5440, 4065, Object not found or not accessible from scope (^PEG0.PEGP._ON) 

 

 

5578, 4065, Object not found or not accessible from scope (^PEG0.PEGP._OFF)".

 

I added " External (\_SB_.PCI0.PEG0.PEGP._ON, MethodObj) "

No idea without seeing what you've done. Attach your edited file.

Share this post


Link to post
Share on other sites

hey man

thank you for this lovely thread

i recently treid to disable my nvidia card and i was successful but i am having sleep issues with my setup

the screen goes off , hdd off , usb off but the cpu fan still on and laptop lights (for power and wifi stays on) and i cannot recover from sleep afterwards

here is a link to my issue

http://www.insanelymac.com/forum/topic/316483-samsung-300e4a-s0esa-laptop-sleep-not-working/

hope you can help me

thanks in advance

Share this post


Link to post
Share on other sites

I have been trying this for days here is files dumped from clover with f4.  Could someone help me turn off Nvidia.  battery dies fast and laptop is running really hot.  the _OFF and _INI is in ssdt-17

 

Acer E5-575G intel HD620 i5 7200u

origin.zip

Share this post


Link to post
Share on other sites

My laptop is Acer V3-771g . 

I added only one line \_SB.PCI0.PEG0.PEGP._OFF () in the beginning of _INI under IGPU in SSDT , then the gt630m was disabled . But the laptop goes shutdown when it is restarted . After awoken from sleeping , the laptop can restart normally .

 

Adding _ON() in _PTS is of no use . I guess _ON() must be added in some where i don't know . 

Share this post


Link to post
Share on other sites

Can you help me to disabling nvidia card? i've done step by step carefully but i still have my nvidia card running. My laptop is Dell Vostro 5460 with Intel HD4000 and NVIDIA GT630M graphics. I attach my DSDT and my config.plist file also, i suspect if anything wrong in my config.plist but i have no idea what it is because i'm new in hackintosh. Thanks in advance.

DSDT.dsl.zip

config.plist.zip

Share this post


Link to post
Share on other sites

I wish to share my experience.

Dell Latitude E6430 has Intel+Nvidia Optimus and Intel can be switched off in BIOS (Optimus = disable, yeah, it switched off Intel) so Nvidia will be only videocard.

So i want to have DSDT and SSDT to be universal and working in both cases.

ACPI has simple check if ClassCode of Intel is 0x0300.

_PTS method

        	If (\_SB_.PCI0.IGPU.DCLS == 0x0300)
        	{
    			\_SB_.PCI0.PEG0.VID._ON()
		} Else {
        		\_SB.PCI0.PEG0.VID._OFF ()
		}

_WAK method

        \_SB.PCI0.PEG0.VID._ON ()

        If (\_SB_.PCI0.IGPU.DCLS == 0x0300)
        {
		\_SB_.PCI0.PEG0.VID._OFF()
	}

Comment: we need Nvidia to be working after wake if it is only card.

With this DSDT I have working sleep/wake/shutdown in both BIOS config.

 

Method _INI in the SSDT

           If (\_SB_.PCI0.IGPU.DCLS == 0x0300)
           {
              \_SB.PCI0.PEG0.VID._PS3 ()
           }


Share this post


Link to post
Share on other sites

Guys, I'm having problems with my new laptop, Acer Aspire A515-51G-70PU.

It has the NVIDIA Optimus 940MX and I've tried everything to disable it. I'm stuck at the installer boot, It hangs on "Service only ran for 0 seconds".

I'm sure it's a discrete graphics card issue... Attached are my DSDT and SSDT files that I extracted using Clover. Please, help me!

leociotti_DSDT_SSDT.zip

Share this post


Link to post
Share on other sites

Hi 

i have asus gl553vd 

when i used this patch my fan speed go to max level !! how can i fix ?/

Share this post


Link to post
Share on other sites

U36SD i5 2410M tries El Capitan with Enoch Bootloader.


-[0000:00]-+-00.0  Intel Corporation 2nd Generation Core Processor Family DRAM Controller [8086:0104]
           +-01.0-[01]----00.0  NVIDIA Corporation GF119M [GeForce GT 520M] [10de:1050]
           +-02.0  Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116]
           +-16.0  Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a]
           +-1a.0  Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 [8086:1c2d]
           +-1b.0  Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20]
           +-1c.0-[02]--
           +-1c.1-[03]----00.0  Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b]
           +-1c.3-[04]----00.0  Fresco Logic FL1000G USB 3.0 Host Controller [1b73:1000]
           +-1c.5-[05]----00.0  Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083]
           +-1d.0  Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 [8086:1c26]
           +-1f.0  Intel Corporation HM65 Express Chipset Family LPC Controller [8086:1c49]
           +-1f.2  Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller [8086:1c03]
           \-1f.3  Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller [8086:1c22]

 

I want to turn off the Optimus for beginning. I removed kext Geforce* and NV* to able to boot.

I got several dsdt from AIDA64 (acpi*.bin), Windows ACPIdump , Linux dump (tables.zip)

I am troubling finding how turn off. _REG _INI

 

My modified is dsdtmod3.dsl

 

Regards

 

acpi_dsdt.bin

acpi_ssdt1.bin

acpi_ssdt2.bin

acpi_ssdt3.bin

acpi_ssdt4.bin

acpi_ssdt5.bin

acpi_xsdt.bin

dsdt.dsl.zip

dsdt mod3.dsl

tables.zip

Share this post


Link to post
Share on other sites

Just finish editing the optimus 520m to off. and i don't need to remove geforce kext anymore also with skipnvidiagfx=yes in org.chameleon.boot.plist

 

question..

Do i really need to put m_On in PTS method?

 

 

 


    Method (M_ON, 0, NotSerialized)
    {
        If (CondRefOf (\_SB.PCI0.PEG0.GFX0._ON))
        {
            \_SB.PCI0.PEG0.GFX0._ON ()
        }

        If (CondRefOf (\_SB.PCI0.PEG0.GFX0._PS0))
        {
            \_SB.PCI0.PEG0.GFX0._PS0 ()
        }
    }

    Method (_PTS, 1, NotSerialized)  // _PTS: Prepare To Sleep
    {
       

       // M_ON()     // ...................Needed or not

        If (LNotEqual (Arg0, 0x05))
        {
            PTS (Arg0)
        }
    }

        Method (M_OF, 0, NotSerialized)
    {
        If (CondRefOf (\_SB.PCI0.PEG0.GFX0._OFF))
        {
            \_SB.PCI0.PEG0.GFX0._OFF ()
        }

        If (CondRefOf (\_SB.PCI0.PEG0.GFX0._PS3))
        {
            \_SB.PCI0.PEG0.GFX0._PS3 ()                  // no SGOF 
        }
    }

    Method (_WAK, 1, Serialized)  // _WAK: Wake
    {
        M_OF ()                           // shutdown in wake
        If (LOr (LLess (Arg0, One), LGreater (Arg0, 0x05)))
        {
            Store (0x03, Arg0)
        }

        WAK (Arg0)
        Return (Package (0x02)
        {
            Zero, 
            Zero
        })
    }

 

 

....

....

   Scope (_SB.PCI0)
    {
        Method (_INI, 0, NotSerialized)  // _INI: Initialize
        {
            M_OF ()  // Shut down when initialize computer
            Store (0x07D0, OSYS)
            If (CondRefOf (\_OSI, Local0))
            {
                If (LOr (_OSI ("Darwin"), _OSI ("Linux")))
                {
                    Store (0x03E8, OSYS)

 

....

....

dsdt.aml

Share this post


Link to post
Share on other sites

Hello,

boot Enoch

10.14 (Mojave)

You can help me prepare a file for my device DSDT

for graphics < Battery for x < 

Laptop HP 15.6'' Sleekbook Pavilion

Intel® Core™ i3-3227U .intell HD 4000 > GT 630M 1GB

but I changed my Wi-Fi card AR9285

good hack .

 

System DSDT HP 15.aml

Share this post


Link to post
Share on other sites

I need a feedback from users of ASUS KabyLake+optimus notebooks.  (ASUS FX753, GL753, GL502)

Who managed to successfully shut off nVidia and have no fan speed issues?

 

Iam able to switch optimus off , but fan goes crazy full on.

general desription in this topic:

Link

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By al3asdfmovie
      Buongiorno a tutti,
      E la prima volta che scrivo su questo forum, spero di non sbagliare nulla!
      Scrivo qua sperando che qualcuno di voi possa darmi una grossa mano, perchè ho letto di tutto, visto qualsiasi video possibile, ma non riesco proprio ad uscirne fuori.
      Ci avevo già provato 3 anni fa, ma ero riuscito solo su un notebook Sony, sul fisso non ero riuscito a fare nulla. Dicevano che c'erano problemi con i driver della serie Skylake, così ho voluto riprovare ora a distanza di anni.
      Premetto che non sono un informatico, non ho conoscenze particolari. Sono semplicemente un ragazzo che si informa, legge tutorial ed esegue, quindi chissà che la soluzione non sia in realtà una banale sciocchezza.
       
      Dunque, il problema consiste nel fatto che, in circa 8 ore di prove, non sia ancora riuscito ad andare oltre il caricamento del logo, dopo aver selezionato la chiavetta da clover.
      Sto cercando di installare High Sierra, ho provato con una chiavetta con un programma che non ho capito bene perchè, ma non posso scriverlo qui, e una con Clover Configurator (che tra l'altro, nella schermata boot mi da un'interfaccia diversa da quella che ho visto nel tutorial, o anche solo 3 anni prima), ma il problema è sempre lo stesso: dopo circa metà caricamento, o mi esce il simbolo di divieto, o si riavvia il computer, riportandomi nel boot di clover.
      Ho provato un po' di flags, come -v, -x, -s, -f, nv_disable=1 (tra l'altro, per evitare problemi al principio, ho impostato la scheda video di intel come primaria), cpus=1, dart=0, Slide=0, insomma, qualsiasi cosa leggessi in giro che avesse portato esiti positivi, la provavo
      Ho provato su porte sub 3.0, 2.0 e le 2.0 dietro al pc.
      Penso sia irrilevante, ma nel caso, sto usando una chiavetta da 32 gb.

      Nella firma dovrebbero esserci tutte le specifiche del mio PC, non so se debba postare altro. Nel caso scusatemi, ditemi pure cosa manca che la aggiorno.
      Spero davvero che qualcuno di voi possa aiutarmi. Ho un MacBook Air (High Sierra l'ho scaricato da qui) e ho scoperto quanto sia più affidabile usare Final Cut rispetto a quel bug chiamato Premiére Pro che ho usato per anni, e vorrei poterlo usare anche sul fisso, senza dover acquistare un iMac. Ho letto in giro che con Mojave non è supportata l'accelerazione grafica, per questo vorrei installare High Sierra.

      Grazie mille a chiunque vorrà aiutarmi!
    • By bounty96
      Hello there,
       
      I can't get my soundcard to work on OS X Mojave. Everything else is working. Graphiccard work, LAN work, front camera work, ...
       
      I am on a Laptop:
      Wortmann Terra Mobile 1529H, Clevo W550SU1, 15,6" WXGA (1366x768)
      Intel Haswell HM86 Chipset, Intel Core i5-4210M, Intel HD Graphics 4600
      8GB Samsung DDR3L 1600MHz Ram, Samsung 850 EVO SSD mSATA
      Toshiba SATA HDD, DVD Drive SATA
      Realtek RTL8111 PCI-E LAN Card, Realtek ALC269 Sound Card
      Intel Dual Band Wireless-AC3160 WLAN + BT (removed becouse I don't need it)
      OS X Mojave + Clover (4868) UEFI Boot
       
      Everything else which I can say about my soundcard is:
      Intel Haswell HDA Controller [8086][0C0C]
      Intel Lynx Point HDA Controller [8086][8C20] (probably HDMI sound?)
       
      Codec: Realtek ALC269VB
      Vendor Id: 0x10ec0269
      Subsystem Id: 0x15585455
      Revesion Id: 0x100100
       
      Codec: Intel Haswell HDMI
      Vendor Id: 0x80862807
      Subsystem Id: 0x80860101
      Revesion Id: 0x100000
       
      I have tried several things: Used patched AppleHDA.kext (one time a downloaded, another time I have patched that myself with Apple HDA Patcher 1.9),
      AppleHDA Enabler.kext,
       
      Lilu.kext + AppleALC.kext (but there I don't know how to use them, I have tried to inject with Clover but it doesn't work).
       
      So have anybody an idea to solve that problem (or had solved it already by himself)?
      With Lili.kext and AppleALC.kext do I have to just inject a layout-id or is there more to pay attention?
      In the github page about AppleALC.kext my codec is listet, but with many many layout-id's. I have tried like 30 or so but no solution.
       
      I dont have a audio output device at all in systempreferences. And in systemreport/extensions I see that AppleHDA are not loaded.
      I don't know what to do and hope that anybody could help me.
    • By arsradu
      Hi guys,
       
      So, this little tutorial is meant to help people fix a new issue with Mojave: opening jpg files (looks like it happens with larger files, not so much with smaller ones) using Quick Look (on spacebar key pressed) or Preview app, using the dedicated GPUs.
      The issue is that, when trying to open jpg files (for some reason, it doesn't occur with pngs), the pop-up window would remain in an endless loop. And from that point forward, any other app trying to open the same file will either become unresponsive (in the case of the Preview app) or just stay in endless loop (in case of Quick Look)
       
      As a workaround, in case the tutorial below doesn't work for you, you can use Grab (built-in app in MacOS) to open said files.
       
      This issue DOES NOT occur using the iGPU. So...if you're comfortable using the iGPU, just switch to that and you should be good to go. You don't need this tutorial.
       
      This tutorial is based on @Cyberdevs' research and testing on this topic (especially useful if you're using an RX series AMD video card), and my own very limited time testing this on my rig. I just thought it would be useful to create a new thread for it so that people can discuss this particular issue here.

       
      With that being said, I'll just move on to the actual tutorial.
       
      New (probably better) method.
       
      Switch your SMBIOS in Clover config in regards to the dedicated GPU you're using, instead of the CPU. Take a look here and choose the corresponding SMBIOS closest to your hardware.
      Yeah, that's it.
       
      In case you lose CPU PM with this method, there are multiple ways to fix that, and they do not make the object of this thread.  It worked perfectly fine for me though and I didn't need to change anything else.
       
      Alternatively, you can also try one of the MacPro SMBIOSes, such as MacPro5,1 or MacPro6,1. It was tested multiple times and it showed good results. 
      Keep in mind that choosing these will most likely not display you an iGPU in System Report, since those machines generally (probably all of them) use Xeon CPUs with no iGPUs either.
       
      A simple Lilu plugin
       
      Thanks to vulgo for the plugin and @Matgen84 for sharing and testing it, we now have yet another possible solution to this issue. It's a Lilu plugin (which means that it requires Lilu.kext in order to work) it's called NoVPAJpeg, and it can be downloaded from here.
      You use it as a regular kext, alongside Lilu. I prefer (and recommend) using it within the EFI folder, in Clover/kexts/Other. But if you want to use it in S/L/E, that should work just fine.
       
      More info can be found in this post here.
       
      In case you wanna try alternative medicine  ...
       
      The main thing we need to do is actually very simple: we need to enable the iGPU (integrated GPU) by default, in BIOS, while actually being connected to the dedicated GPU.
       
      For ATI GPUs (curtesy of @Cyberdevs' post here).
       
      The discreet GPU should be set as primary in BIOS and your displays should be connected to your discreet GPU
      The iGD/iGPU/iGFX must be enabled in BIOS/UEFI as the secondary GPU.
       
      I removed the DSDT Reconfigured the config.plist to and removed some flags which weren't needed because of the DSDT added the InjectATI + Ornioco Framebuffer (I removed the Orinoco framebuffer because of some weird glitches but it might be useful for other AMD GPUs if you inject the correct framebuffer according to your GPU. No need to inject anything for nVidia GPUs unless your GPU needs it) Added the InjectIntel + ig-platform-id for my intel HD530 (for intel HD 530 I use the 0x19120001 ig-platform-id)  
      Steps 5 to 7 might not be necessary I just did them anyway, if anyone succeeded to get quicklook working without those steps let me know so I can exclude those steps.

           Also confirmed to work with AMD R9 270X on a SandyBridge rig (without an iGPU) using WhateverGreen + Lilu kexts, which also helped to solve the transparency issue along with the Quick Look problem, it also resolved the buggy Screen Capture (Command+Shift+5) issue as well. 
       
          Also, do:
      nvram cleanup kextcache & prelinked kernel rebuild reboot  More info on that here.
       
       
      For NVIDIA GPUs
       
      This is what I needed for my NVIDIA rig and the MSI motherboard in the signature. Your milage may vary, depending on your hardware. But, the idea should be the same regardless.
       
         For MSi motherboads (check out my motherboard details in the signature)
       
      Set your BIOS to use PEG (dedicated GPU) so you can boot.
      Since you're reading this, chances are that you're already connected to the dedicated GPU and the BIOS is set to PEG. So just go into BIOS and see if you're using the iGPU or the dedicated (PEG) graphics device by default.
      If you're already using this, skip to Step 3 (the part AFTER Reboot). Reboot (I think you don't necessarily need to boot into the OS...but you do need to reboot at least until Clover UI) Reboot back into BIOS and set it from PEG to IGD (integrated graphics) WITHOUT removing the cable. Save Reboot again.  
         The result should be that the OS is tricked into thinking you're booting with the IGPU when in fact you're using the dedicated GPU.
       
         For Gigabyte motherboards
       
         Set:
      Peripherals -> Initial Display Output -> iGFX Chipset -> Internal Graphics -> Enabled
           DVMT Pre-Allocation -> default 64M.
           DVMT Total Gfx Mem -> default 256M Save Reboot  
         You should do this with the cable connected to the dedicated GPU.
       
      You will also need to patch the iGPU from Clover config.
      1. Graphics -> Inject Intel (UNCHECK Inject Nvidia or ATI if it's checked).
      2. ig-platform-id (in my case for Intel HD 4600 Desktop) it was: 0x0d220003
       
      And use IntelGraphicsFixup.kext (now included into WhateverGreen.kext) in Clover/kexts/Other. In my particular case, without the kext, I would get freezes in Safari.
       
      Another way to activate the iGPU while having the dGPU set as primary is by going into BIOS/SAG/Graphics Configuration/iGPU and setting Multi-Monitor to [Enabled], all the rest remains on [Auto], and set Inject/Intel to [True] in Clover config.*.
       
      Thanks to @gjw for the tip.
       
      *Motherboard dependent. But the multi-monitor option might be the same regardless of manufacturer.
       
       
      This might be a bug with Mojave and it could be fixed by Apple in the future. but in the meantime, feel free to use this if it helps you fix the issue.
       
      For HP motherboards (including laptops), so far no solution, unless the BIOS somehow allows to switch from eGPU to iGPU and vice-versa.
       
      Cheers!
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
×