Jump to content

2 posts in this topic

Recommended Posts

Ah well, since I didn't find a most appropiate thread to post this in, I opened a new one.


Before anything, please note, that the following work has been done on hardware, which already has been made into a Hackintosh (with myH*ck I think), but can easily adapted by experienced users to a fresh installation, as it "only" depends on the right BIOS setup, extensions and bootloader flags.


Just wanted to confirm, that a 5 display setup with the Asus X58 Motherboard, a 'new' GTX 650Ti and the totally outdated GeForce 210, which is in service already for 2 years in this machine, is possible and working more-or-less out-of-the box, assuming you do a sane post-installation as shown in this post.


The Hardware specs:

Tested with:

  • 1 x 32" Panasonic TV (HDMI)
  • 2 x 19" Medion (DVI)
  • 1 x Samsung SyncMaster (DVI)
  • 1 x Dell (VGA)

Final Variant:

  • 3 x 24" Samsung SyncMaster (DVI, 1920x1200) (on the desktop table)
  • 2 x 19" Medion (DVI, 1600x900) (above the three displays)

(5 x DVI with 2 HDMI<->DVI adapters of course)
 

 

The Software specs

Mac OS X 10.8.4

Chameleon r2286

org.chameleon.Boot.plist:

    darkwake=0
    npci=0x2000
    UseKernelCache=Yes
    EthernetBuiltIn=Yes
    GeneratePStates=Yes
    GenerateCStates=Yes
    GraphicsEnabler=No


SMBIOS.plist: SMproductname = MacPro3,1


Setup of the BIOS

Storage/HDD: AHCI
Sleep: S3
Video repost on resume: Yes

Optional: set the cpu and chassis fans to manual and then to a sane rpm value (about 900 - 1,000 for example) for a slient machine

and the other usual stuff for this board, found on the insanelymac forum or somewhere else; boot order is set to the mac disk first.

 

The tests of the Hardware

This is a machine only for serious work (programming and stuff) and NOT for gaming, so the 1GB RAM on each card is totally enough. Since the Mac OS X does NOT support "old" analog video outputs, you may only use the (in total) 2 HDMI and 3 DVI connectors.

Furthermore, Kubuntu 13 had no problem at all to use also the analog outputs together with the digital ones (so, I assume, it would even work with 6 displays, using the vga output on the gtx 650ti) and Win XP (SP3) gets stuck with only 2 displays per adapter (in total 4, but ok). Windows 7 SP1 is installed too, and I think it will be as capable as Kubuntu, so up to 6 in total, but I did not test this; right now it works with the three connected displays.

When the new/final displays arrive, I will make some nice photo for 'the proof' and attach it. Right now, to be able to work again until they arrive, it's 1 x Panasonic and 2 x Medion. I do not expect any different behaviour with 3 x 1920x1080 and 2 x 1600x900 displays, but we will see.



The Software installation (Mac):

To determine the correct configuration of Extensions and "/Extra" content, so everything is working (Network, Audio, etc.), I had some painful time, mainly consisting of booting into Safe Mode to correct things, which always took extra long, until I decided to throw all away (from the previous installtion, based on myH*ck/M*ltiB**st), and start clean again as possible, since some extensions from previous installations of M*ltiB**ast/myHack/whatever may still reside in the Extensions directory?!

I removed all extensions I certainly knew they were connected with some Hackintosh-stuff AND by the way moved some others to "/System/Library/Extensions.disabled" (yep, you would have to create that one first), such as the drivers for ATI cards, ATTO hardware, Apple iSight, AppleIntel Framebuffer, Apple Thunderbolt, etc., as they are not necessary for this machine and the test runs with the "-v" or "-f" flags for the bootloader are now a little bit faster.


In the end, it was much easier, than I feared:

  1. Install the extension FakeSMC.kext into "/System/Library/Extensions" ("S/L/E").
  2. Install a patched AppleACPIPlatform.kext (by ErmaC), which is only for this MoBo, into "S/L/E". This can be done with M*ltiB**st 5.5.5 (Drivers & Bootloaders > Drivers > System > AppleACPIPlatform Rollback > 10.6.8 Rollback) or manually
  3. Install a patched AppleIntelCPUPowerManagement.kext. This can be done with M*ltiB**st 5.5.5 (Drivers & Bootloaders > Drivers > System > Patched AppleIntelCPUPowerManagement > OS X 10.8.0 - 10.8.4) or manually
  4. Install the DSDT.aml file by ErmaC for the Asus X58 MoBo in "/Extra" and perform a small edit (with MaciASL) of the "HDEF" device: change the "layout-id" to "0x01, 0x00, 0x00, 0x00". This enables the internal audio speakers.
  5. Adjust the smbios.plist file to "SMproductname=MacPro3,1" (you can do that with Chameleon Wizard); if you should have issues with AppStore, try changing the "SMserial" or "SMboardproduct" values (search for them on the web)
  6. Optional, but maybe handy: Install the "lspcidrv.kext" (if this is necessary nowadays anyway?!) in "/Extra/Extensions" and some nice theme (with Cham. Wizard)
  7. As always after installation of Kernel extensions, run "Kext Utility 2.5.1" to re-generate the Kernel Cache and maybe use the Apple Disk Utility to repair permissions on your boot volume.
  8. Set the above mentioned settings (with Chameleon Wizard) within the org.chameleon.Boot.plist file. I think someone mentioned somewhere, that "darkwake=0" is not necessary anymore. Well, it certainly doesn't make any problems.


Maybe I forgot some detail (such as installing/patching the AppleHDA.kext with M*ltiB**ast, but this is the essential way.

Maybe steps 2.) and 3.) are not really necessary, as the DSDT.aml file may fix it all, but I'm not sure.
Someone else would have to test that. =)


Status

OK  Video
OK  Audio
OK  Network
OK  USB 2.0
??   USB 3.0 (have no hardware to test, I think; maybe I can confirm this some time later)
OK  Sleep
OK  Restart
OK  App Store
OK  Boot from Chameleon into Win XP or Win 7 on other disks

In the end quite a powerful and silent machine (due to two extra chassis fans I also got recently) for programming.


What now needs to be done is some fine-tuning within Mac OS.

For example, I installed OSXFUSE and NTFS-3G, to be able to read AND write to the Win volumes from Mac OS and so I want to mount them at startup time with commands such as:

mkdir /Volumes/WinXP && sudo mount -t ntfs-3g /dev/disk1s1 /Volumes/WinXP/
mkdir /Volumes/Win7 && sudo mount -t ntfs-3g /dev/disk2s1 /Volumes/Win7/

This would enable me to work with them as built-in HDD icons on the desktop with their correct names. Just have to figure out, how to do that exactly, since editing the "/etc/fstab" file doesn't seem to work in ML.



In Kubuntu 13 and Windows XP/7 there was no further special treatment necessary, as they would see all hardware out-of-the-box.




Happy hacking people!



A small side note: If anyone knows how to enable more than 16 Spaces in Mac OS X 10.8.4, it would be nice to tell me.

I did some digging into the private APIs of Apple's frameworks and the Dock, but in the little time i had to test this, it was not possible to program a tool to have more than 16 and I would like to have about 64 - don't ask why. But may be this will become obsolete with 5 displays and 16 spaces.

Share this post


Link to post
Share on other sites
Advertisement

So, after 50 days of actual work with the system, I can say, that it's totally awesome and very handy. There was only once a total freeze of the system, when some bug (I guess) occurred in Blizzard's game Hearthstone. The attached JPEG shows, how I arranged the monitors and, with 5 instances of VLC (on Mac OS X you have to copy the program four times), displaying 5 different Full HD episodes of Sword Art Online. All of them were running smoothly.

 

Sidenote: As always, the performance of games in Mac OS X is not as good as in Win 7, so I switch sometimes to Win 7 to play Diablo 3 or Path of Exile. I guess with a GTX 760 there would not be that much of a peformance impact in Mac OS X.

 

With some further helper utilities (TotalSpaces, SizeUp and SimpleKeys), I can now manage the total 80 screens very comfortable and move windows between them. 

 

 

In Win 7, there are no problems, except that I cannot (without extra software to buy) set a different background image for each monitor, as I did in Mac OS X (duh!).

 

 

Kubuntu 13 has no problems at all, everything is working fine.

 

 

post-1290243-0-18932000-1394127015_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By twikoffin
      Hello. My hardware is:
      AMD Athlon X2 7750 dual-core
      Gigabyte NVIDIA 8400GS 512MB ( [VGA] ,HDMI,DVI)
      Motherboard Gigabyte based on NFORCE without AHCI support (only IDE)
      I have successfully installed Mac OS Yosemite, Mavericks and El Capitan with AppleNFORCEATA.kext
      But I can't use it with Mac OS 10.8, don't know why, it just gives error and my internal HDD's are not appearing in Disk Utility.

       
         
    • By NyssSun
      Hello everyone, as you can see in the title, I'm having problems with the graphics driver card (I think).
      Because when I log in for example, the screen start showing to me like some blank lines and then they go away.
      I think it could be some problem related to drivers, but when I go to (Apple Icon), About this Mac it told me the right graphics card, Gigabyte 210 1024MB.
      What could I do to solve this problem ?, when I browse in the internet it happens those glitches in my screen.
      If you want the specifications of my computer are these:
      HP Compaq 8000 elite sff
      Intel Core Duo E7500
      Gigabyte GeForce 210
      4GB RAM 1333MHz
      Thank you for all your help, regards.
       
    • By kevang
      Hello and happy new year everyone,
       
      I have been trying to get my "old" computer running completely on Sierra for a few weeks now (before Christmas).  I had been on Snow Leopard for 6 or 7 years.  Was a fast setup then.  Will build new rig in next couple months...  anyhow.
       
      I have a stable running Sierra.  No freezes, have internet, sound, video.  Have 2 issues main issues;
       
      Issue 1 - Clover cannot detect Windows 10.  Clover cannot auto-boot.
      > Sierra is on SSD
      > Windows 10 & Snow Leopard are on different partitions of WD 2TB HDD
      > Connected to Intel SATA 0, 1, 2, 3 slots
      > Upon boot, Clover only displays the 2 apple drives; OS X Sierra & Recovery (does not auto boot)
      > Here's the strange thing.  When I navigate to EXIT CLOVER, Clover resets/refreshes/reboots.  Now it can see all the attached drives.
      > From here, I can select Windows or Sierra.  Not the best experience.
       
      Issue 2 - OS X does not shut down.  
      > So many people that have this issue.  On Shutdown, screen goes black, systems just hangs.  
       
      What I've tried.
      > Pressing F2 at First Clover boot (the 2 drives) and also on second iteration (all drives displaying).  This shows the preboot.log.  Seems the first time, Scanning doesn't work for some reason.
      > I have attached preboot1 and reboot 2 for context.
      > Clover Configurator - I have selected FixShutdown and Halt Enabler in ACPI.  Doesn't do anything for Shutdown.
      > Scan is set to Legacy.  Timeout set to 3 seconds.  
      > DefaultBootVolume set to LastBootedVolume
       
      Attached
      1. 2 screens; Volumes from Finder / the 2 screens from Clover.  
      2. preboot logs
      3. config.plist
       
      So many thanks for anyone willing to take a look and help me troubleshoot.  Been tinkering over 2 weeks now.
       
      ~Eric


      config.txt
      preboot1.txt
      preboot2.txt
    • By hornpipe2
      I have a Mac Mini 2006 (upgraded) with Intel GMA950 graphics, running MLPostFactor 10.8.5.  It is connected to an ASUS VS197 LCD panel using DVI-D.  This is natively a 1366x768 panel that is recognized and works fine.
       
      However, the other choices for resolution are 4:3 800x600 and 1024x768, and then the oddballs 832x624 and 1360x768.  None of these are useful as a low-resolution widescreen for gaming or watching DVD content.  Specifically I want to get access to 848x480 or 854x480, and also 1024x576.  SwitchResX makes these choices available, but it doesn't work with a "full screen" game, presumably because the game directly queries OSX Display to get a list of valid resolutions and SwitchResX is bypassing that system instead.
       
      So the solution is obvious: buy a new computer pull the monitor's EDID data, hack it to enable new resolutions, and then tell OSX to use this custom EDID instead of the one retrieved from the monitor.
       
      Following the steps of the EDID injection guide, here is where I am:
       
      * Retrieve EDID, DisplayVendorID etc from ioreg.
      00 FF FF FF FF FF FF 00 04 69 F2 19 24 94 00 00 31 16 01 03 80 29 17 78 EA F5 45 A4 55 50 9E 27 0F 50 54 BD EE 00 81 C0 01 01 01 01 01 01 01 01 01 01 01 01 01 01 66 21 56 AA 51 00 1E 30 46 8F 33 00 9A E6 10 00 00 1E 00 00 00 FD 00 32 4B 18 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 41 53 55 53 20 56 53 31 39 37 0A 20 20 00 00 00 FF 00 43 43 4C 4D 54 46 30 33 37 39 32 34 0A 00 F1 * Use an EDID editor to enable new 848x477 and 1024x576 resolutions.  (Verify with an online EDID tool, and compare to the previous version)
      00 FF FF FF FF FF FF 00 04 69 F2 19 24 94 00 00 31 16 01 03 80 29 17 78 EA F5 45 A4 55 50 9E 27 0F 50 54 BD EE 00 81 C0 4B C0 4B CA 4B CF 61 C0 61 CA 61 CF 01 01 66 21 56 AA 51 00 1E 30 46 8F 33 00 9A E6 10 00 00 1E 00 00 00 FD 00 32 4B 18 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 41 53 55 53 20 56 53 31 39 37 0A 20 20 00 00 00 FF 00 43 43 4C 4D 54 46 30 33 37 39 32 34 0A 00 47 * Create a new subfolder and plist within /System/Library/Overrides/Display/ containing the new EDID string and monitor name.
      * Reboot.
       
      Now the problems begin.  Even though the plist file is being read (which I know because the Monitor Name has changed in Displays), the custom EDID is not being used.  When I dig into IORegExplorer I am able to come up with AAPL00,EDID string and it is the unmodified one read from the monitor.  I even tried a plug-and-unplug while OSX is running, and also tried to reset the SMC and NVRAM, but no dice.
       
      Do I need to start digging into DSDT hacking?  Is the Intel driver pulling down EDID during boot and I need to override it somewhere else?  What am I missing here?
    • By DaniiSwan
      Hello,
       
      I've been attempting for the past few days to install OS X Mountain Lion on my Lenovo Thinkpad Edge E530 with little success. So much so that I've finally decided I'm probably out of ideas and created this forum post requesting help.
       
      My Laptop Specs are:
       
      Intel Core i3-2328m (Sandy Bridge CPU at 2.2GHZ with support for SSE2 , SSE3 and SSSE3)
      8GB RAM
      500GB Hitachi Z7K500 HDD
      Lenovo 627226G Motherboard (Intel HM77 Chipset)
      Intel HD Graphics 3000
       
      More Detailed Specs ---> https://drive.google.com/open?id=0B-GXUa1I8xyDZU1SdklDSlhER2c
       
      So far , I've attempted to install iAtkos ML2 and ML3U via USB and so far both have worked up until the first sighting of the apple logo then the laptop restarted. In both cases , I was using a separate USB with chameleon bootloader on but in the instance where I tried to use the onboard bootloader on ML3U , I hit enter and the screen simply remained black.
       
      Any help would be much appreciated
       
      Thank you for your time.
×