Jump to content
Benny-Danny

[Ajuda] Qual OSx instalar?

48 posts in this topic

Recommended Posts

Olá!! Sou novo no mundo do hackintosh. Posso dizer que percebo algumas coisas de computador pois montei o meu computador actual (e já lhe fiz uns upgrades) e instalo SO e programas sem problemas.. mas, antes de avançar com uma instalação hackintosh, gostaria de esclarecer umas dúvidas que tenho.

 

Já experimentei o system info e, de acordo com o resultado, parece que os meus componentes são compatíveis.

Se puderem, veja a imagem que anexo para confirmar.

 

Após analisar a imagem, a minha pergunta é:

 

Qual é o OSx mais recomendado (e de preferencia o mais recente possível) que posso instalar na minha máquina?

 

Actualmente tenho o windows 7, e tenho 4 discos independentes (não são partições) ligados a funcionar. Posso manter o windows 7 à mesma a funcionar?

 

O que vou precisar (software, passoas a dar, etc) para poder correr o OSx no meu computador actual?

 

Agradecia ajuda nesta área pois hackintosh não estou mesmo nada à vontade.

 

Se encaminharem-me para outros sites/posts/tópicos, por favor não o façam para algo inglês pois o meu inglês é muito mau..

 

Se eu estiver a fazer alguma coisa de errado com este post, por favor digam-me.

 

Aguardo informação.

 

Obrigado desde já!

post-1288219-0-50191000-1389916433_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

Olá

 

Primeiramente, Bem-Vindo, espero que você possa futuramente contribuir com a nossa comunidade.

 

Pelo teu hardware eu recomendo você instalar o Mountain Lion... Não sei se o Mavericks irá rodar sem modificação com esse teu CPU, mas o ML já é bem atual

 

Tem como fazer dual-boot, tri-boot e até quadri-boot com OSX, mas eu sempre recomendo ter um HDD proprio para o OSX quando se é iniciante na coisa.

 

Aqui no fórum português existem diversas áreas e tópicos que vão te auxiliar, esse é muito bom: http://www.insanelymac.com/forum/topic/284026-pos-instalacao/

Existe google tradutor caso você tenha que enfrentar um tutorial em inglês

 

Leia as regras: http://www.insanelymac.com/forum/index.php?app=forums&module=extras&section=boardrules&id=3

 

E fazer um hack requer: paciência, leitura e muita vontade.

Share this post


Link to post
Share on other sites

@PimentelX86

 

Obrigado pela tua ajuda desde já. Espero, sinceramente, conseguir obter conhecimentos suficientes para poder ajudar.

 

Li com atenção os links que colocas-te, inclusive as regras, mas existem muitos termos que são novos para mim, e então algumas coisas ainda são muito confusas.

 

Portanto, já tenho uma pen 8GB com o ficheiro raw escrito usando o SUSE Studio Image Writer, e já fiz download do Clover (zip contendo ficheiro *.pkg)

 

Então, eu tenho vários discos rígidos. Vou reservar o de 200GB apenas para o OSx, penso ser suficiente.

Segundo percebi, agora é arrancar com o pen e instalar o OSx, certo? Isso não vai causar logo conflito directo com o windows 7 que tenho no outro disco? É melhor desligar o disco do windows ou não há problema?

 

Entretanto, já estou a procurar os *.kext para os meus componentes, antes de tentar instalar o OSx...

 

Alguma coisa me falta, ou por enquanto, estou a fazer as coisas mais/menos bem?

 

Cumprimentos!

Share this post


Link to post
Share on other sites

para evitar problemas com o sector de arranque "boot" de win 7, te recomendo que para fazer la instalaçao de MAC OS X desconecta o disco de win primero, logo quando tiver Mac Instalado  i  arancando desde o disco que instalaste, podes reconectar win i tendras la opcion de dual boot

Share this post


Link to post
Share on other sites

Olá

 

É nesse caso é só arrancar com o pendrive e instalar...

 

Clover é um bootloader bem complexo, o mais dificil dele é configurar o config.plist... por isso recomendo que você escolha o Chameleon que é bem mais fácil

Donwload: http://www.insanelymac.com/forum/files/download/59-chameleon-22-svn/

 

Eu tenho 2 HDD como já percebeu pela assinatura, eu instalo o OSX com os 2 HDD conectados na mobo, eu não retiro o HDD do Windows, deixo os 2 lá, mas se tu quiser evitar problemas... faz o que iFire te disse.

 

Lembre-se que um hack não é feito somente de kext a maior parte é somente configuração a única realmente necessária é a FakeSMC

Share this post


Link to post
Share on other sites

@PimentelX86

 

Obrigado pela tua ajuda desde já. Espero, sinceramente, conseguir obter conhecimentos suficientes para poder ajudar.

 

Li com atenção os links que colocas-te, inclusive as regras, mas existem muitos termos que são novos para mim, e então algumas coisas ainda são muito confusas.

 

Portanto, já tenho uma pen 8GB com o ficheiro raw escrito usando o SUSE Studio Image Writer, e já fiz download do Clover (zip contendo ficheiro *.pkg)

 

Então, eu tenho vários discos rígidos. Vou reservar o de 200GB apenas para o OSx, penso ser suficiente.

Segundo percebi, agora é arrancar com o pen e instalar o OSx, certo? Isso não vai causar logo conflito directo com o windows 7 que tenho no outro disco? É melhor desligar o disco do windows ou não há problema?

 

Entretanto, já estou a procurar os *.kext para os meus componentes, antes de tentar instalar o OSx...

 

Alguma coisa me falta, ou por enquanto, estou a fazer as coisas mais/menos bem?

 

Cumprimentos!

 

ta tudo certo, faça o que o iFire falou, alem de ser mais seguro é mais facil, eu já fiz isso e sempre deu certo.

 

agora uma recomendação minha.

 

Seria melhor para começar, usando o Chameleon, o Clover é bom, mas fica melhor quando tudo está configurado, seus HDs com dualboot funcionado e tudo mais, dai sim pode passar a usar o Clover.

 

Fica a dica.

Share this post


Link to post
Share on other sites

Olá!

Obrigado pelas dicas.

 

Segui a sugestão do iFire e desliguei os outros discos, deixando apenas um. Consegui iniciar a pen USB e abriu o menu de instalação do OSx. Mas, estranhamente, ele reconhece os discos no menu de arranque, mas quando vou para instalar, apenas aparece a flash drive usb como "possível" drive de instalação.

Anexo foto.

 

Vou então utilizar o Chameleon, seguindo o vosso conselho de ser "mais fácil" pois é isso que eu preciso para iniciar-me neste mundo.. coisas fáceis de momento. Mas, por enquanto, não consigo selecionar a drive para instalar (a de 200GB). Liguei todas as drives para ver se me apareceria alguma disponível para instalação, mas nada.

 

Abraço!

post-1288219-0-32168600-1389968460_thumb.jpg

Share this post


Link to post
Share on other sites

Olá

 

O que tens que fazer é escolher o pendrive para dar boot, pois é a partir dele que irá chegar na tela de instalação...

Você não deve escolher o HDD que irá querer instalar o OSX, mas sim o pendrive....

 

Quando chegar no instalador é que irá particionar o HDD que quer instalar o OSX... lembrando que a tabela tem que ser GUID e o formato Mac OSX Reg.Cronologico

Share this post


Link to post
Share on other sites

Olá

 

O que tens que fazer é escolher o pendrive para dar boot, pois é a partir dele que irá chegar na tela de instalação...

Você não deve escolher o HDD que irá querer instalar o OSX, mas sim o pendrive....

 

Quando chegar no instalador é que irá particionar o HDD que quer instalar o OSX... lembrando que a tabela tem que ser GUID e o formato Mac OSX Reg.Cronologico

Olá!

 

Sim, eu fiz isso.. depois aparece o idioma de instalação para escolher, aparece o "contrato" e por fim, aparece um menu para escolher onde instalar o OSx. É aí que não me aparece nenhum dos HDD, apenas a usb drive na qual, claro, não posso instalar o OSx.

Share this post


Link to post
Share on other sites

tenta criar um Penboot com o Chameleon.

 

ou se está usando a imagem do Olarila, antes de iniciar pressione a tecla 1, e tente dar boot com o Chameleon.

 

Segundo percebi, o Chameleon não é um programa para correr em OSx? É que se assim for, não consigo executar pois só tenho windows.

 

Olá

 

Tem que fazer algumas configurações na Bios... Ajustar o Modo Sata para AHCI é o básico...

 

Outras configurações: http://olarila.com/forum/viewtopic.php?f=2&t=1804

Ajusta o quer der para ajustar.

Já havia lido esse link e configurado a BIOS no "possível", no que dava para ajustar. No entando, o problema persiste.. aliás, no menu da BIOS inicial, onde lista os discos todos, tenho uma opção onde diz "Sata: IDE" e só me aparece a opção SATA. Quanto ao ACPI 2.0 support e ACPI APIC support, esses estão activados.

Share this post


Link to post
Share on other sites

Olá

 

O Chameleon não é um programa é um bootloader.

 

Você diz que só tem a opção IDE?

 

Tenta apertar 1 e mudar para o Chameleon quando der boot no pendrive e um cursor estiver piscando

 

Sim, só aparece a opção IDE. Okay, quando chegar a casa vou experimentar mudar para o chameleon. Obrigado desde já pela vossa atenção.

Share this post


Link to post
Share on other sites

ok estamos ai.

 

enquanto a instalação não sai, vai lendo as meterias que te foram recomendadas, isso vei te ajudar bastante.

 

mas você já está começando bem, não desista.  ;)

Share this post


Link to post
Share on other sites

Tu controladora es JMB 363  SATA/IDE , por esto no tienes la opcion de AHCI en la bios i o Instalador no ve tu disco quando quieres instalar, usa  um de estes dois injectores , que deve sulucionar este problema, copias en S/L/E de tu USBInstaller o em Extra/Extensions, boot com

 

-f -v npci=0x2000 GraphicsEnabler=No

 

 

 

JMB363 SATA -IDE.zip

Share this post


Link to post
Share on other sites

Obrigado.. tenho passado a tarde inteira a ler e ler.. algumas coisas fiquei esclarecido, outras, cada vez mais confuso.. Penso que tem que ser passos pequenos de cada vez.

 

Agora, vou tentar seguir todas as vossas soluções, mas, antes, visto a minha BIOS não estar a dar para alterar para AHCI (isto porque, segundo pesquisei, parece não ter alguns problemas na BIOS), vou flashar uma BIOS alterada (custom) que permite a alteração de IDE para AHCI. Depois, configurar logo o windows 7 para arrancar em AHCI e ver se os discos estão todos a funcionar com esse método. Após isso, mais uma vez, vou tentar o processo normal que tentei até agora. Caso não dê resultado, vou tentar as soluções apresentadas e depois apresento feedback.

Share this post


Link to post
Share on other sites

Olá

Modificar a Bios pode resultar em muitos problemas, como o mal gerenciamento de energia devido as modificações nas tabelas DSDT e SSDT

Tenta atualiza-la... talvez em uma atualização mais recente a opção AHCI seja integrada...

Share this post


Link to post
Share on other sites

Olá! Já consegui instalar e iniciar o OSx. Mas, infelizmente, não consigo colocar a internet a funcionar, e já corri o chameleon mas não consigo colocar o bootmanager a funcionar, preciso sempre da USB flash drive para iniciar o OSx.

 

Se eu consegui-se colocar a internet (ethernet RJ45) a funcionar talvez fosse mais fácil...

Share this post


Link to post
Share on other sites

Olá

O que fizestes para conseguir instalar?

Fazer um hack é fazer as coisas por parte e tudo tem seu tempo.

Primeiro vem a instalação do bootloader Chameleon.

Depois se cria a pasta Extra na pasta HD
Dentro dessa pasta Extra deve ser criado 2 arquivos principais, crei com ajuda do app Chameleon Wizard:
*org.chameleon...
*SMbios


Instala a kext FakeSMC com ajuda do app Kext Wizard e ativa P e C States

Depois ativa a tua gráfica, ta aqui um guia: http://olarila.com/forum/viewtopic.php?f=2&t=716

Share this post


Link to post
Share on other sites

Olá PimentelX86

 

Para instalar, como disse, usei uma BIOS (pois não havia nenhuma mais recente oficial). A bios que tenho suporta AHCI, mas, por defeito, não dava para alterar de IDE para AHCI, então tive que flashar uma alterada e aí depois, utilizando o Chmeleon (tecla 1, como disseram).

 

Vou então tentar instalar o bootloader.

 

Mas, segundo esta notícia, supostamente a minha placa já vem com suporte por defeito no OSx, certo? http://appleinsider.com/articles/11/03/24/expanded_gpu_support_in_apples_mac_os_x_10_6_7_hints_at_future_mac_hardware

 

Cumprimentos.

Share this post


Link to post
Share on other sites

Olá

 

Suporte por defeito? Não entendi isso...

 

O que posso te dizer é que a tua gráfica já tem suporte, mas é preciso ativa-la de certa forma, por isso te dei o guia... para que saiba ativar a tua gráfica.

 

Sobre a mobo... posso te dizer que tu irá ter efeitos colaterais por modifica-la, mas isso é só vendo no futuro próximo.

 

Te concentra em configurar as coisas... instala o Chameleon via pkg o processo é automático e evita muita dor de cabeça.

Share this post


Link to post
Share on other sites

Olá,

Sim, pensava de ser suporte por defeito no âmbito de já estar activado, ser ter que fazer nada, mas pelo que percebi, não é bem assim.

 

Já li e reli cerca de 5 vezes o tópico sobre as kext da placa gráfica mas continuo sem entender o que é realmente preciso fazer para activar a gráfica.

 

Pelo que percebo, é preciso 3 kext e, no meu caso, tendo uma ATI Radeon HD 5670, preciso dos ATI5000Controller, ATISupport e ATIRadeonX5000, certo? Já sei qual é a minha Vendor ID e Dev ID (0x100268D8).

 

Sei que depois tenho que adicionar o vendor id e dev id na linha IOPCIMatch. Mas não sei de qual dos kext tenho que fazer isso.

 

Por fim, sei que tenho que instalar esses 3 kext. Isto foi o que eu percebi.. Mas, para mim, o tópico é muito complicado pois está a usar uma linguagem avançada demais para mim. E também tentei procurar na internet esses 3 kext e não consegui encontrá-los. Talvez esteja a procurar no local ou com os nomes errados.

Share this post


Link to post
Share on other sites

Olá

 

Olha, eu nunca tive gráfica ATI e por isso nem sei como ativa ao certo... pelo que percebi é necessário adicionar o DevID e o VenID nas 3 kexts que alias já estão no OSX e não precisa baixar nada...

 

Veja qual é a kext que controla a tua gráfica e tente entender... até sinto por não poder te dar maiores informações.

 

Boa sorte!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By DOGER92
      Hi guys, I'm new to the world of Hackintosh. I write in this section because I have a problem with the graphics card of my laptop. As far as I understand from the web, it is not possible to use a dedicated graphics card on a laptop. So I'm trying to use the integrated processor one. The problem is that I have tried various procedures seen online, but in spite of this I cannot solve the problem. If you need this is the equipment of my laptop:

      Asus VivoBook Pro 15 N580VD-FI038T

      Screen: Led 15.6” 16:9 (Ultra HD 3480x2160).
      Chipset: Intel HM175.
      Cpu: Intel Core i7-7700HQ (2.80 GHz / 3.80 GHz, 4 core, 6 MB CACHE L3).
      Graphics Card: INTEL HD Graphics 630 + NVIDIA GeForce GTX 1050 4 GB GDDR5.
      Hard Disk: SSD M.2 512 GB SATA 3.0 + SSD 750GB.
      Ram: 32GB DDR4-2666.
      Audio: audio stereo Harman Kardon.
      Webcam: webcam HD with integrated headphone.
      Lan: Intel LAN 10/100/1000, Wi-Fi 802.11ac (2x2), Bluetooth 4.2.
      USB: 2 x USB 2.0, 1 x USB 3.0, 1 x USB 3.1 Type-C Gen 1, 1 x HDMI, 1 x LAN RJ-45, 1 x jack
      Slot: 1 x SD.

      I hope there is someone who can help me with this problem
    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By Georgiles
      Laptop: Asus Vivobook F510UA
      CPU: Intel Core i5-8250U
      Graphic: Intel UHD 620
      Wifi: Intel Dual Band Wireless-AC 8265 (no kexts for intel wifi) :(
      Card Reader: Realtek_CardReader(RTL8411B_RTS5226_RTS5227)
      Camera: ASUS UVC HD 7.Audio: Conexant Audio CX8050
      Touchpad: ELAN1300
       
       by parkrypto: thank you tctien342 for the amazing guide.
       
      https://github.com/tctien342/Asus-Vivobook-S510UA-High-Sierra-10.13-Hackintosh
       
      Ebayed the laptop for $290 + tax = $350
      added: 16gb RAM + existing 8GB = 24GB          Timetec Hynix IC 16GB DDR4 2400MHz PC4-19200 Non ECC Unbuffered 1.2V CL17 2Rx8 Dual Rank 260 Pin SODIMM Laptop Notebook Computer Memory Ram Module Upgrade S Series (16GB)     
      added: cheap wifi         TP-Link USB Wifi Adapter for PC N150 Wireless Network Adapter for Desktop - Nano Size Wifi Dongle Compatible with Windows 10/7/8/8.1/XP/Vista Mac OS 10.9-10.15 Linux Kernel 2.6.18-4.4.3 (TL-WN725N)     
      added: NAND 1TB Internal PC SSD https://www.amazon.com/gp/product/B073SB2MXT/ref=ppx_yo_dt_b_asin_title_o01_s01?ie=UTF8&psc=1
      Gadget Reviews upgraded too, video: https://www.youtube.com/watch?v=39EquX5PTkQ
       
      I just installed. Everything works fine. I'll test final cut pro, premiere pro with 4k footage and get back with you on performance. 
      For now moves like a performant Mac book pro. 
      I installed Catalina first but I could not make the Intel UHD 620 Graphics get proper QE/CI. 
      Mojave is just fine. I want to use this system for quick video editing on the go.
      Geekbench in my signature.  
      If you need any files or have any questions pls ask.
       






      asus f510u mojave.zip
    • By JoelChris
      Hi guys! I really need help right now.
      So I've just updated my Hackintosh to Catalina 10.15.3 with these following specs,

      Z390 Designare
      Core i9 9900k
      RX 590 Nitro + 8gb Gold Edition
      32 GB ram of Corsair RGB Pro

      After the update, I tried to boot and it's a black screen after loading.
      I also have recently updated the WEG and Lilu, but there's nothing new. It's still stuck with a black screen.

      I have attached my Clover below..
      CLOVER.zip
      Please help and Thankyou so much!
×