Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
tragediana150

[AMD] General Chat, Questions & Answers

116 posts in this topic

Recommended Posts

You have either not set AHCI in the BIOS to Enabled or the boot order is not set correctly. put in the BIOS to AHCI Enabled! put your USB stick or your external HDD to the first place in the BIOS.

-_-

Share this post


Link to post
Share on other sites
hello there mavericks is working on my amd the issue is that it hangs without -f (still waiting for root device) tried totallyfixstillwaiting.kext did not helped, tried kext utility repair permissions, did not worked

 

any thoughts?

 

Are you booting with npci=0x3000 or npci=0x2000?

Share this post


Link to post
Share on other sites

Which kernel do you recommend for FX8350 + Nvidia 560 GFX ?

Not sure your motherboard since you have not filled out your signature but I may have a similar system. Asus Sabertooth 990fx v2 + FX-8350 @ 4.5ghz and SLI EVGA GTX 580 SC's. I was able to install and run with the BSA_kernel v9. I installed 10.9 and then updated to 10.9.1 with no problems. I used the kernel only as the supplied system.kext would not let me boot with 10.9 or 10.9.1.

Share this post


Link to post
Share on other sites

You have either not set AHCI in the BIOS to Enabled or the boot order is not set correctly. put in the BIOS to AHCI Enabled! put your USB stick or your external HDD to the first place in the BIOS.<br /> -_-

 

 

Are you booting with npci=0x3000 or npci=0x2000?

Thank you for your replays.

 

Yes ahci is set on bios, im using npci=0x3000 

Share this post


Link to post
Share on other sites

hi guys, my amd usb not working.some body  told me need to patch dsdt how to do that. now i am using amd kernel rc9 >restart working .shutdown not working.no pink icon .thanks 

Share this post


Link to post
Share on other sites

Ok, so I know this isn't really kernel related, but I just had to share this info: 

 

If you have a jailbroken iPhone, you can download a tweak called Remote Messages 2 for iOS 7, which will allow you to use your browser as a front end remote for your messages app.  Finally, iMessage from my desktop LOL  :)

 

6D59S.png

Share this post


Link to post
Share on other sites

Ok, so I know this isn't really kernel related, but I just had to share this info: 

 

If you have a jailbroken iPhone, you can download a tweak called Remote Messages 2 for iOS 7, which will allow you to use your browser as a front end remote for your messages app.  Finally, iMessage from my desktop LOL  :)

 

6D59S.png

I think there is a way to have it running almost natively....

 

Just need help from one of the awesome dev's....

 

BACKGROUND INFO:

 

There was an app made for Android that worked on sending iMessage and what they would do is Middle-Man the conversation forwarding it from a Mac Mini and therefore getting auth working as it seemed to come from a vanilla kernel

Share this post


Link to post
Share on other sites

Hey Guys,

 

need some help in installing OSX 10.9 on my system.

Specs:

AMD Phenom II x4 965 BE

Gigabyte GA-790XTA-UD4

8GB RAM

Radeon HD5850

 

I tried Installing OSX via MyHack and used the BSA R9 Kernel by copying the new mach_kernel on my usb flash drive.

 

Results:
-v      --> Restart

-x -v      --> Stuck at PCI configuration begin

npci=x2000 -x -v     --> Graphic Glitch when Apple Logo appears + stuck

GraphicsEnabler=NO npci=x2000 -x -v     --> OPEMU: UD2 in an endless loop

 

now Im thinking about switching to another kernel..
Any recommodations or ideas how to get this work?

Thanks
Rischi

Share this post


Link to post
Share on other sites

Hey Guys,

 

need some help in installing OSX 10.9 on my system.

 

Specs:

 

AMD Phenom II x4 965 BE

Gigabyte GA-790XTA-UD4

8GB RAM

Radeon HD5850

 

I tried Installing OSX via MyHack and used the BSA R9 Kernel by copying the new mach_kernel on my usb flash drive.

 

Results:

-v      --> Restart

-x -v      --> Stuck at PCI configuration begin

npci=x2000 -x -v     --> Graphic Glitch when Apple Logo appears + stuck

GraphicsEnabler=NO npci=x2000 -x -v     --> OPEMU: UD2 in an endless loop

 

now Im thinking about switching to another kernel..

Any recommodations or ideas how to get this work?

 

Thanks

Rischi

take another kernel, either R7 or R8 or look under downloads, boot with these boot flags: -v -f npci=0x2000 (or npci=0x3000) PCIRootUID=0 (or PCIRootUID=1) usekernelcache=NO GraphicsEnabler=No (or graphicsEnabler=Yes)

Share this post


Link to post
Share on other sites

Thanks 

but it didnt worked for me

 

I used this kernel: AMD 10.9.x BRONYA release version 7

 

with bootflags -v -f npci=0x3000 PCIRootUID=1(and 0) usekernelcache=NO GraphicsEnabler=No

 

Im getting to install menu but when I start the install process Im getting an error
For understanding a picture of the error massage here:

 

https://dl.dropboxusercontent.com/u/227630669/2014-02-10%2021.36.35.jpg

 

Share this post


Link to post
Share on other sites

sorry, but the image is not clear on what problems you have.
did you have done the BIOS settings correctly ==> USB stick to the first postion
and AHCI Enabled
uninstall all unnecessary hardware and the Windows HDD (NTFS)
if you should made ​​the top spots, then renewed install the USB stick with the current MyHack app and install the Chipset driver to Extra/Extensions then start your system with the boot flags you made previously

Share this post


Link to post
Share on other sites

Hello, folks!

 

Worth to see: http://rampagedev.wordpress.com/2014/02/08/amd-support/

 

Another developer is now committed to AMD hackintoshing, this time by providing high-quality post-installation solutions. Anyone that can help him will be doing a great service for all AMD OSX86 users.

 

All the best!

Share this post


Link to post
Share on other sites

@Spakk

 

I've made ahci enabled,
USB Stick at first for Boot,
Unplugged all USB devices except Mouse and Keyboard
and disconnectet all hdds and disc drives which are not necessary
Got only one HDD left with 3 partitions but whithout an install of windows; only Data partitions

I have already renewd the usb stick with myHack but it still didn't worked

About the Chipset Driver:
Where do I find those?
Looked for them several times but wasnt able to find them

 

Thans again for your help!

Share this post


Link to post
Share on other sites

@Spakk

 

I've made ahci enabled,

USB Stick at first for Boot,

Unplugged all USB devices except Mouse and Keyboard

and disconnectet all hdds and disc drives which are not necessary

Got only one HDD left with 3 partitions but whithout an install of windows; only Data partitions

 

I have already renewd the usb stick with myHack but it still didn't worked

 

About the Chipset Driver:

Where do I find those?

Looked for them several times but wasnt able to find them

 

Thans again for your help!

I'm not clairvoyant. we need details from your hardware, create a signature from your hardware. then install the SystemInfo.app, which is available for windows, linux and Mac OSX, launch the app and make a picture and upload it here, then we can help you :)

Share this post


Link to post
Share on other sites

in a few days ago.. i've tried to install Mountain Lion in Amd Phenom 1 in DFI Lanparty board, i used Bronya kernel.

never success to boot in to setup, always KP with display error in IOACPIFamily. any suggest for my..?! thanks before. :(

Share this post


Link to post
Share on other sites

Take a picture of the kernel panic, then we can help you better

Share this post


Link to post
Share on other sites

The best part is when you make update on Mavericks

Share this post


Link to post
Share on other sites

The best part is when you make update on Mavericks

I will install Mavericks separately. Does Kepler cards work with Mountain Lion?

Share this post


Link to post
Share on other sites

The best part is when you make update on Mavericks

 

 

 

 

OK! any good guide for installing Mavericks? I have a Kepler GPU GTX 650Ti

Share this post


Link to post
Share on other sites

 

 

thank you,

 

I saw it a different way, it would not be easier to create an iso / dmg bootable, which allows precise customization (kernel / kext) hardware concerned with a well-described method that would allow everyone to make their own distro , the same would greatly help the coders for their travails huge kernel compilation and would target better the real problems traveling indirectly related to the kernel because many people often confuse the issues kernels and Extension kext unsuitable, in my case, I made test cores with a Pentium D, as my successive freezes fail to see the real cause of KP blames the kernel but there was nothing, I realized that corecrypto asked me problem with another kernel quite by chance .

 

make an iso / dmg, but it's still easy to make it bootable, it's another thing I've never managed with the tools OS X Disk Utility.

 

I was well on the preboot but then it did not want, I let the matter drop

 

 

Annuler les modifications

 

 

thank you

 

pretty !! but this involves a DVD, would prefer a bootable iso or dmg

 

 

euh ??

 

no DVD bootable , dmg bootable ;)

 

 

@gils83, and others

 

The project which I was working on will create bootable ISO images using bash scripts. These can then be burned to a CD or used directly. These will be directly usable with VMWare and Virtualbox using Chimera bootloader. It has all the necessities for El Torito booting via ISO and as a result a CD.

 

The plan is to normalize it's dependencies, and provide a more generic boot loader. From this installer you should be able to have a simple guide, simple set of customizations. And also the guide/knowledge on how to change the installer to extend it to your own needs. As an open source project the issue tracker and pull request feature, will allow others to make contributions. (read up on gitflow and github if your not sure how this works).

 

A bit of patience and I will have something ready for this community ^_^

 

 

 

Replying to old work. To make a bootable iso with Chameleon (TESTED)

sudo hdiutil makehybrid -o Custom.iso “/path-to-contents” -iso -hfs -joliet -eltorito-boot "/path-to-contents/usr/standalone/i386/cdboot" -no-emul-boot -hfs-volume-name “Custom” -joliet-volume-name “Custom”
** Please note that sometimes Chameleon cdboot stores in /usr/standalone/chameleon/cdboot

 

UNTESTED DMG

sudo hdiutil makehybrid -o Custom.dmg “/path-to-contents” -hfs -eltorito-boot "/path-to-contents/usr/standalone/i386/cdboot" -no-emul-boot -hfs-volume-name “Custom”

Share this post


Link to post
Share on other sites

Duran Keely , yes it is create for only bootloader ! But no DVD , because permissions is other , and problem loading from creating DVD!

 

I create video and you will understand ! ))

Wait ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    •   Thank you Baio77. Here is my CLOVER folder and the Hack info. 
            For Some Reason I can't upload my CLOVER folder. But here you can download...
      https://www.dropbox.com/s/vjprxs1idtj9pt7/CLOVER.zip?dl=0     Thank you again!!!   HackInfo_Report.zip
    • The brightness is NOT from Sierra, in my signature you find tools with which to give info on your system .....
      Post Hack Info and the clover folder ......
      Only in this way can I help you ......
    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  


×