Jump to content
Sign in to follow this  
Followers 0
YungRaj

USB Sound Card and VoodooHDA have same problems

24 posts in this topic

Recommended Posts

I have posted in the chat about this problem, and since it didn't get solved I am going to bring it to the forum

USB Sound Card = http://www.amazon.com/Channel-External-Sound-Audio-Adapter/dp/B007HISGRW/ref=sr_1_3?ie=UTF8&qid=1389232335&sr=8-3&keywords=USB+Sound+Card

Audio Device = Realtek ALC892

 

 

OS: Mavericks 

Bootloader: Chameleon

BootFlags before attempts to fix: npci=0x2000 busratio=20 GraphicsEnabler=No

BootFlags after: -F amd_kernel busratio=20 npci=0x2000 GraphicsEnabler=Yes AtiConfig=Putoro

 

Note: The USB Sound Card works fine on Other OS'es, including Windows 8 and Ubuntu 12.04

 

When I reinstalled Mavericks on 10.9.1 from 10.9 using Bronvoka's kernel http://www.osx86.net/files/file/3657-amd-fx-109-mavericks-kernel-nvidia-work/)

 

I was using my USB Sound Card at the time, and then after a while it would start to crackle noise. It wouldn't work right, it would play sound on and off

After I while I just used Mavericks without the USB Sound Card plugged in, and I would go about my business.

One day I just plug it in as a last resort to getting it to work. It starts working! Only unless I try to restart chrome after attempting to play music.

It was working fine until I wanted to roll back to 10.9.

 

I tried rolling back to 10.9 using the same kernel, this time it was the same thing but way worse.

 

The USB Sound Card would not play sound right with any quality, having the same clicking and popping and whatnot noise. When I started to look at the videos I was playing the music in, the video would terribly lag. I knew this wasn't normal, since I have a very powerful card.

 

So what someone of the support chat of this website said was to try to install VoodooHDA.kext.

 

So I did.

 

I finally got the kext working, getting it to notice the audio device, etc etc

 

When I tried playing music or any of the sounds on the system, SAME THING AS THE USB SOUND CARD

 

Crackling, popping, sounds sounding like it was bad connection to the device, but really not..

 

 

Again I tried getting help on the Support chat, and they suggested since I have an AMD Radeon Graphics Card, that might be the issue

 

I tried GraphicsEnabler=Yes, and I would get a memory allocation error (because I have an AMD Processor)

 

 

 

 

 

WHAT I ALSO TRIED IS USING A NEW KERNEL (http://wiki.osx86project.org/wiki/index.php/Patched_Kernels)

Andy V's kernel for 10.9  The second on the list for 10.9 (http://www.insanelymac.com/forum/files/file/173-109-kernel-xcpm-free/)

 

 

So what I tried doing is manually adding in my own set of boot flags

 

 

I TRIED WITHOUT NPCI and that led me to a white screen 

 

I tried everything in The ATIConfig, and Putoro led me to a successfull boot BUT NOT WITHOUT THE NPCI FLAG (0x2000)

 

 

 

After I thought that would let me be able to play sound properly, but AGAIN Putoro AND GE set to Yes would NOT GET MY USB SOUND CARD OR VOODOO WORKING

 

 

I tried playing with Mid AUDIO SETTINGS (especially setting to 414000). Not work 


I need some way to get one working because I think the problems in the quality of the output of sound are related..

 

 

And I believe the problems might be Graphics related but I am not sure

 

 

ANY HELP IS APPRECIATED.

Share this post


Link to post
Share on other sites
Advertisement

"Crackling sound after a while" usually indicates a timing issue.

On PCs running OS X, removing forced IRQs from your DSDT usually fixes this.

Ignore the headline (slow data transfers are another symptom) and follow the advice given here.

Share this post


Link to post
Share on other sites

Okay, first you need to actually ascertain if it is indeed something that needs a DSDT fix and if then, what fix does it need. Does the crackle happen more of then at any particular time?

 

Maybe it happens more when the mouse moves (IRQ clash with GPU), or when the system is under load, or when the HDD is being used heavily (Kext issue with IOPCI I think).

Share this post


Link to post
Share on other sites

...

 

Just remove the forced IRQs from the DSDT and see if it helps, it's a simple edit, it's not like you need to take programming classes before you can do it. It's really no harder than editing a text document.

 

If it doesn't help, it certainly won't do any harm, and you'll learn something along the way.

 

Extract and open your DSDT in a DSDT editor, use the search function in the editor to find the devices (HPET, TIMR, RTC and so on) mentioned in the topic that I linked to, find the forced IRQs and remove them.

 

If you run into trouble with that (like compiling errors) I or someone else will help you right here.

Share this post


Link to post
Share on other sites

I see you have an AMD cpu. Try to simply disable C1E Support in BIOS. This helped with my sound issues, except for the static noise, still working on that one.

Share this post


Link to post
Share on other sites

I already have C1E Disabled in my BIOS..

 

I will have to try editing my DSDT. But in order to do that, I need to start doing my own researching on how to do it.

Share this post


Link to post
Share on other sites

Right so I have the editor running so do I copy the code from the article into the section where it is and then just replace the code with what is in the article?

Share this post


Link to post
Share on other sites

No, that's not going to end well!

 

You find the corresponding code as it is in your own DSDT and remove the forced IRQs.

 

Use the navigator to the left to run through the code and find the HPET, RTC, TIMR (etc) devices.

 

You can try searching for them by name...but they might not have the same name..

Share this post


Link to post
Share on other sites

DSDT Editor has a search function, use it

 

Also, not methods, devices. You're looking for devices.

 

Device (HPET), Device (PIC), Device (TIMR), Device (RTC). See? it's not complicated.

 

The names used in your DSDT might not be the same.

 

Identify those devices and simply remove (example):

IRQNoFlags ()
{2}

All you need to do is remove the forced IRQs. Do not under any circumstances copy anything from the article. Those code snippets are just examples. They're not for you to use. You must edit your own.

 

Look more closely at the "Before" - "After" code examples in the article (ignore the HPET for now). You will notice that they are completely identical. Except the code that I listed above was removed.

So don't copy anything. Just remove the forced IRQs.

 

It's really very simple, the hardest part is identifying the devices mentioned, if they aren't named exactly the same as in the examples given.

Share this post


Link to post
Share on other sites

So I search in the device for IRQ and delete

 

IRQNoFlags{}

{2}

?


In HPET IRQFlags is added


And hey I don't have the RTC0 and TMR devices listed in my DSDT editor.

Share this post


Link to post
Share on other sites

Yes, for the devices mentioned in the guide. I repeat: Your devices may be named differently. If you can't match by device name, try matching something else....look for a device that looks exactly the same..

 

{2} is just an example, it can also be 8 or another number.

 

Better to just put "IRQNoFlags{}" in the search box and see what pops up. Then click "Next" to find the next instance.

 

Try removing the forced IRQs from your HPET device, the point is letting OS X figure out which ones it wants to use. This usually works better.

Share this post


Link to post
Share on other sites

Hehe. Just extract your DSDT again the same way you did before!

 

Then zip it and attach it here (use the full editor to attach files). I'll do the edits for you... you can lose your virginity by hacking something else later.. :P

Share this post


Link to post
Share on other sites

First save, then compile.

 

The copy the resulting dsdt.aml to /Extra and you're done.

 

If there is a problem (which there shouldn't be) with booting, then you can type DSDT=none at the Chameleon boot prompt to skip loading the DSDT.

 

I advise that you keep a copy of your clean, unmodified DSDT - if you extract your DSDT after booting with the modified DSDT loaded, you will (surprise) extract the already modified DSDT.

 

EDIT

 

Really? You had no compiling errors??

Share this post


Link to post
Share on other sites

You ignored my question about your serial port, I'm going to assume that you're not using it.. them.. looks like your board has two...

 

Your original DSDT is an ACPI table that's part of your BIOS. We are overriding this table with dsdt.aml.

Chameleon loads dsdt.aml so that OS X sees the contents of this file instead of your DSDT ACPI table, which is safe and sound and can be extracted again whenever you want, there are various methods.

 

One of which is to boot without loading DSDT.aml :)

 

Here it is with serial ports and PS2 devices removed.

I also removed the forced IRQs from the HPET that you left in and fixed a ton of compiling errors.

dsdt.aml.zip

 

Share this post


Link to post
Share on other sites

It was worth a try I think. Leave this one in /Extra, either way it's better for OS X use than it was before we edited it.

 

Disable PS2 mouse/keyboard and serial ports in your BIOS.

 

If you can disable floppy drive and parallel port, kill those too.

 

Make sure your HPET is set to 64-bit if such a setting is available, also in the BIOS.

Share this post


Link to post
Share on other sites

I think it's related to your patched kernel. Study the topic linked below, see if anyone else has the same problem. Also there might be a better kernel available.

I can't help you any further, I haven't used a patched kernel since I ran Leopard 10.5 on my Pentium 4 several years ago.

I know there are kernel flags that help with timing issues but I don't remember anything anymore, besides there might be lots of new stuff that I don't know about either.

 

Go here: http://www.insanelymac.com/forum/topic/281450-mavericks-kernel-testing-on-amd-formerly-mountain-lion-kernel-testing-on-amd/

 

Leave the BIOS settings like I told you and use the DSDT that I patched, I know it didn't improve your sound situation but for other potential issues what we have done here is better than how it was before.

 

Good luck.

Share this post


Link to post
Share on other sites

I figured out my issue, my busratio was not set properly. I just turned that boot flag off and then it worked!

Share this post


Link to post
Share on other sites

I'm using clover high current seems fix mic make noise.

this problem happened when I use ATR4600 mic and iGrado Headphone at same times on Syba SD-CM-UAUD USB Stereo Audio Adapter, C-Media Chipset, RoHS.Seems like it's Syba SD-CM-UAUD USB Stereo Audio Adapter, C-Media Chipset, RoHS's bug.only plug ATR 4600 on Syba SD-CM-UAUD USB Stereo Audio Adapter, C-Media Chipset, RoHS doesn't have noise,but have pop.the HS-100B does not have this problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By shinho73
      Can someone help me fix reboot issue? Actually it reboots, but sometimes the hackintosh just hangs with screen off. Here is the Extra folder containing org.chameleon.boot.plist. https://drive.google.com/drive/folders/1MX8-DpQk9kaRUfjPcToxf-ElWh-bN6EY?usp=sharing  and the spec of the PC. https://drive.google.com/drive/folders/1NlcUNK5DBzJFxeFeuyt92eRjQqwO5T32?usp=sharing Can someone look at it? I might be doing something wrong. Any help will be greatly appreciated. Thank you. 

    • By shinho73
      I need a good vanilla guide for AMD A8 7600 with A58M-E FM2+ mother board and Palit GEforce GT 730. Any help will be greatly appreciated. Thank you.



    • By Coddyx
      Hi,
       
      I followed the AMD OSX Vanilla Guide and managed to successfully build my first hackingtosh.
      Everything works great EXCEPT for my MSI - Radeon RX 580 8 GB GAMING X.
      I ran some benchmarks (and tried World of Warcraft) and I am getting ~50% of the performance I am usually getting in Windows 10.
      Unigine Heaven reports ~950 vs 1750 in Windows and World of Warcraft runs @ 30 fps lowest settings vs 60 fps ultra settings in Windows.
       
      Here are the kexts I am using:
      AppleALC Lilu NullCPUPowerManagement RealtekRTL811 VirtualSMC WhateverGreen  
      I should mention that this is an AMD hackingtosh running on Ryzen 5 1600 3.2 GHz 6-Core Processor.
       
      I read and I completely understand that I should not expect 100% performance. But I believe a 50% drop is out of the ordinary.
       
      If anyone has ideas on what I could try to up the performance it would be greatly appreciated.
       
      Thank you!
       
       
    • By vlgngrbrdmn
      Hey all,
       
      This is my first time posting to this forum.
       
      Here is my problem: My main issue is random freezing of my display (i.e. cannot move my mouse) and nothing being displayed after my monitors go to sleep (i.e. lock my screen, wait a few minutes, try to move mouse/type on keyboard. My displays wake up but display "no signal"). I have to reboot in order to use my Hackintosh again.

      Another issue that I am experiencing is that, every time I reboot my system and login initially, my right and left vertical displays do not display correctly until I turn one of them off and back on again. It is kind of hard to describe what is wrong, but basically the dimensions of the display and the orientation (horizontal vs. vertical) is wrong, and my mouse does not display in the correct place on the screen.

      Either way, after some research it looks like this all may be due to my Framebuffer being incorrect. However, I am having a hard time trying to determine whether that is the case and, if so, how to fix it.

      I did manually try to add a Framebuffer ("Kamarang") into my config.plist below, however that did not seem to make a difference.

      Any help with this would be much appreciated! Also, please let me know if I should upload anymore information.

      Currently, My setup consists of 1 Dell U3415w and 2 Dell 2415 monitors in an "H" configuration (both 2415s setup vertically on either side of the U3415W).

      This is all being powered by a SAPPHIRE Radeon RX Vega 64 (https://www.newegg.com/Product/Product.aspx?Item=N82E16814202326) with each monitor plugged via a DisplayPort.

      I am currently running the latest version of macOS Mojave, 10.14.4.

      I am also using the latest version of the Clover boot loader (4920) with the following kexts located in kexts\Other:
      AppleALC.kext AtherosE2200Ethernet.kext Lilu.kext USBInjectAll.kext VegaTab_64.kext VirtualSMC.kext WhateverGreen.kext My config.plist file contains the following:
      ?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>#DisableDrivers</key> <array> <string>CsmVideoDxe</string> <string>VBoxExt4</string> </array> <key>ACPI</key> <dict> <key>DSDT</key> <dict> <key>Fixes</key> <dict> <key>FixHPET</key> <true/> <key>FixIPIC</key> <true/> <key>FixRTC</key> <true/> <key>FixShutdown</key> <true/> <key>FixTMR</key> <true/> </dict> <key>Patches</key> <array> <dict> <key>Comment</key> <string>change XHCI to XHC</string> <key>Disabled</key> <false/> <key>Find</key> <data> WEhDSQ== </data> <key>Replace</key> <data> WEhDXw== </data> </dict> <dict> <key>Comment</key> <string>change XHC1 to XHC</string> <key>Disabled</key> <false/> <key>Find</key> <data> WEhDMQ== </data> <key>Replace</key> <data> WEhDXw== </data> </dict> <dict> <key>Comment</key> <string>change SAT0 to SATA</string> <key>Disabled</key> <false/> <key>Find</key> <data> U0FUMA== </data> <key>Replace</key> <data> U0FUQQ== </data> </dict> </array> </dict> <key>DropTables</key> <array> <dict> <key>Signature</key> <string>DMAR</string> </dict> <dict> <key>Signature</key> <string>MATS</string> </dict> </array> <key>FixHeaders</key> <true/> <key>SSDT</key> <dict> <key>Generate</key> <dict> <key>PluginType</key> <true/> </dict> </dict> </dict> <key>Boot</key> <dict> <key>Arguments</key> <string>keepsyms=1 dart=0 debug=0x100 shikigva=40</string> <key>DefaultVolume</key> <string>LastBootedVolume</string> <key>Timeout</key> <integer>5</integer> </dict> <key>BootGraphics</key> <dict> <key>#DefaultBackgroundColor</key> <string>0xF0F0F0</string> <key>EFILoginHiDPI</key> <integer>1</integer> <key>UIScale</key> <integer>1</integer> </dict> <key>CPU</key> <dict> <key>#BusSpeedkHz</key> <integer>133330</integer> <key>#FrequencyMHz</key> <integer>3140</integer> <key>#HWPEnable</key> <true/> <key>#HWPValue</key> <string>0x30002a01</string> <key>#QPI</key> <integer>4800</integer> <key>#SavingMode</key> <integer>7</integer> <key>#TDP</key> <integer>95</integer> <key>#TurboDisable</key> <true/> <key>#Type</key> <string>0x0201</string> <key>#UseARTFrequency</key> <true/> </dict> <key>Devices</key> <dict> <key>Audio</key> <dict> <key>Inject</key> <integer>1</integer> <key>ResetHDA</key> <true/> </dict> <key>Properties</key> <dict> <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,ig-platform-id</key> <data> AAASGQ== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> </dict> </dict> <key>USB</key> <dict> <key>FixOwnership</key> <true/> </dict> </dict> <key>GUI</key> <dict> <key>Hide</key> <array> <string>PREBOOT</string> </array> <key>Scan</key> <dict> <key>Entries</key> <true/> <key>Linux</key> <true/> <key>Tool</key> <true/> </dict> </dict> <key>Graphics</key> <dict> <key>FBName</key> <string>Kamarang</string> <key>Inject</key> <dict> <key>ATI</key> <false/> <key>Intel</key> <false/> <key>NVidia</key> <false/> </dict> <key>RadeonDeInit</key> <true/> </dict> <key>KernelAndKextPatches</key> <dict> <key>KernelPm</key> <true/> <key>KextsToPatch</key> <array> <dict> <key>Comment</key> <string>Port limit increase</string> <key>Disabled</key> <false/> <key>Find</key> <data> g710////EA== </data> <key>InfoPlistPatch</key> <false/> <key>MatchOS</key> <string>10.12.x</string> <key>Name</key> <string>com.apple.driver.usb.AppleUSBXHCI</string> <key>Replace</key> <data> g710////Gw== </data> </dict> <dict> <key>Comment</key> <string>Port limit increase (RehabMan)</string> <key>Disabled</key> <false/> <key>Find</key> <data> g32IDw+DpwQAAA== </data> <key>InfoPlistPatch</key> <false/> <key>MatchOS</key> <string>10.13.x</string> <key>Name</key> <string>com.apple.driver.usb.AppleUSBXHCI</string> <key>Replace</key> <data> g32ID5CQkJCQkA== </data> </dict> <dict> <key>Comment</key> <string>Port limit increase (PMHeart)</string> <key>Disabled</key> <true/> <key>Find</key> <data> g/sPD4MDBQAA </data> <key>InfoPlistPatch</key> <false/> <key>MatchOS</key> <string>10.14.0</string> <key>Name</key> <string>com.apple.driver.usb.AppleUSBXHCI</string> <key>Replace</key> <data> g/sPkJCQkJCQ </data> </dict> <dict> <key>Comment</key> <string>Port limit increase (Ricky)</string> <key>Disabled</key> <false/> <key>Find</key> <data> g/sPD4OPBAAA </data> <key>InfoPlistPatch</key> <false/> <key>MatchOS</key> <string>10.14.x</string> <key>Name</key> <string>com.apple.driver.usb.AppleUSBXHCI</string> <key>Replace</key> <data> g/sPkJCQkJCQ </data> </dict> <dict> <key>Comment</key> <string>External Icons Patch</string> <key>Disabled</key> <false/> <key>Find</key> <data> RXh0ZXJuYWw= </data> <key>InfoPlistPatch</key> <false/> <key>Name</key> <string>AppleAHCIPort</string> <key>Replace</key> <data> SW50ZXJuYWw= </data> </dict> </array> </dict> <key>RtVariables</key> <dict> <key>BooterConfig</key> <string>0x28</string> <key>CsrActiveConfig</key> <string>0x67</string> <key>MLB</key> <string>C02601270QXGPF7FB</string> <key>ROM</key> <string>UseMacAddr0</string> </dict> <key>SMBIOS</key> <dict> <key>BoardSerialNumber</key> <string>C02601270QXGPF7FB</string> <key>ProductName</key> <string>iMac17,1</string> <key>SerialNumber</key> <string>C02R2HZDGG7L</string> <key>SmUUID</key> <string>91E0E343-A938-4117-BBC7-234EA3ED265E</string> </dict> <key>SystemParameters</key> <dict> <key>InjectKexts</key> <string>Yes</string> <key>InjectSystemID</key> <true/> </dict> </dict> </plist> Also, for what it is worth, sleep is disabled on my system:

      Again, thank you all for taking time out of your day to help a fellow hackintosher out!
×