Jump to content

[Help] Sleep Problem and VGA for Mavericks


10 posts in this topic

Recommended Posts

Hi :D

I've just Installed Mavericks (10.9.1 from scratch) on my Sony Vaio S, and with some researches and asking, I got the graphics working (Intel only, because I have Nvidia Optimus, which is unsupported by mac) HDMI only, and sound (HDMI/Mic/Head/Front) and battery % (all theses using DSDT patches, and a big thanks to Mirone for the sound fix, and the other devs for there patches -RehabMan- for VoodooPS2 and battery patch).

Everything is working well but w/out sleep.

In fact, if when I close the lid, the computer enters sleep mode, my green indicator goes from green to orange, the problem is when I open the lid and the system tries to wake up, the orange light goes green and then the computer turns off, and nothing on the screen, I tried to make the computer goes to sleep from the Apple menu: same issue.

If I have any USB key (especially storage devices) I can't get it to sleep, and the computer turns off just after the orange light, as the USBs prevent it from going to sleep so it wakes up.

Generally, when the computer tries to wake up, the indicator goes green and then off.

The other "issue" is that I can't find any port (HEX digits) to enable VGA port, I've got HDMI only (and sound works as well), well if there is any. :/

And thank you :D



AICPI is patched by Clover

Using SSDT generated by 

No NullCPU

No SleepEnabler (gives me KP)

Using GenericUSBXHCI.kext, and I have 2 USBs 3.0 and 1 USB 2.0 controlled by the same controller (intel)

LPC is running natively and RTC is being patched by Clover (even if RTC patch isn't needed because I don't get CMOS resets)


Note: If you need any files, just ask me, but here is my DSDT (w/ Audio/IGPU/Batt patches) :)


Link to comment
Share on other sites

You do patch USB3 Intel in DSDT for working sleep, see this: http://www.insanelymac.com/forum/topic/287901-how-to-get-intel-7-series-usb-30-fully-working-step-by-step-guide/

Sorry for my english

Normally, the OP says that you may install GenericUSBXHCI.kext instead of the DSDT patch, so maybe, this wont fix anything. But thank you anyway :D

Link to comment
Share on other sites

Hmmm... i know my system won't sleep without usb3 dsdt patch, try and see if all work well

Newly sorry for my bad English

I tried to patch the thing using what the OP said, I couldn't (since I don't know how to patch DSDT w/out the .txt file :P ) copying these lines gave me a lot of errors and a bunch of warnings, so I tried the patch from this post and it seem to get AppleXHCI kext to work, but still didn't fix the sleep, I removed GenericXHCI to see the result.

What should I do now?

I want to precise that when the computer goes to sleep, the light changes to orange (normal) but when I click it turns green and then off (black, no light in the button) and it takes less than a second : click->green light->off->the PC turns on again as if it was forced to power off.

Link to comment
Share on other sites


  • Create New...