Jump to content
About Just Joined group Read more... ×
CicciMTS

[Guide] iAtkos s3 v2 Snow Leopard 10.6.8 on Acer Aspire One D150

9 posts in this topic

Recommended Posts

Inception

After my experience with iAtkos s3 v2 and Acer Aspire One D150 i decided to write a guide can help someone.

 

Hardware Config:

This is the hardware configuration of my Acer Aspire One D150-1Bb. It's very important check the components.

CPU: Intel Atom N270 @ 1,6Ghz 32-bit
RAM: Corsair 2Gb
Video: Display Intel 945GSE
Wireless: Broadcom4312
Ethernet: Atheros AR8121

 

Whats is necessary

1. USB Pen 8Gb

2. Ethernet Network

3. An other Hackintosh o Mac

4. Many patience.

 

Pre-Install: Boot from USB

After you download the iAtkos s3 v2 (Snow Leopard 10.6.3) ISO you can restore it on USB at least 8Gb. You can do it with another Mac or Hackintosh, or if you have external DvD reader, you can create a DvD to boot.

Restore the ISO of iAtkos with Utility Disk and then you must install the bootloader.

The only one that works for me it was Chameleon v2 RC4.

 

Pay attention where you install the bootloader!

Chameleon 2.0 RC4.zip

After that the iAtkos is ready to install.

 

Installation

The BIOS

Put the USB before start the PC. On Start push F2 to access to BIOS where we need to set the Hard Disk in SATA Mode.

So, from "Information" tab slide to "Main" tab and scroll down to "SATA Mode". Set it on "AHCI". After that slide to "Boot" tab and scroll down to USB HDD, pushing F6 take the usb on the first place. Now save all with F10 and Yes. 

The USB will boot.

 

The Installer

I don't write flag on boot for the installation, if you have some problems you can try with verbose (-v).

 

During the installation the trackpad will not work, but the keyboard yes, so you can use a USB Mouse (mine is a wireless mouse, so i suppose they works).

 

With Utility Disk create the partition e go on with the installation. When you select the partition where you want install iAtkos, go on Customization (button on bottom left - I'm Italian, so my label is different).

 

You need to install:

 

Bootloader: Chameleon v2 RC4 (the others bootloader gives to me only problems)

Bootloader Options: GraphicsEnabler, USBFix

Patches: /Extra directory, fakesmc, Disabler, RTC, Modified Kernels -> Intel Atom, USB, UUID

Main Hardware

  SATA/IDE: AHCI SATA, Intel SATA/IDE

  Audio: Voodoo Audio

  PS/2: Voodoo PS/2

  CPU Power Management: select all

  Laptop Hardware: Battery, Card Reader, TSC Sync

VGA: Intel (select the first three voice)

Network:

  Wireless: don't select anything. Bcm4312 card gives to me some problem during the first boot, so we will install it after.

  Wired: Atheros (Select all)

 

Now you can install iAtkos s3 v2.

 

Post-Install: il primo avvio

Try one first boot without flag on boot, if you can't start try with these:

-v -f npci=0x2000 arch=i386 cpus=1 GraphicsEnabler=No(o Yes)

Follow the first boot and the configuration of your account and now download all necessary files for setting up the aspire one, because after that you can have some USB problems.

Now reboot.

 

Because the CPU is an Intel Atom we need to use a modified kernel. You can find here ( here the original post) the atom kernel of Snow Leopard 10.6.8 . More or less i followed the post step by step, skipping some step about SL 10.6.7. 

 

IT'S VERY IMPORTANT do a backup of the kext IOUSBFamily.kext e IOUSBMassStorageClass.kext that are necessary to work the USB after the update, that replaces this files.

 

What you have to do:
 

1. Download and unzip the kernel on Desktop

2. Start Terminal.app and write this

sudo -s
mv ~/Desktop/mach_kernel_atom /
cd ~/Desktop
mkdir backup
cd /S*/L*/E*
cp -R AppleHDA.kext ~/Desktop/backup/
cp -R IOUSBMassStorageClass.kext ~/Desktop/backup/
cp -R IOUSBFamily.kext ~/Desktop/backup/

Now you can start the update ONLY FROM COMBO UPDATE (you can find here). IT'S VERY IMPORTANT that, when update finish: NOT reboot.

 

3. Back on Terminal and write

cd /S*/L*/E*
rm -Rf AppleIntelGMA950.kext
rm -Rf AppleIntelIntegratedFramebuffer.kext
rm -Rf AppleHDA.kext
cp -R ~/Desktop/backup/* ./

4. Delete SleepEnabler.kext

 

On my installation the "Extra" folder was hidden, so with ShowHiddenFiles.app you need to show it.

ShowHiddenFiles.zip

Delete SleepEnabler.kext from /Extra/Extensions*.

 

*(If you don't find SleepEnabler.kext on /Extra/Extensions search it on /Sistema/Libreria/Extensions)

 

What you need to do if you forget to delete SleepEnabler.kext

Probably the system go on Kernel Panic because SleepEnabler.kext, so try this flag

pmVersion=0 or 21 or 23 

and when you can remove SleepEnabler.kext

 

 

 

5. Restore USB kext

 

We put "backups" folder on S/L/E (/System/Library/Extensions) folder so copy IOUSBFamily.kext and IOUSBMassStorageClass.kext and paste it on /S/L/E.

If you not have a backup there is mine:

USB Fix 10.6.8.zip

Repair permissions with KextUtility.

 

6. Edit kernel on boot.plist

On my Extra folder i don't have any org.chameleon.boot.plist, so i edit com.apple.boot.plist on /Library/Preferences/SystemConfiguration.

Copy the file and past it on Desktop, then open it with TextEdit.app, changing:

<key>Kernel</key>
<string>custom</string>

to

<key>Kernel</key>
<string>mach_kernel_atom</string>

PAY ATTENTION about you write. For a wrong word the system doesn't boot  :D

Check that the value 

<key>USBBusFix</key>
<string>Yes</string>

is in the file.

Now save and copy com.apple.boot.plist in  /Library/Preferences/SystemConfiguration replacing the older. [if you want you can copy it also on  /Extra]

 

If you want:

You can create org.chameleon.boot.plist copying the text of com.apple.boot.plist and you can create the smbios.plist file with Chameleon Wizard to put it on /Extra.

 

6. Now you can reboot.

 

First boot after Update to 10.6.8

Now we not have any VGA driver, so:

1. from the backup folder restore the AppleHDA.kext on /System/Library/Extensions.

2. unzip the VGA drivers:

3438-GMA950 for 10.zip

and put all files on /S/L/E/.

3. Repair the permissions with KextUtility.app

4. Reboot.

 

Wireless

 

1. From SLE copy IONetworkingFamily.kext and past it on Desktop.

2. Now put it on /Extra/Extensions. (Don't skip the copy on Desktop or you can have permissions problem)

3. Unzip the driver Broadcom

Broadcom43XXFamily.kext.zip

and put it on /Extra/Extensions

4. Repair permissions

5. Reboot 

 

 

Issues

Trackpad: After the repair of USB and reboot the trackpad doesn't works, so i fixed it with this pkg VoodooPS2Controller.pkg.zip

 

USB recognized by System Information but not mounted: You need to restore IOUSBMassStorageClass.kext (at the end of topic) and IOUSBFamily.kext, both of kext.

 

At the time all seems works!

 

Credits

A special thanks to carbo178, which helped me to solve all the problems after installation and without whom I would have (most likely) trashed my netbook  :D

 

Files

 

Chameleon 2.0 RC4.zip

ShowHiddenFiles.zip

USB Fix 10.6.8.zip

Kernel Atom qui (Original post qui)

3438-GMA950 for 10.zip

Broadcom43XXFamily.kext.zip

VoodooPS2Controller.pkg.zip

 

Share this post


Link to post
Share on other sites
Advertisement

Hey guys i followed this guide and all went well first reboot after update it ask me for my password when i enter it the screen goes blue for a second like its going to boot then back to the password screen. if i enter the password wrong it shakes and makes me do it again any help would be appreciated.  here is where i am in the guide and i cant get back to it. 

 

If you want:

You can create org.chameleon.boot.plist copying the text of com.apple.boot.plist and you can create the smbios.plist file with Chameleon Wizard to put it on /Extra.

 

6. Now you can reboot.

Share this post


Link to post
Share on other sites
Guest avevxvx

Gonna have to install OS X in virtual box :/ But, still, a great guide! Will edit my post when I'm done :)

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By tosziro
      Hello,
       
      I successfully installed MacOS Catalina on this machine it booted after it. Keyboard, ethernet, touchpad, battery status was working. Only that was broken was wifi...
       
      Sadly after reboot out of the blue it stop to work completly. Displays kernel panic. I didnt change anything.
      panic 2cpu 2 caller userspace watchdog timeout no successful checkins from com.apple.logd in 120 seconds
       
      This is my first Hackintosh.  I have complety no idea what should I do now. :-(
      Maybe you could help me, Im attaching my EFI config... I used OpenCore to install.
       
      Intel Core i7-4702MQ Intel HD Graphics 4600 / Nvidia 760M  
      Thank you.
      EFI.zip
    • By Damx
      The specs CPU: Intel® Core™ i3 Processor 8130U, 2.20 GHz (Kaby Lake Refresh) Chipset: Intel® 300 Series Graphics: Intel® UHD Graphics 620 Display: 21.5'' 1920x1200 RAM: DDR4 PC2400 4GB SSD1: M.2 PLEXTOR (with original Windows 10) SSD2: SATA SAMSUNG 850 EVO (for macOS) Sound: Realtek ALC269 WiFi / BT: Intel 3168 NGW Realtek Card-reader  
       
      Not working
      WiFi: Intel 3168 NGW Realtek Card-reader  
       
      Pre-Installation
       
      I will not go through the basics since it is explained in details here on this site. Briefly, the process is to:
      Get Clover Get Catalina macOS installer Create USB with 2 MBR partitions (FAT32 for Clover and HFS+J for the installer)  
       
      Required kexts
      AppleALC.kext Lilu.kext RealtekRTL8111.kext VirtualSMC.kext WhateverGreen.kext  
       
      Config.plist
      I used the one provided by RehabMan called config_HD615_620_630_640_650.plist. Download it from GitHub. It has almost everything you will need with only few edits for audio.
      Edits:
      [CPU] Make sure there is lilcpu=9 setting in boot arguments needed for Kaby Lake R CPU to be recognised correctly. [GPU] Make sure there is a patch GFX0 to IGPU under ACPI->DSDT [GPU] Under Devices->Properties->PciRoot(0)/Pci(0x02,0) make sure that the AAPL,ig-platform-id value is 00001B59, and the device-id value is 16590000 [AUDIO] Under Devices->Properties->PciRoot(0)/Pci(0x1f,3) set the layout-id to 40 and the device-id to 70A10000 [SMBIOS] Set Mac model ID is iMac19,2  

       

       
      Notes
      For some reason with latest version of Clover the install partition was not visible. If you run into the same issue you can downgrade Clover to r5103, which worked perfectly. WiFi / BT Intel 3168 NGW needs to be replaced if one needs WiFi. Someone mentioned that to get HDMI work properly you may need to change AAPL,ig-platform-id value to 00001659 for PciRoot(0)/Pci(0x02,0) - not my case but may be considered if you get this issue. Don't forget to generate your serial and other SMBUS values before signing in with iCloud services.  
       
    • By JBergese
      Hello everyone, as the title suggests, I have a problem configuring the "config.plist" file, more precisely in the "Device Properties"> "Add" section.
      I am following this guide: https://dortania.github.io/vanilla-laptop-guide/ and I stopped at this point: https://dortania.github.io/vanilla-laptop-guide/OpenCore/config-laptop .plist / coffee-lake.html # add_1
      As a computer I have an Acer Aspire 5 A515-51G-51V7, and I wanted to configure the "Intel UHD Grapichs 620" integrated GPU, but arriving at the "Add" section, there is no "PciRoot (0x0) / Pci (0x2.0x0) property ) ", having said that the question is How should I do? Do I have to add the property by hand or did I do something wrong?
      Thanks to all the people who want to help me!
    • By Allan
      Especificações técnicas:
          Versão do BIOS: 1.16 (Ultima disponivel no site da Acer) (mude a entrada SATA para AHCI mode, não o Intel Optane que vem por padrão, com essa opção não terá boot)     Intel 8th gen i5 8265U, 1.6GHz CPU     Integrated Intel UHD620     15" 1366x768 HD não vem com touch     Originalmente vem com 8GB, fiz upgrade para 16 DDR4-2400 - Suporta até 32GB.     M.2 2280 256GB SATA SSD     RTL8111 Gigabit Ethernet     Realtek ALC255     WiFi Card - Vem de fabrica uma Qualcomm Atheros QCA9377A-5, mas este modelo não tem suporte no macOS, então substitui pelo modelo da Lenovo Foxconn T77H649 card (Key A/E, padrão 2230) 802.11ac + Bluetooth 4.1 - INFELIZMENTE O BLUETOOTH DESTA MINHA PLACA NÃO FUNCIONA, ESTÁ COM DEFEITO, MAS SE ADQUIRIR ESTA PLACA NOVA, VAI FUNCIONAR DE BOAS.     Integrated HD User Facing Chicony Electronics, WebCam     Integrated Realtek Card Reader RTL8411B (PCI ven id 0x10ec, dev id 0x5287)     1 x 3.5mm entrada pra fones de ouvido     1 x USB 3.1 gen1 tipo A (com PowerShare)     1x USB Tipo C 3.1     2x USB 2.0     1 x HDMI  
      O que funciona?:
      Tudo!! UPDATE: O kext para o cartão de memoria foi atualizado!  
      O que não funciona?:
      Só o Bluetooth por condições da placa... OBS: Se vocês tiverem sugestões de como eu posso consertar essa placa com defeito, e ressuscitar o Bt, estou a disposição para ouvir.  
      Métodos/Guias usados para este Notebook:
      Para instalar o macOS: Hackintosh Guide - Install MacOS with Olarila Image, Step by Step, Install and Post Install, Windows or Mac Ativar o WiFi: Broadcom BCM4350 cards under High Sierra/Mojave/Catalina Patchear o DSDT: DSDT patch requests  
      Screenshots:
       









      Creditos:
      @Hervé ele que me deu este WiFi (T77H649) e me ajudou a ativa-lo.
      @MaLd0n esse é o cara! Sempre deixando nossos Hacks como Macs!
      Agradeço a toda a comunidade pelo trabalho excelente, os caras do Clover, @headkaze com seu app top o Hackintool. Muito obrigado pelo trabalho duro e o suporte dado
      EDIT: Também o @Sinetek pelo kext do Leitor de Cartão. Sinetek-rtsx 0x528710EC.zip
       
      Aqui está minha pasta do Clover, incluso o DSDT preparado! CLOVER - v5112 with Full DSDT.zip
×