Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Allan

[Help] mdworker[1097]: (Warning) Import: Bad path:

13 posts in this topic

Recommended Posts

after I updated OS X ML to Mavericks in MacReal style. 

K4lNId1.png

 

 

everything worked fine.

but after i test Sleep, i have this error message in the Console. what can be?

 

ASgu5KV.png

 

 

 

My Notebook hung up once.

 

checked the system state in DU, and everything oks.

and my HD is ok too.

Share this post


Link to post
Share on other sites
Solved the problem.
 
This problem does not happen only in Hacks, but in any Mac that has the Mavericks installed.
The Mavericks have bug with exFAT partitions, we can try to solve two methods:
 

1 - Exclude Items Using Spotlight’s Preferences

 

Instead of turning the whole thing off, you can simply exclude certain drives or folders from Spotlight by using its Preferences. Head to System Preferences > Spotlight > Privacy.

20130724_howtomanagespotlight_3.jpg

2 - Disable Spotlight:

 

Disable:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

If you find that this step was a unecessary, enter the following command to restore Spotlight’s functionality.

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Note that after reenabling Spotlight, it will need to reindex your drive(s), a process that may take a while depending on the size of the drives and the number of changes that occurred since you disabled Spotlight. You can measure the progress of the rebuild by clicking on the Spotlight icon in the menu bar.

 

20130724_howtomanagespotlight_2.jpg

 

That's it!!  :thumbsup_anim:

 

Share this post


Link to post
Share on other sites

Do not keep Spotlight disabled. Even you do not need it for searching files. Launchpad is related to Spotlight and the App Store too. If you have spotlight disabled you never can update the apps from App Store.

Share this post


Link to post
Share on other sites

You said it yourself, disable Spotlight indexing on that drive.

 

Or this, found it with a quick google search:

 

Add a file called ".metadata_never_index" to the root of all your ExFAT partitioned volumes. It prevents Spotlight from processing that volume on any Mac you plug it into without having to setup settings on every Mac.

You can't create files starting with dot in the Finder so do it via the terminal.

1. Open the terminal and go to the root of the ExFAT partition.
2. type the line below exactly and pressing enter.
touch .metadata_never_index

3. Check it was created by typing in:
ls -la

 

I have an entire 1TB drive in exFAT format, I've never seen this issue myself.

Share this post


Link to post
Share on other sites

now unable to enable root user.

 

I did so: System Preferences > Users & Groups > Login Options > Network Account Server : Join > Open Directory Utlility > Search Policy  and go to Edit menu:

Screen Shot 2014-01-20 at 11.27.37 AM.png

 

In Terminal, use this: su root.

 

Now the doubt is, how to create touch. metadata_never_index within the partitions.

 

how to enter the partitions in as root?

Share this post


Link to post
Share on other sites
Got it!!!

unable to create the file, as I do not enter the root partition, I copied the file metadata_never_index for problematic partitions.

look:

Screen Shot 2014-01-20 at 5.43.14 PM.png

Share this post


Link to post
Share on other sites

That's great, but just FYI I think you misunderstood the instructions:

"Add a file called ".metadata_never_index" to the root of all your ExFAT partitioned volumes"

 

"root" does not have anything to do with sudo or the "root user". Root in this case means the directory root of the drive, also known as "/".

 

You know, root as in the root of a tree, in this case a "directory tree". So for example if the name of your exFAT volume is "passaralho" you would open terminal and enter

 

cd /Volumes/passaralho

 

....which would put you at the root of that drive.

Share this post


Link to post
Share on other sites

Now I understood friend!

 

thank you so much.

look what I did.

 

in Terminal:

su root

 

now i enter as root:

sh-3.2# cd /Volumes/Mac

sh-3.2# touch .metadata_never_index

sh-3.2# ls -la

 

After that appears:

Screen Shot 2014-01-20 at 10.49.27 PM.png

 

Obrigado GV.  :wink_anim: 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×