Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Jaldhar

After unclean vmware shutdown mouse & keyboard no longer work

4 posts in this topic

Recommended Posts

I run VMWare workstation 10.0 on my laptop under Debian GNU/Linux (wheezy.) Amongst others, I had a VM containing Mac OS X originally 10.7 then upgraded up to 10.9. Everything went swimmingly for a while until one day I accidently started up to many VMs and the host machine ran out of RAM and froze solid. I had no option except to power off the machine without doing a proper shutdown. Most of the VMs survived after fscks or the native equivalent with only minor damage. The OS X one is not so good. It seems to boot and gets as far as the login screen but neither the mouse nor the keyboard work. If you leave it long enough it will go to the screensaver so something must be working.

 

I thought I would try booting in single user mode to investigate further but I can't seem to get there. My understanding is that I have to press command (Windows key in my case) + s during boot to enable this right? I don't know if I have the wrong key sequence or VMWare is swallowing it or what.

 

I don't know what else to do. Does anyone have advice for how to fix this?

Share this post


Link to post
Share on other sites

Thanks but it didn't work. When I boot from the iso (which was burned from genuine apple media) it grinds away for a while and then the apple logo is replaced by a circle with a slash through it. What does that mean?

 

Could it be that I need a bootable Mavericks iso because I upgraded to Mavericks?

Share this post


Link to post
Share on other sites

Follow up on this. While looking at the .vmx settings I noticed that Apple Mac OS X did not show up under guest operating systems. So I ran the unlocker again. No dice. After searching on Google and this site I read that there was a newer version (1.2.0) of the unlocker than I had and that was said to work better with 10.0. So I ran that and got the Mac OS X entry back. Selected it and restarted the vm...mouse works but not the keyboard still. Looked at vmx settings again and saw that USB compatability had been set to 3.0. Changed it back to 2.0 and restarted the vm...Success!! After running disk repair from the cd which took a long time, I was finally able to do a normal login. I still have to do some cleanup of corrupted files but I have a recent backup so I'm good.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×