Jump to content
linuxgirl

How to Install MacOSX 10.9 Mavericks on a MSI GS70 Laptop

47 posts in this topic

Recommended Posts

Advertisement

Hi, I am planning on getting the stealth pro with the 870m (not expecting the gfx to work) but I am not quite sure how to setup the super raid..... help?

Share this post


Link to post
Share on other sites

Hey everyone!  Thanks for all the responses and I am glad that many of you have a working installation!  I hope mo.1's additions make it even better.  As you can tell from my name, I don't use the mac install much so apologies for slow responses to questions :)

 

A number of people messaged me about using this for everyday use - well, it works fine when I need it (usually for fixing other people's macs so basic disk utilities, etc) and occasionally I need to use/test a mac-only program.  I have never have problems except for glitchy trackpad.  As for your principal laptop, I dunno if it is worth have such an amazing laptop but not fully getting all the hardware advantages (video card).  For me, I like the extra geek cred for having a triple-boot and because I need basic things from a mac install to fix other people's macs and harddrives sometimes.  Otherwise it's linux (mint) all the way for me.

 

Continue to enjoy the tutorial.  In a month or so I am going to fiddle around some more and see if I can't get more hardware working based on the suggestions here and some config tweaks, will update the guide then.  If you installed additional kexts or did some config mods that helped get things working better, please post them here so I can include them.

 

xo, lg

Share this post


Link to post
Share on other sites

Hi,

 

I got mine working aswell.

 

What I have done is installed Niresh and Clover UEFI (Yes UEFI!) and changed a few things in clover in order to get my Intel HD 4600 Working. 

 

However, I am stuck with the audio because I couldn't figure out where was the kext. The redirection to google is not very clear.

 

Edit : VoodooHDA 0.8.4 did it.

 

Any chance to get internal microphone?

 

Thanks

Share this post


Link to post
Share on other sites

Hi, 

I went through the installation process twice, and I just can't dance because Mac OS does not load from the SSD after being installed.

 

in verbose mode the loading stops at some point, not always the same depending on the flags and plugged devices, then waits for 2-3min and then shows

Resetting IOCatalog
I've tried to move away the intel graphics related extensions and booting with these flags :
-v PCIRootUID=1 npci=0x2000 dart=0 -cpus=1

but nothing seems to make me pass this point...

I also deleted bluetooth kexts and didn't include Elan kexts just in case it would be the problem

Can anyone help me ?

 

PS: I tried jamesst20's method with Niresh + Clover but i couldn't boot from the key, just a black screen with cursor blinking.

Share this post


Link to post
Share on other sites

Thanks for the guide!!! I followed this guide and some others and now my system is working great. How to get the camera working?

Share this post


Link to post
Share on other sites

Hi guys I am thinking of getting the MSI GS60 2QE Ghost Pro these are the specs which I think are close but just wanted to get your opinion if hakintosh would work..

CPU Core i7-4710HQ

Res 1920x1080

GeForce GTX 970m ( i know this won't work in OS X)

Intel HD4600

 

Thanks

Share this post


Link to post
Share on other sites

Hey ccarrieta,

you're lucky, because I bought the MSI GS60-2PEi716SR21 and I'm writing this answer under Mac OSX on this Laptop  :yes:

 

I returned my XMG C703, because I had 5 technical problems (webcam faulty/dark pixels/deformed d-Cover after support repair/2x bios bugs).

 

Now I have bought me the MSI GS60.

Its smaller/more portable and ligther 

and with a GTX 870m its so more powerful...

 

Before I bought the MSI GS60, I was looking for a similar CPU and the i7-4710HQ with a Intel 4600 was good enough.

 

First Pros.:

- For the moment I have only use my Guide from XMG C703 and it works amazing good... 

- In the Bios I was found that you can turn of the GTX 870m and thats really great for battery life (around 3 hours).  :thumbsup_anim:

 

Cons.:

-The Speakers... :hysterical:

  I think in this Laptop are 4 Speakers, under Windows 8.1 the sound are bad, because the front left speaker make bad noises. (like I would over scroll the Volume in VLC-Player 200%)

  Under Mac OSX I have at the moment only 2 speakers behind/under the keyboard on.

 

Whats work at the moment:

- Ethernet

- Brightness

- Keyboard + Pad

- Sound(not fully) only 2 Speakers, no mic | but it is an ALC892 Chip and it is supported...

- webcam

- battery status

- bluetooth

 

Not work at the moment:

- GTX 870m but deactivate in BIOS

- sleep 

- wlan (same as by the XMG, replace it with a supported wlan chip)

- sd-cardslot

 

 
I'm confident that I get shortly more parts to work… (except sd-cardslot and gtx 870m)

 

All in all it is a very cool mobile Gaming and Hackintosh machine...

Share this post


Link to post
Share on other sites

Hey ccarrieta,

 

I have treid to boot into yosemite, but every time I boot from stick with clover I get a black screen with a beachball.

But I know that Apple have switched the graphics kext and I think that is the Problem.

This post is helpful for that problem.

http://www.tonymacx86.com/yosemite-laptop-support/145427-fix-intel-hd4400-hd4600-mobile-yosemite.html

 

yes i have a dual boot system, on one 128gb sad I have Windows 8.1 and on the other I have Mac OS X 10.9.5 with Clover.

At the moment it isn't a perfect boot, because under legacy boot sometimes I can boot with clover into Windows 8.1 and every time into OS X.

And under Uefi boot with clover I can boot every time into OS X, but I can't install Windows.

 

I have treid to install windows 7/8.1 with a uefi-boot stick and with a external usb-drive. It didn't work.

 

But here is a very helpful post!!!

http://www.insanelymac.com/forum/topic/293574-beginners-guide-to-uefi-tripledual-boot-os-x-windows-and-linux-kali-on-an-single-true-gpt-ssd/

 

He have a MSI GT70 with similar Configuration.  :) 

 

SlowMo

Share this post


Link to post
Share on other sites

I was able to boot of the usb I changed to legacy in the bios, but i am stll getting stuck in the boot screen... Did you have to disable the NVIDIA card in the BIOS ? I read somewhere that this needed to be done but i dont see that option in the bios... should I delete the NVIDAI kexts ?

Share this post


Link to post
Share on other sites

I don't have to disable my nvidia card in the bios. I can boot both setting. Here look at my bios setting.

 

https://www.dropbox.com/sh/y17oys22poo4ulv/AAAre3far880ccKZexf4iCRta?dl=0

 

Have you an options like me, Primary Display?

But I don't think this is your problem.

Share this post


Link to post
Share on other sites

Hey I know this is an old thread, but I just hacked my GS60 and just about everything is working great. mo1 or linuxgirl are you able to turn off the keyboard backlighting? Mine keeps blinking red and I want to disable it. I do not dual boot my system. It's strictly OS X

Share this post


Link to post
Share on other sites

Hey nawlinsborn73,

 

I can turn off my keyboards backlight on my MSI GS60 after I turn it on. At first it glows red and I can dimm it, in 2 steps, the third step is off. When I booted Windows and install the correct driver, I can adjust the backlights color and brightness. But this is only when I start the application.

Also, on Mac OS X and the other time it glows red on default, include the 3 Steps.

Share this post


Link to post
Share on other sites

i have a GS70 2pe-210us laptop. i7 4710hq, 16gb ddr3, hd 4600 and gtx 870m. 1920x1080 screen (17.3), intel wifi ,etc

 

Do you know how to get the screen brightness control working? I followed this guide and that is the only thing that does not work (well the wifi doesnt work but i know how to fix that,).

 

I have 2 msata SSD and 1 mechanical 1tb 7200 rpm 2.5" drive.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By zebity
      Hi Hypervisors,
       
      I have been working to move my Late 2009 Xserve MacOS Server onto Ubuntu 18.04 LTS QEMU/KVM based virtual machine using OVMF and Clover.
       
      After much effort and testing based on the following information from: Kraxel's, Kholia, Gordon Turner and Clover site:
      https://www.kraxel.org/blog/2017/09/running-macos-as-guest-in-kvm/
      https://github.com/kholia/OSX-KVM
      https://gist.github.com/gordonturner/2a2e5ecde5e7860b52e2
      https://clover-wiki.zetam.org/Home
       
      I have now managed to get OVMF/Clover boot and install of MacOS Sierra.
       
      I started with Ubuntu 16.04 initially but this required download and compile of QEMU to get update of machines to: pc-q35-2.9 or better, so I moved to Ubuntu 18.04, which has pc-q35.2.11 available as standard.
       
      So I am now working with standard Ubuntu 18.04 LTS based systems with following packages: kvm/qemu/libvirt/bridge-utils/ovmf/virt-manager
       
      As I want to use PCIe Passthrough for a number of PCIe card currently installed in the server (SmallTree 10GbE & Areca ARC-1883 SAS RAID) I set up my machine with linux kernel boot configuration (/etc/default/grub) of: 
      GRUB_CMDLINE_LINUX_DEFAULT="iommu=1 intel_iommu=on" (as my machine is intel VT-d based HW virtualisation)
       
      This resulted in creation of a number of iommu groups (see /sys/kernel/iommu_group directory for this and this posting for information: https://forum.level1techs.com/t/ubuntu-17-04-vfio-pcie-passthrough-kernel-update-4-14-rc1/119639 , noting that Ubuntu 18.04 LTS has kernel version: 4.15.0-22-generic so there is no need to do kernel update for iommu to work).
       
      Using bare minimal Clover config.plist:
       
       
      And following Clover UEFI drivers:
       
      I can boot MacOS, but it is very very slow... it sits on the apple boot logo for over a minutes before finally moving onto the progress bar.
      The other problem I have is that no PCI or Network devices appear in the "About This Mac" System Information Report and I cannot get any network connectivity from bridged E1000 network device.
       
      Here is my virtlib.xml dump for the virtual machine:
       

      Can any one advise of whether I need to update the CLOVER config.plist to add extra items in to allow network and PCI Passthrough to work.
       
      Thank you.
       
      Regards,
       
      Zebity
       
    • By MaLd0n
      Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder CLOVER Post Install.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By frankiee
      Hi there, time for my first guide after asking so many things
       
      Updated for newer Clover versions and with additional instructions for more apps: gdisk and RU.
       
      So what may be overlooked sometimes in the whole boot loader discussion is the ability of UEFI to do more than just loading an OS. This is why I see ".efi" files as "apps" because in fact they just are, built on a special kind of API: UEFI. So, you can actually do stuff like editing, diagnosing, testing certain stuff at the lowest possible system level without booting to any OS.
       
      DISCLAIMER: Use this guide at your own risk! For educational purposes only! Should do not any harm, but remember you are dealing with rather low level stuff. But at least for me everything went flawless.
       
      Prerequisites:
      Working clover installation Clover Configurator or some app to edit the config.plist  
      1) Memtest
       
      This is how to install the UEFI version of Memtest with Clover:
      Download memtest, I used this link: Image for creating boot-able USB Drive Open the archive by double clicking on it. Mount the file memtest86-usb.img within by double clicking again. Now, you should see a folder named EFI in this volume, containing a folder BOOT. Open it. The files containing it are the actual app, in 32 and 64 bit versions. Think in almost all cases we want to use the 64 bit version. Now, mount your EFI partition, using Clover configurator. Create a folder named MemTest86 in the EFI folder on your main drive. Copy all files in the EFI/BOOT folder from the mounted image to your newly created folder. That ends the basic setup! Now, we add the correct Menu entry to the clover boot menu, so that we can actually start this app.
       
      Get into clover configurator, open your standard config.plist from your boot drive and go to the GUI section. Under "Custom Entries", add an entry like this:
       

       
      Please note while the path you enter is not case sensitive, you must make sure you use the backslash "\" for entering paths, and not a slash. So basically what we do is tell clover where it can find the app, give it a name, and tell clover it is a "Windows" app. Note: with older Clover versions we had to set this to "Linux", but for now "Windows" is the setting that works.
       
      If you prefer to do a manual config, add this entry to your config.plist, under GUI/Custom/Entries:
      <dict> <key>CustomLogo</key> <true/> <key>Disabled</key> <false/> <key>FullTitle</key> <string>MemTest86</string> <key>Hidden</key> <false/> <key>Ignore</key> <false/> <key>Image</key> <string>\EFI\CLOVER\themes\Icons\os_mint.png</string> <key>Path</key> <string>\EFI\MemTest86\BOOTX64.efi</string> <key>Type</key> <string>Windows</string> <key>VolumeType</key> <string>Internal</string> </dict> Now, save and reboot and you should see the newly created entry. Note that I also used a custom Icon - this is optional - in case you don't you will just see a generic windows icon instead:
       

       
      And this is how it looks like:
       

       

       
      PS: also noticeably faster and you get also more features with this version than with the older version, for example it does now write a log file. For more Information, see: http://www.passmark.com/forum/showthread.php?4315-Memtest86-Version-5-Beta-%28Pure-UEFI%29
       
       
      2) gdisk
       
      Another app you can use is the UEFI version of gdisk (aka GPT fdisk), which you can use to edit and change your partitions.
       
      Warning! Install and use this app at your own risk! If you do something wrong here you might nuke your drive(s), so only use that if you know what you are doing.
       
      This is how to do it (even easier):
      Download here: https://sourceforge.net/projects/gptfdisk/files/gptfdisk/1.0.1/gdisk-binaries/gdisk-efi-1.0.1.zip/download Mount your EFI partition Unzip the file and copy the resulting folder to your EFI Folder, so your path goes like this "/Volumes/EFI/EFI/gdisk-efi" Get into clover configurator, open your standard config.plist from your boot drive and go to the GUI section. Add an entry like this:  
      If you prefer to do a manual config, add this entry to your config.plist, under GUI/Custom/Entries:
      <dict> <key>CustomLogo</key> <false/> <key>Disabled</key> <false/> <key>FullTitle</key> <string>GDisk</string> <key>Hidden</key> <false/> <key>Ignore</key> <false/> <key>Image</key> <string></string> <key>Path</key> <string>\EFI\gdisk-efi\gdisk_x64.efi</string> <key>Type</key> <string>Windows</string> <key>VolumeType</key> <string>Internal</string> </dict> When everything went OK you should see this after selecting the respective entry in Clover:
       

       
       
      3) RU
       
      I recently found one more app that might be interesting to some, and thats "Read Universal" or in short "RU". This is a tool that enables you to debug your BIOS and read (and modify!) every imaginable data, including UEFI variables, ACPI Tables etc.
       
      Warning, again! I think blindly messing around with this app is even more dangerous, but on the other hand it gives you access to a lot of potentially interesting stuff.
      Download here: http://ruexe.blogspot.de/ The next steps are basically the same as above so make a folder in your EFI partition, copy the .EFI files and make another custom entry in your config.plist Here are some screens:
       

       

       

       
       
      So this is what you also can do with UEFI and clover. I am curious which other useful applications might exist!
       
      Anybody who knows, maybe post it here?
    • By TimNeumann
      MB: Asus X99 A-II
      RAM: G.Skill Ripjaws V F4-3200C16D-32GVK (3200MHz, 4x 16GB DIMMs, so Total 64GB) in quad-channel configuration.
      CPU: i7 6800k @4.0Ghz
      GPUs: GTX 1080 Ti and GTX 1060 3GB
      (each one a monitor, because I can't get DVI to run parallel with DP on the 1080Ti, and my second monitor only has DVI/VGA)
      OS: High Sierra 10.13.2 (17C88) / Clover revision: 4392
       
      Hello everybody,
      I occasionally have system crashes and suspect that it is related to RAM. However, this RAM is completely new, and a run with MemTest86+ from the USB stick showed no errors. However, if I use Memtest on MacOS, I get a bunch of error messages, but sometimes none (I restart the computer between tests).  
      As I just discovered, my RAM is not on the recommended vendor list of my motherboard, nor is it on the manufacturer side of the RAM. I have read several times that the RAM may not have been tested by the manufacturer on this platform. Not a single X99 motherboard is listed for this RAM.
      So I also suspect that my RAM is not compatible.
      But if that were the case, how could it sometimes work completely error-free?
       
      During RAM tests in summer 2017 (a slightly different setup, 4x8GB but still G.Skill Ripjaws V) I had no errors at Memtest under MacOS, if I remember correctly. At that time it ran under Sierra 10.12.6. AptioMemoryFix.efi could also cause problems.
      I am appreciative for any help!
       
      Here is an excerpt from a faulty test.
      It is noticeable that it is always the same address during the test, but a different one after each test.
      Memtest version 4.22 (64-bit) Copyright (C) 2004 Charles Cazabon Copyright (C) 2004-2008 Tony Scaminaci (Macintosh port) Licensed under the GNU General Public License version 2 only Mac OS X 10.13.2 (17C88) running in multiuser mode Memory Page Size: 4096 System has 12 Intel core(s) with SSE Requested memory: 57232MB (60012990464 bytes) Available memory: 57232MB (60012990464 bytes) Allocated memory: 57232MB (60012990464 bytes) at local address 0x00000001033e1000 Attempting memory lock... locked successfully Partitioning memory into 2 comparison buffers... Buffer A: 28616MB (30006495232 bytes) starts at local address 0x00000001033e1000 Buffer B: 28616MB (30006495232 bytes) starts at local address 0x00000007ffc4d800 Running 1 test sequence... (CTRL-C to quit) Test sequence 1 of 1: Running tests on full 57232MB region... Stuck Address : ok Linear PRN : testing 7 of 16 FAILURE! Data mismatch at local address 0x0000000e88133d30 Expected Data: 0xc4c340079ac9a645, Actual Data: 0xc4c3400788468846 Running comparison tests using 28616MB buffers... Random Value : ok Compare XOR : ok Compare SUB : ok Compare MUL : ok Compare DIV : ok Compare OR : ok Compare AND : ok Sequential Increment: ok Solid Bits : ok Block Sequential : testing 80 of 256 FAILURE! Data mismatch at local BUFA address 0x000000078b8c7530, BUFB address 0x0000000e88133d30 BUFA Data: 0x4f4f4f4f4f4f4f4f, BUFB Data: 0x4f4f4f4f88468846 Checkerboard : testing 3 of 64 FAILURE! Data mismatch at local BUFA address 0x000000078b8c7530, BUFB address 0x0000000e88133d30 BUFA Data: 0x5555555555555555, BUFB Data: 0x5555555588468846 Bit Spread : testing 1 of 128 FAILURE! Data mismatch at local BUFA address 0x000000078b8c7530, BUFB address 0x0000000e88133d30 BUFA Data: 0x0000000000000005, BUFB Data: 0x0000000088468846 Bit Flip : testing 74 of 512 FAILURE! Data mismatch at local BUFA address 0x000000078b8c7530, BUFB address 0x0000000e88133d30 BUFA Data: 0x0000000000000200, BUFB Data: 0x0000000088468846 Walking Ones : testing 40 of 128 Clover Files attached
      config.plist
      drivers64UEFI.zip
      kexts.zip
      ACPI.zip
    • By BurpSuite
      screenshot:
       

       
      description:
      github: https://github.com/burpsuite/clover_theme
×