Jump to content

Hard Drive Not Showing Contents But Saying It's Almost Full


12 posts in this topic

Recommended Posts

quick intro, i had a working version of snow leopard or lion on my hackintosh, thanks to conti (awesome guy), working audio, working everything, my system was fairly old though (couple of years), i noticed with time the bootup started to take longer and longer, it got to the point where booting up my system took between 30mins and over an hour. now i felt it was time to update, and see if my system was good enough working with mavericks. since a direct update wasn't possible, i created a new installer, formatted and installed mavericks, thanks to herve (another hackintosh enthusiast), i got mavericks installed, and well, i guess working, no sound, no lan, couldn't get a wlan stick to work, every time i disconnected a usb stick it just froze, and 1 of my hard disks wasn't showing any contents.


a friend of mine was getting the asrock x79 extreme6, sounded like a great motherboard, and herve linked me to rampagedev's guides, which seemd so straight forward that i figured i'd go with that too, i mean an already existing dsdt file and everything working out the box, sounds awesome.


after putting together my new machine. i installed mavericks pretty swiftly, but i pretty much got the exact same problems. of course i only read the installer guide on the site and not the read me, which now confuses me a lot.


so now i'm stuck with a new system at the exact same position.


no audio, but let's jump to the part i'm figuring i'd fix first.


since installing mavericks, i didn't touch any of the drives. but 1 hard drive, shows no content for me, as if it were empty.


which is insane, because disk utility tells me the disk is to over 90% full (which i know it is/was), and has over 8,000 files on tere. but when i select that drive under finder it claims the drive is empty.


i tried looking at the drive's folder through "Go to" and terminal but no luck, no folders found.


does anybody have any ideas as to what could be helpful here?


thank you very much for your time.

Link to comment
Share on other sites

For the audio, solutions will differ on a motherboard-by-motherboard basis. Usually with patience you'll get it working in the end. The first step is to find out what audio codec you have eg. ALC8XX and then start your research from there. Or better yet, find someone with the same mobo as you and see what they did.


For the hard drive, this is what I'd do for starters. Backup your files (use another PC if possible). Boot into Windows, launch disk management or a 3rd party tool of your choice and see if you can find out what's going on. Something may be up with your disk and you might need to reinitialise or reformat it. If you can get it working as an NTFS disk, chances are you'll then be able to boot into OSX use disk utility to do the rest. Then copy back your files.

Link to comment
Share on other sites

hi long cat,

thank you so much for the reply. i looked at rampagedev's site, i looked in his dmg, and it was too confusing for me. the instructions said pick out your motherboard manufacturer, then select the right ssdt, but it has 4 in there, i tried all of them and none worked for me.


the guide it self doesn't say much about the board, just that i am supposed to use the bootloader, but that bootloader didn't work for me, i had to change it as well for it to work on my system.


so yes, now i'm looking for help to get my audio to work.

Link to comment
Share on other sites

as for the hard disk i don't have a pc anywhere, i have a macbook pro and some other old hackintosh. the hard drive is in mac journaled. i guess i'll try the drive with my other hackintosh and see if the lion installation will recognize it.

Link to comment
Share on other sites

Yeah, try the older hackintosh first. First step is to get your files off and back them up. Then you can use whatever means to reformat and get it working on your new system without fear of losing any data.


Btw, any hackintosh IS a PC too. Install windows, dual boot.


I think you might be barking up the wrong tree with the audio though. Lookup the definitions of bootloader and SSDT. A bootloader is what loads your OS, in your case, most likely charmeleon is your bootloader. If that isn't working, you won't have an operating system to use. An SSDT is related to speed step, which manages how your CPU performs under certian loads and helps to conserves energy.


To get audio working, you might need a modified AppleHDA.kext or another configuration of kexts depending on your mobo. Research what kexts are, how to install them. Then find out what audio codec you have. Then start to look around for what kexts you might need.


It might also be helpful if you posted your full system specs.

Link to comment
Share on other sites

asrock x79 extreme6 (new)

i7 3820 (new)

6gb ddr3 1600

nvidia gtx 260

psu 750 be quiet dark power pro 10

thanks a lot for clearing all that up, i've been using the wrong terms xDDD


according to rampagedev's guide, i am supposed to use this for audio:

which makes no sense to me at all. i downloaded the zip file but it has no kext in there.

Link to comment
Share on other sites

If you're confused about Rampage dev's instructions, you could ask over at his site. The download you pointed to looks like scripts to patch AppleHDA. You probably just want a pre-patched one.


Are you sure that that applies to your motherboard in the first place though? Google says that mobo has the ALC898 codec, not 892.


If I were you, I'd look for a pre-patched AppleHDA.kext for the ALC898 codec. I can't really help with the specifics, but if you get in contact with someone like Rampage or Toleda they'll know exactally what you need to do.

Link to comment
Share on other sites

it was practically impossible to get support from him.


i said that i couldn't get his bootloader to launch my installer with his bootloader, so i had to change the graphics enabler to yes to get it to work, now i need to get the audio to work. and he basically replied to that, you're not supposed to use the bootloader on the installer but on the system. i explained that i figured if it didn't launch the installer it wouldn't launch the system so i tried it there first, but i got it to work, i just need help on the sound, and he replied "Change change GE to Yes", so i explained my audio problem again, and now i'm still waiting for a reply.


but i think maybe we got started off on the wrong foot. i got linked to his site by herve over at osxlatitude (very helpful guy, he really took his time with me like you are long cat = thanks again longy). And I wrote Rampagedev an e-mail saying that i had a little dilema with the asrock x79 extreme6 and the asrock x79 fatality. that i was looking for an inbetweener.


he replied:

"Look for the ud4 mother board."

after doing a site search and looking through most of his pages, i said:
"Your site has no UD4 motherboard and under google you get so many different ud4 motherboards: GA-790XTA-UD4, GA-Z68XP-UD4."

and explained that i came to his site because i heard great things about his guides, so i want to get a motherboard that he wrote a guide about.

he replied:

"Yes there is.... Look at all the support pages on my site for each manufacture."

i did that again, but couldn't find one and asked:

"Can't you send me a link, under gigabyte you have ud3, ud5, ud7. a search on your site also comes back with nothing... but never mind. I'll just go with the asrock x79 extreme 6, you seemed to have gotten that to work pretty nicely. I really just need a decent working system. Or do you mean UP4?"


that was a week ago and I still haven't gotten a reply from him. maybe he just doesn't like noobs.


i'm not sure if i am allowed to post links here to other forums, but someone on a site said he got his asrock extreme6 to work with "ALC898_no_DSDT 1.0" and posted a link, so i will try it with that, been using myhack on my system for as long as it took me to write this message, and it's still going, myhack never took this long before. we'll see how this goes.

Link to comment
Share on other sites




Same thing on my old machine with the Lion installation on it. It says the drive is almost full, shows how many files are on there if i click on get info, but it shows absolutely no content, even though it is a mac os journaled drive.



It shows:


Line Out

Line Out

Digital Out

Virtual Audio Device

*quicktime/itunes don't even play the mp3s i pick on any of these options"


vlc plays them but i receive sound from any of those.

Link to comment
Share on other sites

Rampage is one of the most knowledgeable guys around here and as such has to deal with helping out a lot of people. He just might not have the time atm. Hackintosh has a steep learning curve, but part of the fun sometimes is trying to figure it out yourself.


I have an x79 mobo too, and like you, getting audio to work was a bit of a battle. But good thing is, once you know what you need you're good to go. I've got the gigabyte x79 UP4 - it has the ALC892 codec so the exact config won't work for you, but they're both x79 so it's a start. Will PM you later (maybe tomorrow) with what I did.


As for the HD, so you were you previously using this with your old hack, right? And now it's not working even with it? Are you sure you haven't damaged the connections or something like that when swapping it around. Are you sure the files aren't hidden and that you have permission to see the disk contents? Either or, I hope you have a backup of it. If the disk isn't stuffed, at the least a reformat sounds like it might be a good idea.

Link to comment
Share on other sites

i don't have a backup, and i need those files, it's basically the backup of everything that was on my main drive, because i needed to format that main drive for my fresh installation.


i guess maybe i did mess up the connectors.


and no don't misunderstand i don't think any less of rampage, maybe he doesn't have time or maybe he just doesn't like me because i asked so many stupid questions and couldn't find his ud4 entry, i'm not blaming him for anything, i'm sure he must be pretty knowledgable, having created so many guides and dsdts. but the problem is i can't get it to work on my system, not because his guide is bad, but because i am not knowledgable enough to get it.


i'll keep trying, have to try all 4 dsdts that he has in his guide on my system, maybe one of them will work with the current setup.

Link to comment
Share on other sites

i got the audio to work, i just downloaded the latest AppleHDA.kext from osx86 and it worked like a charm, no tweaking necessary.


thanks for being so patient with me long cat and trying to help me.


regarding the hard drive, i completely failed with that. i tried out "Stellar Phoenix Mac Data Recovery" and it seems as if the program formatted the drive before looking through it, and now disk utility says it's empty. when i use the program it says it is all under ".Trashes", but it can't recover even a single document.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...