Jump to content
theconnactic

IntelHD3000 - Cannot get QE/CI and Atheros 9285 won't work!

14 posts in this topic

Recommended Posts

Hi, folks!

 

Having lots of difficulties with these, which I took for granted as easy fixes. As always, tried hard to solve it myself, but since the troubleshooting steps that worked for others aren't working for me, I really could use some help.

 

The computer is a Sony Vaio laptop, with a Sandy Bridge I3-2370-TM CPU, Intel HD3000 graphics and Atheros 9285 Wi-Fi (as already described in the topic's title). 

 

I patched my DSDT with the 9285 patch and with the HD3000 patch from Olarila: http://olarila.com/forum/viewtopic.php?f=26&t=1500 (warning: portuguese), but also tried without these patches and combinations of GraphicsEnabler=Yes/No and PCIRootUID=0/1. I use a MacBookPro 8,1 system definition as recommended for my hardware (sandy bridge). Attached is a Darwin Dumper report, an Everest Ultimate report, my current patched DSDT and my current org.chameleon.Boot.plist.

 

Any help will be much appreciated!

 

All the best!

Share this post


Link to post
Share on other sites
Advertisement

TheConnatic, does the card work in  mountain lion? (both wifi and graphics)

Share this post


Link to post
Share on other sites

Didn't try it, I don't have a ML/Lion installer at hand anymore... Both should work: a lot of people reported success with the HD3000, and the 9285 requires a very simple and well-tested DSDT patch. In fact, it should be a cakewalk: I don't know why I'm not being able to get both to work...

 

All the best!

Share this post


Link to post
Share on other sites

then what happens if you use the IntelHD3000Graphics.kext and the IO80211.kext from a computer that has 10.7.5 or 10.8.5?

Share this post


Link to post
Share on other sites

P.S.: just added to my DSDT a patch from Artur-PT to which I was directed by reading an old post from iFire: #3. Will reboot as soon as I finish a download and report here.


P.P.S.: yes, I prefer to focus first on solving QE/CI...


P.P.P.S.: but found this post from Oldnapalm and perhaps the 9285 will get dealt with first: http://www.insanelymac.com/forum/topic/289824-atheros-9285/  (EDIT: done, now wi-fi works like it should. :D)

Share this post


Link to post
Share on other sites

so you got to patch your ar9285 by adding 168c; 2a... your dev. id is in the hd3000 kext too right?

Share this post


Link to post
Share on other sites

Right, first thing i tried ;)

 

I'm not Bono Vox but I still haven't found what i'm looking for. This is getting harder than I could imagine.

 

Tried accordingly with the topics linked in my latest post PSs with a cleaner DSDT - only DGTP and Dual-Link patches: still no joy.

 

This time, besides the DSDT, i'm also uploading an IOREG: DSDTIOREG.zip


P.S.: for the sake of accuracy, what i'm missing is Quartz Extreme: i think Core Image is indeed working, since the Launchpad doesn't freeze or hang, and i have proper resolution (but I had to adjust that with Graphics Mode in Chameleon) and 64MB of shared VRAM.

Share this post


Link to post
Share on other sites

No joy: got a black screen with this framebuffer, had to boot without my DSDT to reach the Desktop - without QE/CI in this case (I think dual-link is needed for any framebuffer to give acceleration with my laptop's monitor).


P.S.: without a doubt, that was a step forward though: the black screen means at least this driver is loading...

P.P.S.: removed AppleIntelSNBGraphicsFB.kext and got to square one: good resolution and relative UI fluidity (Core Image) but no graphics acceleration for iLife, iWork, Youtube etc (Quartz Extreme).

Share this post


Link to post
Share on other sites

SOLVED!

 

I just copied the AppleIntelSNBGraphicsFB.kext from inside the /S/L/E of my USB installer and voilà, everything is fine now. I notice i slight brightness dim when the Desktop is reached, but nothing like a deal breaker. I have to boot without my DSDT, though, meaning i'll have to resort to other solutions to get my Conexant audio working - perhaps VoodooHDA, that doesn't really make a difference for me.

 

One think that eludes my understanding is why the stock kext didn't work, and the one from the installer does? Aren't they the same? Or perhaps MyHack corrupted the kext somehow during the installation process? Worth investigating. For now, i'm quite happy with this notebook, which became now one of the very few that fully work under OSX without need to replace any hardware parts.

 

All the best!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Georgiles
      Laptop: Asus Vivobook F510UA
      CPU: Intel Core i5-8250U
      Graphic: Intel UHD 620
      Wifi: Intel Dual Band Wireless-AC 8265 (no kexts for intel wifi) :(
      Card Reader: Realtek_CardReader(RTL8411B_RTS5226_RTS5227)
      Camera: ASUS UVC HD 7.Audio: Conexant Audio CX8050
      Touchpad: ELAN1300
       
       by parkrypto: thank you tctien342 for the amazing guide.
       
      https://github.com/tctien342/Asus-Vivobook-S510UA-High-Sierra-10.13-Hackintosh
       
      Ebayed the laptop for $290 + tax = $350
      added: 16gb RAM + existing 8GB = 24GB          Timetec Hynix IC 16GB DDR4 2400MHz PC4-19200 Non ECC Unbuffered 1.2V CL17 2Rx8 Dual Rank 260 Pin SODIMM Laptop Notebook Computer Memory Ram Module Upgrade S Series (16GB)     
      added: cheap wifi         TP-Link USB Wifi Adapter for PC N150 Wireless Network Adapter for Desktop - Nano Size Wifi Dongle Compatible with Windows 10/7/8/8.1/XP/Vista Mac OS 10.9-10.15 Linux Kernel 2.6.18-4.4.3 (TL-WN725N)     
      added: NAND 1TB Internal PC SSD https://www.amazon.com/gp/product/B073SB2MXT/ref=ppx_yo_dt_b_asin_title_o01_s01?ie=UTF8&psc=1
      Gadget Reviews upgraded too, video: https://www.youtube.com/watch?v=39EquX5PTkQ
       
      I just installed. Everything works fine. I'll test final cut pro, premiere pro with 4k footage and get back with you on performance. 
      For now moves like a performant Mac book pro. 
      I installed Catalina first but I could not make the Intel UHD 620 Graphics get proper QE/CI. 
      Mojave is just fine. I want to use this system for quick video editing on the go.
      Geekbench in my signature.  
      If you need any files or have any questions pls ask.
       






      asus f510u mojave.zip
    • By jamesxxx1997
      Hi everyone !
      I have a laptop thinkpad x1 yoga 2018 , the sound device is realtek alc285.
      My friend and I spend numerous time on patching its layout-id , however either the headphone jack or laptop audio recording have noises.
      Any help is appreciated , thank you !!!
       
      HdaCodec#0 (Realtek ALC285).bin
      HdaCodec#0 (Realtek ALC285).txt
      HdaCodec#1 (Realtek ALC285).bin
      HdaCodec#1 (Realtek ALC285).bin.cpgz
      HdaCodec#1 (Realtek ALC285).txt
      HdaCodec#2 (Intel Kaby Lake HDMI).bin
      HdaCodec#2 (Intel Kaby Lake HDMI).txt
    • By soumaxetuirk
      If you have a working Brightness Slider and you might be using Brightness slider or manual hotkeys to control brightness then this guide may help you to use your Native hotkeys of laptop.
       
      (All the Credits goes to @RehabMan     For OS-X-ACPI-Debug Kext and DSDT Patches.)
       
       
      This step assumes that you are using RehabMan's VoodooPS2Controller or Acidanthera's PS2Controller
      Install the kext: https://github.com/RehabMan/OS-X-ACPI-Debug Open MaciASL and click on patch.(Add rehab man repo) Apply "Add DSDT Debug Methods" and "Instrument EC Queries" that are under Brightness Fix. Save the DSDT and restart Look in Syslog as you press the key corresponding to brightness to determine which _QXX methods handle the keys (UPDATE: From Sierra Apple changed logging process. So you won't find ACPIdebug result using syslog command. Instead use following command )
      log show --last 5 | grep ACPIDebug 6. Then patch DSDT:
      into method label _Q1D replace_content begin // Brightness Down\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0205)\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0285)\n end; into method label _Q1C replace_content begin // Brightness Up\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0206)\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0286)\n end; Change the variable _Q1D/_Q1C as per the log. 

      7. Try compiling and check if it generates errors
      8. If it does, then change the PS2M to PS2X according to the one found in your DSDT
      9. Save and place the compiled DSDT.
      10. Now you should see that you have your corresponding keys to change your brightness 
       
       
       FOR  more detail and Queries,Check Out original Post of @RehabMan Here;
      http://www.insanelym...18#entry1997112
      Get Latest Version of  OS-X-ACPI-Debug kext here:
      https://bitbucket.org/RehabMan/os-x-acpi-debug/downloads
    • By jcrcarmo
      Hello everyone,

      Greetings from Brazil! I'm running macOS Catalina 10.15.2 on my Lenovo Ideapad 300-15ISK laptop. Everything works smoothly, except decent battery management, so I decided to rebuild my DSDT from scratch, so I can patch it properly. It was a bit messy to start with.

      I followed Rehabman's guide (to the letter) posted on tonymacx86. However, I keep getting a compile error, no warnings at all, just 'syntax error, unexpected PARSEOP_ARG1'.  Please refer to attached PNG image and .dsl file.

      I've searched endlessly for a solution, but can't fix it no matter what I try. Any ideas on how to fix this issue? I really appreciate your time and help.

      Best regards and Happy Holidays!

      DSDT.dsl
    • By MatthewMac
      Hello a few days ago I installed a wireless card to get wifi called: Broadcom DW1820A model: 94350ZAE. Could someone help me to modify my efi folder to let the card work correctly? When I switch on the laptop everything is running ok in verbose mode but when later it appears the Apple logo to finally load everything all the computer get stucked so I can’t do anything (there is only the apple logo and a bar), the only way to use my laptop is disabling the wifi card from bios or using the boot arg: brcmfx_driver=1, and I don’t know why it happens this.
      I tried to follow/use some guides but I can’t fix it, so I need help from a professional of Hackintoshes…
      My laptop is a DELL vostro 5568 8 gb ram, i5 7200 2,4GHz, intel hd graphics 620 and the ssd 250gb.
      Here you can download my efi folder and a IOreg file of my computer
      If you need more information etc tell me.
      I only can upload 10mb and my efi folder is 25mb so I'll upload the most important files.
      Thankyou.
       
      MacBook Pro14,1.ioreg
      efi folder things.zip
×