Jump to content
Uoc Nguyen

Thinkpad T430 - Mavericks 10.9.x - Yosemite 10.10

104 posts in this topic

Recommended Posts

Hi all.

 

I would like to share the results of  mixing my work and work of  other before me on my T430s (2355).

I use the post of UocNguyen as template(Thanks for the work!)

Working:

  • CPU PowerManagement  (SpeedStep enabled using ssdt-gen script and clover states generation option)
  • Intel HD4000 with AppleIntelFrameBufferCapri patched at latest version (10.9.3) to use internal LVDS and external DP port (i read apple removed support for embedded VGA start from 10.8.3 kext, from my tests i'm able to use a VGA monitor while start laptop from docking station with lid closed but there are something bad with EDID probe and with refresh so i think the very big problem is the VGA output use the same channel of internal LCD/LVDS)
  • Audio work with patched AppleHDA (and IOAudioFamily from 10.9.0) Speaker/Headphone/Internal Mic/Mic on headphone/
  • Ethernet work with AppleE1000.kext
  • Trackpoint, touchpad and keyboard work with VoodooPS2
  • Patched Bluetooth kext with support for BCM20702A0
  • USB 3 with GenericUSBXHCI ( Run at 5gbps), all 3 ports are capable to charging an iPad
  • Battery recognized with ACPIbatteryManager
  • WWAN HSPA Working with SIM inserted, modded CellPhoneHelper.kext,IOSerialFamily and modded CCL in /Library/ModemScripts/ (tell me if work!)
  • UEFI boot with latest version of CLOVER
  • Sleep, wake, restart and shutdown fully working (10.9.2 seems to resolve this issue)
  • Keyboard. Multimedia keys: Sleep, Prev / Play / Pause / Next (Brightness control with Fn-F8/F9 not work, mapped in DSDT with Fn-K/P)
  • Windows Installation on other SSD partition run fine with VMware Fusion Bootcamp and directly form choose it in Boot selection menù (when you boot with windows you must restore Clover EFI boot option manually in UEFI BIOS to start osx later, because the Micro$oft Boot loader set itself as primary when start  :yes: )

Additional external device:

* NOT working and know problem:

  • Intel Centrino Advanced-N 6205 Wireless adapter( simply no kext exist for this device....)
  • I tried to install mPCI-E Broadcom WLAN used in my old T420s but it's seems not possible to flash modded bios without external programmer. No success with any other methods like tape pin 20 of mPCI-E or placing in second mPCI-E slot.
  • Card reader (Partially working with VoodooSDHC kext, but sometimes system hangs. I removed the SD reader for using Wifi adapter)
  • Brought video from iTunes doesn't play on LVDS device (LCD display attached on VGA on board doesn't support HDCP)
  • WWAN icon in status bar appear only after sleep/wake cycle :huh: 
  • Headphone jack sometimes not work after sleep (it's seems to fixing itself after another sleep/wake cycle :blink:)
  • Headphone Volume control 

 

 

 For install use info from T420 thread: http://www.insanelymac.com/forum/topic/285678-lenovo-thinkpad-t420-with-uefi-only/page-25?do=findComment&comment=1952283

NOTE: need to change the SMBIOS hardware section and CustomUUID to your own hardware.

My pack: https://www.firedrive.com/file/9991150C50684CB7

 

I want to thanks all creators of any components used for this test.

 

PS: sorry for bad english  ;) 

Share this post


Link to post
Share on other sites
Advertisement

Good job @eilatuno

 

It is long time I have not boot into OS X as I am quite busy and most of time I'm working on Linux environment. Just back and took an upgrade to OS X 10.9.3 and it work well. I'm updating new report to #1 to keep topic clean and easy to find information.

Share this post


Link to post
Share on other sites

Hey guys! I'm having a problem with my T430 (Intel GPU). At first, after installing mavericks with a myHack installation USB, my laptop wouldn't start. After replacing the Bluetooth-related kext with the ones you provided, I was able to boot, but I couldn't get the actual Bluetooth working (it seems to be undetectable). My experience with other thinkpad laptops (which are, in general, quite good for this stuff) is that the problem was the Chamaleon bootloader, so I decided to install Clover, but when I installed it and after rebooting it (I replaced the standard config.plist with yours), I got the strange EFI bootloader screen (which is not related with clover in anyway, it's part of the UEFI Bios system). So, to sum up, I don't know what do I have to do in order to install Clover and boot up the machine.

Oh, the disk is partitioned as GPT and the Bios is set to "Legacy First".

 

Thank you guys!!

Share this post


Link to post
Share on other sites

Hey guys! I'm having a problem with my T430 (Intel GPU). At first, after installing mavericks with a myHack installation USB, my laptop wouldn't start. After replacing the Bluetooth-related kext with the ones you provided, I was able to boot, but I couldn't get the actual Bluetooth working (it seems to be undetectable). My experience with other thinkpad laptops (which are, in general, quite good for this stuff) is that the problem was the Chamaleon bootloader, so I decided to install Clover, but when I installed it and after rebooting it (I replaced the standard config.plist with yours), I got the strange EFI bootloader screen (which is not related with clover in anyway, it's part of the UEFI Bios system). So, to sum up, I don't know what do I have to do in order to install Clover and boot up the machine.

Oh, the disk is partitioned as GPT and the Bios is set to "Legacy First".

 

Thank you guys!!

Hi Anita if you use my package you must set UEFI only boot setting in your BIOS config. Before this you must configure the EFI/ESP partition and place the EFI folder from the zip directly in this small partition that already exist if you partition table is GPT. You have only to reformat this hidden partition from HFS to FAT32. This is a good guide for do this: http://www.insanelymac.com/forum/topic/287737-how-toclover-on-efi-partitionadd-to-bios/.

Share this post


Link to post
Share on other sites

Oh, thank you!! I'll check it out now and post what happens  ;)

 

EDIT: Ok, so I've successfully installed Clover, but every time I try to boot Maverick, the screen goes completely black (with no Apple logo whatsoever) and, after 2 minutes or so, the computer reboots. Booting with the -v flag shows this message:

efiboot loaded from device Acpi(PNP0A03.0)/Pci(1F|2)/SATA(0.0)/HD(Part2.SigFF040F85-B046-95E0-91830FEBA0857)
boot file path: System\Library\CoreServices\boot.efi
..

My GPU is a Intel 4000 and I have NOT added any SMBIOS or UUID to my config.plist. I have tried to boot with GraphicsEnabler=N, but clover keeps stuck in that step.

Share this post


Link to post
Share on other sites

Oh, thank you!! I'll check it out now and post what happens  ;)

 

EDIT: Ok, so I've successfully installed Clover, but every time I try to boot Maverick, the screen goes completely black (with no Apple logo whatsoever) and, after 2 minutes or so, the computer reboots. Booting with the -v flag shows this message:

efiboot loaded from device Acpi(PNP0A03.0)/Pci(1F|2)/SATA(0.0)/HD(Part2.SigFF040F85-B046-95E0-91830FEBA0857)
boot file path: System\Library\CoreServices\boot.efi
..

My GPU is a Intel 4000 and I have NOT added any SMBIOS or UUID to my config.plist. I have tried to boot with GraphicsEnabler=N, but clover keeps stuck in that step.

Have you tried to boot without caches from clover?

Share this post


Link to post
Share on other sites

Ok, I'm tired of trying. I don't know what to do. Did you used niresh or myhack, or just created a Clover OS X Installation USB??

Share this post


Link to post
Share on other sites

Ok, ok!! Sorry for being that annoying, but I've finally managed to get EVERYTHING working. The problem is that, after updating to 10.9.2, I don't know how to patch the AppleIntelCapri kext thing. Can someone please, please, upload their own patched version, I would really appreciate that a lot. Thanks for all!! ;)

Share this post


Link to post
Share on other sites

Ok, ok!! Sorry for being that annoying, but I've finally managed to get EVERYTHING working. The problem is that, after updating to 10.9.2, I don't know how to patch the AppleIntelCapri kext thing. Can someone please, please, upload their own patched version, I would really appreciate that a lot. Thanks for all!! ;)

Anita

 

you can use this http://fileom.com/q231lkyl331z

 
;-)

Share this post


Link to post
Share on other sites

The screen keeps on going to black before I see the desktop. I have changed the kexts (bluetooth and capri ones) and corrected permissions. Is there anything I'm doing wrong?? Do i have to add something to Clover's config.plist?? Is it that I need to use the DSDT?? What am I doing wrong??

Share this post


Link to post
Share on other sites

The screen keeps on going to black before I see the desktop. I have changed the kexts (bluetooth and capri ones) and corrected permissions. Is there anything I'm doing wrong?? Do i have to add something to Clover's config.plist?? Is it that I need to use the DSDT?? What am I doing wrong??

if you use my pack, the DSDT is already included...

Share this post


Link to post
Share on other sites

To alleviate some confusion, most of your post install issues have been discussed over here in the 420 thread: http://www.insanelymac.com/forum/topic/285678-lenovo-thinkpad-t420-with-uefi-only/page-25?do=findComment&comment=1952283 This link also drops you right on tluck's 420 guide which is a good jumping off point for those of you still having trouble installing. The thread was meant to be renamed to include the 430 but I never provided the OP with my files. It seems that Uoc Nguyen and eliatuno have a good packs. Please feel free to head over there and continue the discussion. I'd hate to see fellow 430 owners struggle and redo research when there's a parallel thread. Thanks for your work so far.

Share this post


Link to post
Share on other sites

@Sheep_Reaper: I think it is better to make another thread for T430 caused T420 and W520 are good threads for modern Thinkpads but they are a bit old and have some different hardware with T430 need another solution to solve it such as: NVIDIA card, Intel HD 4000, Bluetooth... I have research across all related threads and forum to make T430 work well with latest release of the Mavericks. Based on your reply, I think it is better to put all related links to OP to make it easy to reach and solve people issues (common issues).

Share this post


Link to post
Share on other sites

Ah ha,

 

Quite persuasive. I concur. However, the OP for the 420 thread is hard to contact. He has not been active for quite some time. As 430 questions pop up, I will direct them here. Currently there is at least one user that needs to enable discrete graphics and has thus far been unsuccessful. Perhaps you could jump in temporarily over to the 420 thread for some advice? I have a 2349GCU so no discrete graphics I'm afraid.

Share this post


Link to post
Share on other sites
Hi all

 

i've updated my system to 10.9.4, so i patched the new version of AppleIntelFramebufferCapri and IOBluetoothFamily, you can find them at end of post.

i tried to patch AppleHDA but audio don't work has expected, so i ask if anyone has successfully patched audio for ALC269?

 

i've another question for you, this update (10.9.4) and 10.9.3, broke my shutdown/reboot sequence, is the same for anyone?

 

Have a nice day

modded_10.9.4.zip

Share this post


Link to post
Share on other sites

Layout for T430s is 28, i tried to insert platform 28 in resources but i think is necessary to mod properly the appleHDA bin....

Share this post


Link to post
Share on other sites

Thanx for the nice Guide. I followed it but when it booted the installer USB it says CPU halted and shutsdown. So i used myHAck and installed the system and was able to login to the installed system using -v -f GraphicsEnabler=No. Any help on how to setup graphics, ethernet , audio. Below is my Thinkpad config

 

Thinkpad T430( Model: 2350-B49), Core i5 (ivy), Intel HD4000, 12 GB RAM, 1600X900 res.

Share this post


Link to post
Share on other sites

Hey,

 

i managed to get everything working except BT and Mic. 

Can you please tell me what you have done to get it work?

Thanks!

 

//EDIT:

Sound working

BT working

 

Hey,

 

i managed to get everything working except BT and Mic. 

Can you please tell me what you have done to get it work?

Thanks!

 

//EDIT:

Sound working

BT working

Can you tell us if Brightness work and what kexts was used if so. Any info on getting the battery monitor working wold be helpful. Thanx

Share this post


Link to post
Share on other sites

Hi all.

 

I would like to share the results of  mixing my work and work of  other before me on my T430s (2355).

I use the post of UocNguyen as template(Thanks for the work!)

Working:

  • CPU PowerManagement  (SpeedStep enabled using ssdt-gen script and clover states generation option)
  • Intel HD4000 with AppleIntelFrameBufferCapri patched at latest version (10.9.3) to use internal LVDS and external DP port (i read apple removed support for embedded VGA start from 10.8.3 kext, from my tests i'm able to use a VGA monitor while start laptop from docking station with lid closed but there are something bad with EDID probe and with refresh so i think the very big problem is the VGA output use the same channel of internal LCD/LVDS)
  • Audio work with patched AppleHDA (and IOAudioFamily from 10.9.0) Speaker/Headphone/Internal Mic/Mic on headphone/
  • Ethernet work with AppleE1000.kext
  • Trackpoint, touchpad and keyboard work with VoodooPS2
  • Patched Bluetooth kext with support for BCM20702A0
  • USB 3 with GenericUSBXHCI ( Run at 5gbps), all 3 ports are capable to charging an iPad
  • Battery recognized with ACPIbatteryManager
  • WWAN HSPA Working with SIM inserted, modded CellPhoneHelper.kext,IOSerialFamily and modded CCL in /Library/ModemScripts/ (tell me if work!)
  • UEFI boot with latest version of CLOVER
  • Sleep, wake, restart and shutdown fully working (10.9.2 seems to resolve this issue)
  • Keyboard. Multimedia keys: Sleep, Prev / Play / Pause / Next (Brightness control with Fn-F8/F9 not work, mapped in DSDT with Fn-K/P)
  • Windows Installation on other SSD partition run fine with VMware Fusion Bootcamp and directly form choose it in Boot selection menù (when you boot with windows you must restore Clover EFI boot option manually in UEFI BIOS to start osx later, because the Micro$oft Boot loader set itself as primary when start  :yes: )

Additional external device:

* NOT working and know problem:

  • Intel Centrino Advanced-N 6205 Wireless adapter( simply no kext exist for this device....)
  • I tried to install mPCI-E Broadcom WLAN used in my old T420s but it's seems not possible to flash modded bios without external programmer. No success with any other methods like tape pin 20 of mPCI-E or placing in second mPCI-E slot.
  • Card reader (Partially working with VoodooSDHC kext, but sometimes system hangs. I removed the SD reader for using Wifi adapter)
  • Brought video from iTunes doesn't play on LVDS device (LCD display attached on VGA on board doesn't support HDCP)
  • WWAN icon in status bar appear only after sleep/wake cycle :huh: 
  • Headphone jack sometimes not work after sleep (it's seems to fixing itself after another sleep/wake cycle :blink:)
  • Headphone Volume control 

 

 

 For install use info from T420 thread: http://www.insanelymac.com/forum/topic/285678-lenovo-thinkpad-t420-with-uefi-only/page-25?do=findComment&comment=1952283

NOTE: need to change the SMBIOS hardware section and CustomUUID to your own hardware.

My pack: https://www.firedrive.com/file/9991150C50684CB7

 

I want to thanks all creators of any components used for this test.

 

PS: sorry for bad english  ;) 

I have a t430 (Model: 2350-b49). I have all of them working on the installed MAvericks 10.9.0 except Brightness control. So i wanted to know if there is any kext to implement this without DSDT and any shortcut key to do this brightness change

Share this post


Link to post
Share on other sites

I have a t430 (Model: 2350-b49). I have all of them working on the installed MAvericks 10.9.0 except Brightness control. So i wanted to know if there is any kext to implement this without DSDT and any shortcut key to do this brightness change

HD3000/HD4000 Brightness Fix:

DSDT Patches from here: https://github.com/RehabMan/Laptop-DSDT-Patch

 

Apply:

"Rename GFX0 to IGPU"

"Brightness Fix (HD3000/HD4000)"

- rename patch must be done first and to all DSDT/SSDT that contain references to GFX0 that you're including in your final SSDT set

- Brightness patch must be done to the DSDT or SSDT that contains the definition for Device GFX0 (search for 'Device (GFX0)'

- Place DSDT and SSDT (if necessary) into a place where the bootloader will load them. For Clover, EFI/CLOVER/ACPI/patched (DSDT.aml, SSDT-x.aml where 'x' is a number). For Chameleon, /Extra/ssdt.aml, /Exra/ssdt-1.aml, /Extra/ssdt-2.aml, etc.

 

Install: https://github.com/RehabMan/OS-X-ACPI-Backlight

 

Shortcut keys are a separate issue from working backlight control... Depends on the PS2 drivers you're using.

Share this post


Link to post
Share on other sites

HD3000/HD4000 Brightness Fix:

DSDT Patches from here: https://github.com/RehabMan/Laptop-DSDT-Patch

 

Apply:

"Rename GFX0 to IGPU"

"Brightness Fix (HD3000/HD4000)"

- rename patch must be done first and to all DSDT/SSDT that contain references to GFX0 that you're including in your final SSDT set

- Brightness patch must be done to the DSDT or SSDT that contains the definition for Device GFX0 (search for 'Device (GFX0)'

- Place DSDT and SSDT (if necessary) into a place where the bootloader will load them. For Clover, EFI/CLOVER/ACPI/patched (DSDT.aml, SSDT-x.aml where 'x' is a number). For Chameleon, /Extra/ssdt.aml, /Exra/ssdt-1.aml, /Extra/ssdt-2.aml, etc.

 

Install: https://github.com/RehabMan/OS-X-ACPI-Backlight

 

Shortcut keys are a separate issue from working backlight control... Depends on the PS2 drivers you're using.

Can we do this with a kext rather than a DSDT( never done this).  Any guide as how to upgrade Mavericks 10.9.0 to 10.9.4

Share this post


Link to post
Share on other sites

Can we do this with a kext rather than a DSDT( never done this).  Any guide as how to upgrade Mavericks 10.9.0 to 10.9.4

Requires kext and DSDT edits. Follow instructions in post #48.

 

Upgrading OS X point version will depend on your procedure for installing... Many updates contain changes to kexts you may have patched, and thus will be overwritten.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By dandepeched
      I want to share my Thinkpad configuration that is running smooth with most of the functionality working.
       
      Laptop Specification
      Tested on 20KS003AXS model with macOS Mojave (10.14.6)
       
      Not Supported Hardware
      Native Wi-Fi (Intel AC 3165) Discrete graphics card (ATI Radeon RX 550) Card reader Fingerprint sensor Microphone 3.5" output (only headphones are working) Wi-Fi Fix
           Native Wi-Fi adapter was replaced with Broadcom BCM94352Z adapter
       
      Known Issues
      Lid close and FN keys stop working after sleep (fixed after reboot) Minor glitches for battery status is observed from time to time (empty or red battery icon while 100% charge) Handoff is unstable (works from time to time)  
      Configuration can be downloaded from my GitHub repo
    • By fusion71au
      This is a brief guide on how to create a vanilla El Capitan (also same process for Sierra) OS X Installer USB with an updated prelinked kernel containing FakeSMC.

      It is tailored for those users who want to understand the “nuts and bolts” of how to create an installer and also to help brush up on their terminal skills (rather than have one made for them with the numerous automated “tools” available or even Apple’s createinstallmedia) :
       
       
      Specifically, it is also a “Proof of Concept” which shows that installation is possible without even having to rely on boot loader kext injection.

      Prerequisites
      Existing Yosemite installation (or Mavericks - see post#4 for steps 7,8) “Install OS X El Capitan.app" downloaded to the Applications folder Pacifist FakeSMC.kext - Slice or Kozlek branch Bootloader - Clover or Chameleon 8GB or larger USB drive (16GB recommended), formatted HFS+ (MBR or GUID) named “Installer”  
      Procedure
      1.  Boot into Yosemite with the kext-dev-mode=1 boot flag
      2.  Open OS X terminal and type the following lines, followed by <Enter> after each line.
          The image restore and file copying may take a while to complete, and at the end of the process, the Installer volume is renamed to “OS X Base System"....
       
      sudo -s hdiutil attach /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/SharedSupport/InstallESD.dmg asr restore -source /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg  -target /Volumes/Installer -erase -format HFS+ -noprompt -noverify rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages cp -av /Volumes/OS\ X\ Install\ ESD/Packages /Volumes/OS\ X\ Base\ System/System/Installation cp -av /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg /Volumes/OS\ X\ Install\ ESD/BaseSystem.chunklist /Volumes/OS\ X\ Base\ System diskutil unmount /Volumes/OS\ X\ Install\ ESD exit 3.  Right click on the “OS X Base System” Volume and click “Get Info”
       

      4.  Click on the lock icon and untick “Ignore ownership on this volume”
       

      5.  Extract/Copy the El Capitan Kernels folder into /System/Library/ of the USB with Pacifist.  NB It is found in the "Essentials.pkg" in /System/Installation/Packages
       

      6.  Delete or Rename the original /System/Library/PrelinkedKernels/prelinkedkernel —> OG.prelinkedkernel
       

      7.  Copy FakeSMC.kext and other necessary kexts (e.g. VoodooPS2Controller.kext for laptops) into the /Library/Extensions folder of the installer USB using Finder.
       

      8.  Back in terminal, type the following lines, followed by <Enter> after each line to rebuild the prelinkedkernel…..
       
      sudo -s chmod -R 755 /Volumes/OS\ X\ Base\ System/Library/Extensions chown -R 0:0 /Volumes/OS\ X\ Base\ System/Library/Extensions touch /Volumes/OS\ X\ Base\ System/System/Library/Extensions kextcache -u /Volumes/OS\ X\ Base\ System exit Any errors should be noted but the output below is normal e.g.


      9. Install your Bootloader targeting the OS X Base System volume
       
       
       
       
      10.  Boot your system with the USB without injected kexts into the OS X Installer GUI....
       
       
       
       
       
      Post Install
      The original prelinked kernel in a fresh install of El Capitan will also lack FakeSMC ie it will only be linked to Apple signed kexts.  In order to boot into El Capitan the first time around without boot loader kext injection, the PLK needs to be rebuilt for the El Capitan volume like we did for the installer:
       
      1.  Boot into Yosemite with the kext-dev-mode=1 boot flag
      2.  Delete or Rename the original /System/Library/PrelinkedKernels/prelinkedkernel for the El Capitan volume —> OG.prelinkedkernel
      3.  Copy FakeSMC.kext and other necessary kexts (e.g. VoodooPS2Controller.kext for laptops) into the /Library/Extensions folder of El Capitan using Finder
      4.  Back in terminal, type the following lines, followed by <Enter> after each line to rebuild the prelinkedkernel.  In this example, the El Capitan volume is named "El_Capitan" - change if you have named it something else...
      sudo -s chmod -R 755 /Volumes/El_Capitan/Library/Extensions chown -R 0:0 /Volumes/El_Capitan/Library/Extensions touch /Volumes/El_Capitan/System/Library/Extensions kextcache -u /Volumes/El_Capitan exit 5. Install your Bootloader targeting the El Capitan volume.  This step is only necessary if you are installing El Capitan on a new drive without existing boot loader (not required if installing on a disk with existing boot loader beside Yosemite).
      6. Reboot your system without injected kexts into El Capitan!
       
       
      Other links
      The All-In-One Guide to Vanilla OS X for beginners
       
      Updates for Sierra and High Sierra   Custom Prelinkedkernel Generator Tool I have made a custom prelinkedkernel generator "PLK.tool" for Sierra + El Capitan.  Instructions:   1.  Download and extract the attached BaseSystem_PLK.tool.zip into your ~/Downloads folder.   2.  Copy any extra kexts necessary for booting your hack to ~/Downloads/BaseSystem/ExtraKexts (e.g. FakeSMC, VoodooPS2Controller), making sure SIP is disabled. 3.  Copy BaseSystem.dmg to ~/Downloads/BaseSystem  4.  Open terminal and run the following commands... cd ~/Downloads/BaseSystem chmod +x PLK.tool ./PLK.tool ---> supply your admin password ---> will place your new custom prelinkedkernel on the desktop.       macOS High Sierra bypass Firmware and MBR checks in post#13.
      BaseSystem_PLK.tool_ElCap.zip
      BaseSystem_PLK.tool_Sierra.zip
      BaseSystem_PLK.tool_Mojave.zip (need to run in Mojave to avoid dependency errors)
      BaseSystem_PLK.tool_Catalina.zip
    • By zkingtut
      Hello Everyone ,,
       
      I'd  like to share with you my experience with Lenovo ThinkPad P50 ( EFI , and Installation Process with some tips ) Hopefully to be useful for anyone who own Lenovo ThinkPad P50 
       
      Before start I want to show you my device specs , and I'm  sure 99% this will work too with any P50 have different spec. specially Intel i7 CPUs:
       
      - Intel Xeon E-3 1535 v5 ( P530 Intel HD Graphics )
      - 32 GB RAM
      - 256 GB SK Hynix Nvme SSD pc401 hfs256gd9tng-62a0a - for Mac OS  ( be careful not all nvme ssd are compatible)
      - 256 GB Samsung Evo 850 SSD - for Windows 
      - 4K Screen 
      - Nvidia Quadro M2000M 4 GB ( Useless - Disabled )
      - Intel WiFi Card ( Should be change to a compatible Broadcom one )
       
      BIOS SETUP :
       
      I highly recommend this steps before going to BIOS SETUP according to my experience with this Laptop :
       
            *( Update your BIOS Firmware to the latest one using windows )
       
            *( Remove Battery , Open the back cover and unplug the small CMOS BATTERY for about  4~5 minutes and put everything back again )
       
             * ( Remove any SSD HDD Nvme disks , USB , DisplayPort , Dock .. etc during installation, keep only the target Disk )
       
      -------------------------------------------
      Now Power your PC and Press F1 to enter the BIOS SETUP
       
         - Reset BIOS to its defaults
         - Adjust Date and Time 
         - Config ----> Network ---> Wake Up on Lan ( AC Only )
                                                         Network Stack ( Disabled )
       
        - USB ----> USB UEFI support  ( Enabled)
       
        - Display ------> Total Graphic Memory (256 MB)
                                     Graphic Device ( Hybrid)
       
        - RAID -----> Disabled
       
        - Security -----> Security Chip Selection ( Discrete TPM )
                                     Secure BOOT ( Disabled )
                                     Intel SGX Control ( Software Control )
       
        - Start Up ------>BOOT Priority order ( USB HDD - Mac OS Disk - Windows - and so on ....... with this order )
                                     UEFI/Legacy ( UEFI Only )
                                     CSM Support  ( NO )
      ----------------------------------------------------------------------------------------------------------------------------------
       
      **   F1 to Enter Bios - F12 for Boot Menu
      ***   Delete the EFI Folder in your Installation USB and replace it with the Attached one 
      ****   Generate new serial for SMBIOS MacBook Pro 13.1
      *****    If your CPU is XEON then go to Config.plist CPU Section and Add 0x05A5 under Type ( Fix for Unknown CPU )
      ****** You can delete boot-args "brcmfx=1 & brcmfx-driver=#a" if you want , I used it in my case with 1820A card to fix wifi issue
      ******    After you successfully installed OS , now Copy the same EFI Folder to your main EFI Boot Disk Partition 
      *******    Now install all the attached KEXTS to "Library / Extensions"  using Hackintool.app or by any method and rebuild cache and repair permissions
      ********    Check and compare the KEXTS in Library/ Extensions and Delete the repeated ones from Clover / Kexts / Others ( Important don't duplicate the same kexts here and there )
       
      FYI : LiluFriend.kext include ( Lilu , WhatEverGreen, AppleALC , AirportBrcmFixup ) All In One 
       
       
       
      You are Done 
      ---------------------------------------------------------------------------------------------------------------------------------
       
      What is working :
       
      - 4K Intel HD P530 2048 MB 
      - AUDIO
      - CAMERA 
      - ALL USB 3 PORTS , NO THUNDERBOLTS 
      - Keyboard and TouchPad 
      - Battery indicator 
      - Display Brightness 
      - Sleep 
      - DSDT has been patched , USB Ports modified only to MacBookPro 13.1
       
                   See the Screen Shot 
       
      Important Notice For Future OS Updates Installations : 
       
      To avoid Kernel Panic during install any future updates process please remove ( FakeSMC.kext and LiluFriend.kext ) from Library/Extensions directory to Clover / Kexts / Others .
      After update process finish put them back to Library/Extensions and delete them from clover . I hope this is clear enough
      ---------------------------------------------------------------------------------------------------------------------------------
       
      Happy Hackintosh , Let me know if you have any issue or difficulties during installation or later , I will try to help you
       
      EFI.zip
      kexts.zip

×