Jump to content
Uoc Nguyen

Thinkpad T430 - Mavericks 10.9.x - Yosemite 10.10

104 posts in this topic

Recommended Posts

Hi all.

 

I would like to share the results of  mixing my work and work of  other before me on my T430s (2355).

I use the post of UocNguyen as template(Thanks for the work!)

Working:

  • CPU PowerManagement  (SpeedStep enabled using ssdt-gen script and clover states generation option)
  • Intel HD4000 with AppleIntelFrameBufferCapri patched at latest version (10.9.3) to use internal LVDS and external DP port (i read apple removed support for embedded VGA start from 10.8.3 kext, from my tests i'm able to use a VGA monitor while start laptop from docking station with lid closed but there are something bad with EDID probe and with refresh so i think the very big problem is the VGA output use the same channel of internal LCD/LVDS)
  • Audio work with patched AppleHDA (and IOAudioFamily from 10.9.0) Speaker/Headphone/Internal Mic/Mic on headphone/
  • Ethernet work with AppleE1000.kext
  • Trackpoint, touchpad and keyboard work with VoodooPS2
  • Patched Bluetooth kext with support for BCM20702A0
  • USB 3 with GenericUSBXHCI ( Run at 5gbps), all 3 ports are capable to charging an iPad
  • Battery recognized with ACPIbatteryManager
  • WWAN HSPA Working with SIM inserted, modded CellPhoneHelper.kext,IOSerialFamily and modded CCL in /Library/ModemScripts/ (tell me if work!)
  • UEFI boot with latest version of CLOVER
  • Sleep, wake, restart and shutdown fully working (10.9.2 seems to resolve this issue)
  • Keyboard. Multimedia keys: Sleep, Prev / Play / Pause / Next (Brightness control with Fn-F8/F9 not work, mapped in DSDT with Fn-K/P)
  • Windows Installation on other SSD partition run fine with VMware Fusion Bootcamp and directly form choose it in Boot selection menù (when you boot with windows you must restore Clover EFI boot option manually in UEFI BIOS to start osx later, because the Micro$oft Boot loader set itself as primary when start  :yes: )

Additional external device:

* NOT working and know problem:

  • Intel Centrino Advanced-N 6205 Wireless adapter( simply no kext exist for this device....)
  • I tried to install mPCI-E Broadcom WLAN used in my old T420s but it's seems not possible to flash modded bios without external programmer. No success with any other methods like tape pin 20 of mPCI-E or placing in second mPCI-E slot.
  • Card reader (Partially working with VoodooSDHC kext, but sometimes system hangs. I removed the SD reader for using Wifi adapter)
  • Brought video from iTunes doesn't play on LVDS device (LCD display attached on VGA on board doesn't support HDCP)
  • WWAN icon in status bar appear only after sleep/wake cycle :huh: 
  • Headphone jack sometimes not work after sleep (it's seems to fixing itself after another sleep/wake cycle :blink:)
  • Headphone Volume control 

 

 

 For install use info from T420 thread: http://www.insanelymac.com/forum/topic/285678-lenovo-thinkpad-t420-with-uefi-only/page-25?do=findComment&comment=1952283

NOTE: need to change the SMBIOS hardware section and CustomUUID to your own hardware.

My pack: https://www.firedrive.com/file/9991150C50684CB7

 

I want to thanks all creators of any components used for this test.

 

PS: sorry for bad english  ;) 

Share this post


Link to post
Share on other sites
Advertisement

Good job @eilatuno

 

It is long time I have not boot into OS X as I am quite busy and most of time I'm working on Linux environment. Just back and took an upgrade to OS X 10.9.3 and it work well. I'm updating new report to #1 to keep topic clean and easy to find information.

Share this post


Link to post
Share on other sites

Hey guys! I'm having a problem with my T430 (Intel GPU). At first, after installing mavericks with a myHack installation USB, my laptop wouldn't start. After replacing the Bluetooth-related kext with the ones you provided, I was able to boot, but I couldn't get the actual Bluetooth working (it seems to be undetectable). My experience with other thinkpad laptops (which are, in general, quite good for this stuff) is that the problem was the Chamaleon bootloader, so I decided to install Clover, but when I installed it and after rebooting it (I replaced the standard config.plist with yours), I got the strange EFI bootloader screen (which is not related with clover in anyway, it's part of the UEFI Bios system). So, to sum up, I don't know what do I have to do in order to install Clover and boot up the machine.

Oh, the disk is partitioned as GPT and the Bios is set to "Legacy First".

 

Thank you guys!!

Share this post


Link to post
Share on other sites

Hey guys! I'm having a problem with my T430 (Intel GPU). At first, after installing mavericks with a myHack installation USB, my laptop wouldn't start. After replacing the Bluetooth-related kext with the ones you provided, I was able to boot, but I couldn't get the actual Bluetooth working (it seems to be undetectable). My experience with other thinkpad laptops (which are, in general, quite good for this stuff) is that the problem was the Chamaleon bootloader, so I decided to install Clover, but when I installed it and after rebooting it (I replaced the standard config.plist with yours), I got the strange EFI bootloader screen (which is not related with clover in anyway, it's part of the UEFI Bios system). So, to sum up, I don't know what do I have to do in order to install Clover and boot up the machine.

Oh, the disk is partitioned as GPT and the Bios is set to "Legacy First".

 

Thank you guys!!

Hi Anita if you use my package you must set UEFI only boot setting in your BIOS config. Before this you must configure the EFI/ESP partition and place the EFI folder from the zip directly in this small partition that already exist if you partition table is GPT. You have only to reformat this hidden partition from HFS to FAT32. This is a good guide for do this: http://www.insanelymac.com/forum/topic/287737-how-toclover-on-efi-partitionadd-to-bios/.

Share this post


Link to post
Share on other sites

Oh, thank you!! I'll check it out now and post what happens  ;)

 

EDIT: Ok, so I've successfully installed Clover, but every time I try to boot Maverick, the screen goes completely black (with no Apple logo whatsoever) and, after 2 minutes or so, the computer reboots. Booting with the -v flag shows this message:

efiboot loaded from device Acpi(PNP0A03.0)/Pci(1F|2)/SATA(0.0)/HD(Part2.SigFF040F85-B046-95E0-91830FEBA0857)
boot file path: System\Library\CoreServices\boot.efi
..

My GPU is a Intel 4000 and I have NOT added any SMBIOS or UUID to my config.plist. I have tried to boot with GraphicsEnabler=N, but clover keeps stuck in that step.

Share this post


Link to post
Share on other sites

Oh, thank you!! I'll check it out now and post what happens  ;)

 

EDIT: Ok, so I've successfully installed Clover, but every time I try to boot Maverick, the screen goes completely black (with no Apple logo whatsoever) and, after 2 minutes or so, the computer reboots. Booting with the -v flag shows this message:

efiboot loaded from device Acpi(PNP0A03.0)/Pci(1F|2)/SATA(0.0)/HD(Part2.SigFF040F85-B046-95E0-91830FEBA0857)
boot file path: System\Library\CoreServices\boot.efi
..

My GPU is a Intel 4000 and I have NOT added any SMBIOS or UUID to my config.plist. I have tried to boot with GraphicsEnabler=N, but clover keeps stuck in that step.

Have you tried to boot without caches from clover?

Share this post


Link to post
Share on other sites

Ok, I'm tired of trying. I don't know what to do. Did you used niresh or myhack, or just created a Clover OS X Installation USB??

Share this post


Link to post
Share on other sites

Ok, ok!! Sorry for being that annoying, but I've finally managed to get EVERYTHING working. The problem is that, after updating to 10.9.2, I don't know how to patch the AppleIntelCapri kext thing. Can someone please, please, upload their own patched version, I would really appreciate that a lot. Thanks for all!! ;)

Share this post


Link to post
Share on other sites

Ok, ok!! Sorry for being that annoying, but I've finally managed to get EVERYTHING working. The problem is that, after updating to 10.9.2, I don't know how to patch the AppleIntelCapri kext thing. Can someone please, please, upload their own patched version, I would really appreciate that a lot. Thanks for all!! ;)

Anita

 

you can use this http://fileom.com/q231lkyl331z

 
;-)

Share this post


Link to post
Share on other sites

The screen keeps on going to black before I see the desktop. I have changed the kexts (bluetooth and capri ones) and corrected permissions. Is there anything I'm doing wrong?? Do i have to add something to Clover's config.plist?? Is it that I need to use the DSDT?? What am I doing wrong??

Share this post


Link to post
Share on other sites

The screen keeps on going to black before I see the desktop. I have changed the kexts (bluetooth and capri ones) and corrected permissions. Is there anything I'm doing wrong?? Do i have to add something to Clover's config.plist?? Is it that I need to use the DSDT?? What am I doing wrong??

if you use my pack, the DSDT is already included...

Share this post


Link to post
Share on other sites

To alleviate some confusion, most of your post install issues have been discussed over here in the 420 thread: http://www.insanelymac.com/forum/topic/285678-lenovo-thinkpad-t420-with-uefi-only/page-25?do=findComment&comment=1952283 This link also drops you right on tluck's 420 guide which is a good jumping off point for those of you still having trouble installing. The thread was meant to be renamed to include the 430 but I never provided the OP with my files. It seems that Uoc Nguyen and eliatuno have a good packs. Please feel free to head over there and continue the discussion. I'd hate to see fellow 430 owners struggle and redo research when there's a parallel thread. Thanks for your work so far.

Share this post


Link to post
Share on other sites

@Sheep_Reaper: I think it is better to make another thread for T430 caused T420 and W520 are good threads for modern Thinkpads but they are a bit old and have some different hardware with T430 need another solution to solve it such as: NVIDIA card, Intel HD 4000, Bluetooth... I have research across all related threads and forum to make T430 work well with latest release of the Mavericks. Based on your reply, I think it is better to put all related links to OP to make it easy to reach and solve people issues (common issues).

Share this post


Link to post
Share on other sites

Ah ha,

 

Quite persuasive. I concur. However, the OP for the 420 thread is hard to contact. He has not been active for quite some time. As 430 questions pop up, I will direct them here. Currently there is at least one user that needs to enable discrete graphics and has thus far been unsuccessful. Perhaps you could jump in temporarily over to the 420 thread for some advice? I have a 2349GCU so no discrete graphics I'm afraid.

Share this post


Link to post
Share on other sites
Hi all

 

i've updated my system to 10.9.4, so i patched the new version of AppleIntelFramebufferCapri and IOBluetoothFamily, you can find them at end of post.

i tried to patch AppleHDA but audio don't work has expected, so i ask if anyone has successfully patched audio for ALC269?

 

i've another question for you, this update (10.9.4) and 10.9.3, broke my shutdown/reboot sequence, is the same for anyone?

 

Have a nice day

modded_10.9.4.zip

Share this post


Link to post
Share on other sites

Layout for T430s is 28, i tried to insert platform 28 in resources but i think is necessary to mod properly the appleHDA bin....

Share this post


Link to post
Share on other sites

Thanx for the nice Guide. I followed it but when it booted the installer USB it says CPU halted and shutsdown. So i used myHAck and installed the system and was able to login to the installed system using -v -f GraphicsEnabler=No. Any help on how to setup graphics, ethernet , audio. Below is my Thinkpad config

 

Thinkpad T430( Model: 2350-B49), Core i5 (ivy), Intel HD4000, 12 GB RAM, 1600X900 res.

Share this post


Link to post
Share on other sites

Hey,

 

i managed to get everything working except BT and Mic. 

Can you please tell me what you have done to get it work?

Thanks!

 

//EDIT:

Sound working

BT working

 

Hey,

 

i managed to get everything working except BT and Mic. 

Can you please tell me what you have done to get it work?

Thanks!

 

//EDIT:

Sound working

BT working

Can you tell us if Brightness work and what kexts was used if so. Any info on getting the battery monitor working wold be helpful. Thanx

Share this post


Link to post
Share on other sites

Hi all.

 

I would like to share the results of  mixing my work and work of  other before me on my T430s (2355).

I use the post of UocNguyen as template(Thanks for the work!)

Working:

  • CPU PowerManagement  (SpeedStep enabled using ssdt-gen script and clover states generation option)
  • Intel HD4000 with AppleIntelFrameBufferCapri patched at latest version (10.9.3) to use internal LVDS and external DP port (i read apple removed support for embedded VGA start from 10.8.3 kext, from my tests i'm able to use a VGA monitor while start laptop from docking station with lid closed but there are something bad with EDID probe and with refresh so i think the very big problem is the VGA output use the same channel of internal LCD/LVDS)
  • Audio work with patched AppleHDA (and IOAudioFamily from 10.9.0) Speaker/Headphone/Internal Mic/Mic on headphone/
  • Ethernet work with AppleE1000.kext
  • Trackpoint, touchpad and keyboard work with VoodooPS2
  • Patched Bluetooth kext with support for BCM20702A0
  • USB 3 with GenericUSBXHCI ( Run at 5gbps), all 3 ports are capable to charging an iPad
  • Battery recognized with ACPIbatteryManager
  • WWAN HSPA Working with SIM inserted, modded CellPhoneHelper.kext,IOSerialFamily and modded CCL in /Library/ModemScripts/ (tell me if work!)
  • UEFI boot with latest version of CLOVER
  • Sleep, wake, restart and shutdown fully working (10.9.2 seems to resolve this issue)
  • Keyboard. Multimedia keys: Sleep, Prev / Play / Pause / Next (Brightness control with Fn-F8/F9 not work, mapped in DSDT with Fn-K/P)
  • Windows Installation on other SSD partition run fine with VMware Fusion Bootcamp and directly form choose it in Boot selection menù (when you boot with windows you must restore Clover EFI boot option manually in UEFI BIOS to start osx later, because the Micro$oft Boot loader set itself as primary when start  :yes: )

Additional external device:

* NOT working and know problem:

  • Intel Centrino Advanced-N 6205 Wireless adapter( simply no kext exist for this device....)
  • I tried to install mPCI-E Broadcom WLAN used in my old T420s but it's seems not possible to flash modded bios without external programmer. No success with any other methods like tape pin 20 of mPCI-E or placing in second mPCI-E slot.
  • Card reader (Partially working with VoodooSDHC kext, but sometimes system hangs. I removed the SD reader for using Wifi adapter)
  • Brought video from iTunes doesn't play on LVDS device (LCD display attached on VGA on board doesn't support HDCP)
  • WWAN icon in status bar appear only after sleep/wake cycle :huh: 
  • Headphone jack sometimes not work after sleep (it's seems to fixing itself after another sleep/wake cycle :blink:)
  • Headphone Volume control 

 

 

 For install use info from T420 thread: http://www.insanelymac.com/forum/topic/285678-lenovo-thinkpad-t420-with-uefi-only/page-25?do=findComment&comment=1952283

NOTE: need to change the SMBIOS hardware section and CustomUUID to your own hardware.

My pack: https://www.firedrive.com/file/9991150C50684CB7

 

I want to thanks all creators of any components used for this test.

 

PS: sorry for bad english  ;) 

I have a t430 (Model: 2350-b49). I have all of them working on the installed MAvericks 10.9.0 except Brightness control. So i wanted to know if there is any kext to implement this without DSDT and any shortcut key to do this brightness change

Share this post


Link to post
Share on other sites

I have a t430 (Model: 2350-b49). I have all of them working on the installed MAvericks 10.9.0 except Brightness control. So i wanted to know if there is any kext to implement this without DSDT and any shortcut key to do this brightness change

HD3000/HD4000 Brightness Fix:

DSDT Patches from here: https://github.com/RehabMan/Laptop-DSDT-Patch

 

Apply:

"Rename GFX0 to IGPU"

"Brightness Fix (HD3000/HD4000)"

- rename patch must be done first and to all DSDT/SSDT that contain references to GFX0 that you're including in your final SSDT set

- Brightness patch must be done to the DSDT or SSDT that contains the definition for Device GFX0 (search for 'Device (GFX0)'

- Place DSDT and SSDT (if necessary) into a place where the bootloader will load them. For Clover, EFI/CLOVER/ACPI/patched (DSDT.aml, SSDT-x.aml where 'x' is a number). For Chameleon, /Extra/ssdt.aml, /Exra/ssdt-1.aml, /Extra/ssdt-2.aml, etc.

 

Install: https://github.com/RehabMan/OS-X-ACPI-Backlight

 

Shortcut keys are a separate issue from working backlight control... Depends on the PS2 drivers you're using.

Share this post


Link to post
Share on other sites

HD3000/HD4000 Brightness Fix:

DSDT Patches from here: https://github.com/RehabMan/Laptop-DSDT-Patch

 

Apply:

"Rename GFX0 to IGPU"

"Brightness Fix (HD3000/HD4000)"

- rename patch must be done first and to all DSDT/SSDT that contain references to GFX0 that you're including in your final SSDT set

- Brightness patch must be done to the DSDT or SSDT that contains the definition for Device GFX0 (search for 'Device (GFX0)'

- Place DSDT and SSDT (if necessary) into a place where the bootloader will load them. For Clover, EFI/CLOVER/ACPI/patched (DSDT.aml, SSDT-x.aml where 'x' is a number). For Chameleon, /Extra/ssdt.aml, /Exra/ssdt-1.aml, /Extra/ssdt-2.aml, etc.

 

Install: https://github.com/RehabMan/OS-X-ACPI-Backlight

 

Shortcut keys are a separate issue from working backlight control... Depends on the PS2 drivers you're using.

Can we do this with a kext rather than a DSDT( never done this).  Any guide as how to upgrade Mavericks 10.9.0 to 10.9.4

Share this post


Link to post
Share on other sites

Can we do this with a kext rather than a DSDT( never done this).  Any guide as how to upgrade Mavericks 10.9.0 to 10.9.4

Requires kext and DSDT edits. Follow instructions in post #48.

 

Upgrading OS X point version will depend on your procedure for installing... Many updates contain changes to kexts you may have patched, and thus will be overwritten.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By nysander
      I start this topic to make my Lenovo Thinkpad W540 usable with High Sierra
       
      I followed many guides but this one started by @tluck made me most progress: 
      My setup as in signature
       
      I will update first post with statuses of working features:
       
      Graphics:
      Nvidia Quadro - disabled
      Intel HD 4600 - working @ 1920x1080 and 1,5GB RAM (had to set ig-plaform-id as Haswell desktop, mobile do not work)
      using intelGraphicsFixUp.kext
       
      Sound:
      internal speakers and mic works with AppleACL.kext and profile 28

      USB:
      i boot MacOS from USB drive and it works, mouse and pendrive also works
      USB power not work yet, so USB WiFi dongle and iPhone connection not work (no power @ USB)
      IOReq finds only USB 3.0 controller not USB 2.0 even though I have 2 ports USB 3.0 and 2 ports USB 2.0
       
       
      Integrated Camera:
      recognised in IOReq but not working now (probably due to USB)
       
      Bluetooth:
      as USB but works without problem

      Ethernet:
      works with intelMausiEthernet.kext

      Keyboard:
      internal is PS2 so VoodooPS2Controller.kext is needed - some mappings I would like to have different but works

      Touchpad:
      works with VoodooPS2Controller.kext from @tluck topic
       
      Trackpoint:
      One time works mostly not - debugging in progress
       
      Batery Status:
      not working
       
      Integrated WiFi:
      intel -  not working
       
      Sleep / Hibernate:
      not working
       
      Backlight:
      not working
       
      Other found issues:
      besides that graphics works @ 1920x1080 and have a lots of ram window shadows (especially dock shadow) looks bad
       
      External VGA:
      not tested yet
       
      External Mini Display Port / Thunderbolt:
      not tested yet
       
      I will post my clover / debug config later
       
       
    • By gengik84
      Ciro82==>>Thanks
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      ShowAllfiles 
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      “CONDIZIONI OBBLIGATORIE”
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Immagine 
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Immagine  
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
      Immagine 
       
      =====================
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Esempio
      ===========================
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
       
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.13.... 
      BENE…IL PROCESSO DI CREAZIONE E’ INIZIATO…
      AVREMO CIRCA 20/30 MINUTI DI TEMPO LIBERO A CUI DEDICARSI A CIO’ CHE VOGLIAMO………………………………………..  
      COLGO L’OCCASIONE PER FARVI NOTARE LA VELOCITA’ E LA SICUREZZA DI QUESTO METODO
      CONFRONTATE QUESTO CON IL TERZO METODO E NOTERETE CHE CON UN SOLO PASSAGGIO, OSSIA IL COMANDO DATO AL TERMINALE, FACCIAMO IN UNA SINGOLA OPERAZIONE TUTTI I VARI STEP DESCRITTI SULL’ ALTRO METODO.
      DETTO QUESTO, MOLTO IMPORTANTE E’ SOTTOLINEARE CHE COSI’ FACENDO EVITEREMO ERRORI  DI DISTRAZIONE RIGUARDO AI PASSAGGI O FRAINTENDIMENTI.
      Immagine 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      *NOTA*:
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      =========================
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      ==========================
      Bootloader
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.
      Immagine 

       
      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  selezionate OsxAptioFixDrv-64
                             *  :Se nel vostro sistema è presente una scheda grafica (discreta) della serie 9xx nVidia selezionate OsxAptioFix2Drv-64 al posto di  OsxAptioFixDrv-64 *
      ** OsxAptioFix2Drv :E' necessario per poter impostare CsrActiveConfig= 0x3 **
      ***OsxAptioFix3Drv oppure AptioMemory --> (consigliato) devono essere usati su hardware Skylake o successivi perché permettono alla nvram di lavorare correttamente
           (mi raccomando o uno o l'altro)
      Proseguite con l’installazione.
      Immagine 
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      ===========================
      Per installazione Legacy
      Immagine 
      ===========================
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      Immagine 
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      Immagine 
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      Immagine 
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      Immagine 
      7) Sezione System Parameters: Su inject kext mettete YES
      Immagine 
      ===========================
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Info:
      ===========================
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Immagine 
      
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
       
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      --------------------------------------------------------------------
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
       
       
       
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto.zip
      Pacchetto-2.zip
      apfs.efi-10.13-NoLog.zip
      Pacchetto-Fake+Sensors 6.26.1440.zip
      apfs.efi-10.13.1-No_LOG.zip
      apfs.efi-10.13.2_No_Log.zip
      apfs.efi-10.13.3-No_Log.zip
      apfs.efi-10.13.4-No_Log.zip
      apfs.efi-10.13.5_No_Log.zip
      C_I_M.zip
       
      apfs.efi-10.14-beta1_No_Log.zip
    • By partha.slg123
      Hackintosh High Sierra 10.13.3 USB Installer Boot Into USB DIrectly Enter Exit Option Menu. Clover Boot Menu Not Showing. Plz Help .................
       

       
      My System Specification :

      CPU : Core i5 6400
      MB : Asus H110M-CS
      RAM : 8GB DDR 4
      HDD : WD 1TB For Windows And WD 500 GB For Hackintosh
      Bootloader : Clover
    • By Ssking
      Hello...
      i am ssking....
      Now i am using
      Asus n43jf laptop
      1st generation core i 5 460m
      4gb ddr 3 ram
      500 gb harddisk
      Intel  graphics 1650 mb and Nvidia geforce gt 425m 1gb ddr3
      now i am using yosemite 10.10.5 nicely
      but how to disable intel gpu and use nvidia 425m 1gb gpu?
      Is there any way to use nvidia gpu from my dual graphics laptop?
    • By zeg66
      Please help me with this 10.9.5 system. Motherboard: Gigabyte 965p-s3 rev3.3, gpu: Ati Radeon HD6450 (dvi/hdmi/vga). 
      Using any of the 3 ports on the 6450 (dvi, hdmi, vga), I see all the white letters on black background during boot but when they complete and it's time for the graphics to start I get a black screen and sometimes a restart after that. Using Clover 4411. Is there any way to get past this?
×