Jump to content
Uoc Nguyen

Thinkpad T430 - Mavericks 10.9.x - Yosemite 10.10

104 posts in this topic

Recommended Posts

Download

http://goo.gl/qlWGgU

 


UPDATE

 


10.10.1 - Nov 18, 2014:

- Updated to 10.10.1

- Use modified Apple's IOBluetoothFamily.kext version for Bluetooth.

- Switch back to Apple's AppleHDA.kext.

- Patch on the fly using CLOVER for AppleHDA and AppleIntelFramebufferCapri

- Use NVIDIA Web Driver, URL to download from this thread: topic/301416-nvidia-web-driver-updates-for-yosemite/

- BIOS settings: set boot mode to Both (UEFI & Legacy), UEFI First to avoid problem with Optimus and NVIDIA Discrete mode

 


10.10 beta 5 - Oct 13, 2014:

- Updated to 10.10 beta 5

- Added package for 10.10: Bluetooth work with old IOBluetoothFamily.kext from 10.9.x. Updated DSDT for NVIDIA, Optimus and Intel only.

- Move to mega.co.nz for better hosting and versioning.

 


10.10 beta 3 - Sep 26, 2014:

Anyone tried 10.10 Yosemite? I tried last night and it's work with some issues, but useable. I have updated to Beta 3 also.

Here is some screenshots:

 

post-206862-0-14962300-1412026300_thumb.png

post-206862-0-19564200-1412026313_thumb.png

 

Short summary:

 

- Bluetooth

- NVIDIA not work (DP1, not tested on Beta3)

- Intel HD4000: native res but no QE/CI

- Sound: Need to patch AppleHDA.kext for layout 28

- Battery: need new patch in DSDT (use tluck's T420 DSDT work)

- Sleep / Shutdown work as Mavericks

 

 

Quick way:

 

- Update your CLOVER first to latest: sourceforge.net/projects/cloverefiboot/files/latest/download

- Create bootable usb or partition using this guide: http://www.insanelymac.com/forum/topic/298521-easy-yosemite-1010-usb-installer-updated-9-2-2014/

Note: you will need to copy BaseSystem.dmg (it is big as 470MB) so you will need at least 8GB USB. I have 6.5GB partition and it is fit for setup size but I don't have room for modding (kext, backup...)

- Download CLOVER package from tluck's topic then extract, backup your kexts and copy all EFI/CLOVER/kexts/10.10/*.kext to /S/L/E/

- Add kext-dev-mode=1 to CLOVER kernel argument.

- After install / upgrade you will need to re-copy all kexts.

 

Update 1: Never mind, NVIDIA work well after repair permission. System FAN and Thermal Sensor for NVIDIA not show (need to patch with new DSDT)

Update 2:

- System FAN, GPU and other thermal sensor work after update DSDT, updated HW Monitor and latest FakeSMC.

- NVIDIA Work but not detect / turn on built-in monitor, need to detect displays in displays settings to turn it on after boot.

- Bluetooth still not work

- Sound work with VoodooHDA

- Battery work

 

Look like CPU throttled too much, it is stick at 3Ghz most time and temperature is about 90oC @@, might need to generate SSDT or can be Yosemite issue. The temperature is about ~50-60oC with Intel HD4000.

 


 

10.9.3:

 

  • ​HWMonitor version 6.8.1307 support FAN sensor (Check for update inside app and install FakeSMC and all it's plugins)
  • NVIDIA: new version not work, replace with old working kexts (NV*.kext)
  • Intel HD 4000 Capri: patch with Platform-ID `0300 6601` - Hex: `01 00 00 00 02 00 00 00 30 02 00 00`
  • AppleHDA: patch-hda-3.1 NOT work - Work with VoodooHDA 2.8.4 (download from zip file here or pkg installer here
  • AppleIntelCPUPowerManagement.kext patch with AICPMPatch

  • Bluetooth: using modified kext from #26 (thanks @eilatuno)

  • Others old kexts: AppleACPIPlatform.kext, IOUSBFamily.kext
  • Shutdown / Restart / Sleep work well using latest CLOVER r2671


 

10.9.1:

  • Sound stop working as AppleHDA.kext updated for VoiceOver bug fix, re-patch with patch AppleHDA script 3.1 from this thread
  • Everything work well as 10.9.0 as last. Still have problem with Shutdown / Restart / Sleep


 

 

STATUS

 


* Working parts:

  • Intel HD 4000 (Capri): Full resolution: 1600x900, QE/CI
  • NVIDIA GF108M (NVS 5400M):  Full resolution: 1600x900, QE/CI
  • VGA, Display Port
  • Wired network / Ethernet
  • Think Light, Keyboard backlit (BIOS controlled)
  • Webcam
  • Mic, Speaker, Audio Jack
  • Bluetooth
  • Trackpoint, Touchpad
  • USB 3.0
  • Battery
  • UEFI with CLOVER r2366
  • Keyboard. Multimedia keys: Sleep, Prev / Play / Pause / Next (Brightness control with Fn-F8/F9 not work)
  • Shutdown / Restart / Sleep

* NOT working parts:

  • Intel Centrino Advanced-N 6205 Wireless adapter
  • Card reader


 

HOW TO

 

1. Create Mac OS X Maverick 10.9 USB installer: Google it!

 

2. Install CLOVER EFI bootloader or Chameleon

Use my config.plist if you install CLOVER

NOTE: need to change the SMBIOS hardware section and CustomUUID to your own hardware.

 

3. Backup and copy kexts from attached file

 

4. Option: install LCD display profile

 

5. Option: install HWMonitor.app 

 

6. DSDT: Use diff tool to apply diff changes

a) I'm using 3 different DSDT file for 3 graphic config mode:

  • DSDT.d.dsl / DSDT.d.aml: for Discrete graphic only BIOS config
    • VGA, Mini-DP work well but hottest
    • Temperatures on my machine:
      • CPU: avg: 65oC, range: 60-85
      • GPU: avg: 60oC, range: 56-74
  • DSDT.o.dsl / DSDT.o.aml: for Optimus graphic BIOS config - NOTE: you will need to backup & remove  /S/L/E/NVDA* because of OS X not support Optimus mode and it caused conflict loading video driver.
  • DSDT.i.dsl / DSDT.i.aml: for Integrated graphic only BIOS config

B) Optimus & Integrated gave me much more cooler temperatures but NO VGA, Min-DP - I usually use Integrated mode for travelling and Discrete mode for work because I need extend to my external Dell monitor.

 

c) Temperatures when using Integrated only mode:

  • CPU: avg: 45oC, range: 40-70-80

d) I added FAN control to DSDT based on T420 / W520 guides, Thinkvantage button will be used to toggle turbo fan mode.

 

7. SSDT: I used auto generated P-States and C-States CLOVER's option

 


 

Hardware Specifications

 


 

- Model: Thinkpad T430 2344BMU
- lshw -numeric on Ubuntu 13.10

 

Hardware specs

 

 

HOSTNAME
    description: Notebook
    product: 2344BMU (LENOVO_MT_2344)
    vendor: LENOVO
    version: ThinkPad T430
    serial: [REMOVED]
    width: 64 bits
    capabilities: smbios-2.7 dmi-2.7 vsyscall32
    configuration: administrator_password=disabled chassis=notebook family=ThinkPad T430 power-on_password=disabled sku=LENOVO_MT_2344 uuid=[REMOVED]
  *-core
       description: Motherboard
       product: 2344BMU
       vendor: LENOVO
       physical id: 0
       version: Win8 Pro DPK TPG
       serial: [REMOVED]
       slot: Not Available
     *-cpu
          description: CPU
          product: Intel® Core i5-3320M CPU @ 2.60GHz
          vendor: Intel Corp.
          physical id: 1
          bus info: cpu@0
          version: Intel® Core i5-3320M CPU @ 2.60GHz
          serial: None
          slot: CPU Socket - U3E1
          size: 1200MHz
          capacity: 1200MHz
          width: 64 bits
          clock: 100MHz
          capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms cpufreq
          configuration: cores=2 enabledcores=2 threads=4
        *-cache:0
             description: L1 cache
             physical id: 3
             slot: L1-Cache
             size: 32KiB
             capacity: 32KiB
             capabilities: internal write-through instruction
        *-cache:1
             description: L2 cache
             physical id: 4
             slot: L2-Cache
             size: 256KiB
             capacity: 256KiB
             capabilities: internal write-through unified
        *-cache:2
             description: L3 cache
             physical id: 5
             slot: L3-Cache
             size: 3MiB
             capacity: 3MiB
             capabilities: internal write-back unified
     *-cache
          description: L1 cache
          physical id: 2
          slot: L1-Cache
          size: 32KiB
          capacity: 32KiB
          capabilities: internal write-through data
     *-memory
          description: System Memory
          physical id: 7
          slot: System board or motherboard
          size: 16GiB
        *-bank:0
             description: SODIMM DDR3 Synchronous 1333 MHz (0.8 ns)
             product: CMSO8GX3M1A1333C9
             vendor: AMI
             physical id: 0
             serial: 00000000
             slot: ChannelA-DIMM0
             size: 8GiB
             width: 64 bits
             clock: 1333MHz (0.8ns)
        *-bank:1
             description: SODIMM DDR3 Synchronous 1333 MHz (0.8 ns)
             product: CMSO8GX3M1A1333C9
             vendor: AMI
             physical id: 1
             serial: 00000000
             slot: ChannelB-DIMM0
             size: 8GiB
             width: 64 bits
             clock: 1333MHz (0.8ns)
     *-firmware
          description: BIOS
          vendor: LENOVO
          physical id: c
          version: G1ET94WW (2.54 )
          date: 04/22/2013
          size: 128KiB
          capacity: 11MiB
          capabilities: pci pnp upgrade shadowing cdboot bootselect edd int13floppy720 int5printscreen int9keyboard int14serial int17printer int10video acpi usb biosbootspecification uefi
     *-pci
          description: Host bridge
          product: 3rd Gen Core processor DRAM Controller [8086:154]
          vendor: Intel Corporation [8086]
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 09
          width: 32 bits
          clock: 33MHz
        *-pci:0
             description: PCI bridge
             product: Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port [8086:151]
             vendor: Intel Corporation [8086]
             physical id: 1
             bus info: pci@0000:00:01.0
             version: 09
             width: 32 bits
             clock: 33MHz
             capabilities: pci pm msi pciexpress normal_decode bus_master cap_list
             configuration: driver=pcieport
             resources: irq:42 ioport:5000(size=4096) memory:f0000000-f10fffff ioport:c0000000(size=301989888)
           *-display
                description: VGA compatible controller
                product: GF108M [NVS 5400M] [10DE:DEF]
                vendor: NVIDIA Corporation [10DE]
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a1
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
                configuration: driver=nvidia latency=0
                resources: irq:16 memory:f0000000-f0ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:5000(size=128) memory:f1000000-f107ffff
        *-display
             description: VGA compatible controller
             product: 3rd Gen Core processor Graphics Controller [8086:166]
             vendor: Intel Corporation [8086]
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 09
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:46 memory:f1400000-f17fffff memory:e0000000-efffffff ioport:6000(size=64)
        *-usb:0
             description: USB controller
             product: 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1E31]
             vendor: Intel Corporation [8086]
             physical id: 14
             bus info: pci@0000:00:14.0
             version: 04
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi xhci bus_master cap_list
             configuration: driver=xhci_hcd latency=0
             resources: irq:43 memory:f3920000-f392ffff
        *-communication:0
             description: Communication controller
             product: 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1E3A]
             vendor: Intel Corporation [8086]
             physical id: 16
             bus info: pci@0000:00:16.0
             version: 04
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi bus_master cap_list
             configuration: driver=mei_me latency=0
             resources: irq:48 memory:f3935000-f393500f
        *-communication:1
             description: Serial controller
             product: 7 Series/C210 Series Chipset Family KT Controller [8086:1E3D]
             vendor: Intel Corporation [8086]
             physical id: 16.3
             bus info: pci@0000:00:16.3
             version: 04
             width: 32 bits
             clock: 66MHz
             capabilities: pm msi 16550 bus_master cap_list
             configuration: driver=serial latency=0
             resources: irq:19 ioport:60b0(size=8) memory:f393c000-f393cfff
        *-network
             description: Ethernet interface
             product: 82579LM Gigabit Network Connection [8086:1502]
             vendor: Intel Corporation [8086]
             physical id: 19
             bus info: pci@0000:00:19.0
             logical name: eth0
             version: 04
             serial: [REMOVED]
             size: 100Mbit/s
             capacity: 1Gbit/s
             width: 32 bits
             clock: 33MHz
             capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
             configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k duplex=full firmware=0.13-3 ip=192.168.0.101 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
             resources: irq:44 memory:f3900000-f391ffff memory:f393b000-f393bfff ioport:6080(size=32)
        *-usb:1
             description: USB controller
             product: 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1E2D]
             vendor: Intel Corporation [8086]
             physical id: 1a
             bus info: pci@0000:00:1a.0
             version: 04
             width: 32 bits
             clock: 33MHz
             capabilities: pm debug ehci bus_master cap_list
             configuration: driver=ehci-pci latency=0
             resources: irq:16 memory:f393a000-f393a3ff
        *-multimedia
             description: Audio device
             product: 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1E20]
             vendor: Intel Corporation [8086]
             physical id: 1b
             bus info: pci@0000:00:1b.0
             version: 04
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi pciexpress bus_master cap_list
             configuration: driver=snd_hda_intel latency=0
             resources: irq:49 memory:f3930000-f3933fff
        *-pci:1
             description: PCI bridge
             product: 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1E10]
             vendor: Intel Corporation [8086]
             physical id: 1c
             bus info: pci@0000:00:1c.0
             version: c4
             width: 32 bits
             clock: 33MHz
             capabilities: pci pciexpress msi pm normal_decode bus_master cap_list
             configuration: driver=pcieport
             resources: irq:16 ioport:4000(size=4096) memory:f3100000-f38fffff ioport:f1800000(size=8388608)
           *-generic
                description: System peripheral
                product: MMC/SD Host Controller [1180:E822]
                vendor: Ricoh Co Ltd [1180]
                physical id: 0
                bus info: pci@0000:02:00.0
                version: 07
                width: 32 bits
                clock: 33MHz
                capabilities: msi pm pciexpress bus_master cap_list
                configuration: driver=sdhci-pci latency=0
                resources: irq:16 memory:f3100000-f31000ff
        *-pci:2
             description: PCI bridge
             product: 7 Series/C210 Series Chipset Family PCI Express Root Port 2 [8086:1E12]
             vendor: Intel Corporation [8086]
             physical id: 1c.1
             bus info: pci@0000:00:1c.1
             version: c4
             width: 32 bits
             clock: 33MHz
             capabilities: pci pciexpress msi pm normal_decode bus_master cap_list
             configuration: driver=pcieport
             resources: irq:17 memory:f3000000-f30fffff
           *-network DISABLED
                description: Wireless interface
                product: Centrino Advanced-N 6205 [Taylor Peak] [8086:85]
                vendor: Intel Corporation [8086]
                physical id: 0
                bus info: pci@0000:03:00.0
                logical name: wlan0
                version: 34
                serial: [REMOVED]
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=iwlwifi driverversion=3.11.0-12-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
                resources: irq:47 memory:f3000000-f3001fff
        *-pci:3
             description: PCI bridge
             product: 7 Series/C210 Series Chipset Family PCI Express Root Port 3 [8086:1E14]
             vendor: Intel Corporation [8086]
             physical id: 1c.2
             bus info: pci@0000:00:1c.2
             version: c4
             width: 32 bits
             clock: 33MHz
             capabilities: pci pciexpress msi pm normal_decode bus_master cap_list
             configuration: driver=pcieport
             resources: irq:18 ioport:3000(size=4096) memory:f2800000-f2ffffff ioport:f2000000(size=8388608)
        *-usb:2
             description: USB controller
             product: 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1E26]
             vendor: Intel Corporation [8086]
             physical id: 1d
             bus info: pci@0000:00:1d.0
             version: 04
             width: 32 bits
             clock: 33MHz
             capabilities: pm debug ehci bus_master cap_list
             configuration: driver=ehci-pci latency=0
             resources: irq:23 memory:f3939000-f39393ff
        *-isa
             description: ISA bridge
             product: QM77 Express Chipset LPC Controller [8086:1E55]
             vendor: Intel Corporation [8086]
             physical id: 1f
             bus info: pci@0000:00:1f.0
             version: 04
             width: 32 bits
             clock: 33MHz
             capabilities: isa bus_master cap_list
             configuration: driver=lpc_ich latency=0
             resources: irq:0
        *-storage
             description: SATA controller
             product: 7 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1E03]
             vendor: Intel Corporation [8086]
             physical id: 1f.2
             bus info: pci@0000:00:1f.2
             version: 04
             width: 32 bits
             clock: 66MHz
             capabilities: storage msi pm ahci_1.0 bus_master cap_list
             configuration: driver=ahci latency=0
             resources: irq:45 ioport:60a8(size=8) ioport:60bc(size=4) ioport:60a0(size=8) ioport:60b8(size=4) ioport:6060(size=32) memory:f3938000-f39387ff
        *-serial UNCLAIMED
             description: SMBus
             product: 7 Series/C210 Series Chipset Family SMBus Controller [8086:1E22]
             vendor: Intel Corporation [8086]
             physical id: 1f.3
             bus info: pci@0000:00:1f.3
             version: 04
             width: 64 bits
             clock: 33MHz
             configuration: latency=0
             resources: memory:f3934000-f39340ff ioport:efa0(size=32)
     *-scsi:0
          physical id: 0
          logical name: scsi0
          capabilities: emulated
        *-disk
             description: ATA Disk
             product: HITACHI HTS72505
             vendor: Hitachi
             physical id: 0.0.0
             bus info: scsi@0:0.0.0
             logical name: /dev/sda
             version: GH2Z
             serial: [REMOVED]
             size: 465GiB (500GB)
             capabilities: gpt-1.00 partitioned partitioned:gpt
             configuration: ansiversion=5 guid=583f6577-bf94-48b1-a9be-67462968b84f sectorsize=4096
           *-volume:xxx [REMOVED]
     *-scsi:1
          physical id: 3
          logical name: scsi1
          capabilities: emulated
        *-cdrom
             description: DVD-RAM writer
             product: DVD RW AD-7740H
             vendor: Optiarc
             physical id: 0.0.0
             bus info: scsi@1:0.0.0
             logical name: /dev/cdrom
             logical name: /dev/sr0
             version: 1.S1
             capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
             configuration: ansiversion=5 status=nodisc
  *-battery
       product: 45N1007
       vendor: SANYO
       physical id: 1
       slot: Rear
       capacity: 93240mWh
       configuration: voltage=11.1V

 

Big thanks for everyone who has involved in this thread and who created stuffs, guides, tools...

Thanks for @tluck & experts in this thread to provide related update and information which I used in my package.

 

Feel free to ask and discussion here about Mac OS X on T430 series, I will try to help if I can in my spared time.

Edited by Uoc Nguyen

Share this post


Link to post
Share on other sites
Advertisement

Hi,  when do you plan on posting kexts?  I've recently install 10.9 on my T430 however am yet to get USB3 or the webcam working.  I've used myhack/chameleon, should I instead be using clover to ensure success?

 

Aside from the Nvidia chipset, my hardware seems to be identical to yours.

Share this post


Link to post
Share on other sites

Hi,

 

I bought a Thinkpad T430 last year and would like to install OS X Mavericks.  The H/W configuration is similar to you guys.  Could you guys please share the steps and procedures?

 

Many Thanks.

Share this post


Link to post
Share on other sites

Just to notify that I updated #1

 

Sorry for lately update, I was very busy and I can not find any spare time to collect changes, package them together and update guide.

Share this post


Link to post
Share on other sites

Thanks Uoc Nguyen.  I'm new to hackintosh and I probably will have other questions be posted later.

 

Thanks again for your help.

Share this post


Link to post
Share on other sites

Uoc Nguyen

 

I have T430 Model 2347-A82

 

Could you please post or MSG me the screen shots of your bios settings? I also would like to know if you used any switches to allow Mavericks to install I am currently getting the spinning loader to a black screen. If it helps to see my specs I can get these for you your help would be appreciated.

 

Also I was able to get Mountain Lion to work with some of the files you posted so I believe I am just missing something simple with Mavericks install.

 

Thank You

Share this post


Link to post
Share on other sites

@techitch: My BIOS config is normal, I enabled almost everything. You can see boot switches in CLOVER/config.plist file inside my attachment in post #1.

 

Let's post your screenshot of your boot progress with switch '-v' without quote.

Share this post


Link to post
Share on other sites

@Uoc Nguyen thank you for your response I think thats where I went wrong I used another method to boot because it was more straight forward for my new skills. May I ask how to find my SMBIOS and CUSTOMUUID? I found these values in your config.plist but I don't know how to get these values. I will work on using CLOVER in the morning to see if I get further installing OS X M. If it still hangs I will upload screen shot using -v switch


@ Uoc Nguyen: Found UUID in bios dough GOOGLE helps a lot!! working on SMBIOS now

Share this post


Link to post
Share on other sites

You can download Clover Configurator from here: http://mackie100.webwacemaster.altervista.org/ -> generate new SMBIOS for you and copy it back to your config.plist

You can use SMBIOS MacBookPro 9.2 like me, it is for IvyBridge Core i5/i7.

 

About CUSTOMUUID, you can remove it if you can not found, find it in your BIOS main screen (BIOS / Main UUID)

Share this post


Link to post
Share on other sites

@Uoc Nguyen I'm stuck @ Clover step I was able to update config but can figure out how to boot to Clover. 

 

1. How should I format clover usb drive?

 

Thanks for any help you can provide.

 

Scott

Share this post


Link to post
Share on other sites

@uoc-nguyen

 

So I have created mavericks USB bootable disk using this command

 

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --nointeraction

 

I have modified config.plist

I have clover installed

 

I am stuck on configuring clover to boot so I can install mavericks

Share this post


Link to post
Share on other sites

  You must create a GPT UEFI compatible disk (Follow this instruction to create it: https://wiki.archlinux.org/index.php/UEFI#EFI_System_Partition)

 

  In short, you must have an ESP (EFI partition), it is a small FAT 32 partition (about >= 128M depend your need) with EFISYS flag. It used to store CLOVER or any EFI firmware / bootloader, Linux kernel, config file, theme...

 

  After created a GPT partition you can verify it by command `sudo diskutil list /dev/diskX` with diskX is your USB disk, usually is disk1 as disk0 is your internal HDD, and you will see something like this:

post-206862-0-64115800-1388079586_thumb.png

 

I use some live Linux distro for some reasons, that's why my partition number 1 (EFI) is large.

 

  Since EFI partition is a system partition so Operating System usually hide it. You can mount it by command `sudo disk mount /dev/diskXsY` (if your EFI is first partition of your USB disk then diskXsY should be disk1s1). Now you can install CLOVER and copy config files... to this partition and create your Mac Installer Bootable USB.

 

  Hint: Press F12 to select boot from USB after reboot

 

Happy hacking!

Share this post


Link to post
Share on other sites

Finally, got wireless work with 7$ USB Wifi dongle with 150MB/s - http://www.comfast.cn/product1/product168_en.html

 

Look like Realtek fault, the device show as ethernet instead of wireless and need to use Wireless Network Utilities to connect to AP.

 

Download Mac OS X 10.8 install package from this page. It work well for 10.9.1.

Share this post


Link to post
Share on other sites

I own a T430 Type 2347A39.

 

After install your kexts I got everything working except the audio and the restart, sleep etc. I was working before the kexts installs...

But how did you got the fn-F9 to work for increase brightness?? My screen is too dark and I have no option to increase...

Share this post


Link to post
Share on other sites

I own a T430 Type 2347A39.

 

After install your kexts I got everything working except the audio and the restart, sleep etc. I was working before the kexts installs...

But how did you got the fn-F9 to work for increase brightness?? My screen is too dark and I have no option to increase...

  • Audio: you will need to patch AppleHDA and edit DSDT to use it, I'm patched and using the layout 28, you can use my patched AppleHDA version 2.5.3 from 10.9.1 AppleHDA.kext-10.9.1.zip
  • For brightness, currently I'm using the _Q14, _Q15 (Fn-K, Fn-P) in DSDT to control the brightness. If you want to use Fn+F8/F9, you need to find out which Keycode used and will need to edit the DSDT or `/System/Library/Extensions/VoodooPS2Controller.kext/Contents/PlugIns/VoodooPS2Keyboard.kext/Contents/Info.plist`
  • IFAIK, Shutdown / Restart / Sleep may caused by UEFI CLOVER, I take some work around but it still not stable to use, it is needed to edit the DSDT _PTS, _WAK method, try to use some code from this thread http://www.insanelymac.com/forum/topic/285678-lenovo-thinkpad-t420-with-uefi-only/page-25?do=findComment&comment=1952283 as reference. I tried a lots but still no luck.
Edited by Uoc Nguyen

Share this post


Link to post
Share on other sites

My hardware is almost the same as yours. I using no UEFI for now, I'm booting with legacy.

I've installed all the kexts and display and was working as I wrote in the first post. After that, I added your DSDT without diff and got appleintelcpupowermanagement panic at the boot beginning.

I'll try again adding the DSDT first.

I'll try to use the fn-P K for brightness and your patched audio.

Thanks

Share this post


Link to post
Share on other sites
  • Can you boot with single user safe mode?
  • Did you repair the permission for kexts you copied from my attachment? if not, you can boot up with the install USB/DVD and repair it use this command: 
    chown -R root:wheel /Volumes/OSXROOT/System/Library/Extensions
    chmod -R 755 /Volumes/OSXROOT/System/Library/Extensions
    kextcache -u /Volumes/OSXROOT/
    

    replace OSXROOT with your mounted installed OSX volume

Share this post


Link to post
Share on other sites

Using DSDT.i I could boot but Audio not working even with the patched kext and Video only VGA. Keyboad, TrackPad, Bluetooth, Ethernet Working.

Using DSDT.d Nvidia looks loads correct but blank screen after the boot.

Share this post


Link to post
Share on other sites

Now I got almost everything working, thank you. Just the brightness of the screen is still annoying me. Altough I move to maximum, it still draker than I got in Windows... How to try to increase? DSDT edit? where exactly?

Share this post


Link to post
Share on other sites

Very interesting: I did a ctrl-alt-del and just after the logout the screen got the real max brightness!!! The question now is how to fix that?

Share this post


Link to post
Share on other sites

I have same problem with the NVIDIA backlight control, the baclight slider and sun OSC icon show and response to Fn-K / Fn-P but the backlight not change. Tried many way but not success. There are 2 things you may interesting:

  • It is reflect with NVIDIA's pwm-info parameter, I tried to remove and the backlight slider / sun OSC gone, tried with W520 but same problem, I think it can be calculate / export from video rom file.
  • You may try something in T420 topic

Share this post


Link to post
Share on other sites

Sometime I see a flickering happening with some colors contrasts. It's bothering me.

For the brightness issue I installed the rehabman blinkscreen hack but no success here.

Share this post


Link to post
Share on other sites

@uoc-nguyen

hi, I used your kext to install my T430,It is ok for driver, but ethernet card can't build-in, so I can't login app store. Do you have this problem?

ps. I don't use your dsdt file because it was always made me can't start my apple system.

I use the clover to load the mac os.

Share this post


Link to post
Share on other sites

Hey,

 

i managed to get everything working except BT and Mic. 

Can you please tell me what you have done to get it work?

Thanks!

 

//EDIT:

Sound working

BT working

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By NikTheNoob
      Hi,
       
      I'm rather new to Hackintosh and trying my first build with OpenCore on AMD, but I run into issues causing OpenCore to crash before even loading the macOS installer. As I'm not sure which one is causing the crash, I'm trying to resolve all of them and one of the error messages has to do with WhateverGreen, which I was able to see in this slow-mo loading video. Basically I'm getting an error that I'm running an unsupported processor, even though I think I was following this guide by the step.
      What could be causing this and what do I need to do to resolve it?
       
      CPU: AMD Ryzen 2700X
      MB: Gigabyte Aorus X470 Ultra Gaming
      Memory: 4x8 GB HyperX Predator, 3000 MHz Cl15
      Storage: Samsung Evo 970 Nvme 512 GB, Crucial MX500 500GB SATA
      GPU: MSI Radeon RX580 GamingX 8GB
    • By mikezexter
      (Dear moderators please replace this topic to another category if I made a mistake in choosing it)
       
      Hello everybody. I need some help in trying to fix native AppleHDA sound on my X230T.
      VoodooHDA works perfectly but without needed HDMI audio channel so I need to try fix my sound in native mode.
       
      AppleALC told us here (README) that in v1.2.1 Added ALC269 layout-id 18 for Thinkpad X230 by Hypereitan. And if it works I didn't need to create this topic.  Unfortunately layout ids 1,2,3,18 and 55 didn't help me to fix sound issue.
       
      My Clover: https://drive.google.com/open?id=1FuGS7iE59ydgiMsxZcDMarlAFH3FliNE (it's 2 MB bigger than I could upload for now)
      I've also uploaded some screenshots of what I've seen after 5 reboots in a row changing layout ids. Please help me to fix this issue.
       
    • By ludufre
      Installing macOS Catalina 10.15.3 on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      01/30/2020 23:52h GMT-0
      - Added 10.15.3 update instructions.
       
      12/11/2019 04:24h GMT-0
      - Added 10.15.2 update instructions.
      - Replaced IntelMausiEthernet.kext with IntelMausi.kext.
       
      11/08/2019 20:30h GMT-0
      - Added instructions to swap Command with Option keys in VoodooPS2Controller.kext.
      - Added additional FileVault 2 UEFI drivers be more practical.
       
      10/30/2019 01:42h GMT-0
      - Added 10.15.1 update instructions.
      - Replaced AppleALC.kext with VoodooHDA.kext
      - No more issues after sleep or misconfiguration with jack sense.
       
      10/29/2019 18:18h GMT-0
      - Replaced the config.plist with AppleIntelCPUPM = true.
       
      10/27/2019 05:37h GMT-0
      - Replaced the DW1560 wireless card with BCM94360CS2.
       
      10/20/2019 20:47h GMT-0
      - Removed AppleBacklightFixup.kext.
      - WhateaverGreen now implements backlight since 1.2.5.
       
      10/20/2019 18:10h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 BCM94360CS2 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff and Continuity ->  Work after replaced wireless.
      - Instant Hotspot ->  Not work.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
       
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
       
      - RAM upgrade:
      16GB (2x8GB). No mistery here. Just upgade.
       
      - Wireless upgrade:
      Previously I have the DW1560 working almost perfectly, now replaced with BCM94360CS2 that is full native supported. 
      More info below.
       
      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Make trackpad appear in System Preferences
      - Make Instant Hotspot work.
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Catalina install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the CloverEFI from official repository (used 5097) and install only with these options on "Install macOS Catalina":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - AudioDxe (Just to have nice sound on boot)
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
       
      FileVault 2
       
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
       
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      OR download attached bellow.
       
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
       
      That's it! FileVault 2 will work without problems.
       
       

       
       
      Make things works
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below
      - Put SSDT-L440.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.6.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Copy the Clover Configurator to flash drive because you will need later.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC from here. I used all Kexts and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/) from version 1.0.8 (If you followed the steps to enable FileVault 2 above, skip to the next item).
      - Download the Lilu.kext from here. I used the version 1.3.8.
      - Download the VoodooPS2Controller.kext from here. I used version 2.0.4.
      - Download the IntelMausi.kext from here. I used the version 1.0.2.
      - Download the VoodooHDA.kext from here. I used the version 2.9.2. (Need to turn up the volume on Info.plist, more instructions below)
      - Download the WhateverGreen.kext from here. I used the version 1.3.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
       
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
       
       
      Audio volume adjustment
       
      - Open the Info.plist inside VoodooHDA.kext/Contents/ with TextEdit.app or any text editor of your choice.
      - Change:
      <key>PCM</key> <integer>90</integer> to:
      <key>PCM</key> <integer>140</integer> Or, download the versions 2.9.2 attached bellow.
       
       
      Keyboard swap Command with Option (optional)
       
      - If you prefer, you can swap Command and Option keys, to map Win Key - Command and Alt - Option.
      - Change /Volumes/EFI/EFI/CLOVER/OEM/S400CA/UEFI/kexts/10.15/VoodooPS2Controller.kext/Contents/PlugIns/VoodooPS2Keyboard.kext/Contents/Info.plist:
      <key>Swap command and option</key> <true/> to:
      <key>Swap command and option</key> <false/> Or, download the version 2.0.4 already adjusted attached bellow.
       
       
      Wifi and Bluetooth (BCM94360CS2 + M2 NGFF adapter)
       
      Recently I replaced the DW1560 with BCM94360CS2. Now I have fully wireless and bluetooth working (including Instant Hotspot) without any kexts.
       
      See: 
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (Ask on UEFI hack forums over there to someone patch for you. Every dump is unique, so mine don't work to you.);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/10.15/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 2.0.3. (To enable Wireless)
      - Download the BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext from here. I used the version 2019-10-17. (To enable Bluetooth)
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.4. (To enable Handoff and Continuity)
       
      Keep in mind that the bluetooth kexts are currently in development and the official releases will be available in future in the repository: https://github.com/acidanthera/BrcmPatchRAM/releases
       
       
      Now you can start the installation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
      - Choose the flash drive (white icon).
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install
       
      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
       
      Choose the internal disk (gray hdd icon) if not already selected.

      The second part of the installation will begin. This will take 16 minutes.

       

      Post installation
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
       
      Copy the EFI folder to desktop.
       
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
       
      Move the EFI folder from Desktop to EFI partition of the internal disk.
       
      Eject the flash drive.
       
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      System Updates
       
      10.15.1
       
      Updated without changing or updating anything.
       

       
       
      10.15.2
       
      Before install, update the following kexts:
      - VirtualSMC.kext and all kexts and VirtualSmc.efi. I used version 1.0.9.
      - Lilu.kext. I used version 1.4.0.
      - WhateverGreen.kext. I used version 1.3.5.
      - AppleALC.kext. I used version 1.4.4.
      - VoodooPS2Controller.kext. I used version 2.1.0.
      (all download links above)
       
      Download the latest CLOVERX64.efi.zip build. I used version 5100.
      Mount EFI partition and unzip to:
      - /Volumes/EFI/EFI/CLOVER/CLOVERX64.efi
      - /Volumes/EFI/EFI/BOOT/BOOTX64.efi (rename the copy of CLOVERX64.efi to BOOTX64.efi
       
      Install update. Will reboot at least four time.
       
       
      10.15.3
       
      Updated with success without changing anything.
       
       

      And last but not least

      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @"Sniki", @Mieze, @headkaze and all others members involved directly or indirectly.
       
       
      Attachments
       
       
      SSDT-L440.aml
      config.plist
      VoodooHDA.kext.zip
      VoodooPS2Controller.kext.zip
      Filevault 2 additional drivers.zip
    • By Franklin_NGO
      Hello, does anyone here has experience on thinkpad P hackintoshing? I'm using vanilla guide (my EFI is here: https://www.mediafire.com/file/i3xzh9lnjpae9nj/EFI_Thinkpad_P53s.zip/file) Hackintosh: Catalina 10.15.2 Hardware: CPU: Intel Core i7-8665U Processor (1.90GHz GHz 8MB) GPU: NVIDIA Quadro P520 2 GB GDDR5/ intel UHD 620 RAM: 16.0GB PC4-19200 DDR4 Soldered 2400MHz SSD/ HDD: 1TB SSD Samsung PCIe Motherboard/Laptop model: Intel Coffee Lake-U/Y PCH rev. 30/ Thinkpad P53s BIOS: Lenovo version 1.60 (12/30/2019) Screen: 15.6 "FHD IPS AntiGlare LED Backlight 1920x1080 Ethernet Card: Intel I219-LM Wifi/BT Card: Wireless Intel AC adapter 9560 2x2ac with BT5.0   Status: disabled dGPU, patched HD620 (able to boot to the installation USB without fake ID)   Problem: I finished the first phase of installation (auto reboot at 2 minutes remaining); then I was able to boot to the new installed disk, but it keeps rebooting at "13 minutes remaining". The verbose as in the picture. Thank you and good day.
×