Jump to content
IIIdefconIII

Beginners guide to UEFI Triple/Dual boot OS X, Windows and Linux (Kali) on an single true-gpt ssd

155 posts in this topic

Recommended Posts

Trying to Dual Boot Mac OS X El Capitan and Ubuntu 16.04

 

Config:

HP-Pavillion-G6-2231tx

Intel Core i3-3110M

Intel HD4000

Realtek Ethernet

Clover Bootloader r3625

 

Partition-1: EFI

Partition-2: Mac OS

Partition-3: Ubuntu 16.04

 

Problem:

So my problem arose after I updated Ubuntu, in those update, there was a new kernel image too, so of course, Grub2 got reinstalled with new configs. After doing the update, Clover doesn't show up, and I get to it by Boot Device Options. Upon booting to Mac OS I reinstalled clover after deleting it from the EFI partition, Clover installed successfully, I then reboot the laptop, but guess what, it boots directly to Ubuntu. No matter how I do it, but now if there is Ubuntu folder with grub in EFI then the laptop boots directly into it whether the Clover is present or not.

 

Thank you, but please help. :)

Share this post


Link to post
Share on other sites
Advertisement

Trying to Dual Boot Mac OS X El Capitan and Ubuntu 16.04

 

Config:

HP-Pavillion-G6-2231tx

Intel Core i3-3110M

Intel HD4000

Realtek Ethernet

Clover Bootloader r3625

 

Partition-1: EFI

Partition-2: Mac OS

Partition-3: Ubuntu 16.04

 

Problem:

So my problem arose after I updated Ubuntu, in those update, there was a new kernel image too, so of course, Grub2 got reinstalled with new configs. After doing the update, Clover doesn't show up, and I get to it by Boot Device Options. Upon booting to Mac OS I reinstalled clover after deleting it from the EFI partition, Clover installed successfully, I then reboot the laptop, but guess what, it boots directly to Ubuntu. No matter how I do it, but now if there is Ubuntu folder with grub in EFI then the laptop boots directly into it whether the Clover is present or not.

 

Thank you, but please help. :)

 

Oki, please boot from the Clover USB, then go to some option in that menu to add it to the bios, then in bios you can change it to clover, i had this before with windows. please check and confirm, thank you

Share this post


Link to post
Share on other sites

my support stops here, i transferred to vmware cause i didnt want to do all the manuel patches each big update. ;) good luck!

Share this post


Link to post
Share on other sites
On 11/16/2013 at 9:05 PM, IIIdefconIII said:

Fix Clover bootloader to dual boot OS X Mavericks / Windows 8.1 from ssd/hdd
 

First Part:

Really easy, go to youre BIOS and go to the Boot tab. Find UEFI Hard Disk Drive BBS options or something simulair to what i have.

Then set Clover as primairy. Like we did in post #6.

That should be it. Confirm working, If you do not have a option to change it in bios then you should use the second part of this post.

Second part:

Optional, if the first part didn't work for you then proberly you uefi firmware is badly written by youre manufacter. Some times you need the next steps to succesfully boot into clover.
 

Like a year ago with my old clover we had to use these following steps. Prpbery cause of old Clover back then. So if its booting straiglty to Windows instead of Clover and the first part didnt fixed it, then read this.

  1. Boot from the OS X Clover usb again. (If you cant boot from usb and it goes to windows automaticly, just reset youre pc, as soon as it shows bios loading, reset it again, and then select usb as boot device)
  2. Mount the main EFI with Clover configurator;
  3. Open the main EFI file drive on the desktop, browse to EFI/Clover and copy CLOVERX64.efi  to /EFI/Mircosoft/Boot.
  4. In EFI/Microsoft/Boot rename the file bootmgrfw.efi to bootmgfw-orig.efi
  5. In EFI/Microsoft/Boot rename the file CLOVERX64.EFI to bootmgfw.efi
  6. Reboot without the Clover USB

Clover entrie for Windows

post-688682-0-73111300-1409339086_thumb.png

 

Now you should have a working Dual boot OS X Mavericks and Windows 8.1 from the interal Clover EFI partition.

 

On 11/16/2013 at 9:05 PM, IIIdefconIII said:

Fix Clover bootloader to dual boot OS X Mavericks / Windows 8.1 from ssd/hdd
 

First Part:

Really easy, go to youre BIOS and go to the Boot tab. Find UEFI Hard Disk Drive BBS options or something simulair to what i have.

Then set Clover as primairy. Like we did in post #6.

That should be it. Confirm working, If you do not have a option to change it in bios then you should use the second part of this post.

Second part:

Optional, if the first part didn't work for you then proberly you uefi firmware is badly written by youre manufacter. Some times you need the next steps to succesfully boot into clover.
 

Like a year ago with my old clover we had to use these following steps. Prpbery cause of old Clover back then. So if its booting straiglty to Windows instead of Clover and the first part didnt fixed it, then read this.

  1. Boot from the OS X Clover usb again. (If you cant boot from usb and it goes to windows automaticly, just reset youre pc, as soon as it shows bios loading, reset it again, and then select usb as boot device)
  2. Mount the main EFI with Clover configurator;
  3. Open the main EFI file drive on the desktop, browse to EFI/Clover and copy CLOVERX64.efi  to /EFI/Mircosoft/Boot.
  4. In EFI/Microsoft/Boot rename the file bootmgrfw.efi to bootmgfw-orig.efi
  5. In EFI/Microsoft/Boot rename the file CLOVERX64.EFI to bootmgfw.efi
  6. Reboot without the Clover USB

Clover entrie for Windows

post-688682-0-73111300-1409339086_thumb.png

 

Now you should have a working Dual boot OS X Mavericks and Windows 8.1 from the interal Clover EFI partition.

I wanted to thank you especially for this section of your tutorial. I have a different computer but I had used your tutorial for my dual boot win10 and Mojave hack. I had success and have been going strong for four months. I did a bios upgrade and it changed my EFI. I couldn't boot clover. I tried everything, flashed back old bios, gparted to reformat EFI partition to re-install clover. No Go. After hours of frustration, I was set to re-install win10 and Mojave from scratch. When I came back to your post to refresh my memory about installing a dual boot. I read this section about badly written firmware from the manufacturer. and your instruction in this section to copy cloverx64 to the Microsoft boot folder in clover and renaming it. YOU saved me hours of work redoing my hack! I got my clover boot BACK! no re-installations necessary! So Kudos and Thanks! Johnm

 

Share this post


Link to post
Share on other sites
37 minutes ago, jmacie said:

 

I wanted to thank you especially for this section of your tutorial. I have a different computer but I had used your tutorial for my dual boot win10 and Mojave hack. I had success and have been going strong for four months. I did a bios upgrade and it changed my EFI. I couldn't boot clover. I tried everything, flashed back old bios, gparted to reformat EFI partition to re-install clover. No Go. After hours of frustration, I was set to re-install win10 and Mojave from scratch. When I came back to your post to refresh my memory about installing a dual boot. I read this section about badly written firmware from the manufacturer. and your instruction in this section to copy cloverx64 to the Microsoft boot folder in clover and renaming it. YOU saved me hours of work redoing my hack! I got my clover boot BACK! no re-installations necessary! So Kudos and Thanks! Johnm

 

 

Im glad you got it working, and that people still read this guide. Has been a while for me using a triple boot system.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      Catalina 10.15.2 - Windows 10
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) No problem so far ASUS HyperKit with a KINGSTON NVMe SSD - 250 GB  
      What is not working:
      -  
       
      Not tested:
      VideoProc says that Hardware Decoding\Encoding is fully supported and enabled on both HD 530 and RX 5700 but I didn't test it Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: Primary Display: Auto iGPU Multi-monitor: Enabled RC6(Render Standby): Enabled DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: Intel SpeedStep: Enabled CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5098): Click here -> ASUS-Z170_catalina.zip  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:
       

       




       
       
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Notes:
       
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
    • By johnny28
      Ho una tastiera wireless Apple Magic Keyboard con tastierino numerico (layout italiano), con Catalina OK, ma quando la uso con Windows 10, ho un piccolo problema i tasti "<" e "\" sono scambiati, nel senso che quando pigio sul tasto "\" ottengo invece "<" e viceversa. C'è modo di correggere il problema, senza dover ricorrere ad un software a pagamento come "Magic Keyboard Utlities" ?
    • By kingoffright
      Dear all,
       
      I have a external harddisk about 500GB, I installed the clover into it and the harddisk is GPT format, below is the 3 partitions details:
      FS01: EFI - disk0s1 - fat32
      FS02: install mac  image - disk0s2 -  hfs+
      FS03: install windows 10 - disk0s3 - fat32
       
      I can use this external harddisk to install Mac without issue, I use below steps to install windows 10
      enter the FS03:
      cd to efi/boot/ and excuete bootx64.efi
      after pop up the windows install screen, i click next and it shows error 'A media driver your computer needs is missing...' and the installation can not go any further.
      Firstly I use ultraiso to write the windows 10 image to a flash disk and no issue to start install window 10 so the image is working fine. Since I dont know how to write
      a wiindow installation image into harddisk partition, I used winrar extra all the files into disk0s3, am I missing some steps or actually clover not support to install windows
      by partitions, apprecating any helps.
       
×