Jump to content
Sign in to follow this  
Followers 0
Liliniser

AppleHDA patched successfully but int. mic has very low sensitivity!

7 posts in this topic

Recommended Posts

Hello everybody. I have a problem while patching AppleHDA for my audio vt1802. I use a laptop which has below spec.

 

Intel® Core i7-2670QM CPU @ 2.20GHz
Intel Cougar Point HM65, Intel Sandy Bridge
VIA VT1802
Intel HD Graphics 3000

 

I followed great tutorials and now I have int. speaker, ext. headphone, ext. mic, and int. mic operating. Everything works just fine except that the internal microphone has super low sensitivity. At first, I thought it was not working bacause even thought it was listed on the SystemPreferences>Sound>Input section, the input level bar didn't show any response. But soon, I realised it does work because it showed reaction when I smashed on my laptop  :P.

 

So I concluded that the sensitivity matters. Now I'm looking for a solution to boost the int mic's input gain. What I've been trying are

 

1. add <key>Boost</key><integer>3</integer> in the node of mic's in Platforms.xml

    ==> no effect 

    (one funny thing is that the ext. mic does have effect on this)

 

2. adjusting layout.xml

    1) adding MuteGPIO in the Mic section

        ==> the entire sound lost

    2) adding SignalProcessing properties

        ==> no effect (maybe some other changes exist but I didn't notice)

 

[CodecVerbs]
02471c10 02471d01 02471e17 02471f90 --> int. speaker
02571c30 02571d40 02571e21 02571f02 --> ext. headphone
02971c20 02971d01 02971ea0 02971f90 --> int. mic
02b71c40 02b71d90 02b71e81 02b71f01 --> ext. mic (changed to line-in as you can see)
02470c03 02570c02 --> EAPD stuff

 

I'm frustrated and almost given up. This post is the last hope :(. Please shed a light on me guys. I've attached ioreg, codecdump, layout.xml, and platforms.xml. Sorry for my poor English!

 

Best regards.

audio_data.zip

Share this post


Link to post
Share on other sites
Advertisement

Unfortunately, it doesn't work because of the MuteGPIO thing.

When I remove that MuteGPIO, it works like a charm but int. mic is still the same.

I assume that VT1802 is somehow not fully compatible with AppleHDA. 

I appreciate for your help Mirone. 

Cheers!

Share this post


Link to post
Share on other sites

Hello lazzy.

 

Unfortunately, I don't own this laptop any more. But you can refer a couple of sites for that audio chipset. Please have a look at below links.

 

1. https://github.com/maxfierke/Lemu4-Hackintosh-Config/tree/master/vt1802p_devel

2. http://www.osx86.net/files/file/3934-applehda-via-vt1802p-1092/

 

I hope you get what you need. Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Wolfield
      I have a receiver with 7.1 channels, in which I transmit the formats Dolby Digital and DTS without problems by Windows, through the HDMI output of HD4000. On that same Laptop, I have the Hackintosh, with the High Sierra 10.13.6, and with audio enabled using AppleALC, but in the audio preferences, I can not enable the Digital audio format. Also did not find players like Mirillis SplashPro (which I have used in Windows) with the option of HDMI output Bitstream. Is it possible to enable this digital output on Hackintosh?
    • By moman2000
      Hi,
       
      Here it is (attached) for anyone who needs it for patching or restoring!
       
      Taken from macOS 10.14 Beta 1 18A293u
       
      Regards,
      Mohamed
      AppleHDA_282.5.kext.zip
    • By rio2
      How to make AppleHDAController load on Ryzen boards?
      Rename(/add) your audio controller to your DSDT/SSDT as HDEF Add a _DSM method to your HDEF device with layout id 1 Patch the AppleHDAController binary, because it has a static table containing the supported PCI Vendor/DeviceID pairs and it also checks the VendorID against known values. As an example I provide a dif file and patched 10.13.3 binary, but if you want to I can patch the binary for other versions.  
      After AppleHDAController loads to actually get sound working you need to patch AppleHDA.kext for the codec on your board. First I tried to use Lilu+AppleALC for this task, but for some reason it refused to work. (I might look into it later why) But for the time being it was easier to use toleda's cloverALC script for that, but to make it work I had to change(/remove) the specified location of the HDEF device from the script. And for some reason it also required me to mount the EFI partition manually.
       
      Change this:
      if [[ $(cat /tmp/HDEF.txt | grep -c "HDEF@1") != 0 ]]; then Into this:
      if [[ $(cat /tmp/HDEF.txt | grep -c "HDEF") != 0 ]]; then  
      AppleHDAController_Patched10.13.3
      AppleHDAController-10.13.3-AMD.bdiff
    • By fietipaldi
      Hi there,
       
      I had to reinstall El Capitan on my Hackintosh, as it was installed in Clover Legacy Mode before (with everything working just fine).
      Now I installed it again in UEFI mode and since then, Audio (ALC892) is not working anymore (Neither in UEFI or Legacymode).
      I tried to install the same 2 Kexts as before (AppleHDA modified and HDAEnabler1) using Kextutility (wich was working fine before as well).
      It always fails to install AppleHDA, as it cannot Backup or modify the Original AppleHDA in System/Extensions (Can't copy sourcefile).
      I also tried the same, using the root Account, using terminal with kextunload / load and even a script for clover.
      They all fail to modify / delete the Original AppleHDA. Trying to rename / move or delete the Original file with Terminal or Finder is not working as well, I get an Error, saying that the file cannot be modified because OS X requires it.
       
      So how can I install the Kext to get my audio working again? System is El Capitan (10.11.6)...

      Thank You!
    • By vanquybn
      My Laptop is using ALC 292 and it is runnning: AppleALC.kext, CodecCommander.kext. Thoese kexts work fine for me on MacOS 10.31.1/10.12.x
      After update to 10.13.2 my headphone have no sound, The icon switched when jack plug-in but phone have no sound. The internal speaker and HDMI jack work fine for me.
      Would you please help? Thank you in advance
×