Jump to content
InsanelyMac Forum
RehabMan

Haswell early reboot, Mavericks, locked MSRs, and HP Envy 15-J063CL (i7-4700MQ)

Recommended Posts

Your config doesn't for me. 

Finally i found config works for installer ( dart=0 kext-dev-mode=1 nv_disable=1  )

after install it 's only need dart=0 it works very well (active wifi native)

but hd4600 doesn't work very lag. I flow another topic 

but can you share your dsdt ssdt and all your kext for 10.10

thanks

config.plist.zip

Share this post


Link to post
Share on other sites
Advertisement

10.9.5 is not released

10.9.5 is just released a couple hours ago, i update from 10.9 to 10.9.5, after i used your patch, it still goes into early boot, i can't even boot with -x or -f or -s with original kernel/patched kernel, i patch it with the terminal in my installer, but as no one patch the mach_kernel and list the md5, i can't verify mine. Might anyone send me a patched kernel that's works? thanks a lot

Thanks and this patch seems working for my Asus G750 Laptop with 10.9.5 now.

hi jsl, might you send me your 10.9.5 patched kernel? thanks a lot.

 

edit: i found that i cannot successfully patch it, as their md5 is the same. is there any method to patch it on windows? or anyone can help me to patch this? i uploaded the vanilla kernel of 10.9.5, thanks guys.

 

edit2: Thanks to @Onixs for helping me to patch my kernel, it was patched successfully, and i want to provide more info for everyone.

the md5 of vanilla mach_kernel is: 8f9adba4ca2f55907b8ec8d4bbf4c555 and that of patched is 0563c5d1fd99db17198d53ad60c9d9ba

mach_kernel.zip

Share this post


Link to post
Share on other sites

Note: Updated post #1 with md5 information for 10.9.5. Seems likely the same patch will continue to work for 10.9.5.

Share this post


Link to post
Share on other sites

Note: Updated post #1 with md5 information for 10.9.5. Seems likely the same patch will continue to work for 10.9.5.

Thanks for your excellent contribution for this patch in Mavericks 10.9.x.

Since Yosemite GMC, DP8, and PB4 were released, is it possible to help me for patching kernel in any one of them ?

Although I can boot by Clover now, I need boot by Chameleon to edit my DSDT & SSDT to enable HDMI audio and disable Optimus Nvidia card in my Asus G750 laptop.

Share this post


Link to post
Share on other sites

Thanks for your excellent contribution for this patch in Mavericks 10.9.x.

Since Yosemite GMC, DP8, and PB4 were released, is it possible to help me for patching kernel in any one of them ?

Although I can boot by Clover now, I need boot by Chameleon to edit my DSDT & SSDT to enable HDMI audio and disable Optimus Nvidia card in my Asus G750 laptop.

When Yosemite is released, I'll update my blog and this post, but not before then.

 

For now, you can use Clover. In fact, I'd recommend Clover over Chameleon...

Share this post


Link to post
Share on other sites

Hi all,

please just explain me a thing.

I now have a Haswell Pentium g3258, hanging at XCPM thing... using an Amd kernel would make me boot to my desktop ? (old vanilla install as my notebook just catched fire)

 

Many thanks 

 

Edit-.

Tried several AMD kernels, but nothing

 

Does Lion (or ML) have any chance to work with this processor?

Share this post


Link to post
Share on other sites

Hi all,

please just explain me a thing.

I now have a Haswell Pentium g3258, hanging at XCPM thing... using an Amd kernel would make me boot to my desktop ? (old vanilla install as my notebook just catched fire)

 

Many thanks 

 

Edit-.

 

Tried several AMD kernels, but nothing

 

Does Lion (or ML) have any chance to work with this processor?

Mavericks does not seem to support the Haswell Pentium/Celeron chips. I've heard that 10.8.5 does.

Share this post


Link to post
Share on other sites

Hi all, and thanks for this guide, by the way the only one that have some succes with my haswell laptom (MSI cx61 2pc 1214XES) 

Spec:

CPU The latest 4th generation Intel® Core™ i Processor
Chipset Intel HM86
Memory DDR3L ,up to 1600MHz
LCD Size 15.6" HD (1366x768)  LED backlight
Graphics NVIDIA GeForce 820M
Graphics VRAM DDR3 2GB
HDD (GB) 1TB/750GB/500GB SATA 5400rpm
Optical Drive BD Combo / DVD Super Multi
Audio Sound by stereo speakers 
Exclusive Audio Boost technology 
Creative Sound Blaster Cinema
Webcam HD type (30fps@720p)
Card Reader SD
LAN Gigabit LAN
Wireless LAN 802.11 b/g/n
Bluetooth Bluetooth v4.0
D-Sub (VGA) 1
HDMI 1
USB 2.0 port 1
USB 3.0 port 2
Mic-in/Headphone-out 1 / 1
 
Following this post guides I get stuck just before the istall screen opens, this is a screenshot of the point i get stuck (I have seen in a video that after this, it comes the wellcome screen):
kDYlDgE.jpg?2
 
Any idea? any help?
Thanks.

Share this post


Link to post
Share on other sites

...

Any idea? any help?

...

Make sure you inject the correct ig-platform-id for your system. And because you have nvidia, use nv_disable=1 (kernel flag) to keep the nvidia drivers from starting.

Share this post


Link to post
Share on other sites

Thanks

Using the nv_disable=1 i get this screen:

YKlMoZJ.jpg?1

 

Any idea or help of how or where can i get the correct ig-platform-id for my system?

Thanks!


I have get the welcome screen of installer using the bootflag: IntelAzulFB=0

As i read from here: http://www.insanelymac.com/forum/topic/291614-intel-hd4000-and-haswell-inject-aaplig-platform-id/

 

Now i'll go on trough installation... let see the results.

Share this post


Link to post
Share on other sites

Thanks

Using the nv_disable=1 i get this screen:

YKlMoZJ.jpg?1

You're using an old version of VoodooPS2Controller. Current version is here: https://github.com/RehabMan/OS-X-Voodoo-PS2-Controller

 

Any idea or help of how or where can i get the correct ig-platform-id for my system?

Thanks!

For most, 0xa260006 works.

Share this post


Link to post
Share on other sites

Installation finished ok.

But now I cannot start the installed OS.

if nothing touched i get the boot0: error.

but if i try to boot from installer usb , it reboots after load all ketxs.

Screen just before reboot:

Q8IPtPw.jpg

Share this post


Link to post
Share on other sites

Installation finished ok.

But now I cannot start the installed OS.

if nothing touched i get the boot0: error.

but if i try to boot from installer usb , it reboots after load all ketxs.

Screen just before reboot:

Q8IPtPw.jpg

Read post #1, section "How to patch your kernel"

Share this post


Link to post
Share on other sites

Installation was successful and the only problem is multibeas failed.

So i restarted and now i get this error in (this is the last sentence in screen):

IntelCPUMonitor: [Warning] Unsupported Intel processor found, kext will not load

 

I'll try to install again from beginning.

Share this post


Link to post
Share on other sites

Please note: My blog and post #1 this thread updated for Yosemite 10.10

 

I will write a separate "How to patch your kernel" in the Yosemite forum.

 

Those that wish to start now can make the necessary adjustments for the new location of the kernel.

Share this post


Link to post
Share on other sites

are there anyother ways to 'patch the kernel' ?

i got stuck in the terminal

 

i just simply copy and paste(invisible) kernel_mach when i boot into other OSX

 

I used a MyHack 3.3.1 to make a USB installer

i7 4790k

Asrock Extreme 4 Tb Z87

Mavericks 10.9.4(13e28)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×