Jump to content

Z87, Can't boot the installer? Install first with a VM running under Windows!


1 post in this topic

Recommended Posts



a couple of days ago my old P5Q3 Deluxe died (rest in "pieces"...  :hammer:   :whistle: ), I had a Q9550 on it.


I had to replace it and I bought a Z87-Pro, a nice i7 4770K, a new case and a 650w power box.


My problem was that I didn't want to do a clean install and loose all my data, i had a nice and fully operational 10.8.4 OSX installed with many many things inside.


None of the bootloaders I tried were working for me, so i tried to find another solution, and I did:


I've 6 hard drives, 1 using the GUID partition shenme for OSX.


Under windows, I opened vmware 10 (unlocked) and created a VM (WM10) for OSX 10.8, for the hard drive i used "the physical disk type" and mounted the whole disk in the VM (not only a partition).

I gave it 8G of memory and 1 CPU with 8 cores


Strangely it did boot without any problems with audio and lan support.


From there, i opened the App Store and downloaded Maverick.


I tried both myHack and ##### to create a bootable usb installer, but couldn't actually get the installer to boot properly even in safe mode.


I decided to update the VM directly and it worked like a charm (a bit slow thought, it took me nearly 45 mins).


Then i turned off the VM and restarted the computer, i used the USB key created with ##### to start the newly updated OSX,

it worked, from the start I had working graphics and lan but no audio.


I installed voodoohda 2.8.4 but it didn't work (it was somehow crashing), i used the version 2.5.6 and got the audio working.


For some reasons after i restarted once, my lan didn't work anymore, i deleted all the Ethernet connections, used the latest version of ##### and restarted.


Now it's all good, sound, graphics, usb3, sata ahci, I just didn't test the Wireless yet.


The good things are: i kept all my files, all my profiles, all installed softwares!


The bad thing is... there's none... well not exactly, I did loose a couple of hours trying to find the right solution.


I DID NOT update / change / modify the BIOS.

Voilà, it's not perfect but I thought that sharing this could help some of you.
I attached a screnshot of my installation.

One last thing, I stil didn't find out how to boot it without the USB key, i tried cloverefi, chameleon, different versions for each loader, different method of installation,

the ColverEFI installed with the option "for UEFI motherboard" is detected by my Z87-PRO but it doesn't boot the system.


Link to comment
Share on other sites


  • Create New...