Jump to content
TimeWalker75a

OSX on DELL Vostro 3450 / Inspiron N4110 / XPS L702x UEFI Clover

1,149 posts in this topic

Recommended Posts

i can see from debug log, PCH die temp is higher than other, maybe i need a cooling mod. And, when windows 8.1 is out, dell doesn't release the video driver which means it gives up support 14R, fool sh..t. 

I try someone's catalyst driver, works well but brightness doesn't match the right one. so i think i should stay away with windows.

Share this post


Link to post
Share on other sites
Advertisement

Yeah, PCH is hotter because DELL uses just a silicon thermal pad on it to make contact with the heatsink.

For me even if I leave the laptop completely idle CPU die can be as low as 39C, while PCH die will be 46C.. and they share same heatsink/heatpipe assembly..

On AMD SG models of both 14R and 3450 the heatsink is massive if you compare it to intel models .. and yet the tems are high for chipset..

 

We are at least lucky to have a heatink on it, 3360 and 3560 (newer generation ivy bridge vostro) have PCH underneath the keyboard just above the touchpad and there's no heatsink on it.. it gets to 60C even if you type in word and fan runs most of the time to cool it down, while it can't actually cool anything down .. becase again, no heatsink. Dell kept the firmware in EC to behave same as on our generation of laptops - if either CPU or PCH get to 57C - enable fan. But since there's no heatsink on PCH these laptops are f*cked to be hot and noisy.

Share this post


Link to post
Share on other sites

I know this may be unrelated to this thread, but I presume most of us are multi-booting.

I've taken another project as a base to start my own thing (consider  this an alpha?)... currently fan control has been made possible.. Anyone care to try fan override for windows?

sample_image2.png

It will publish GPU temps for AMD models as well. See readme for configuration details. 

 

https://github.com/Dolnor/Dell-SCT-IT8518E-Fan-Control

Share this post


Link to post
Share on other sites

I tested it but it seen like doesnt control fan because between range of safe temp to trip (52-62) the steady speed sometime stay below 2950 and sometime doesnt.

 

temp.pngtemp1.png

 

 

Share this post


Link to post
Share on other sites

Its not setting custom speed, its not possible on any dell laptop. It catches or should I say tries to catch the fan at the speed that you've pit in the config file. Manual control sometimes resets by EC, hence the fan may unstick, but it will revert to a steady sped when there's an opportunity.

Share this post


Link to post
Share on other sites

I have further noticed that the more you read from EC the more garbage information appears there for no reason. I guess this memory space is just too sensitive.. 

I'm now reading the following http://puu.sh/6VRAs.png and it constantly reads gpu temps, chipset temps, cpu temps as 100, fan speeds as 16k rpm etc.. at one point my battery said "no battery installed" even though all the data about it was in ec and it was obviously installed. on second iteration i lost power adapter .. i guess just the fan control would be enough for those who need it .. 

Share this post


Link to post
Share on other sites

this is my testing, and temp is lower than OS X, it causes i use Audible mode. gonna wait for your more mod. BTW, test under windows 8.1.

post-459659-0-33973000-1392434359.png

Share this post


Link to post
Share on other sites

I've done some crucial changes to the slim app. the notifyicon text can hold only 64 characters, so it's not much we can utilize- don't go with  profile names.. been looking at baloontips (which can update when you have them show up), but they are ugly.

 

1. config changed, now each setting is a separate entry. no more legacy point entries.

2. some crucial checks for when the fan is not controlled by bios. if fan has locked at a greater speed than requested - give bios control back. if fan speed is 0 and 0 is not requested per profile's config - give bios control back

3. because of changes in 2 I made the fan speed bar colorize depending on the mode. if fan has locked the speed bar will be white, if bios still controls the fan it will be green. if passive mode is used the notifyicon text will say that "Mode: Locked" if fan was locked in off state because there's no bar to report this.

4. if gpu temp is found to be 0 then never again should the program read gpu temp from 0x56 register, because it will produce garbage if done otherwise

5. added possibility to specify -delay XX in the app shortcut to delay the start of the application, since the port driver takes some time to start (with SSD anyway).

I will push the code later at some point. (setting in your shortcut IT8518E-SCT-FC.exe" -delay 15 will delay the app start for 15 second)

 

6WQKG.png 6WQLp.png

 

 

I've done some changes to OSX ACPI tables for fan control .. the one thing that you need is _PTS patch to reset TCTL bit after every power state transition. Also, I should implement additional checks from (2) into the acpi table as well. but you can use it none the less at its current state.  https://github.com/Dolnor/Vostro-3450-Fan-Override (the alt one is the one that locks the fan at 3000rpm, you can change the value if you want). Basically you replace the PollDevc table with this one, all the configuration is done inside this table. Then you just edit the ACPISensors plist for ACPIProbe to math the name PLL0000 and not POLL0000. Then it should work in the same manner as the windows app does (except the checks i've mentioned).

 

bins-it8518e-fc.rar

Share this post


Link to post
Share on other sites

thx for great job. just test under windows, works well, but seems dell quits win8.1, so i use os x more than windows. 

 

For alt-ssdt test, i found there are two methods named  "XCNT", "OSYS" under "Platform Profile" of "ACPI Debugging Plugin", so i get :

 

2/15/14 6:21:15.000 PM kernel[0]: ACPIProbe (PLLD): [Error] unable to register method "XCNT"

2/15/14 6:21:15.000 PM kernel[0]: ACPIProbe (PLLD): [Error] unable to register method "OSYS"
 

But i correct "TAVG","TCTL" instead. then get.... it works.

 

2/15/14 6:36:12.000 PM kernel[0]: ACPIProbe (PLLD): method "TAVG" registered

2/15/14 6:36:12.000 PM kernel[0]: ACPIProbe (PLLD): method "FCTL" registered
2/15/14 6:36:12.000 PM kernel[0]: ACPIProbe (PLLD): TAVG = 57
2/15/14 6:36:12.000 PM kernel[0]: ACPIProbe (PLLD): FCTL = 1
2/15/14 6:36:13.000 PM kernel[0]: ACPIProbe (PLLD): TAVG = 57
2/15/14 6:36:13.000 PM kernel[0]: ACPIProbe (PLLD): FCTL = 1
2/15/14 6:36:15.000 PM kernel[0]: ACPIProbe (PLLD): TAVG = 58
2/15/14 6:36:15.000 PM kernel[0]: ACPIProbe (PLLD): FCTL = 1
 

Share this post


Link to post
Share on other sites

There you go .. the behavior coded in is the same as "Audible" profile under Windows.

I will update the "Passive" profile's analog and push this to git when I have time. 

HWMonitor application has been patched to include monitoring for fan control mode. As expected - it's either auto or steady.

 

6X0xt.png

 

osx-fan-control.zip

mirror: https://www.dropbox.com/s/t69jtriziymbtih/osx-fan-control.zip

Share this post


Link to post
Share on other sites

wow, wonderful, this is what i expect thing when i join hackintosh world. BTW, tw can u upload it to a cloud site? cause download speed is sucks. 

THX. 

 

EDIT:

works now. thanks a lot. 

post-459659-0-00299900-1392475092_thumb.png

Share this post


Link to post
Share on other sites

Thanks for testing both of the apps. The behavior in OSX is more stable because it directly reads from ACPI and writes by means of ACPI too, while in Windows it requires third party driver to access EC port.. and this driver sometimes writes rubbish data into EC memory space.

 

I will see if I can persuade @kozlek to implement profile switching for acpi probe. 

As in, you could have a set of profiles defined in SSDT. Each profile should have a INVL value defining the update interval in ms and a set of method names that should be polled based on that profile. Then it would be cool to have a button somewhere in HWMonitor's GUI which would report all the parsed profiles from SSDT table and would actually let you chose the profile you want. This will allow to have multiple fan control profiles and profiles for debugging certain things in ACPI tables.

 

P.S. Pushed acpi tables (with comments) and binaries (with HWMonitor patch) to my git.

Share this post


Link to post
Share on other sites

Hi,

 

I'm getting the following error message when I type 

 

bcfg boot add 3 fs3:\EFI\CLOVER\CLOVERX64.efi "Clover"

 

bcfg is not recognized as an internal or extenal command, operable program , or batch file

 

My hard disk is fs0 fs1 fs2, while usb drive is fs3

 

Any suggestions how to resolve?

 

 

Share this post


Link to post
Share on other sites

You are using wrong shell binary that has no bcfg support. The shell you are supposed to use is hidden and will appear when you press F3 in GUI. The stock clover shell binary doesn't know bcfg.

 

Also, don't add clover from USB drive to bcfg, there's no point in doing that. This part is for adding boot entry that points to efi system partition.

 

Share this post


Link to post
Share on other sites

1. Flashing a UEFI-capable modified BIOS

BIOS images are meant only for Dell Vostro 3450 and Inspiron 14R (both Intel model and AMD Switchable Graphics models) and no other! Vostro 3350 and 3550 use Inyde H2O BIOS, not SecureCore Tiano!

These models use Ami Aptio.

Share this post


Link to post
Share on other sites

I guess I stand corrected, I was under the assumption it was insyde. I guess I had it mixed up with some newer gen Vostros then... If even that. Does Dell even use Insyde yet? Or they are still paying premium for SCT and Aptio which both become sh+t after going through Dell's OEM customizations.

 

Share this post


Link to post
Share on other sites

Great! it working fine, now we know when is controlling by bios, very nice feature. can you set up a red flag on the number when goes over 68 or 70?

 

image.pngimage.png

                                          HWMonitor.png

Share this post


Link to post
Share on other sites

The notifyicon text is rendered all together, so I can't set the color to individual part of it. The notifyicon icon is rendered from a font resource. The font color is plain white, so for it to turn red I'd need to recolor the font and add a secondary resource file. I suppose I could do that, but would it make a dramatic difference? Chances of it exceeding 70C when you are seeing your task bar are slim.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Klaidonis
      I am making a minimal Clover build for the fastest boot possible with the boot6 file in legacy mode.
      While looking at the preboot.log, I noticed that there is a line without explanation (at 0:892). Apparently, whatever it is, the execution time of it is close to 2 seconds, more than 55% of the total logged boot time in the current configuration. This does not change whether I use USB 2 or USB 3 port.
       
      Is there a way to eliminate or speed up the above? Also, is there anything else you can suggest to improve the performance based on the below log file? Which moment in the boot process corresponds to the start time in preboot.log?  
      The last thing I would like to understand is the delay/timeout after the boot6 file has loaded, and the number 6 disappears from the screen. For about 2 seconds or slightly less, I can press any key, and then it will enter the BIOS-like interface from the boot6 file. Without further knowledge, it seems like those 2 seconds are just delay time, and only after that is CLOVERX64.efi actually started, which, I presume, is approximately when the preboot.log timer starts. So, if the aforementioned is correct, can I get rid of this delay as well? Note that I am using the boot1f32 file to chain-load boot6, which does not include the initial 2-second wait period for a keypress.
       
      === preboot.log ===
      0:100 0:100 MemLog inited, TSC freq: 2394459554 0:100 0:000 CPU was calibrated with ACPI PM Timer 0:100 0:000 LegacyRegion2: Chipset/proc: 0x0A048086 0:100 0:000 Next Generation Core processors (PAM 0x80-0x86) 0:100 0:000 Test PAM1=(0x41=90, 0x5a=90, 0x81=11, 0x91=00) at chipset 0A048086 0:100 0:000 , Install = Success 0:112 0:012 BiosVideoDriverBindingStart! 0:112 0:000 BiosVideoCheckForVbe 0:112 0:000 EdidOverride not found 0:121 0:009 Edid1+ 0:121 0:000 found Detail Timing 1920x1080 0:121 0:000 timing string after 0xFE:AUO 0:121 0:000 timing string after 0xFE:B156HAN01.2 0:122 0:000 0 1280x1024 attr=9B - ok, edid- 0:122 0:000 1 1024x768 attr=9B - ok, edid-, 1024x768, working, highest, pref=1 0:122 0:000 2 640x480 attr=9B - ok, edid-, 640x480, working 0:122 0:000 3 800x600 attr=9B - ok, edid-, 800x600, working 0:123 0:000 4 1920x1080 attr=9B - ok, edid+, working, highest, pref=4 0:123 0:000 BV new mode: 4 1920x1080 0:398 0:275 SetMode pref 4 (4) = Success 0:892 0:493 VGA Pci.Hdr.Command=6 - not enabled 2:623 1:731 2:623 0:000 Now is 21.02.2020, 13:03:21 (GMT) 2:623 0:000 Starting Clover revision: 5103 (master, commit 3f3b85da0) on CLOVER EFI 2:623 0:000 Build with: [Args: -D NO_GRUB_DRIVERS_EMBEDDED -t GCC53 | -D NO_GRUB_DRIVERS_EMBEDDED --conf=/Users/sergey/src/CloverHackyColor/Conf -D USE_LOW_EBDA -a X64 -b RELEASE -t GCC53 -n 5 | OS: 10.14.6] 2:623 0:000 SelfDevicePath=PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0)\HD(1,MBR,0x04944021,0x3F,0x3BC1042) @940C9698 2:623 0:000 SelfDirPath = \EFI\CLOVER 2:623 0:000 SimpleTextEx Status=Success 2:623 0:000 === [ Get Smbios ] ======================================== 2:623 0:000 Type 16 Index = 0 2:623 0:000 Total Memory Slots Count = 2 2:623 0:000 Type 17 Index = 0 2:623 0:000 SmbiosTable.Type17->Speed = 1600MHz 2:623 0:000 SmbiosTable.Type17->Size = 4096MB 2:623 0:000 SmbiosTable.Type17->Bank/Device = BANK 0 DIMM0 2:623 0:000 SmbiosTable.Type17->Vendor = Hynix 2:623 0:000 SmbiosTable.Type17->SerialNumber = 00000000 2:623 0:000 SmbiosTable.Type17->PartNumber = HMT451S6MFR6A-PB 2:623 0:000 Type 17 Index = 1 2:623 0:000 SmbiosTable.Type17->Speed = 1600MHz 2:623 0:000 SmbiosTable.Type17->Size = 8192MB 2:623 0:000 SmbiosTable.Type17->Bank/Device = BANK 2 DIMM1 2:623 0:000 SmbiosTable.Type17->Vendor = Kingston 2:623 0:000 SmbiosTable.Type17->SerialNumber = 5A060A8A 2:623 0:000 SmbiosTable.Type17->PartNumber = KHX1600C9S3L/8G 2:623 0:000 Boot status=0 2:623 0:000 Running on: 'Aspire V5-573G' with board 'Dazzle_HW' 2:623 0:000 === [ GetCPUProperties ] ================================== 2:623 0:000 CPU Vendor = 756E6547 Model=40651 2:623 0:000 The CPU supported SSE4.1 2:623 0:000 BrandString = Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz 2:623 0:000 The CPU supported turbo 2:623 0:000 MSR 0x35 20004 2:623 0:000 MSR 0xE2 before patch 1E008405 2:623 0:000 MSR 0xE2 is locked, PM patches will be turned on 2:623 0:000 MSR 0xCE 0008083D_F3011800 2:623 0:000 corrected FLEX_RATIO = 0 2:623 0:000 MSR 0x1B0 00000000 2:623 0:000 FSBFrequency = 71 MHz, DMI FSBFrequency = 100 MHz, Corrected FSBFrequency = 100 MHz 2:623 0:000 MaxDiv/MinDiv: 24.0/8 2:623 0:000 Turbo: 27/27/27/30 2:623 0:000 Features: 0xBFEBFBFF 2:623 0:000 Threads: 4 2:623 0:000 Cores: 2 2:623 0:000 FSB: 100 MHz 2:623 0:000 CPU: 1700 MHz 2:623 0:000 TSC: 1700 MHz 2:623 0:000 PIS: 100 MHz 2:623 0:000 ExternalClock: 25 MHz 2:623 0:000 === [ GetDevices ] ======================================== 2:623 0:000 GOP found at: PcieRoot(0x0)/Pci(0x2,0x0)/AcpiAdr(0x80010100) 2:623 0:000 PCI (00|00:00.00) : 8086 0A04 class=060000 2:623 0:000 PCI (00|00:02.00) : 8086 0A16 class=030000 2:623 0:000 - GOP: Provided by device 2:623 0:000 - GFX: Model=Intel HD Graphics 4400 (Intel) 2:623 0:000 PCI (00|00:03.00) : 8086 0A0C class=040300 2:623 0:000 PCI (00|00:14.00) : 8086 9C31 class=0C0330 2:623 0:000 PCI (00|00:16.00) : 8086 9C3A class=078000 2:623 0:000 PCI (00|00:1B.00) : 8086 9C20 class=040300 2:623 0:000 PCI (00|00:1C.00) : 8086 9C10 class=060400 2:623 0:000 PCI (00|00:1C.02) : 8086 9C14 class=060400 2:623 0:000 PCI (00|04:00.00) : 168C 0034 class=028000 2:623 0:000 - WIFI: Vendor=Atheros 2:623 0:000 PCI (00|00:1C.03) : 8086 9C16 class=060400 2:623 0:000 PCI (00|05:00.00) : 10EC 5287 class=FF0000 2:623 0:000 PCI (00|05:00.01) : 10EC 8168 class=020000 2:623 0:000 - LAN: 0 Vendor=Realtek 2:623 0:000 PCI (00|00:1C.04) : 8086 9C18 class=060400 2:624 0:000 PCI (00|01:00.00) : 10DE 0FE4 class=030200 2:624 0:000 PCI (00|00:1D.00) : 8086 9C26 class=0C0320 2:624 0:000 PCI (00|00:1F.00) : 8086 9C43 class=060100 2:624 0:000 PCI (00|00:1F.02) : 8086 9C03 class=010601 2:624 0:000 PCI (00|00:1F.03) : 8086 9C22 class=0C0500 2:624 0:000 === [ GetDefaultSettings ] ================================ 2:624 0:000 Clover load options size = 0 bytes 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Aspire V5-573G--00-00-00-00-00-00. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Aspire V5-573G. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Aspire V5-573G-1700. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Dazzle_HW. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Dazzle_HW-1700. Dir not exists 2:624 0:000 set OEMPath by default: EFI\CLOVER 2:637 0:012 EFI\CLOVER\config.plist loaded: Success 2:637 0:000 === [ GetListOfThemes ] =================================== 2:637 0:000 === [ Found config plists ] =============================== 2:637 0:000 - config.plist 2:637 0:000 === [ GetEarlyUserSettings ] ============================== 2:637 0:000 timeout set to 0 2:637 0:000 Custom boot CUSTOM_BOOT_DISABLED (0x0) 2:637 0:000 Default theme: embedded 2:637 0:000 === [ LoadDrivers ] ======================================= 2:637 0:000 === [ InitScreen ] ======================================== 2:637 0:000 Console modes reported: 4, available modes: 2:637 0:000 - [01]: 80x25 2:637 0:000 - [02]: 80x50 2:637 0:000 - [03]: 100x31 2:637 0:000 - [04]: 240x56 (current mode) 2:637 0:000 SetScreenResolution: 1920x1080 - already set 2:637 0:000 SetScreenResolution: 1920x1080 - already set 2:637 0:000 reinit: self device path=PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0)\HD(1,MBR,0x04944021,0x3F,0x3BC1042) 2:637 0:000 === [ GetMacAddress ] ===================================== 2:637 0:000 === [ ScanSPD ] =========================================== 2:637 0:000 Scanning SMBus [8086:9C22], mmio: 0xB3619004, ioport: 0x5040, hostc: 0x1 2:656 0:018 Slot: 2 Type 24 8192MB 1600MHz Vendor=Kingston PartNo=KHX1600C9S3L8G SerialNo=050A0006000A080A 2:657 0:000 === [ GetAcpiTablesList ] ================================= 2:657 0:000 Get Acpi Tables List from RSDT: 2:657 0:000 - [00]: FACP ACRPRDCT len=268 2:657 0:000 - [01]: UEFI ACRPRDCT len=566 2:657 0:000 - [02]: FPDT ACRPRDCT len=68 2:657 0:000 - [03]: ASF! ACRPRDCT len=165 2:657 0:000 - [04]: HPET ACRPRDCT len=56 2:657 0:000 - [05]: APIC ACRPRDCT len=140 2:657 0:000 - [06]: MCFG ACRPRDCT len=60 2:657 0:000 - [07]: BOOT ACRPRDCT len=40 2:657 0:000 - [08]: LPIT ACRPRDCT len=148 2:657 0:000 - [09]: ASPT ACRPRDCT len=52 2:657 0:000 - [10]: DBGP ACRPRDCT len=52 2:657 0:000 - [11]: SSDT ACRPRDCT len=1337 2:657 0:000 - [12]: SSDT ACRPRDCT len=2776 2:657 0:000 - [13]: SSDT ACRPRDCT len=12013 2:657 0:000 - [14]: SSDT ACRPRDCT len=11433 2:657 0:000 - [15]: SSDT ACRPRDCT len=2230 2:657 0:000 Calibrated TSC Frequency = 2394459554 = 2394MHz 2:657 0:000 === [ GetUserSettings ] =================================== 2:657 0:000 === [ Found DSDT tables ] ================================= 2:657 0:000 === [ ScanVolumes ] ======================================= 2:657 0:000 Found 8 volumes with blockIO 2:657 0:000 - [00]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0) 2:659 0:001 Result of bootcode detection: bootable Linux (grub,linux) 2:659 0:000 - [01]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x1,0x0,0x0) 2:660 0:001 Result of bootcode detection: bootable unknown (legacy) 2:660 0:000 - [02]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(1,GPT,8017BD66-1E24-4B31-8E09-BC49BECD6CC4,0x800,0x21330000) 2:661 0:001 Result of bootcode detection: bootable Windows (vista,win) 2:661 0:000 - [03]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(2,GPT,82F3B738-65E9-458E-B2F1-BB55D4F00885,0x21331000,0x3D0800) 2:663 0:001 - [04]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(3,GPT,E701DCD8-E3C5-4BFA-B61B-BFF4D80153FD,0x21701800,0x18C4F000) 2:664 0:001 - [05]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(4,GPT,4DB1239A-A9D7-4045-A162-7EF1B3A5913B,0x3A350C21,0x3A3B616E) 2:665 0:001 Result of bootcode detection: bootable Windows (vista,win) 2:665 0:000 - [06]: Volume: PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0) 2:677 0:011 Result of bootcode detection: bootable unknown (legacy) 2:677 0:000 USB volume 2:677 0:000 USB volume 2:677 0:000 - [07]: Volume: PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0)\HD(1,MBR,0x04944021,0x3F,0x3BC1042) 2:688 0:011 Result of bootcode detection: bootable unknown (legacy) 2:688 0:000 USB volume 2:688 0:000 USB volume 2:688 0:000 This is SelfVolume !! 2:688 0:000 PutNvramPlistToRtVars: nvram.plist not found 2:689 0:000 No AudioIoProtocols, status=Not Found 2:689 0:000 === [ InitTheme ] ========================================= 2:689 0:000 use daylight theme 2:689 0:000 using embedded theme 2:689 0:000 got embedded sound 2:689 0:000 Channels: 2 Sample rate: 8000 Hz Bits: 16 2:689 0:000 output to channel 0 with volume 70, len=25600 2:689 0:000 sound channels=2 bits=16 freq=8000 2:689 0:000 sound converted to 48kHz 2:689 0:000 not found AudioIo to play 2:689 0:000 sound play end with status=Not Found 2:690 0:001 Using embedded font: Success 2:691 0:000 theme inited 2:691 0:000 Chosen embedded theme 2:691 0:000 after NVRAM boot-args= 2:691 0:000 === [ Dump SMC keys from NVRAM ] ========================== 2:691 0:000 no AppleSMC protocol 2:691 0:000 Entry scan disabled 2:691 0:000 === [ AddCustomTool ] ===================================== 2:692 0:000 === [ GetEfiBootDeviceFromNvram ] ========================= 2:692 0:000 Default boot entry not found 2:692 0:000 DefaultIndex=-1 and MainMenu.EntryCount=4 2:973 0:281 GUI ready  
    • By Jancey
      I used this command: diskutil info disk0s2 | grep -i "Partition UUID" | rev | cut -d' ' -f 1 | rev

      But I accidentally removed the wrong disk and now my main windows drive is not appearing in the bootloader. I can't figure out how to get it back. I tried resetting my windows drive, but I kept getting an error. I also reset my mac and reinstalled Catalina.
    • By gengstapo
      @Hervé
       
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
       
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip
      config.plist.zip
    • By TomZanna
      Hi, I'm trying to install Mac Os Catalina on a HP 550-132NL.
      The system has:
      i7-6700
      RAM 12 GB
      GT 730
      LAN Realtek RTL8161
      ALC3863
       
      It passes the verbose phase but after the Apple logo goes away, it gets stuck on a grey screen and I can only move the pointer.
      Can I try to boot with the iGPU?
       
      origin.zip
      CLOVER_dGPU_USB_3.zip
    • By MaLd0n
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×