Jump to content
tlac

[Guide] How to make a bootable OS X 10.9 Mavericks USB install drive on LINUX

83 posts in this topic

Recommended Posts

Solution to problem 1:

 

Ok i solved the problem in two steps: 

First i deleted the nullcpupowermanagement kext, then the system wasn't rebooting but it got stuck anyway(sorry don't remember which was the error)

To solve then i booted with the following flags: -v -x GraphicsEnabler=Yes

 

So....OK! Now i got in the mac installation but here another problem came out.

 

In my pc I have windows installed on 2 HDD in RAID 0 and I want to install mavericks on a third HDD.

for me it's no a problem to change the sata mode everytime i have to boot but here are the possibilites:

 

IDE mode: I can get to the installation but no HDD is detected(only usb stick)

RAID mode: I can get to the installation but no HDD is detected(only usb stick)

AHCI mode: When i boot Chameleon Freeze on the rotating slash, before the boot selection, not during the OSX boot but during the chameleon boot.

:(

 

 

Yet another update: 

I tried to disconnect the 2 HDD in raid 0(physically, the data cable) and now in AHCI chameleon boots fine as the OSX Installation, and now the HDD is detected, so it works but the need to disconnect sata cable everytimes starts to be frustrating...any idea for a solution?

Also, i managed to install mavericks with the RAID hard disk disconnected in AHCI mode but now when i boot i got stock on:

Waiting for DSMOS... It isn't the last line but probably that's the problem...anyway I have FAKESMC.kext in the extension folder...

 

 

First, thanks for your sharing. For the question you asked, i suggest to only leave a cable at the time. The system can't detect which to use when two cables are connected at the same time.

Share this post


Link to post
Share on other sites
Advertisement

After trying to apply this USB creation method to El Capitan (10.11.3), I ran into this first issue (note I'm running the latest Enoch build, r2795 at the time of this writing):

 

 

Not entitled to link kext scom.apple.kpi.privates Failed to Load executable for kext com.apple.kpi.private. Kext com.apple.kpi.private failed to load (Oxdc008004). Fatted to Load kext com.apple.kpt.private (e•ror Oxdc008004). Failed to initialize kernel component com.apple.kpi.private. Not entitled to link kext pcom.apple.kpl.unsupported* Fatted to load executabLe for kext com.appte.kpi.unsupported. Kext com.apple.kpi.unsupported failed to load (Oxdc008004). Failed to load kext com.apple.kpi.unsupported (error Oxdc008004). Failed to initialize kernel component com.apple.kpi.unsupported. Kext com.apple.kec.corecrypto - library kext com.apple.kpi.bsd not found. Can't toad kext com.apple.kec.corecrypto - failed to resolve library dependencies. Kext com.apple.kec.corecrypto failed to load (Oxdc00800e). Failed to load kext com.apple.kec.corecrypto (error Oxdc00800e). Kext com.apple.kec.pthread - library kext com.apple.kpi.bsd not found. Can't toad kext com.apple.kec.pthread - failed to resolve Library dependencies. Kext com.apple.kec.pthread failed to Load (Oxdc00800e). Failed to toad kext com.apple.kec.pthread (error Oxdc00800e). Kext com.apple.iokit.IORCPIFamily - Library kext com.apple.kpi.iokit not found. Can't load kext com.apple.driver.AppleACPIPlatform - failed to resolve Library dependencies - Kext com.apple.driver.flppleRCPIPlatform failed to Load (Oxdc00800e). Failed to toad kext com.apple.driver.AppleACPIPlatform (error Oxdc00800e). Couldn't alloc class -AppleACPIPlatformExpert" panic(cpu 0 caller Oxffffff80008d18e4): "Unable to find driver for this platform: \-191CPI\-.\n-0/Li rcesixnu/xnu-3248.30.4/iokit/Kernel/I0PlatformExpert.cpp:1665 Debugger called: <panic> Backtrace (CPU 0). Frame : Return Address Oxffffff8396a83df0 : Oxffffff80002df792 Oxffffff8396a03e70 : Oxfiffff80008d18e4 Oxffffff8396a03e80 : Oxffffff8000893d2d Oxffffff83964103ec0 : Oxffffff8000893836 Oxffffff8396a03f30 : Oxffffff800088e4ea Oxffffff8396a03f70 : Oxffffff80008944cc Oxffffff8396a03fb0 : Oxffffff80003ccf77 can't perform kext scan: no kext summary BSD process name corresponding to current thread : Unknown Boot args: -v -f 

Mac OS version: Not yet set 
Kernel version: Darwin Kernel Version 15.3.0: Thu Dec 10 18:40:58 PST 2015; root :xnu-3240.30.4-1/RELEFISE_X06_64 Kernel UUID: DECC9F02-27D7-31F0-9599-119EF2673902C HIB text base: Oxffffff8000100000 System uptime in nanoseconds: 1456686633 

 

Thanks to chris1111's installer, I was able to figure it out: you must create a kernel.plist with at least KernelBooter_kexts set to Yes. Here's the full file created by the installer (not this is for an Ivy Bridge CPU, Haswell and up may be different):

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>KernelBooter_kexts</key>
	<string>Yes</string>
	<key>KernelHasswell</key>
	<string>NO</string>
	<key>KernelLapicError</key>
	<string>Yes</string>
	<key>KernelLapicVersion</key>
	<string>No</string>
	<key>KernelPm</key>
	<string>Yes</string>
	<key>KernelSSE3</key>
	<string>NO</string>
	<key>KernelcpuFamily</key>
	<string>No</string>
</dict>
</plist>

This isn't all, however. After that it would get stuck on waiting for DSMOS, so I suppose FakeSMC wasn't being properly loaded. It turns out org.chameleon.Boot.plist must contain CsrActiveConfig set to 3 to get to graphical mode. For reference, here it is:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>CsrActiveConfig</key>
	<string>3</string>
	<key>Graphics Mode</key>
	<string>1024x768x32</string>
	<key>GraphicsEnabler</key>
	<string>No</string>
	<key>Instant Menu</key>
	<string>Yes</string>
	<key>Kernel</key>
	<string>kernel</string>
	<key>Kernel Flags</key>
	<string>-v darkwake=0 dart=0 PCIRootUID=1</string>
	<key>Legacy Logo</key>
	<string>No</string>
	<key>ShowInfo</key>
	<string>Yes</string>
	<key>UseKernelCache</key>
	<string>Yes</string>
</dict>
</plist>

Share this post


Link to post
Share on other sites

Hello.

I used this guide with a clover setup (two partitions on a thumb drive, clover in the first) and some work.

I was able to get to the install stage, I can choose the destination drive (already prepared) and everything seems ok until the actual install takes place.

It throws out "Undefined error: 0", tried with El captain .2 and Yosemite .5

Am I missing something ?

 

From log "X /Volumes/untitled: Missing CoreServices"

 

There's one missing step.

 

MacOSX installer try to get his files from BaseSystem.dmg but there's no such file in our USB build, this prompt a "Undefined error: 0" and end the installation process.

The solution is: go to media/osx86/ and make a symbolic link called BaseSystem.dmg that's actually a link to the folder itself:

 

 

ln -s . BaseSystem.dmg

 

...and everything works like a charm.

 

Also:

  • there's a problem with some folder that cannot be copied in one of the first steps
  • 7z doesn't work anymore

For the first problem the solution is quite easy: use HFSExplorer ( http://www.catacombae.org/hfsexplorer/ )to extract missing files/directories and copy them in place afterward.

For the second you can use dmg2iso ( http://vu1tur.eu.org/tools/ ),first list partitions inside .dmg then "extract" the largest one.

 

Last, I've used parts from this post: http://www.insanelymac.com/forum/topic/298027-guide-aio-guides-for-hackintosh/?do=findComment&comment=2019599

...to create a working thumb drive with clover.

Share this post


Link to post
Share on other sites

So you achieved a fully working El Capitan installer?

 

I'm surprised that you could successfully use the old dmg2iso in certain step.

Share this post


Link to post
Share on other sites

I'm trying to create an El Capitan Installer. 

I'm using a combination xar 7z to extract the files.

The problem is the links seem to be getting converted to text files.

I am able to boot but the kernel says boot task failed: fsck-safe.

Any way to preserve the links and extract?

Share this post


Link to post
Share on other sites

El Capitan has different file format. This guide is not compatible with that.

Share this post


Link to post
Share on other sites

hi

 

Does anyone solved this problem?

 

"there was a problem reading the mac os x installation disc
carefully clean the disc , and then try reinstalling"

 

on iAtkos M

 

thanks :(

Share this post


Link to post
Share on other sites

Hi 

I followed your guide  and now i can boot to chameleon but after pressing enter my laptop restarts in some time .Should i use some flags for booting the system?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Tom Snow
      Hello everyone, it sure has been a while since I last posted here. I'm trying to upgrade my Hackintosh to High Sierra, and right now it's running Sierra which I installed last year. My hardware is a Gigabyte Z68MA-D2H-B3 mobo with Intel Core i5-2500K. Unfortunately, I can't even run the installer. I have an installer USB stick with Clover 4558 on it, and whenever I try to run the installer from it, I get a KP after an extremely long boot process. There are so many panic messages that flash by so fast, but I think I got everything relevant in these pics.
       
       


    • By Ganesh1990
      Hi,
       
      Can Anyone suggest how to disable USB mass Storage in High Sierra, iam currently running 10.12.6 version, 
      I have Tried the Following steps which came across search in google, 
      I Have deleted,
      IOUSBMassStorageClass.kext
      IOUSBMassStorageDriver.kext
      from /System/Library/Extensions folder and tried 
      sudo touch /System/Library/Extensions
      But still My USB Pendrive is detecting.
      Can anyone please help me...
    • By MikixIT
      Salve a tutti ho installato OSX, Sierra 10.12.6 (16G29), grazie a questo forum
      Ho installato tutti i Kext necessari da Nvidia a quelli per l'audio HDMI,ethernet ecc..
      L'unico problema che  Mouse e tastiera USB collegati ad un hub FUNZIONANO, mentre senza hub usb non funzionano nelle altre porte, NELLE ALTRE PORTE PERO' FUNZIONANO PEN DRIVE USB,ho provato vari kext in rete mentre il Forum era in manutenzione
      Ma non riesco a farli funzionare su altre porte,vi allego La mia EFI( http://www.mediafire.com/file/mimomvp1on4ys58/EFI-MikixIT 12%3A03%3A2018.zip) E vari screen del mio OSX con info varie




    • By ITzTravelInTime
      Questo è il thread in italiano dedicato alla mia app TINU, l'app open source che ho creato per creare chiavetta di installazione di mac utilizzando il metodo "createinstallmedia".
      Il nome è l'acronimo di TINU Is Not U (Per le regole del forum devo censurare, ma la U si riferisce ad un programma che piu o meno svolge lo stesso scopo che per buoni motivi è bandita su questo sito, il punto del metterlo nel nome sta nel sottolineare che la mia app è totalmente diversa)
      L'app è pensata per essere molto semplice ed immediata da usare (con un interfaccia grafica progettata con criteri e metodi usati in ambito professionale per lo sviluppo di applicazioni utente) e per essere molto solida e stabile che funziona sempre al primo colpo (a differenza di altri tool che conosciamo ...)
       
      A livello funzionale quest'app non è altro che un interfaccia grafica per il metodo da terminale "createinstallmedia" che viene sfrutatto dalla stessa per creare la chiavetta, quindi le chiavette create con TINU sono chiavette al 100% vanilla come se le aveste create dal terminale, l' applicazione, rispatto al metodo da terminale, aggiunge però funzioni utili come il controllo ed il riconoscimento di errori nel processo, la formattazione automatica della chiavetta USB che si sceglie di usare in formato Mac OS Extended (journaled) (detto anche HFS+) con mapatura di partizione GUID, ed anche altre opzioni personalizzabili o disattivabili come l'applicare un icona alla chiavetta di instalalzione.
      Tra gli altri vantaggi troviamo il fatto che permette di creare chiavette utilizzando qualunque applicazione di mac che contiene l'eseguibile "createinstallmedia" inclusi installer delle beta ed installer appena rilasciati, e non richiede di fare cose particolari prima come formattare la chiavetta e cambiare lingua al sistema e puo utilizzare applicazioni di mac che si trovano in varie directory nel sistema e non solo quelle che stanno nella cartella delle applicazioni ed hanno un nome specifico (nota che l'applicazione di installazione di mac deve essere quella interacche pesa diversi gb e non quella da pochi mb che l'app store puo scaricare alcune volte e che non contiene tutto quello che serve per permettere a createinstallmedia di funzionare)
       
      Tra l;e altre cose quest'app è l'unica app di questo genere sviluppata e che continua ad essere sviluppata in Italia ed è anche l'unica completamente open source.
       
      Trovate qui alcuni link utili:
       - Scarica l'app:                                                  https://github.com/ITzTravelInTime/TINU/releases
       - Codice sorgente dell'app:                                 https://github.com/ITzTravelInTime/TINU
       
       - FAQs (Domande fatte di frequente, in inglese):   https://github.com/ITzTravelInTime/TINU/wiki/FAQs
       
       - Thread in inglese su tinu (English thread about TINU): http://www.insanelymac.com/forum/topic/326959-tinu-the-macos-install-media-creation-tool-mac-app/
       
      Qui invece ci sono un paio di guide (Anche se l'app è molto facile da usare):
       - Piccola guida su come usare TINU per un hackintosh:                                   https://www.youtube.com/watch?v=Ug1yBZybpD4
       - Piccola guida su come usare TINU per creare cheiavette per Mac "originali":    https://www.youtube.com/watch?v=fZOZOUt2ErM
       
       
      Pianifico molte altre nuove funzioni per future versioni dell'app (vedi il thread in inglese per saperne di più)
       
       
      Il supporto a clover in TINU è pianificato per una versione futura, anche se dei protipi a livvello codice per renderlo possibile, sono gia stati sperimentati con successo.
       
      Spero che anche voi del forum italiano aprezzerete questa app come gli utenti del forum inglese, per idee e suggerimenti, siete liberi di esprimervi :-)
       

×