Jump to content
Chris Etheridge

[GUIDE] Lion on AMD Athlon X2 and Biostar A780L Motherboard

1 post in this topic

Recommended Posts

I have successfully installed lion 10.7.2 onto my AMD machine. A machine that is HIGHLY unsupported and has a motherboard that basically no one else has. Everything works perfectly. I want to give back to all those that helped me, and generally helped my community, so here is a guide that hopefully a few of you will use.

This is when using 2 separate disks per operating system. So if you are wanting to dual boot on ONE hard drive, DON'T follow this.

This guide also shows you how to install it entirely WITHOUT a spare Mac machine.

What you are going to need:

 

iAtkos L2 install DMG (google)

A 4.7Gb DVD
A windows machine 
TransMac (HERE)
A 8GB flash drive (explained later)
Bronzovka's Kernel - I forgot which one I used so I uploaded it (HERE)
PowerISO (or any equivalent ISO burner that can burn DMG)
Additional installation things like Voodoo and network (HERE)


Let's start:

 

Firstly we need to prepare our installation disc.

Launch TransMac (as administrator), and then click 'Open -> Open Disc Image'. Open the iAtkos L2 DMG you have downloaded. 

 

Right click on the image and click 'expand'. A dialog box will pop up asking you where to put it - put it on the desktop for easier access.

That will take a bit of time to complete. Once completed, open that image with TransMac, the same way you did with the original DMG. Now we are going to add our kernel.

Right click in the space of your expanded image, and click 'Copy Here'. Navigate to your mach_kernel and paste it there. Overwrite it.

Now open up PowerISO (as administrator), and insert a blank disk. Use DVD-R, its the safest bet. Then click burn, and select disk image. Select the image that you expanded (so NOT the iAtkos L2 one). Let it burn. It doesn't matter what speed really (I did mine on the top speed and it was fine)

Our media is finished!

Next (Optional):

 

This is my recovery option. Due to having 1000 problems with Macintosh before, I created a 'recovery' flash drive. This basically had every patched kernel there is, a few kexts that I knew were sometimes faulty in the installer and a fresh copy of the installer (copied out with TransMac). This saved my skin after I updated to 10.7.5. You don't NEED to do it, but rather be safe than sorry, right?

Install:

 

Restart your Windows machine (do a full restart, don't hit the button). Go into your BIOS and make sure the following is done:

Chipset -> Northbridge Configuration -> SATA Mode -> AHCI
Boot -> Boot device priority -> (your dvd drive)

Now save changes and exit.

Boot:

 

Once you pass the AHCI initialization and the 'post' screen start hitting F8 furiously. You will be greeted with the iAtkos L2 boot screen.

Make sure the disk is highlighted (use your arrow keys to navigate), and type in the following flags:
 

-v USBLegacyOff=Yes npci=0x2000

These worked for me and my motherboard, they may be different. If they don't work play around with them a bit.

Once the disk has been loaded its gonna take about 10 minutes to load everything. It will 'seem' like its hanging on "...IO.Bluetooth..." but it really isn't. Just give it time. A lot of time. Go play with your dog or cat while you wait.

 

If all is okay you will enter the installer (WOOOO!)

Install:

In the menu bar of the installer select Utilities -> Disk Utility. Let it load up. Select the hard drive you want to install (be careful not to select your Windows hard drive), and then erase it or partition it. I created a 20Gb partition called 'SAFETY' and a 140Gb hard drive called 'MAC'. SAFETY hard drive is used for, well, safety. I install any new updates and kexts on my safety hard drive before I apply them to my main.

Once that is done quit the utility and continue with the installer.

You may customize but I honestly left it how it was. Hit install and go have some ice tea.

 

Once the install is complete DON'T DON'T DON'T restart. I always hastily restarted and forgot about my kernel. Go to Utilities -> Terminal. Type in the following: 
 

cp /mach_kernel /Volumes/Mac

Mac was the name of my Mac hard drive, change it with whatever you called it.

 

First boot:

 

Now we can boot properly. Go back into your bios and set the boot device to your Mac hard drive. Save changes and exit.

Once you have gone past the 'post' screen hit F8 furiously as before. You will once again be greeted by iAtkos (what a nice fellow). Select the mac hard drive this time and type in the EXACT same flags you used for your installation.

If everything is okay you should boot up fine! Follow the first-time set up and see how beautiful your little Mac looks.

Changes:

 

We now need to make a few changes to make our startups a little more easy. In finder search for 'champlist'. Load it up. It will bug you about the internet if there is none, just dismiss it. Select configurations. At the bottom click the bar where it shows the directory of the boot.plist. Make sure it is set to your hard drive and NOT the disk. Tick the following:

-v (verbose mode)
npci=0x2000

Also hit 'Edit as text' and type in the following after the last <string><key> combination.
 

<string>USBLegacyOff</string>
<key>Yes</string>

Now you can click save. It will ask you for your password. Enter it and you're done. (This will remove the need to have to hit F8 furiously every time you boot. I also include -v [its not pretty], but its good to see that everything is loading properly).

You will also need to install VoodooHDA to get audio working. Install it. 

You also need to install RTGMac to get the ethernet port working as well. 

Success! Your Macintosh should be working 100% perfectly now.

Optional - Update:

 

Lots of applications will not work unless you have 10.7.4 / 5 installed. So it is in your best interest to do so. Download the massive update and lets get to it.

Firstly, download THIS kernel. It is bronzvoka's 10.7.5 kernel. 

Mount the update DMG and start it. Once it is complete DON'T DON'T DON'T restart. Copy the kernel you just downloaded to the root of your Mac drive. Also make sure it is named mach_kernel and not anything else.

Reboot and everything should work just fine.

There you have it. A fully working Macintosh install. This will be stable enough to use as your main machine. I am a web developer and am now using Macintosh to develop rather than my Windows. It is far better. My specs, just for reference:

AMD Athlon II 3.3Ghz

BIOSTAR A780L
ATI Radeon HD5770
4Gb DDR2 RAM

Feel free to post any problems you may have. I will be happy to help!

Goodluck!


 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Arman Hossain
      HI 
      I want install High Sierra  on my pc . my CPU is : AMD Ryzen 3 2200g and my MotherBoard is : ASUS EX A320m. and 8gb ram DDR4 ram . i dont have any external gripch card. i have seen some video on youtube how to install High Sierra but they use extranal gripch card to make it good  but i don't have any extranal gripch card . on my windows sysem the shared gpu is 2GB which is using my ram to crate the vega gripch  . i want know is it possible to install High Sierra on my pc with out any extarnal gripsh card  ?


    • By MatthewBayard
      Current Build ( just purchased the RX 580 )
       
      CPU Intel Core i7-3770K 3.5GHz Quad-Core Processor       CPU Cooler Corsair H100i 77.0 CFM Liquid CPU Cooler     Motherboard Gigabyte GA-Z87X-UD7 TH       Memory 4x 8gb     (Corsair CML16GX3M2A1600C10 Vengeance Low Profile   16GB (2x8GB) DDR3 1600 Mhz CL10 XMP Performance Desktop Memory Kit Black)       Case Fractal Design   Define R4 (Black Pearl)       Power Supply Corsair HX750       HDD SATA 6Gb / s 256GB SSD         Wifi TP-LINK TL-WDN4800 N900 Wireless PCI Express Adapter       Graphics Card MSI RADEON RX 580 ARMOR MK2 8G OC Graphic Card      
       
      The installation has failed a dozen times after creating a bootable USB via the instructions outlined at serval different places:
      https://www.tonymacx86.com/threads/[url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]-install-macos-mojave-on-any-supported-intel-based-pc.259381/   
      https://hackintosher.com/forums/thread/mojave-flummoxed-with-ga-z97x-ud7.1338/
      https://hackintosher.com/guides/guide-to-fresh-installing-macos-mojave-on-a-hackintosh-10-14/
       
       
      I have used UniBest to create my builds in the past and they have mostly been successful. I tried the other methods as a last resort. I have not gotten past the Apple boot screen with any method attempting to install Mojave. 
       
       

       
       
       
      I have followed all the guides I can in order to get a successful install. However, it has been hard to get a definitive guide to solve my issues.
       
       
      Could somebody please help me with the correct [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] settings. Ie UEFI Boot Mode or Legacy Boot Mode? 
      Recommended BIOS Settings for my system. 
       
       
      It might also just be the required Clover boot screen setup / flags 
       
       
       
      I also have no clue which [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] configurations are required for me to build.
       
       
       
      Any help at all will be most appreciated.
       
       
      I can post any more information regarding errors and crashes if required.       
       
       
       
       
       
    • By shinho73
      Can someone help me fix reboot issue? Actually it reboots, but sometimes the hackintosh just hangs with screen off. Here is the Extra folder containing org.chameleon.boot.plist. https://drive.google.com/drive/folders/1MX8-DpQk9kaRUfjPcToxf-ElWh-bN6EY?usp=sharing  and the spec of the PC. https://drive.google.com/drive/folders/1NlcUNK5DBzJFxeFeuyt92eRjQqwO5T32?usp=sharing Can someone look at it? I might be doing something wrong. Any help will be greatly appreciated. Thank you. 

    • By shinho73
      I need a good vanilla guide for AMD A8 7600 with A58M-E FM2+ mother board and Palit GEforce GT 730. Any help will be greatly appreciated. Thank you.



×