Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Mavericks AppleHDA HDMI Audio

340 posts in this topic

Recommended Posts

HDMI audio is not native in OS X. See Post #1, edit the dsdt or install a ssdt. Download the guide for the selected method and install.

You are kidding me right? I have read that guide more than ten times and have uploaded requested files over and over yet you do not seem to want to assist me. This is easy for you yet you seem to want to belittle me as a grade school teacher does to a child who does not understand their homework. I don't have much experience in the hack but have invested a lot of time in learning about it and have had much help from another member as well who luckily has had patience with me. In the end it does not make a difference if the mac system does not

work perfect for me--but I can't believe someone with your ability finds it easier to play a noob off instead of simply "trying" to give some assistance.

Share this post

Link to post
Share on other sites

All files show the same thing, no HDMI audio edits present.  Why?

No edits, your problem.

Right...the problem is, is I don't understand this:


Location.aml - ssdt.aml installation folder

1. Chameleon: Extra/

2. Clover: EFI/Clover/ACPI/Patched/

Installation - HDMI audio ssdt (audio_ssdt-hdmi…)

1. Copy Downloads/audio_ssdt-hdmi.. . ./SSDT-1.aml to Location.aml

1. If Location.aml/SSDT.aml is present, install SSDT-1.aml as is:


2. If no Location.aml/SSDT.aml, rename SSDT-1.aml to SSDT.aml and

install as: Location.aml/SSDT.aml

3. The 1st SSDT is SSDT, 2nd is SSDT-1, 3rd is SSDT-2, etc.; no gaps

2. Enable SSDT

1. Chameleon - Extra/org.chameleon.Boot.plist



2. Clover_v2000+ - EFI/Clover/config.plist/ACPI/SSDT



3. Rebuild kernel cache, see Tools 1.

4. Restart

5. Verify HDMI audio




I know I have award Bios..I tried simply placing the SSDT-1 file into my extra folder..that didn't work. Guess I need to use MacIasl? Problem is, is that I don't know how to do this and am not as savvy on what to do as you. That's why I came here looking for some direction.

Share this post

Link to post
Share on other sites

I tried simply placing the SSDT-1 file into my extra folder..

dsdt edits use MaciASL, ssdt does not need edits or MaciASL.

Chameleon use a particular order to load ssdts, explained in installation guide.

It says: if you do not have Extra/SSDT.aml rename SSDT-1.aml to SSDT.aml and install as Extra/SSDT.aml. Restart.

Reply with Chameleon Boot log, IOReg, and the installed ssdt.

Share this post

Link to post
Share on other sites

I have attempted to use your audio_cloverALC-HDMI-110.command_v0.8.1 script to enable HDMI audio on my Hackintosh. It says: No AMD/Nvidia discrete graphics card found. I set gDebug=2 to get more info, output attached.


The machine has an Asus P8H61 motherboard running Mavericks OSX 10.9.5 with an Asus HD5450 Silent graphics adapter. It uses the AMD5000Controller and AMDRadeonX3000 kexts. I have to edit the AMDRadeonX3000 Info.plist to add the IOPCIMatch id 0x68E11002 for the graphics acceleration to work. This id is already in the AMD5000Controller Info.plist. I have previously used your audio_realtekALC-110_v1.0o1.command script to enable the ALC887 audio, which worked fine. I have also attached the output from the command 'ioreg -rxn PEG0@1' which picks up the graphics and HD audio, and a screenshot of IORegistryExplorer.



Terminal Saved Output.txt




config copy.txt


Share this post

Link to post
Share on other sites

It says: No AMD/Nvidia discrete graphics card found. I set gDebug=2 to get more info, output attached.

ioreg.txt and ioreg screenshots, not helpful. IOReg.../File/Save a Copy As...

script updated with display@0. Download from repo and run.

Share this post

Link to post
Share on other sites

I have tried your updated script - it found the graphics card and installed a SSDT. After reboot HDMI audio does not appear in the sound preferences, so I ran the script again - it said AMD HDMI audio is not enabled, just like the first time. I have attached the output from running ioreg and the output from your script the first and second time.




Share this post

Link to post
Share on other sites

can't get clover to generate a boot log file

Clover log: DPCI Manager/Misc/Boot log

ssdt is not loading.

Config.plist is a disaster. Remove any property starting with #


ACPI/DSDT/Fixes/ Set the following properties to NO:


Attach new files
Attach EFI/CLOVER/ACPI/origin/  (1st and last dsdt)

Share this post

Link to post
Share on other sites

Ok, nothing in EFI/CLOVER/ACPI/origin/, nothing in EFI/CLOVER/misc, can't find a folder 'DPCI Manager' on the machine.

Frankly, no difference between IORegs, was the edited config.plist installed?

See El Capitan AppleHDA HDMI Audio for

Post #1/IX - Tools/2. DPCIManager/Misc/Boot log

Post #1/IX - Tools/3. MaciASL/File/Extract Tableset....


Attach new files

Share this post

Link to post
Share on other sites

I replaced some valid keys I cut out of config.plist. There are two OSX partitions on this disk - El Capitan and Mavericks. I thought that Clover was reading the config.plist on this partition - Mavericks as it is set as the DefaultVolume, but it appears to have been reading both. So I have made the same changes to the El Capitan config.plist. Now the HDMI audio works on Mavericks, I haven't got to El Capitan yet. It's working on El Capitan as well - Thanks.

config.plist 3.zip

Cynthia.ioreg 3.zip



Share this post

Link to post
Share on other sites
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By spectra
      Hi people, can someone help to put my HDMI sound working? I already tried different methods and I can't figure a way to fix this problem.   And another question, someone knows why the HDMI port just work if i use macbook pro 14,2 on smbios? Because my hardware is much more similar to 14,3.    
      thanks guys
      My system dump
      DarwinDumper_3.0.4_01.02_12.24.51_MacBookPro14,2_AMI_X64_4392_High Sierra_17D47.zip
    • By Mieze
      A New Driver for Realtek RTL8111

      Due to the lack of an OS X driver that makes use of the advanced features of the Realtek RTL81111/8168 series I started a new project with the aim to create a state of the art driver that gets the most out of those NICs which can be found on virtually any cheap board on the market today. Based on Realtek's Linux driver (version 8.035.0) I have written a driver that is optimized for performance while making efficient use of system resources and keeping the CPU usage down under heavy load.

      Key Features of the Driver
      Supports Realtek RTL8111/8168 B/C/D/E/F/G found on recent boards. Support for multisegment packets relieving the network stack of unnecessary copy operations when assembling packets for transmission. No-copy receive and transmit. Only small packets are copied on reception because creating a copy is more efficient than allocating a new buffer. TCP, UDP and IPv4 checksum offload (receive and transmit). TCP segmentation offload under IPv4. Support for TCP/IPv6 and UDP/IPv6 checksum offload. Fully optimized for Mountain Lion (64bit architecture) but should work with Lion too. As of now there is no support for Snow Leopard but it can be added if someone will create the necessary patches. Supports Wake on LAN. Support for Energy Efficient Ethernet (EEE) which can be disabled by setting enableEEE to NO in the drivers Info.plist without rebuild. The default is YES. The driver is published under GPLv2. Limitations
      As checksum offload doesn't work with jumbo frames they are currently unsupported and will definitely never be. No support for 32bit kernels. Installation
      Before you install the driver you have to remove any installed driver for RTL8111/8168.
      Goto /S/L/E and delete the old driver (Lnx2mac, AppleRealtekRTL8169, etc.). Recreate the kernel cache. Open System Preferences and delete the corresponding network interface, e. g. en0. If you forget this step you might experience strange problems with certain Apple domains, iTunes and iCloud later. Reboot. Install the new driver and recreate the kernel cache. I recommend to use Kext Wizard or a similar utility for the installation. Reboot Open System Preferences again, select Network and check if the new network interface has been created automatically or create it manually now. Configure the interface. Troubleshooting
      Make sure you have followed the installation instructions especially when you have issues with certain domains while the others are working fine. Use the debug version to collect log data when trying to track down problems. The kernel log messages can be found in /var/log/system.log. For Sierra and above use "log show --predicate "processID == 0" --debug" in order to retrieve kernel logs. Include the log data when asking for support or giving feedback. I'm an engineer, not a clairvoyant. Check your BIOS settings. You might want to disable Network Boot and the UEFI Network Stack as these can interfere with the driver. Double check that you have removed any other Realtek kext from your system because they could prevent the driver from working properly. Verify your bootloader configuration, in particular the kernel flags. Avoid using npci=0x2000 or npci=0x3000.  In Terminal run netstat -s in order to display network statistics. Carefully examine the data for any unusual activity like a high number of packets with bad IP header checksums, etc. In case auto-configuration of the link layer connection doesn't work it might be necessary to select the medium manually in System Preferences under Network for the interface. Use Wireshark to create a packet dump in order to collect diagnostic information. Keep in mind that there are many manufacturers of network equipment. Although Ethernet is an IEEE standard different implementations may show different behavior causing incompatibilities. In case you are having trouble try a different switch or a different cable. FAQ
      How can I retrieve the kernel logs?In Terminal type "grep kernel /var/log/system.log". ​I want to disable Energy Efficient Ethernet (EEE) but I don't know how?​Take a look at the driver's Info.plist file. There you will find an option named <key>enableEEE</key>. Change its value from <true/> to <false/>. Don't forget to recreate the kernel cache after changing the value.​ WoL from S5 doesn't work with this driver but under Windows it's working. Is this a driver bug?No it isn't, the driver is working as it should because OS X doesn't support WoL from S5. Current status
      The driver has been successfully tested under 10.8.x and 10.9 with the B, C, D, E, F and G versions of the RTL8111/8168 and is known to work stable on these devices. Changelog
      Version 2.2.2 (2018-01-21) Force ASPM state to disabled/enabled according to the config parameter setting. Requires 10.12 or newer. Version 2.2.1 (2016-03-12): Updated underlying linux sources from Realtek to 8.041.00. Added support for RTL8111H. Implemented Apple’s polled receive driver model (RXPOLL). Requires 10.11 or newer. Support for older versions of OS X has been dropped. Version 2.0.0 (2015-06-21): ​Uses Apple's private driver interface introduced with 10.8. Supports packet scheduling with QFQ. Please note that 2.0.0 is identical to 2.0.0d2. Only the version number has changed. Version 1.2.3 (2014-08-23):Reworked TSO4 and added support for TSO6. Version 1.2.2 (2014-08-44): ​Added an option to disable Active State Power Management (ASPM, default disabled) as ASPM seems to result in unstable operation of some chipsets. ​Resolved a problem with Link Aggregation after reboot. Added a workaround for the multicast filter bug of chipset 17 (RTL8111F) which prevented Bonjour from working properly​ ​Version 1.2.0 (2014-04-24): Updated underlying linux sources from Realtek to 8.037.00. Improved interrupt mitigate to use a less aggressive value for 10/100 MBit connections. ​Version 1.1.3 (2013-11-29): Improved transmit queue handling made it possible to reduce CPU load during packet transmission. Improved deadlock detection logic in order to avoid false positives due to lost interrupts. Version 1.1.2 (2013-08-03): Improved SMB performance in certain configurations. Faster browsing of large shares. ​Version 1.1.0 (2013-06-08): Support for TCP/IPv6 and UDP/IPv6 checksum offload added (can be disabled in Info.plist). Maximum size of the scatter-gather-list has been increased from 24 to 40 segments to resolve performance issues with TSO4 when offloading large packets which are highly fragmented. TSO4 can be disabled in Info.plist without rebuild. Statistics gathering has been improved to deliver more detailed information (resource shortages, transmitter resets, transmitter interrupt count). The interrupt mitigate settings has been changed to improve performance with SMB and to reduce CPU load. Configuration option added to allow for user defined interrupt mitigate settings without rebuild. Version 1.0.4 (2013-05-04):Moved setLinkStatus(kIONetworkLinkValid) from start() to enable(). Cleaned up getDescCommand(). Version 1.0.3 (2013-04-25):​The issue after a reboot from Windows has been eliminated. Version 1.0.2 (2013-04-22):​Added support for rx checksum offload of TCP and UDP over IPv6. Version 1.0.1 (2013-03-31): Improved behavior when rx checksum offload isn't working properly. Adds the chipset's model name to IORegistry so that it will show up in System Profiler. Known Issues
      There are still performance problems with regard to SMB in certain configurations. My tests indicate that Apple's Broadcom driver shows the same behavior with those configurations. Obviously it's a more general problem that is not limited to my driver. WoL does not work in certain configurations. Old systems with 3 and 4 series chipsets exhibit performance issues in recent versions of macOS because there is no optimized power management for these systems in macOS anymore as Apple dropped support for the underlying hardware a long time ago. In case you are affected, please upgrade your hardware or find an alternative solution because I have no plans for a workaround. Sorry, but I don't think that it's worth the effort. Getting the driver
      The source code can be found here: https://github.com/M...driver_for_OS_X There is also a pre-build binary for Mavericks and Yosemite: http://www.insanelym...n-and-wireless/  
      Building from Source
      I'm using XCode 4.6.3 for development. You can get a free copy of XCode after becoming a member of the Apple developer program. The free membership is sufficient in order to get access to development tools and documentation.
    • By Mieze
      Open source driver for the Realtek RTL8111/8168 family.
      New Driver for Realtek RTL8111
      Anybody who is looking for a add-on network card with Realtek NIC might want to consider the Delock 89357. This card is equipped with a RTL8111E-VL (chipset 16) which is known to work perfectly with my driver because this chipset is my primary test device.
    • By maxb2000
      I have a problem with sound via HDMI on GTX 750 Ti. The sound only works after sleep I put and wake up the Hackintosh from sleep. The TV gets detected before sleep in the Sound Settings, but I want to play YouTube, Play Music or anything else there is no sound coming out. After sleep it's working without a problem. So in roder to get sound via HDMI I need to start the hackintosh, put it to sleep, wake it up and then I have sound.
      The question is: Why the sound via HDMI doesn't work without sleep ?
      You can find the the system specs in the signature.