Jump to content
keiner99

Mac OSX 10.9/10.10 auf Lenovo Ideapad u410

33 posts in this topic

Recommended Posts

hey leute :)

 

würd gern mac 10.9 auf meinem lappi installieren, hatte mal 10.8.2 oben aber habe nicht geschafft die hardware Beschleunigung zu aktivieren..

 

jz würd ich gern einen neuen versuch mit 10.9 starten, doch ich schaffe es nicht mal mehr in die Installation..

er sagt immer er kann die Grafik treiber der hd3000 (hab noch den alten i3 drin) nicht laden, bei erneutem versuch 10.8.2 zu installieren das selbe :(

 

bios settings sind richtig auf ahci und uma only gestellt! 

 

hier ein screenshot von dem 10.9 boot versuch..

 

p.s.: hab schon erfolgreich einen hackintosh aus meinem standpc gezaubert da funzt alles wunderbar :D also auskennen tu ich mich ;)

 

Bin dankbar für jede Hilfe :D

 

lg keiner99

post-817614-0-96721100-1382560439_thumb.jpg

Share this post


Link to post
Share on other sites
Advertisement

Hallo!

 

Ich würde dir ja gerne eingehender helfen. Aber ohne nähere Hardware Info ist das etwas schwierig. Plaziere bitte deine Hardware, so wie viele andere es hier tun, in deiner Signatur. Insbesondere von Bedeutung sind CPU, Ram, Graka.

 

Es wäre auch von Interesse, welche Installmethode du benutzen willst.

 

Du solltest mal im Bios Bluetooth, Ethernet und Wifi auszuschalten und wenn möglich die Grafik auf intern stellen.

 

Als SMBios würde ich dir die Verwendung von MacBook Air 5,2 oder MacBook Pro 9,2 bereits im Extra Ordner auf dem Installstick empfehlen. NVDAResman.kext würde ich auf dem Installer in S/L/E entfernen.

 

In der org.chameleon.Boot.plist setze EthernetBuiltIn vorerst auf No. Booten solltest du immer mit flags -f -v. Wenn du Gfx Probleme hast mit flags -x -f -v.

 

Beim !nstallieren wäre es von Vorteil einen USB 2.0 Port zu benutzen.

 

Have fun.

Share this post


Link to post
Share on other sites

sorry, dass ich bis jz nicht geantwortet habe..

 

habs jz selbst hinbekommen :) hab imma vagessn dass ich eine mixture aus sandy und ivy hab und dass hat den entsprechenden erfolg gebracht! :D hab jz full qe/ci und auch sound wlan etc funzen perfekt :D

 

außer bluetooth des geht no ned..

 

lg keiner99

 

edit es lauft doch noch nicht so ganz, ich hoffe ihr könnt mir bei meinen Problemen helfen :)

 

1) ich finde kein kext mit dem das trackpad funktioniert unter 10.9 :(

    hab im moment dieses (http://www.insanelymac.com/forum/files/file/91-voodoops2-109-only/) doch er schafft es nicht das kext zu laden :( hat      wer eine Möglichkeit dieses zu laden oder ein anderes kext das funktioniert unter 10.9?

 

2) im finder wird unter Geräte meine systemplatte nicht angezeigt? weiß nicht warum hatte das problem noch nie.. man siehts bessa auf dem screenshot was ich meine ;)

 

ich hoffe ihr könnt mir helfen :D

post-817614-0-71121900-1382622722_thumb.png

post-817614-0-97457400-1382622733_thumb.png

Share this post


Link to post
Share on other sites

Für dein Trackpad google mal nach "Rehabman voodoops2". Der Github Treffer ist der richtige. Lies dortz die Readme.

 

Für Bluetooth musst du die Infoplist vum Broadcom plugin im IOUSBFamily,kext mit Device und VendorID editieren. Gegen Ende der Plist ist ein Entry für einen Bluetooth 4.0 Stick.

 

Have fun.

 

PS: Nimmst du für den Sound ein gepatchtes AppleHDA,kext?

Share this post


Link to post
Share on other sites

kannst du mir das mit dem bluetooth wo ich das genau eintragen muss genauer erklären? wo finde ich die device und vendorID heraus?

 

nein ich verwend zur zeit die voodoo Lösung für den sound, aber es geht auch eleganter hatte ich schon mal anders ;) aha kann mich nicht mehr genau erinnern..

 

edit: hab die vendor id und device id vom bluetooth herausgefunden :) aber bei IOUSBFamily.kext find ich in der info.plist Datei keinen bluetooth eintrag  :(

 

des mitn touchpad haut auch nicht hin :( kannst du mir des vl näher erklären wie ma was installieren muss?

 

ich hab vendor id: 0x168C

und       device id: 0x3002

 

wo muss ich das jz genau eintragen in der info.plist? find da nix gscheids.. die info.plist kann ich da nicht hochladen da es nicht erlaubt ist..

 

was meinst du genau damit? Broadcom plugin im IOUSBFamily,kext

Share this post


Link to post
Share on other sites

Here you go:

 

Vor dem Chameleon Boot im Bios Bluetooth aktivieren, falls es disabled ist.

 

IOBluetoothFamily.kext von S/L/E auf deinen Desktop kopieren und dort mit einem Rechtsklick der Maus Paketinhalt anzeigen, Ordner Contents und dan PlugIns öffnen, Paketinhalt von BroadcomBluetoothHostControllerUSBTransport.kext anzeigen, Ordner Contents öffnen und dort die Info.plist mit TextEdit öffnen (Rechtsklick/Öffnen mit: TextEdit auswählen).

 

Im Apfel Menue "Über diesen Mac" / "Weitere Informationen" / "Systembericht"/ "Hardware" Bluetooth anzeigen. Dort findest du Hersteller-ID und Product-ID als Hex-Ausdruck.

 

Zum Editieren brauchst du das Ganze aber als Integer $. Ist aber ganz einfach im Terminal zu konvertieren.

 

Terminal öffnen und dann nur zwei kurze Befehle eintippen:

 

let x="ID in hex"

 

echo $x

"Integer ID als Output"

 

Danach wählst ein Entry in der mit TextEdit geöffneten Info.plist aus und ersetzt Product-ID und Vendor-ID mit deinen zuvor konvertierten Daten. Ich habe den MediaLink BT 4.0 Adapter dafür genommen. Wenn du willst kannst du auch den Namen ändern. Info.plist sichern, Kext in S/L/E installieren, Rechte reparieren und danach mit flags -f -v rebooten.

 

Wenn alles gut gegangen ist, kannst du Bluetooth von OSX aus aktiveren. Wenn das nicht geht, von Windows aus oder einem Live Linux.

 

Für dein Audio kannst du das AppleHDA.kext für Conexant 20590 probieren. Vor dem Installieren aber alle Teile von VoodooHDA löschen (auch die Prefpane.)

Das Kexr ist für einen Lenovo T420, funktioniert auch auf meinem EDGE E320 und dürfte auch bei dir funzen. Soweit ich weiß, hast du auch einen Conexant AudioChip.

 

DSDT-Edit auf Layout-ID (12) 0x0C, 0x00, 0x00, 0x00.

 

Wenn du noch keine DSDT hast, kannst du AppleHDA auch über die Chameleon Option aktivieren.

 

Have fun.

Share this post


Link to post
Share on other sites

bei mir steht bei hardware bei bluetooth Es wurden keine Informationen gefunden obwohl bluetooth aktiviert ist im bios des heißt es steht keine device und vendor id drin :( 

Share this post


Link to post
Share on other sites

Schau mal in der org.chameleonBoot.plist ob dort der Key "UseKernelCache" "Yes" vorhanden ist. Dann auf "No" setzen und mit flags -f -v rebooten,

Share this post


Link to post
Share on other sites

sorry dass ich so spät melde hab einiges auf da uni zu tun ;)

 

trackpad funzt jz :)

des einzige was nicht funktioniert is bluetooth, hab im bios bluetooth aktiviert win 8 gestartet und es aktiviert! lappi neugestartet mit UseKernelCache=No -v -f und nichts keine änderung es steht noch immer keine informationen verfügbar :(

 

edit:

 

hab etwas entdeckt mein laptop lasst sich in mac im optimus modus booten :D keine Ahnung wieso aber gibt es eine Möglichkeit die zweite graka zu nutzn? 

hier ein screenshot ;)

post-817614-0-66326500-1382885762_thumb.png

Share this post


Link to post
Share on other sites

Normalerweise funktioniert die zweite Graka, die Nvidia aufgrund Optimus nicht. Ich glaube nicht, dass sich in einem Consumer Produkt, wie dem Ideapad, Optimus deaktivieren lässt. Apple benutzt eine eigene Grafikumschaltung, die zur Gänze nicht mit Optimus kompatible ist.

Daher würde ich OSX immer mit Optimus disabled benutzen. Der Saft der Batterie hält dann einfach länger.

 

Bezüglich Bluetooth: Du hast ja Produkt- und Hersteller, Hast du schon versucht, nach einem wie zuvor beschriebenen Edit der Info.plist, mit dem editierten Kext zu booten? (Schau mal in Win8, ob du etwas über den Chiphersteller herausfindest.)

 

Hol dir System Info ( http://www.osx86.net/files/file/2243-system-info/ ) und schau mal ob das BroadcomBluetoothHCIControllerUSBTransport.kext geladen wird.

 

Have fun.

Share this post


Link to post
Share on other sites

sorry dass ich mich jz erst melde.. es funktioniert nun bluetooth auch :D 

hab es bei der Installation im bios deaktiviert und danach aktiviert, er hat es erkannt und es kam kein Fehler!

danach win7 gebotet und bluetooth eingeschalten, danach mac gebootet und siehe es funktioniert! ich hab nichts editieren müssen!

 

danke für den tipp!

Share this post


Link to post
Share on other sites

Wenn du Bluetooth nicht von OSX aus aktivieren kannst, ist der Edit vielleicht doch nützlich. Ich würde aber, falls du alle Bluetooth Features aktivieren kannst, den Bluetooth Wakeup nicht einschalten. Macht unter Umständen Probleme. Es kommt oft eine Fehlermelding im Verboseboot..........blued...... System fängt dann unter Umständen zu spinnen an.

 

Hoffentlich hast du gewonnen und nun einen :happymac:

 

Freut mich für dich, dass es mit dem Bluetooth doch geklappt hat. :D

 

Have fun.

Share this post


Link to post
Share on other sites

mittlerweile geht es nicht mehr.. kA warum :( naja ich brauch es eig nicht wirklich..

 

andere frage: wlan funzt nach sleep nicht mehr.. wie lässt sich das beheben?

 

lg keiner99

Share this post


Link to post
Share on other sites

Danke lieb von dir. Aber auf meinem Desktop läuft Wifi ooB und am E320 hab ich glaube ich meine DSDT editiert oder die Infoplist (nur Vendor u, Device ID erforderlich) vom Kext, nachdem ich einen WL Check removed Bios mod gefunden habe. Ist schon etwas länger her, daher weiß ich es nicht mehr so genau.

 

Have fun.

Share this post


Link to post
Share on other sites

Sorry hat ewas länger gedauert bis ich dir jetzt antworte. Du weißt ja, leise rieselt der Kalk, aber ohne Spaß, mein ganzer Content, das heißt, in threads in denen ich geantworte habe, war verschwunden. Aber Gott sei dank ist er jetzt wieder da. Jetzt bin ich nicht mehr so planlos.

 

Du hast schon recht, mit deiner Vermutung, dass eine DSDT manches in punkto Sleep regeln kann. Aber der Hauptgrund, warum er nicht funktioniert, liegt im nicht richtig funktionierenden Powermanagement. Hast du noch NullCpuPowerMangement.kext installiert?

 

Have fun.

Share this post


Link to post
Share on other sites

meinst du bluetooth nicht richtig funktioniert wegen nullcpupowermanagement.kext oder wlan und sleep?

 

nein bis jz hab ich dieses kext nicht installiert..

Share this post


Link to post
Share on other sites

ich hab jz alles selbst lösen können! mittlerweile lauft alles auf 10.9.1 wlan bluetooth sound sleep funktionieren perfekt :D falls wer tipps braucht kann gerne fragen ;)

 

kann geclosed werden!

Share this post


Link to post
Share on other sites

falls noch interesse besteht ich hab mittlerweile 10.9.3 perfekt am laufen :)

 

hier eine liste was funktioniert:

 

  • Sleep (wird auch aktiviert wenn ihr den Laptop zuklappt)
  • Speedstep (taktet brav zwischen 800mhz und 1400mhz)
  • Touchpad (perfekt wie unter Windows, mit allen Funktionen)
  • Helligkeitseinstellung vom Display (mit den Funktionstasten oder unter Systemeinstellungen/Monitore und dann über den Balken zum Schieben)
  • Wlan (bis 150mbit/s)
  • Lan (Vollduplex bis 100mbit/s),
  • Tastatur (Logitech Layout kann genutzt werden)
  • USB (alle Anschlüsse, leider nur als USB 2.0)
  • CardReader (hat von alleine funktioniert (OOB)),
  • HDMI (HDMI Bildübertragung einwandfrei)
  • Sound (über AppleHDA + DSDT Patch einwandfrei, Autoswitch Lautsprecher/Kopfhörer, kein Widget/Slider Sync "bug" smile.png)
  • HDMI Audio
  • Mikrofon (intern und über Headset)
  • Kamera (für Facetime)
  • iMessage (habe leider kein IPhone etc, aber ich konnte mich mit der Apple ID ganz normal anmelden!)
  • iCloud

was nicht vernünftig funktioniert ist bluetooth aber das ist ein bekanntes problem ;)

 

bei genauerer interesse bitte pn :) also ein wirklich perfektes Hacbook :D

Share this post


Link to post
Share on other sites

Hallo!

 

Funzt bei dir GenericUSBXHCI.kext nicht für USB3.0? Das kannst normal in der akutellsten Version hier finden.

 

Was mich interessieren würde ist, wie du die Helligkeitsregelung mit den F -Tasten hinbekommen hast.

 

Lg

Share this post


Link to post
Share on other sites

Hi! Doch das GenericUSBXHCI.kext funktioniert eh, doch danach geht sleep nicht mehr.. auch nicht mit den richtigen DSDT Patches..

das mit den Funktionstasten ist bei mir oob gegangen, auch schon unter Mac OSX 10.8

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By dannymozzer_
      Hi,
       
      I've been trying to install Mavericks 10.9, I know it's older now, but It's honestly the version I want to use, the specs of the PC are:
      Asus P8H61-MX USB3
      i3-3220
      8GB DDR3 Memory
      GTX 750 ti
      500GB HDD
       
      I've been following this guide: https://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-yosemite/
      But, after booting, this is the error screen I get, any guidance on what Kexts, SMBios settings, etc. I need? I can tell I'm probably missing something here.

      Thanks,
      Dan
    • By Angelo_
      Hi, I followed the rehabman guide (linked in the vanilla guide on the side of r/Hackintosh, not sure if I can link it) for laptops for my yoga 730ILW13 with an 8265u, Conexant 11870, 8gb of ram, 13.3" fhd and I found that upon booting the installer usb I get this weird issue where the screen displays what it should but the screen is incredibly dim (though it was off before using a flashlight on it) and it flashes every few seconds for a few milliseconds to the correct brightness, I used the plist for hd615-650 (including my 620), not quite sure what could be the culprit, first time hackintoshing a laptop so it might be a stupid brightness kext I forgot but didn't find any in that post or in this forum :c 
      Attached the clover zip so that anyone with more experience than me might give an idea in what could be a way to fix this.
      Thank you in advance 
       
       
       
      CLOVER.zip
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (April 2019) Updated to Clover r4918 Updated Lilu kexts - ALC, WEG Merged Verleihnix' config.plist - especially to NOT inject GFX Updated BacklightInjector as option to WEG.
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
    • By ludufre
      Installing macOS Mojave on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      03/28/2019 15:01h GMT-0
      - Added info about update 10.14.4. 
       
      03/13/2019 13:15h GMT-0
      - Updated info about touchpad replacement and CPU and 4G LTE modem.
       
      02/05/2019 18:47h GMT-0
      - Updated info about CPU replacement and 4G LTE modem.
       
      02/04/2019 15:24h GMT-0
      - Sometimes the VoodooHDA.kext doesn't work.
      - Added AppleHDADisabler.kext to fix that (attached bellow).
       
      01/24/2019 14:42h GMT-0
      - Added more adjustments to use of VoodooHDA.
      - Updated VoodooHDA links to 2.9.1 official (without installer).
      - Changed PCM volume from 90 to 180 in Info.plist (attached modified VoodooHDA.kext bellow)
      - Updated SSDT-L440.aml (Removed HDEF and HDAU, not needed).
      - Updated config.plist (Changed to user Audio layout to 1).
       
      01/22/2019 20:47h GMT-0
      - I gave up on the AppleALC.
      - Headset does not work.
      - Now with VoodooHDA is perfect and the sound even louder.
       
      01/22/2019 14:37h GMT-0
      - Added info about update 10.14.3. 
       
      01/22/2019 13:46h GMT-0
      - Added link to BIOS reassing guide.
       
      01/20/2019 11:49h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
       
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
       
      - RAM upgrade:
      No mistery here. Just upgade.
       
       
      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Upgrade CPU to i7-4712MQ (Ordered. It's on the way) Done, but received i7-4700MQ (47w TDP, with good paste I have no overheating)
      - Replace touchpad with T460 model (Ordered. It's on the way) Done. Sensitivity and perception of quality much better. I recommend 100%!
      - Sierra Gobi5000 4G LTE modem EM7355 (Ordered. It's on the way. I hope works. ) Done, but not work. Recognize but not connect. I already gave up...
      - Upgrade to 16GB RAM Done
      - Make touchpad appear in System Preferences
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the RehabMan's CloverEFI fork (used 4910) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - ApfsDriverLoader-64
      - UEFI Drivers - AptioMemoryFix-64


       
       
      Make things works

      Will be created a partition named EFI and mounted in Desktop.
      - Replace the /Volumes/EFI/CLOVER/config.plist with mine attached below
                    If you have modded BIOS with Advanced Menu and enabled 128MB DRAM-prealloc use 128MB_DRAM-prealloc_config.plist.zip
                    If no, then use 32MB_DRAM-prealloc_config.plist.zip
      - Put SSDT-L440.aml attached below in /Volumes/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.3.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC.kext from here. I used version 1.0.2.
      - Download the VoodooPS2Controller.kext from here. I used version 2018-1008.
      - Download the IntelMausiEthernet.kext from here. I used the version 2018-1031.
      - Download the Lilu.kext from here. I used the version 1.3.5.
      - Download the VoodooHDA from here. I used the version 2.9.1 and patched the sound volume (attached below).
      - Download the WhateverGreen.kext from here. I used the version 1.2.7.
      - Download the AppleBacklightFixup.kext from here. I used the version 2018-1013.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the ACPIBatteryManager.kext from here. I used the version 2018-1005.
       
      - Download the FakeSMC.kext from here. I used the version 2018-0915. Replaced with VirtualSMC.kext due 10.14.4 issues on update.
      - Download the AppleALC.kext from here. I used the version 1.3.4. Replaced with VoodooHDA.kext due mic not working.
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (In addition to removing the whitelist, add the advanced menu);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      Soon, I'll provide step by step in this process. Probably until end of this week.
      In the meantime, if you need to, send me your dump that I do steps 3 and 4 for you.
      I also add the Advanced Menu so you can increase to 128MB the DRAM-prealloc.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 1.1.9.
      - Download the BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext from here. I used the version 2018-0505.
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.2.
       
       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the config.plist inside your destination disk EFI parittion with config.plist inside flash card EFI partition.

      The flash drive EFI partition is unmounted. Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 1.
       
      Last step
       
      Copy all Kexts from flash drive to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/Other/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      Updates
       
      System update 10.14.3
       
      - Updated with success;
      - Everything works perfectly after reboot;
       

       
       
      System update 10.14.4
       
      - Updated Clover to 4910.
      - Updated Lilu.kext to 1.3.5 and WhateverGreen to 1.2.7.
      - After first reboot the update progress stoped with:
      GTrace synchronization point 4 Unsupported CPU Unsupported PCH hmm.. mismatch sizes: 3100 vs 20 It was still possible to start the previous installation, selecting "Macintosh" as opposed to "macOS Install" in Clover.
      So I created a flash drive with Clover 4910 and put only my config.xml, SSDT-L440.aml, the updated Lilu.kext and WhateverGreen.kext. And I decided to test VirtualSMC instead of FakeSMC.kext.
      With this I was able to install update 10.14.4. After installation I can boot normally, even with FakeSMC.kext that already in /Library/Extensions.
      I do not know what exactly happened, but now works everything like was previously.
       


       
       

      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @Shiki and all others members involved directly or indirectly.
       
       
       
       
       
       
      32MB_DRAM-prealloc_config.plist.zip
      128MB_DRAM-prealloc_config.plist.zip
      SSDT-L440.aml
      VoodooHDA.kext.zip
      AppleHDADisabler.kext.zip
    • By Leinad12
      Olá a todos.
      Estou com o macOS Mojave instalado num Lenovo 305 (com um i3 5005 e uma HD 5500) porém tou com um problema.
      Sempre que o computador entra em pausa (Sleep) não consigo voltar a "acordar" (Wake).
      Alguém pode me ajudar pf?
×