Jump to content
InsanelyMac Forum
midi-sama

[Fixed, HDMI only for now] Intel HD4000 w/ 63MB ram w/ QE/CI (Mavericks only, sorry ML :/ )

Recommended Posts

I have saved AppleIntelFramebufferCapri.kext on the desktop and only documents folder from /S/L/E then I executed the command line, is that what I should do?

And then installed it using kext wizard.

Correct, and if it does not work, reinstall vanilla kext from your document folder.

Share this post


Link to post
Share on other sites
Advertisement

It worked, it recognize the HDMI but I can't see anything, it stays blue! I let it for more than 15mins and still blue in both screens. Is the command line for HDMI only?

Share this post


Link to post
Share on other sites

It worked, it recognize the HDMI but I can't see anything, it stays blue! I let it for more than 15mins and still blue in both screens. Is the command line for HDMI only?

The command line copy all ports from IntelCapriFB=3, which has 3 ports. Have you tried IntelCapriFB=3 with vanilla kext?

Share this post


Link to post
Share on other sites

Yes, before and after the command line, same result:

-Black screen but backlight is on

-HDMI works normally

In ICFB=4:

-LVDS works like charm

-HDMI: I get a blue screen (the blue screen you get when you plug an external display) and stays forever like that even after removing the cable

I don't have any miniDisplayPort (YEAH! Sony! --"), 1HDMI and 1VGA port!

Share this post


Link to post
Share on other sites

Use IntelCapriFB=8 and repatch your vanilla kext with the script:

sudo perl -pi -e 's|\x08\x00\x66\x01\x01\x03\x03\x03\x00\x00\x00\x04\x00\x00\x00\x01\x00\x00\x00\x20\x10\x07\x00\x00\x10\x07\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\xF0\xD9\x05\x00\x00\x00\x00\x00\x01\x00\x00\x00\x02\x00\x00\x00\x30\x00\x00\x00\x02\x05\x00\x00\x00\x04\x00\x00\x07\x01\x00\x00\x03\x04\x00\x00\x00\x04\x00\x00\x07\x01\x00\x00|\x08\x00\x66\x01\x01\x03\x03\x03\x00\x00\x00\x04\x00\x00\x00\x01\x00\x00\x00\x20\x10\x07\x00\x00\x10\x07\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\xF0\xD9\x05\x00\x00\x00\x00\x00\x05\x03\x00\x00\x02\x00\x00\x00\x30\x02\x00\x00\x03\x04\x00\x00\x00\x04\x00\x00\x07\x01\x00\x00\x04\x06\x00\x00\x00\x08\x00\x00\x06\x00\x00\x00|'  ~/Desktop/AppleIntelFramebufferCapri.kext/Contents/MacOS/AppleIntelFramebufferCapri

Make sure that you have vanilla kext in desktop.

Share this post


Link to post
Share on other sites
OK, I'll try it now, but I have suggestion: can't we change the LVDS port from ICFP=3 w/ the one from ICFB=4? And can you give me a link to the topic that you take those command line? :D THANK U A LOT :D

 

NEVER MIND

The first command line was made for Mavericks, and I have tested it on Mountain Lion, so that's why it didn't work.

THANKS A LOT :D

I'll see what I cam do for the VGA port :D

Share this post


Link to post
Share on other sites

 

You can enable DP ports by using IntelCapriFB=4 and patch your AppleIntelFramebufferCapri kext with this code (credit to kpkp):

 

sudo perl -pi -e 's|\x04\x00\x00\x81.{107}\x04\x00\x66\x01.{108}|\x08\x00\x00\x06\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x11\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x04\x00\x66\x01\x01\x02\x04\x02\x00\x00\x00\x04\x00\x00\x00\x01\x00\x00\x00\x40\x10\x07\x00\x00\x10\x07\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x05\x03\x00\x00\x02\x00\x00\x00\x30\x02\x00\x00\x02\x05\x00\x00\x00\x04\x00\x00\x07\x04\x00\x00\x03\x04\x00\x00\x00\x04\x00\x00\x81\x00\x00\x00\x04\x06\x00\x00\x00\x08\x00\x00\x06\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x11\x00\x00\x00\x00\x00\x00\x00\x00|' ~/Desktop/AppleIntelFramebufferCapri.kext/Contents/MacOS/AppleIntelFramebufferCapri

Do you have the clover version of this patch ?

Share this post


Link to post
Share on other sites

No need, go to the AIO guide. The HVT can generate a config.plist with the needed patches. And I discovered how to add VRAM for more smooth 3D rederring (not better performances tho)

Share this post


Link to post
Share on other sites

No need, go to the AIO guide. The HVT can generate a config.plist with the needed patches. And I discovered how to add VRAM for more smooth 3D rederring (not better performances tho)

Can you please provide me the page of the guide I need to refer to ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×