Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
sowhatkg

Lenovo Edge e420 / HD3000 internal screen not working

10 posts in this topic

Recommended Posts

Hi all,

Here is what i got on my Lenovo Edge e420.

Mountain Lion with 10.8.5 update, Chameleon bootloader and MacBook Pro 8.1 smbios.

 

Internal screen goes black after the apple logo and external HDMI monitor also does not work.

Got into the system by deleting AppleIntel kexts and enabled screen sharing then put drivers back.

In VNC I see it is working flawlessly with QE/CI and variety of resolutions detected including my native 1366x768.

I've tried Clover also with EDID injection (from Windows) - did not help.

Also tried hdgraphics_patcher (http://www.insanelymac.com/forum/topic/286879-appleintelhdgraphicsfb-fixed-sl-1068/) - used kext from 10.8.4 also did not help still black screen after apple logo.

One thing also - when booting with external monitor connected or when detaching it the internal screen gets blue sometimes for a few seconds like it is "secondary" (I'm not sure though 'couse I can't connect through VNC with external monitor connected).

 

post-408052-0-95912900-1381631380_thumb.png 

 

Guys please help me to move to right direction I got stuck and I really need hackintosh on this laptop.

 

Thank you.

Share this post


Link to post
Share on other sites

Try this:

 

 

Boot into Single User Mode -s 

 

/sbin/mount -uw /

 

cd /System/Library/Extensions

 

rm -r AppleIntelIntegratedFrameBuffer.kext

 

exit

 

Post back with the results.

Share this post


Link to post
Share on other sites

cd /System/Library/Extensions

rm -r AppleIntelIntegratedFrameBuffer.kext

I don't have such a file there - deleted the only one with "FrameBuffer" in file name -  AppleIntelFramebufferCapri.kext with no effect.

Share this post


Link to post
Share on other sites

1. Delete all graphics kexts;


 


AMD


- AMDRadeonAccelerator.kext


- AMDRadeonVADriver.bundle


- AMDRadeonX3000GLDriver.bundle


 


INTEL


- AppleIntelHD3000Graphics.kext


- AppleIntelHD3000GraphicsGA.plugin


- AppleIntelHD3000GraphicsGLDriver.bundle


- AppleIntelHD3000GraphicsVADriver.bundle


- AppleIntelHD4000Graphics.kext


- AppleIntelHD4000GraphicsGA.plugin


- AppleIntelHD4000GraphicsGLDriver.bundle


- AppleIntelHD4000GraphicsVADriver.bundle


- AppleIntelHDGraphics.kext


- AppleIntelHDGraphicsFB.kext


- AppleIntelHDGraphicsGA.plugin


- AppleIntelHDGraphicsGLDriver.bundle


- AppleIntelHDGraphicsVADriver.bundle


- AppleIntelIVBVA.bundle


- AppleIntelSNBGraphicsFB.kext


- AppleIntelSNBVA.bundle


 


ATI


- ATI2400Controller.kext


- ATI2600Controller.kext


- ATI3800Controller.kext


- ATI4600Controller.kext


- ATI4800Controller.kext


- ATI5000Controller.kext


- ATI6000Controller.kext


- ATIFramebuffer.kext


- ATIRadeonX2000.kext


- ATIRadeonX2000GA.plugin


- ATIRadeonX2000GLDriver.bundle


- ATIRadeonX2000VADriver.bundle


- ATISupport.kext


 


Nvidia


- GeForce.kext


- GeForceGA.plugin


- GeForceGLDriver.bundle


- GeForceVADriver.bundle


- NVDAGF100Hal.kext


- NVDAGK100Hal.kext


- NVDANV50Hal.kext


- NVDAResman.kext


- NVSMU.kext


 


2. Use Kext Wizard to repair permissions, rebuild cache


 


3. Install these kexts. https://www.dropbox.com/s/v3ybzzh2snb6wcs/HD3000.zip


 


4. Repair permissions, rebuild cache (use kext wizard).


 


5. Restart.


 


 


NOTE: if you get another black screen, use the frame buffer in "Alternative framebuffer" folder inside the HD3000.zip.


Share this post


Link to post
Share on other sites

genofloresaz

hd3000 8086 dev_id 0116

You should try to switch to SMBios of MBP 8,2 and install temporarily Nullcpupowermanagement.kext. With this combination internal screen should work.

You have to get also modigliani script at olaria.com (registering for free) to patch the pinouts of original AppleIntelSNBGraphicsFB.kext. Try to convert the tables to the following ones (working on Edge E320 with all ports- patched kext from 10 8.5 attached):

 

HD3000 Table:

0000000: 0102 0300 1007 0000 1007 0000  ............

000000c: 0100 0000 0200 0000 3000 0000  ........0...

0000018: 0205 0000 0008 0000 0600 0000  ............

0000024: 0602 0000 1000 0000 0900 0000  ............

0000030: 0000 0000 0004 0000 0900 0000  ............

 

After finishing the script, repair permissions and reboot with flags -f -v. If all ports are working you can switch back to SMBios of MBP 8,1 and remove nullcpupowermanagement.kext. Then reboot again with flags -f -v and you should have a working system again.

 

Have fun.

 

AppleIntelSNBGraphicsFB.kext.zip

Share this post


Link to post
Share on other sites

Thanks for reply !

styrian

You should try to switch to SMBios of MBP 8,2 and install temporarily Nullcpupowermanagement.kext. With this combination internal screen should work.

 

Same black screen. Tried your AppleIntelSNBGraphicsFB.kext.zip with no luck - black screen after logo. 

I've also found this topic - http://www.insanelymac.com/forum/topic/259705-editing-custom-connector-info-for-intel-hd-3000-graphics-sandy-bridge-osx-lion/ I'm not a programmer but I'll try to get into it and post results here.

So far - no solution for internal screen on this laptop.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×