Jump to content
chevalier433

Graphics - No GPU Power Management

270 posts in this topic

Recommended Posts

There is no evidence that it's a GPUsensors or fakesmc issue.

 

He said "after update and running Unigine Heaven my GPU clock gets down to 324 MHz." which is how it works for everyone - Unigine Heaven doesn't use OpenCL.

Share this post


Link to post
Share on other sites
Advertisement

Wow. I am so glad for the official web drivers! Slight improvement in my Unigine Heaven benchmark score, however I have experienced nearly a double FPS increase in some games. Noteably minecraft whose FPS went from 30 to 150+ on my nVidia GT 640. 

 

However it appears as though the OpenCL bug is still present as it still sticks to nearly full clock after opening preview.

 

​I have no doubt that if apple doesn't fix this issue by the GM 10.9.2 that the updated nVidia drivers will.

 

Hey yokonunz, where did you find those web drivers? I can't seem to find this beta on the nVidia website. Are there updated CUDA drivers as well? The preference pane tells me that my CUDA driver is outdated after installing the web drivers you posted.

Share this post


Link to post
Share on other sites

Is there in anyway we can enable AGPM on MacPro3,1 identifier?

Probably. But i found it easier to simply use MacPro4,1 SMBIOS and remove appletymcedriver.kext to aviod KP. Then simply inject your device id into the AGPM info.plist

Share this post


Link to post
Share on other sites

My GTX-770 is running ~10°c hotter than usual, I assume this is because of the lack of power management in Mavericks? My CPU also seems to refuse to drop into C3/C6 states either.

Share this post


Link to post
Share on other sites

Hi there,

I have GTX 570 SC on board, 10.9.1 Mavericks. AGPM in OSX is working fine, but freq of my GPU stays solid on 3D [high]. Not sure why - if AGPM works fine - GPU wont throttle down, there is no link ?

My GPU in Windows 7 idling with temps 24-25'C, while in Mavericks I have 30-35'C.

 

AGPM info.plist

<key>MacPro5,1</key>

<dict>

<key>Vendor10deDevice1081</key>

<dict>

<key>Heuristic</key>

<dict>

<key>ID</key>

<integer>0</integer>

<key>IdleInterval</key>

<integer>250</integer>

<key>SensorOption</key>

<integer>1</integer>

<key>SensorSampleRate</key>

<integer>4</integer>

<key>TargetCount</key>

<integer>5</integer>

<key>Threshold_High</key>

<array>

<integer>45</integer>

<integer>80</integer>

<integer>100</integer>

</array>

<key>Threshold_Low</key>

<array>

<integer>80</integer>

<integer>90</integer>

<integer>98</integer>

</array>

</dict>

<key>LogControl</key>

<integer>1</integer>

<key>control-id</key>

<integer>18</integer>

<key>default-control-id</key>

<integer>18</integer>

</dict>

post-695598-0-06610000-1392559100_thumb.jpg

Share this post


Link to post
Share on other sites

Any news if this bug still exists in the new 10.9.2 build?  (13C62). I don't have a dev account and cannot test myself.

Share this post


Link to post
Share on other sites

Any news if this bug still exists in the new 10.9.2 build?  (13C62). I don't have a dev account and cannot test myself.

Just updated - Still exists.

Share this post


Link to post
Share on other sites

What about 13C64?  I can't believe this bug is going to persist through 2 updates...

 

The actual bug seems to have been around since at least 10.8.5. It just gets triggered more easily in Mavericks. Most notably Preview and QuickLook can now trigger it.

Share this post


Link to post
Share on other sites

Well, guess I'll see what 10.9.2 has to offer.  Probably not much...

 

EDIT: Yep, still {censored}.  WTF, Apple?

Share this post


Link to post
Share on other sites

No luck with 10.9.2 update, every issue remains...

 

Well, guess I'll see what 10.9.2 has to offer.  Probably not much...

 

EDIT: Yep, still {censored}.  WTF, Apple?

 

 

Share this post


Link to post
Share on other sites

And the latest nvidia web driver beta (b15) still doesn't fix it. Not looking good.

 

PimentelX86: There's a bug with Kepler cards where OpenCL causes the card to get stuck in a high power state. This has been around since Mountain Lion, but Mavericks uses OpenCL a lot more at the system level.

 

For example, if I open a picture with Preview my card won't clock back down until I reboot.

Share this post


Link to post
Share on other sites

Hello

What GPU PM issue are you getting?

My issue is that by opening any program like preview or some of the benchmark programs and even FaceTime. The GPU will scale up to 100% frequency and will not come down once I finish using the said program. This will bring temperatures of around 10c higher. My GPU now is at 324mhz core and 648mhz memory, if I open preview it will shoot up to 1.11ghz and 5.00ghz respectively and will not scale down.

Share this post


Link to post
Share on other sites

Hello

There's a bug with Kepler cards where OpenCL causes the card to get stuck in a high power state. This has been around since Mountain Lion, but Mavericks uses OpenCL a lot more at the system level.

 

I undestand, thanks for explain the bug

My issue is that by opening any program like preview or some of the benchmark programs and even FaceTime. The GPU will scale up to 100% frequency and will not come down once I finish using the said program. This will bring temperatures of around 10c higher. My GPU now is at 324mhz core and 648mhz memory, if I open preview it will shoot up to 1.11ghz and 5.00ghz respectively and will not scale down.

 

You card is Kepler? I used(in 2011)a guide to adjust my AGPM, but this is for Fermi cards... if you have Kepler, so... i think this cannot work to you.

Share this post


Link to post
Share on other sites

I don't think it's anything to do with AGPM. The card will clock down fine with OpenGL and CUDA but OpenCL is broken.

We were hoping Apple would fix that with yesterday's update. No such luck. It looks like that is the issue, some people went as far as disable Open CL but that will obviously bring issues of it's own.

Share this post


Link to post
Share on other sites

I don't think it's Apple's problem. It only affects nvidia cards and only from one family so my guess is the bug lies in the nvidia driver and not the OpenCL framework. So it's up to nvidia to sort it out.

 

Disabling OpenCL on my 670 hasn't brought any issues here so far. OS X functions fine.

Share this post


Link to post
Share on other sites

Hello

I undestand, thanks for explain the bug

You card is Kepler? I used(in 2011)a guide to adjust my AGPM, but this is for Fermi cards... if you have Kepler, so... i think this cannot work to you.

Yes, it's a Kepler. I have the AGPM edits with the 13,2 SMBios and the 660M replaced by my GTX 650 OC. It shows loaded and working in Console. For the most part it works fine, the only issue I have is with the programs mentioned above and a few more. Games scale down just fine.

Share this post


Link to post
Share on other sites

Yes, it's a Kepler. I have the AGPM edits with the 13,2 SMBios and the 660M replaced by my GTX 650 OC. It shows loaded and working in Console. For the most part it works fine, the only issue I have is with the programs mentioned above and a few more. Games scale down just fine.

I did similar edits in the AGPM but after a Luxmark (opencl benchmark) the clocks do not go down :/

Share this post


Link to post
Share on other sites

I did similar edits in the AGPM but after a Luxmark (opencl benchmark) the clocks do not go down :/

Yes, that's what I said. Some games that do not use OpenCL work just fine and the GPU clocks down like it should. Luxmark doesn't.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×