Jump to content
acronator

[SUCCESS] Vanilla ML 10.8.5 on GA-Z87X-UD4H & 4770k Haswell

30 posts in this topic

Recommended Posts

 I found that selecting the web driver and rebooting does nothing, it always returns to the OS X default driver.

 

 

FYI, regarding this.

 

I edited the Nvidia driver so I could install with the "correct" SMBIOS (or at least the one with the specs most closely related to this computer)

http://www.insanelymac.com/forum/topic/291929-1085new-nvidia-web-driver-available/?p=1946332

 

But more importantly, I followed this guide (more or less) to get the Nvidia driver installed and enabled.

http://www.insanelymac.com/forum/topic/288582-new-nvidia-retail-driver-install-solution/

 

Note that the link to the driver may not be latest, but doing the nvda_drv=1 and adding the FileNVRAM.dylib file seemed to do the trick.

 

I'm staying with Mountain Lion until I see Nvidia drivers for Mavericks, because the drivers seemed to do the trick for me.

 

Though it sounds like Lyle M may have a different issue (different graphics card).

Share this post


Link to post
Share on other sites
Advertisement

Hi guys,

 

First off, a huge thanks to acronator for the guide ( and rockinron_1 for the original guide ), I got ML (10.8.5) booted up and running on the same hardware without any problems. Sleep, network, etc. worked out-of-the-box, and sound was enabled using the same route in the guide.

 

I decided to try giving Mavericks a shot, though (slightly stupidly overwriting my ML install after partitioning in the installer)... It installed fine (took a while for the installer to reach the language-selection screen, but after that all was well). At least until I booted it... No network/ethernet or sound (the latter to be expected), and my non-USB3 ports kept disconnecting my dongles. Graphics worked, though. That was a little something at least!

 

I couldn't find any useful logs in Console or anything like that, and various bootflag combos didn't seem to help at all, so I'm now re-installing ML. 

 

Just wondering if anyone else with this board has had similar issues on Mavericks? I've done a search on the forum but can't find any word on the network or USB issue.

 

Cheers.

 

 

Specs:

GA-Z87X-UD4H

4770k

GTX 770 (Gigabyte 2GB)

16GB RAM

256GB SSD as OS drive

 

EDIT: I'm going to give Mavericks another shot (starting from scratch again but I'll use a different drive to ML this time). I'll make notes of any odd messages that pop up when booting using -v; I can't imagine this post is much use without this further info...

Edited by Square_Feet

Share this post


Link to post
Share on other sites

UPDATE: Sept 26 2013

Following issues come up frequently:
  • Sleep/wake problem where the system freezes while waking up (no display either). 
  • Random complete system hangs where everything just freezes
  • Prolonged waits and temporary freezes with the wheel spinning away to glory or the mouse not moving. 

​Repaired permissions and also ran kext utility. Issues continue. Chipping away..will update once I have a stable system. 

 

 

I own the same board and I think that I found a solution for these freezes. Simply I disabled all the C-States in bios. (C1E - C6 - C7). After that I'had no hangs or freezes for about two days. 

The big problem is that right now we could use all the power saving system of the cpu. I only got a limited speedstep, (8x and 35x) of course limited native speedstep is better than nothing but I think we had to work hard to archive a perfect speedstep like on old cpus, and two TURBO steps. Other than that our DSDT is full of Errors and Warnings, so is very difficult to use a custom DSDT to fix things. My problem is that this is my first hack since SnowLeopard times and things has changed so much... 

 

 

PS: I suggest to use Clover instead of Chameleon because with clover iCloud, AppStore and Messages are working natively. 

Share this post


Link to post
Share on other sites

please help .

hello is the first time I post in this sorry foro.y it for help but no longer do ...

 

I had mac osx Lion on a PC with motherboard ga- G41MT- s2p and processing intel core2 duo E5700 running perfectly other hardware was normal dvd player lg - lg blueray multicard reader with bluetooth and everything was fine except the audio hdmi .....

 

This month I decided to change the motherboard and processor for me what I had was a little short on presatciones ..... for what I use ........ so change the motherboard with a gigabyte ga- z87x - UD4H processor and I put a intel i7 4770k ...... from what I 've read around here has this combination of motherboard and processor, called Haswell on Mac ....

 

I downloaded the app store mavericks since I followed the steps in this guia...http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-mavericks/

 

I created the pendrive installation I have installed I have copied the mach_kernel , I have even tested with mach_kernet Haswell I installed the chameleon bootloader in on pendrive and the whole process of the added guide AppleIntelE1000e.kext ( for connecting lan plate ) added FakeSMC.kext , added GenericUSBXHCI.kext ,smbios from the extra folder chameleon have it set to imac 14.1, 14.2 Lga 1150 socket which is my. ok……

 

Reboot system from usb osx installation Mavericks, I erase the hard drive where you will have to go with plus installed osx osx format (journaled )

install os x Mavericks smoothly. I go back to boot from usb installation disk open terminal and run the following commands ....

cp -R / System / Library / Extensions / FakeSMC.kext / Volumes / ¨ name you have put the hard doctor where anger installed ¨ / System / Library / Extensions /

 

cp -R / System / Library / Extensions / GenericUSBXHCI.kext / Volumes / ¨ name you have put the hard doctor where anger installed ¨ / System / Library / Extensions /

 

cp -R / System/Library/Extensions/AppleIntelE1000e.kext / Volumes / ¨ name you have put the hard doctor where anger installed ¨ / System / Library / Extensions /

 

reboot

 

should restart and when restarting from usb installation but this vex select the hard disk where I installed the osx .... should boot but freezes on logo screen legacy of chameleon that is white with the gray apple in the middle and bottom turning points as if loading but does not load or shows me kernel panic errors , no nothing there remains fixed .... I tried with the kernel flags and nothing more of the same and have tried with - v and the only errors that are thrown me cpu 0x3c unknown or unsupported but gets through there and stopped trying to configure bluetooth or something I locolizar desconetcado the if that were the bluetooth , which gives me problems , but I am the same ........

 

just note that I'm not using GraphicCard ,uso la grafica incorporada en la placa que es intel HD 4600

 

and I have only installed one 2 pciexpress asus pce N10 Wireless-N PCI-E adapter and the other 

Parallel / serial card PCI-E 

I guess not the cause of which will not turn out as mode-v are recognized

 

 

anyone can guide me a bit about the pq not start os x???

 

Sorry for my English but I'm Spanish and I had to pull google translate what I meant ..

Share this post


Link to post
Share on other sites

 

please help .

hello is the first time I post in this sorry foro.y it for help but no longer do ...

 

I had mac osx Lion on a PC with motherboard ga- G41MT- s2p and processing intel core2 duo E5700 running perfectly other hardware was normal dvd player lg - lg blueray multicard reader with bluetooth and everything was fine except the audio hdmi .....

 

This month I decided to change the motherboard and processor for me what I had was a little short on presatciones ..... for what I use ........ so change the motherboard with a gigabyte ga- z87x - UD4H processor and I put a intel i7 4770k ...... from what I 've read around here has this combination of motherboard and processor, called Haswell on Mac ....

 

I downloaded the app store mavericks since I followed the steps in this guia...http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-mavericks/

 

I created the pendrive installation I have installed I have copied the mach_kernel , I have even tested with mach_kernet Haswell I installed the chameleon bootloader in on pendrive and the whole process of the added guide AppleIntelE1000e.kext ( for connecting lan plate ) added FakeSMC.kext , added GenericUSBXHCI.kext ,smbios from the extra folder chameleon have it set to imac 14.1, 14.2 Lga 1150 socket which is my. ok……

 

Reboot system from usb osx installation Mavericks, I erase the hard drive where you will have to go with plus installed osx osx format (journaled )

install os x Mavericks smoothly. I go back to boot from usb installation disk open terminal and run the following commands ....

cp -R / System / Library / Extensions / FakeSMC.kext / Volumes / ¨ name you have put the hard doctor where anger installed ¨ / System / Library / Extensions /

 

cp -R / System / Library / Extensions / GenericUSBXHCI.kext / Volumes / ¨ name you have put the hard doctor where anger installed ¨ / System / Library / Extensions /

 

cp -R / System/Library/Extensions/AppleIntelE1000e.kext / Volumes / ¨ name you have put the hard doctor where anger installed ¨ / System / Library / Extensions /

 

reboot

 

should restart and when restarting from usb installation but this vex select the hard disk where I installed the osx .... should boot but freezes on logo screen legacy of chameleon that is white with the gray apple in the middle and bottom turning points as if loading but does not load or shows me kernel panic errors , no nothing there remains fixed .... I tried with the kernel flags and nothing more of the same and have tried with - v and the only errors that are thrown me cpu 0x3c unknown or unsupported but gets through there and stopped trying to configure bluetooth or something I locolizar desconetcado the if that were the bluetooth , which gives me problems , but I am the same ........

 

just note that I'm not using GraphicCard ,uso la grafica incorporada en la placa que es intel HD 4600

 

and I have only installed one 2 pciexpress asus pce N10 Wireless-N PCI-E adapter and the other 

Parallel / serial card PCI-E 

I guess not the cause of which will not turn out as mode-v are recognized

 

 

anyone can guide me a bit about the pq not start os x???

 

Sorry for my English but I'm Spanish and I had to pull google translate what I meant ..

 

Solves the problem was I had to install chameleon the latest version ......

 

everything running 14.2 imac smbios Lga 1150 socket 
missing hdmi audio fix ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ITzTravelInTime
      Hi guys, this thread is to show you a new and open source app, created by me, that I called TINU:
       
      The name means: TINU Is Not #####, the U refers to a popular software that is used to create Mac OS hackintosh installers (that for good reasons is banned on this forum), but the aim of the name is to explain that this app is a totally different thing from that software and works in a totally different way.
       
      This app basically is a graphical interface for the createinstallmedia executable that is inside the Mac OS installer apps, it is capable to create a Mac OS installer on a drive completely vanilla like what you do using the command line method, and also this method is recommended by apple itself.
       
      Allows you to create easily a macOS install media without messing around with command line stuff and without using disk utility, all you need to do is use the app and then install clover on the usb drive once TINU has finished or leave it as is you want to use it on a Mac.
       
      Features:
        - Simple to use UI that allows you to easily start the macOS install media creation process   - It can work with every Mac OS installer app that has the createinstallmedia executable inside of it's resources folder (including also beta and newly released installers)   - You can use any drive or partition you want that can be erased and is at least 7 GB of size   - Works on Mac OS recovery, so you can create a macOS install media from a bootable macOS installer or from the macOs recovery   - All vanilla, the macOS install medias created with this tool are 100% vanilla, just like you created them using the command line "createinstallmedia" method   - Open source, you will know what this program does on your computer and also you can create your own version by downloading and playing with the source code   - Does not requires to do anything of special first, just open the program   - No need to go in disk utility first, TINU can format your drive for you   - Uses recent and more modern APIs and SDKs and Swift 3 language   - Transparent graphics style available (use alt + s on the keyboard or View->Use transparent style)   - Works using the latest versions of macOS and will also support newer Mac installers out of the box without needing for an update    Features that I'd like to add in the future:    - Advanced section, to customize your macOS install media   - Installer customization: Kernelcache/prelinkedknerel and boot files replacement (a feature that can be handy while dealing with old Macs or with beta installers when you need to mod or change the boot files some times)   - Install clover and configure clover   - Install kexts inside the kexts folder of clover   - Clover drivers customization   - Use custom dsdt in clover   - integrated pre-made clover config templates database from a remote and open repository   - Support for other languages, at least Italian   Rquirements:  - A computer that runs Mac OS X Yosemite or a more recent version (Mac OS X El Capitan is required to use TINU in a macOS recovery or installer)  - A drive or a free partition of at least 7 GB that you want to turn into a macOS/Mac OS X installer  - A copy of a macOS/Mac OS X installer app (Maveriks or newer versions are supported) in the /Applications folder or in the root of any storage drive in your machine (excepted the drive or volume you want to turn into your macOS install media)   Note that this app is under the GNU GPL v3 license so any reuse of the source code must follow the license's terms   TINU 1.1 Stable release:    - Download available here:    https://github.com/ITzTravelInTime/TINU/releases    - Source code:     https://github.com/ITzTravelInTime/TINU   TINU 2.0 pre-release:    - Source code:    https://github.com/ITzTravelInTime/TINU/tree/development    - Download available here:    https://dl.dropboxusercontent.com/s/nvzss51qcieynve/TINU.zip     Frequently asked questions about TINU: https://github.com/ITzTravelInTime/TINU/wiki/FAQs     NOTE: if you have problems with your USB installer of 10.13.4 or newer version not being detected by clover you have to use the latest clover and if it still does not detectets your usb installer you have to remove the invivible file called .IAPhysicalMedia located into the root of the usb installer. This issue is caused by a changement in the apple's createinstallmedia, don't blame TINU for that, tinu does only uses the installer creation method from apple, which has been changed, causing this problem for hackintosh users, this issue should be resolved in the latest versions of clover which will no longer require that you do changements to let your usb dive to be detected, a setting to do this fix automatically in tinu is also comeing in a new pre-release of TINU 2 I leave also some screenshots as well








    • By oliveiro
      Hi community !
      Is anybody successful with 10.13.x and multiple GPUs on a desktop hack ?
      My main rig (see in signature) HD4600 + GTX550Ti + GTX560 is working perfectly under 10.11.6 and 10.12.6.
      Very simple to install, Intel IGPU set to active and primary in bios, inject intel and igplatformid in bootloader (enoch or clover), no nividia injection, since Fermi GPUs are natively supported. Smbios set to iMac14.2 for my Haswell CPU, and to avoid AppleGraphicsDeviceControl devices unloading.
      But from 10.13.0 to 10.13.3, system boots fine until login screen where WindowServer crashes with a "no MTLDevice" error (MeTaL device I guess). I could workaround that error by unloading nvidia devices in AppleGraphicsDeviceControl, but that kind of defeats the purpose, since only the IntelHD4600 can then be used.
      10.13.4 brings a little improvement, desktop can be reached, all 3 gpus active (AppleDisplay instances appear in IORegistryExplorer for Intel and Nvidias) but only Intel HDMI output shows desktop correctly, both nvidias (HDMI or DVI output) only show a black desktop where the mouse pointer can be moved normally. Displays can be arranged, orientation and resolution can be changed, as if everything was fine, but it is not.
      Console shows the following repeated messages :
           WindowServer (Skylight) : Unable to composite display surface due to null compositor.
           WindowServer (CoreDisplay) : [ERROR] - Attempting to get capabilities from capabilities with no devices
      Does anybody have an idea on how to avoid or workaround these errors ?
      Thanks !
      O.
      Things I've tried:
      Bios Graphic Devices order changes (breaks everything unless IGPU is primary) nvidia injection in bootloader (fails in enoch, disables secondary nvidia GPU outputs in clover) Smbios changes and/or AppleDeviceControlPolicy plist edits (simply enables or disables nvidia outputs) nvidia official or web drivers (no changes at all, even though webdrivers are properly loaded ; requires nvram emulation with enoch) enoch or clover (no difference except clover boots a bit faster - than enoch with nvram - thanks to proper UEFI boot I guess) lilu intel and/or nvidia and/or coredisplay graphicsfixups (no visible changes but graphics devices names, and thus enables or disables AGPM) use binaries from Sierra 10.12.6 for CoreDisplay and/or Skylight frameworks (never reached desktop) NVIDIAeGPUSupport (no changes)
    • By ITzTravelInTime
      Questo è il thread in italiano dedicato alla mia app TINU, l'app open source che ho creato per creare chiavetta di installazione di mac utilizzando il metodo "createinstallmedia".
      Il nome è l'acronimo di TINU Is Not U (Per le regole del forum devo censurare, ma la U si riferisce ad un programma che piu o meno svolge lo stesso scopo che che per buoni motivi è bandito su questo sito, il punto del metterlo nel nome sta nel sottolineare che la mia app è totalmente divera)
      L'app è pensata per essere molto semplice ed immediata da usare (con un interfaccia grafica progettata con criteri e metodi usati in ambito professionale per lo sviluppo di applicazioni utente) e per essere molto solida e stabile che funziona sempre al primo colpo (a differenza di altri tool che conosciamo ...)
      A livello funzionale quest'app non è altro che un interfaccia grafica per il metodo da terminale "createinstallmedia" che viene sfrutatto dalla stessa per creare la chiavetta, quindi le chiavette create con TINU sono chiavette al 100% vanilla come se le aveste create dal terminale, a questo l' applicazione aggiunge funzioni utili come la formattazione automatica della chiavetta USB che si sceglie di usare in formato Mac OS Extended (journaled) (detto anche HFS+) con mapatura di partizione GUID.
      Tra gli altri vantaggi troviamo il fatto che permette di creare chiavette utilizzando qualunque applicazione di mac che contiene l'eseguibile "createinstallmedia" inclusi installer delle beta ed installer appena rilasciati, e non richiede di fare cose particolari prima come formattare la chiavetta e cambiare lingua al sistema e puo utilizzare applicazioni di mac che si trovano in vaie directory nel sistema e non solo quelle sche stanno in applicazioni ed hanno un nome specifico (nota che l'applicazione di installazione di mac deve essere quella interacche pesa diversi gb e non quella da pochi mb che l'app store puo scaricare alcune volte e che contiene tutto quello che serve per permettere a createinstallmedia di funzionare)
      l'applicazione è completamente aprta ed open source e trovate qui alcuni link utili:
       - Scarica l'app: https://github.com/ITzTravelInTime/TINU/releases
       - Repo github di TINU: https://github.com/ITzTravelInTime/TINU
       - FAQs (in inglese): https://github.com/ITzTravelInTime/TINU/wiki/FAQs
       - Thread in inglese su tinu (English thread about TINU): http://www.insanelymac.com/forum/topic/326959-tinu-the-macos-install-media-creation-tool-mac-app/
      Qui invece ci sono un paio di guide (Anche se l'app è molto facile da usare):
       - Piccola guida su come usare TINU per un hackintosh: https://www.youtube.com/watch?v=fZOZOUt2ErM
       - Piccola guida su come usare TINU per creare cheiavette per Mac "originali": https://www.youtube.com/watch?v=fZOZOUt2ErM
      Attualemente è in fase di sviluppo una nuova versione di questa app che verrà rilasciata a breve e che include diverse novità e migliorie importanti.
      Per chi se lo chiede, il supporto a clover in TINU è pianificato per una versione futura, anche se dei protipi a livvello codice per renderlo possibile, sono gia stati sperimentati con successo.
       
      Spero che anche voi del forum italiano aprezzerete questa app come gli utenti del forum inglese, per idee e suggerimenti, siete liberi di esprimervi :-)

    • By Angelo_
      HI, i've installed high sierra a while ago and never really used it that much but i got bored of w10 so i've decided to use it as my daily driver for a while and i noticed that usb 3.0 ports don't work with usb 3 devices and only with usb 2.0 devices(capped at the 480mb/s limit of usb 2.0), is there a way to get past that? i couldn't find it in this forum, i don't need the speed that much for right now(even tho i might since i shoot in raw and usb 2.0 is slow for file transfer of big photos or videos i take on holidays or on days off)  but i'd like to at least be able to use the usb 3.0s with my usb 3 devices and hub. 
      Hope that i write this post correctly, english is not my main language.
      ps  i don't need because i'm on lan but does it exist a driver/kext for intel wifi/bluetooth combo integrated in my z87 mpower(centrino 2200) ? bluetooth works already.
×