Jump to content
xpamamadeus

Ozmosis

5,985 posts in this topic

Recommended Posts

5.Yes.  Nvidia GTX 6xx,7xx series ATI 7xxx series and never,Intel HD 3000 and never.I am not sure if HD Graphics (HD 2000) have UEFI GOP.

Sometimes brands just dont release this to public and u have to ask them for this becouse there are many UEFI motherboards  that have really bad UEFI GOP support and are not updated frequently.

 

Hope it helps.

 

If u wanna flash your MSI GTX 650 then just go to their forum and search for bios by your PN of card.

If u cannot find then post request and u will get it in no time.

Clarification on buying a video card with UEFI GOP already present:

The onboard Intel graphics UEFI GOP firmware is (if present) included as part of the motherboard bios.

Note: only applies to some Z87 and Z77 chipset boards.

However: AFAIK, the latest standalone video cards do NOT include a UEFI GOP firmware.

Such as: a MSI GTX 760 card,

http://www.newegg.com/Product/Product.aspx?Item=N82E16814127745

Bios update for that card (must be signed in to their forum to view download link):

https://forum-en.msi.com/index.php?topic=172726.msg1257788#msg1257788

which, when sold as new, has only an empty "placeholder" spot for the UEFI GOP bios.

Note: I was able to find an update for my MSI GTX 650 card elsewhere on that same forum. The UEFI GOP bios update indicates that the UEFI portion of the video card bios was digitally signed by Microsoft. Maybe by leaving to the end user the job of bios flash updating, the card makers avoid paying Microsoft some kind of royalty fee?

Share this post


Link to post
Share on other sites
Advertisement

Clarification on buying a video card with UEFI GOP already present:

The onboard Intel graphics UEFI GOP firmware is (if present) included as part of the motherboard bios.

Note: only applies to some Z87 and Z77 chipset boards.

However: AFAIK, the latest standalone video cards do NOT include a UEFI GOP firmware.

Such as: a MSI GTX 760 card,

http://www.newegg.com/Product/Product.aspx?Item=N82E16814127745

Bios update for that card (must be signed in to their forum to view download link):

https://forum-en.msi.com/index.php?topic=172726.msg1257788#msg1257788

which, when sold as new, has only an empty "placeholder" spot for the UEFI GOP bios.

Note: I was able to find an update for my MSI GTX 650 card elsewhere on that same forum. The UEFI GOP bios update indicates that the UEFI portion of the video card bios was digitally signed by Microsoft. Maybe by leaving to the end user the job of bios flash updating, the card makers avoid paying Microsoft some kind of royalty fee?

My MSI GTX 660 TF3 originaly comes with uefi gop bios.

MSI have bios to remove UEFI GOP support for that card

http://www.msi.com/product/vga/N660-TF-2GD5-OC.html#/?div=BIOS

This bios is used to solve motherboard compatible issue. If your card is Hybrid bios and face this issue, please update your BIOS.

Not all comes with that..

I flash this bios about almost year ago and did not save original one ...

Later i get UEFI GOP again but from forum..

They dont include that on all cards becouse there are motherboards  like my last asus maximus iv extreme (p67)that wass having problems with UEFI GOP bios.

 

i sold that motherboard becouse of that and when i sold it out asus make a bios update that are solving that.

 

Soo i am sure some of manufacturers are leaving UEFI GOP bios to users to flash becouse of that kind of problems.Not becouse they pay microsoft..

Share this post


Link to post
Share on other sites
Great news for NVRAM not saving on new bioses!! 
As i promise  i will investigate nvram problems using gigabyte new bioses i found a way to fix this problem in new bioses.
 
We must doo 2 things.
First ist to find and delete nvramsmi module in bios.
Second its to find and replace runtime module in bios with one from old bios that work.
U will not find this modules with mmtool! We need to use phoenixtool for finding GUID of module and then we can delete/replace it using MMTOOL 
 
Good luck!
 
Plz report if u have sucess with this new mod :D
 
Now i am running latest F16 bios with working nvram.
 
Fu.k u gigabyte for screw us like that!!
 
here the file we need to replace for z77x ud5h users.
 
and GUID of nvramsmi that need to be deleted.
842A454A-75E5-408B-8B1C-36420E4E3F21

 

one small bug with this fix,flashing using qflash dont work after this mod!

but we can always flash from windows using @bios!

looking at quo bios runtime it seems that its almost identical to ud5h old working version,same lengt only a few bytes changed.

new version that not save nvram its smaller.

 

maybe some smart guy like coderush can investigate this problem and make patch for all gigabyte boards,maybe even asus..

Share this post


Link to post
Share on other sites

In trying to find a BIOS that has writable nvram can we take it that any BIOS with the 842A454A-75E5-408B-8B1C-36420E4E3F21 module is unable to write to nvram?

 

My P9X79 Pro can't write to nvram and is running the latest 4302 BIOS. I went looking back through previous updates and BIOS 3305 was the last one that didn't include this module. Would this mean that the runtime from 3305 is the last one that can write to nvram?

 

Update 1: Well, I tried to replace the Runtime file in 4302 with the one from 3305. Deleted the nvramsmi module and threw in Ozmosis while I was at it. Alas, the system powers up but there's no video. I guess the runtime is too old for this BIOS. I'll try flashing stock 3305 now and see if nvram writing works.

 

Update 2: Clover couldn't UEFI-boot my system for some reason after the 3305 BIOS downgrade. It took ages to load and then eventually hung at a blue screen with cursor. I'd removed the DSDT to avoid any clash but that didn't help. I then tried rolling Ozmosis into 3305 but got the same black screen on boot. I don't know if this is an Ozmosis issue or a general issue with editing CAP files but both times I flashed a modified BIOS it wouldn't post.

 

Update 3: I'm wondering if USB Flashback was even writing the modified files. With a stock BIOS the flash is now a 2-step process. Normal flash in EZ Flash and then on reboot a text screen comes up where it starts updating the BIOS. I wasn't getting this second screen with the modified files last night. Maybe it checks the BIOS first before actually updating it. This first appeared a couple of versions back and I guess it's stuck now as it even appeared when flashing 3305. Thanks Asus...

Share this post


Link to post
Share on other sites

In trying to find a BIOS that has writable nvram can we take it that any BIOS with the 842A454A-75E5-408B-8B1C-36420E4E3F21 module is unable to write to nvram?

 

My P9X79 Pro can't write to nvram and is running the latest 4302 BIOS. I went looking back through previous updates and BIOS 3305 was the last one that didn't include this module. Would this mean that the runtime from 3305 is the last one that can write to nvram?

 

Update 1: Well, I tried to replace the Runtime file in 4302 with the one from 3305. Deleted the nvramsmi module and threw in Ozmosis while I was at it. Alas, the system powers up but there's no video. I guess the runtime is too old for this BIOS. I'll try flashing stock 3305 now and see if nvram writing works.

 

Update 2: Clover couldn't UEFI-boot my system for some reason after the 3305 BIOS downgrade. It took ages to load and then eventually hung at a blue screen with cursor. I'd removed the DSDT to avoid any clash but that didn't help. I then tried rolling Ozmosis into 3305 but got the same black screen on boot. I don't know if this is an Ozmosis issue or a general issue with editing CAP files but both times I flashed a modified BIOS it wouldn't post.

 

Update 3: I'm wondering if USB Flashback was even writing the modified files. With a stock BIOS the flash is now a 2-step process. Normal flash in EZ Flash and then on reboot a text screen comes up where it starts updating the BIOS. I wasn't getting this second screen with the modified files last night. Maybe it checks the BIOS first before actually updating it. This first appeared a couple of versions back and I guess it's stuck now as it even appeared when flashing 3305. Thanks Asus...

Update 3 :D

I think that it must be 2 stage process only when u upgrade intel MEI or downgrade intel MEI

Share this post


Link to post
Share on other sites

Yeah that's possible. Still doesn't explain why both edited ROMS wouldn't post. The 3305 only had the Ozmosis files added.

 

I was looking through coderush's thread for clues. I assumed flashing with USB Flashback was still the way to bypass the security check, but maybe it isn't anymore?  USB Flashback is my only recovery method if things go bad. I don't have a SPI programmer so I'm gonna have to let the experts do the figuring out on this one.

Share this post


Link to post
Share on other sites

Yeah that's possible. Still doesn't explain why both edited ROMS wouldn't post. The 3305 only had the Ozmosis files added.

 

I was looking through coderush's thread for clues. I assumed flashing with USB Flashback was still the way to bypass the security check, but maybe it isn't anymore?  USB Flashback is my only recovery method if things go bad. I don't have a SPI programmer so I'm gonna have to let the experts do the figuring out on this one.

Did u try latest bios with only nvramsmi module deleted?

Without replacing runtime ?

Nothing more,clean bios no ozmosis nothing just for test how it works on asus whenn we delete nvram smi module ?

 

I take some time to see the diferences in working vs not working modules but nothing readable found :D

Share this post


Link to post
Share on other sites

I tried replacing the CsmVideo module with the Gigabyte one I'm using in the Z68. This time it posted fine so changing just that module didn't seem to break anything. However it isn't giving me full res on boot.

 

I'll try deleting the nvramsmi and see what happens.

Share this post


Link to post
Share on other sites

Ok with nvramsmi deleted the flash still worked. However Clover EFI wouldn't boot. I just got a blinking underscore. Chameleon also does the same.

 

Booting UEFI Clover from USB worked the first time, but it was loading EmuVariable. When I disabled EmuVariable it wouldn't boot again (hung at loading Extensions.mkext from cache). It's supposed to boot OS X just after this.

 

Curiously I seem to be having better luck with flashing modified roms today. I just tried 4302 with nvramsmi deleted and the runtime from 3305. Last night this didn't work, but it booted just now (no Ozmosis files this time). Alas, same story as before. Clover EFI won't boot and Clover UEFI won't boot without EmuVariable.

Share this post


Link to post
Share on other sites

Ok I finally managed to get Clover to UEFI boot on 3305. And I can confirm that nvram is writable.

 

However, I'm now getting TSC sync errors which are new. I guess the later BIOS versions took care of this. Explains why removing VoodooTSCSync seemed to have no ill effect.

 

Just tried flashing 3305 with Ozmosis and it's the old black screen/no post situation again. So it looks like Ozmosis is the reason my modified roms weren't booting last night.

 

Here's my MMTOOL report for 3305 with Oz 801M included.

Share this post


Link to post
Share on other sites

Is there any way that you guys might be able to help me.

 

Z87-DELUXE-DUAL-ASUS-1405.CAP.zip

 

I have a Z87 Asus board as you see. The saving nvram issue was supposedly confined to Z77 according to Asus but not true, as this board which is excellent even the o/b WiFi and Bluetooth works and Realtek o/b will work soon. Audio works now but distorts. But nvram is NOT saved without EmuVariableUefi-64.efi

 

Question - I am completely unable to delete the nvramsmi from the BIOS, would you XP or other expert here be prepared to have a go at removing it for me. There are four bios versions available ex Asus 1008/1205/1305/1405 but all are the same as far as saving Nvram is concerned. So I cannot provide a version which works. Interestedly it appears that the Gryphon board does save nvram.

 

Any thoughts ideas would be appreciated - Tks.

Share this post


Link to post
Share on other sites

Thanks for finding a BIOS version that has working NVRAM Riley!  

 

 

 

I don't know when I will have time for this again, but I will check on 3305 and see if I have a similar problem.

 

I inserted the modules that seemed to me to be responsible for making NVRAM work into my 4302 version, but it did not enable NVRAM.  I'll keep trying.

Share this post


Link to post
Share on other sites

i already did in PM..

U didnt get message or ?

https://www.dropbox.com/s/kxx8wsy4kez23kg/z77xud5h_mod4.f16.zip

 

Xpam, can you give me some hint in following

i'm using one of your's z77x-ud5h bioses with ozmosis (Z77XUD5HF14(no hda enabler).rom)

but having trouble with iMessages, it look's like there are no access to nvram? but i successfully changed spec to macmini6.2 (including 2 serials). and it keeps after reboot.

where is the issue?

 

second, i tried this bios https://www.dropbox.com/s/kxx8wsy4kez23kg/z77xud5h_mod4.f16.zip - and got a brick (well, suxessfully downgraded to f14)

i think, its because this bios requires efi from graphics card, but i have rather old one (gtx260)

tried to boot without this cart, with hd4000, tried to change legacy in CSM, then insert gtx260 back - no luck, stuck on AB code

i think that i need some modules, that you had injected for you custom firmware, but what?

Share this post


Link to post
Share on other sites

Xpam, can you give me some hint in following

i'm using one of your's z77x-ud5h bioses with ozmosis (Z77XUD5HF14(no hda enabler).rom)

but having trouble with iMessages, it look's like there are no access to nvram? but i successfully changed spec to macmini6.2 (including 2 serials). and it keeps after reboot.

where is the issue?

 

second, i tried this bios https://www.dropbox.com/s/kxx8wsy4kez23kg/z77xud5h_mod4.f16.zip - and got a brick (well, suxessfully downgraded to f14)

i think, its because this bios requires efi from graphics card, but i have rather old one (gtx260)

tried to boot without this cart, with hd4000, tried to change legacy in CSM, then insert gtx260 back - no luck, stuck on AB code

i think that i need some modules, that you had injected for you custom firmware, but what?

There are no deleted modules,but it seems that CSM does not work with this F16 becouse it has older runtime module.. ?

To solve imessage u need to set all smbios variables.

 

THX to stlvnub

#!/bin/bash
#SMBIOS
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BiosVersion=MM61.88Z.0106.B00.1208091121
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductName=Macmini6,2
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:SystemSerial=replace
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductFamily=Macmini
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductId=Mac-F65AE981FFA204ED
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BaseBoardSerial=Replace
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:SystemSKU=MD389LL/A
#OzmosisNVRAM
sudo nvram 7C436110-AB2A-4BBB-A880-FE41995C9F82:boot-args="-fakesmc-use-nvram"

#APPLE
sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=Replace e.g %90%90%9090%90
#4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB
sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:FirmwareFeatures=%C0%00%7F%FF
sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:FirmwareFeaturesMask=%C0%00%14%03 

#CODE
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BiosVersion
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BiosDate
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductName
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductFamily
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:SystemVersion
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:SystemSerial
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductId
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BoardVersion
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BaseBoardSerial
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:Manufacturer
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProcessorSerial
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:SystemSKU
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BaseBoardAssetTag
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ChassisAssetTag
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:CpuType
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:EnclosureType

#CODE
#4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM
#4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB
#4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:FirmwareFeatures
#4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:FirmwareFeaturesMask

just replace the "Replace"

For imessage most important to set

ROM=macadress of primary ethernet card

Share this post


Link to post
Share on other sites

@xpamamadeus:

Your last "z77xud5h_mod4.f16" bios gave no visible method to simply power the machine on and then successfully boot Windows 8 to desktop.

So, please: remember that the number one priority when offering any of your Ozmosis modded bioses for the Z77X-UD5H board: it must be able to boot any existing operating system without need of changing any bios settings (beyond the default bios settings: Intel SATA ports in AHCI mode, etc.).

That is: nothing required for a successful boot, beyond simply hitting the F12 key and selecting whichever hard drive to boot from, and be able to successfully boot: XP 32-bit, Windows 7, Windows 8.1, OSX Mountain Lion.

So: please keep at least that much flexibility inside whatever bios releases you're offering.

Or, at least: warn ahead of time: "this bios release requires XYZ bios configuration changes" in order to boot Windows at all.

Or: "this bios release only tested to work with a UEFI video card AND only with OSX Mountain Lion, and requires XYZ bios configuration changes (such as: disable CSM, or whatever) from default settings"; or "this bios only works with a GPT-formatted hard drive", etc.

Luckily, the Z77X-UD5H board has dual bios. But even with that, there could still be a possibility for certain unlucky sequences of events to occur, that would result in a bricked motherboard.

Share this post


Link to post
Share on other sites

How about you just do not flash what you do not know?

GB support web site your best friend...

He did not post it for every one..

Also you can even brick MB with official flash...

 

Share this post


Link to post
Share on other sites

How about you just do not flash what you do not know? GB support web site your best friend... He did not post it for every one.. Also you can even brick MB with official flash...

How can he know it if not flash? It's better to say "never flash hack os modded bioses".

Share this post


Link to post
Share on other sites

I used the F16 bios and it works good. The only problem is that I have to reinstall Windows 8 in UEFI mode, but I don't mind. Only thing is that my UEFI USB stick won't be recognized with this bios.

Share this post


Link to post
Share on other sites

Is there any way that you guys might be able to help me.

 

attachicon.gifZ87-DELUXE-DUAL-ASUS-1405.CAP.zip

 

I have a Z87 Asus board as you see. The saving nvram issue was supposedly confined to Z77 according to Asus but not true, as this board which is excellent even the o/b WiFi and Bluetooth works and Realtek o/b will work soon. Audio works now but distorts. But nvram is NOT saved without EmuVariableUefi-64.efi

 

Question - I am completely unable to delete the nvramsmi from the BIOS, would you XP or other expert here be prepared to have a go at removing it for me. There are four bios versions available ex Asus 1008/1205/1305/1405 but all are the same as far as saving Nvram is concerned. So I cannot provide a version which works. Interestedly it appears that the Gryphon board does save nvram.

 

Any thoughts ideas would be appreciated - Tks.

 

Hey tonydickinson,

 

I own a P8Z77-V LX and I downgraded from 2204 to 1603 ROM, now I can save the NVRAM settings. I found out where the settings are stored for my board:

 

000|               |CEF5B9A3-476D-497F-9FDC-E98143E0422C|00180048|01FFB8|RAW

 

That's my NVRAM firmware volume ; ) if you wan't to I can try to burn in your settings permanently but it would be a good idea

when you send me your smbios.plist settings, so our settings wouldn't overlap ; ) and I know

what's your machine settings that should be stored.

 

Btw. ASUS has no nvramsmi module, those seetings must be stored in any other module.

 

Even I'd like to know if you're able to flash a modified bios ??? ; ) then we know if a mod is worth the effort.

 

regardz

Share this post


Link to post
Share on other sites

There are no deleted modules,but it seems that CSM does not work with this F16 becouse it has older runtime module.. ?

To solve imessage u need to set all smbios variables.

 

THX to stlvnub

#!/bin/bash
#SMBIOS
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BiosVersion=MM61.88Z.0106.B00.1208091121
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductName=Macmini6,2
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:SystemSerial=replace
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductFamily=Macmini
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductId=Mac-F65AE981FFA204ED
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BaseBoardSerial=Replace
sudo nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:SystemSKU=MD389LL/A
#OzmosisNVRAM
sudo nvram 7C436110-AB2A-4BBB-A880-FE41995C9F82:boot-args="-fakesmc-use-nvram"

#APPLE
sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=Replace e.g %90%90%9090%90
#4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB
sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:FirmwareFeatures=%C0%00%7F%FF
sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:FirmwareFeaturesMask=%C0%00%14%03 

#CODE
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BiosVersion
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BiosDate
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductName
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductFamily
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:SystemVersion
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:SystemSerial
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProductId
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BoardVersion
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BaseBoardSerial
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:Manufacturer
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ProcessorSerial
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:SystemSKU
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:BaseBoardAssetTag
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:ChassisAssetTag
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:CpuType
#4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:EnclosureType

#CODE
#4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM
#4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB
#4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:FirmwareFeatures
#4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:FirmwareFeaturesMask

just replace the "Replace"

For imessage most important to set

ROM=macadress of primary ethernet card

 

Hello,

 

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%01%02%03%04%05%06

This value doesn't saved after reboot, all other are saved.

 

After reboot 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM became 0 !

 

what's wrong ? is-it same for all users ?

 

Fred

Share this post


Link to post
Share on other sites

Hello,

 

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%01%02%03%04%05%06

This value doesn't saved after reboot, all other are saved.

 

After reboot 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM became 0 !

 

what's wrong ? is-it same for all users ?

 

Fred

 

As I understood it should be somthing like sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=  your firewire mac adress

 

» explained here - thanks to ElNono_@tonymac

Share this post


Link to post
Share on other sites

As I understood it should be somthing like sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=  your firewire mac adress

 

» explained here - thanks to ElNono_@tonymac

I do that, but value isn't saved after reboot.

 

Fred

Share this post


Link to post
Share on other sites

I do that, but value isn't saved after reboot.

 

Fred

Did you even try nvram ROM=%01%02%03%04%05%06 < but that's not your real firewire mac adress, right?

 

However it should exactly look like that %01%02%0304%05, as read at tonymac the two middle values should be skipped!

Read twice: (firewire mac address with two middle bytes removed if present, otherwise ethernet mac address)

 

Paste a dump from DPCIManager / Misc section.

 

You can verify the settings with SMBIOS Parser after reboot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Slice
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
      What application in macOS can create SVG graphics?
      Inkscape is not working in macOS 10.11+. Pity.
      LibreOffice Draw works with SVG but buggy.
      Boxy SVG cost 10$ but looks good enough. It creates the best in simplicity files and have more then enough features.
      Illustrator is good but expensive.
       
      How to improve SVG file?
      Clover has restricted support for SVG. It is your job to make compatible file and as small as possible to speedup rendering.
      Some helps:
      Help:Inkscape – From invalid to valid SVG Inkscape files
      From invalid to valid SVG Adobe Illustrator files
      From invalid to valid SVG files of other editors: BKchem, ChemDraw and CorelDRAW
      Help:Illustrator – Assistance with creating and saving SVG images in Adobe Illustrator that will pass W3C validation
      User:Quibik/Cleaning up SVG files manually
      Later I will write own instructions specific to Clover abilities.
       
      How to create SVG fonts?
      You can google to find ready-to-use SVG fonts.  I found some problems with too beaty fonts: slow rendering and overflow crash. Be careful.
      You can get ttf or otf fonts and convert them into svg by using online WEB services. Not a problem to google.
      But then I want to find a way to simplify the font to reduce a size and speedup rendering.
      You can create own font by FontForge It is opensource and available for Windows, Mac and GNU+Linux. It creates otf font which you can convert to svg font.
       
       
    • By apianti
      Just so you all know I actually have done something. I have pushed the source to both my github and to sourceforge, please commit to the experimental branch and I will merge it into the stable branch once it is safe. Also, nothing meaningful happens yet so don't get too excited. Only the Visual studio build works right now. I haven't set up the Xcode or Makefile builds yet, I'm trying to do them now.
       
      https://github.com/apianti/Clover
      https://sourceforge.net/p/cloverefiboot/Clover
       
      IA32/X64/ARM/ARM64 testing ISO (6/7/2018): Clover-3.0-experimental.iso
    • By cvad
      Bootdisk Utility Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      BDU_v2.1.2018.023b.zip
      MakeCloverBDUReadyZip.bat.zip
      Enjoy...
       
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
      BDU_v2.1.2015.016b.zip
      BDU_v2.1.2015.018b.zip
      BDU_v2.1.2016.019b.zip
      BDU_v2.1.2016.020b.zip
      BDU_v2.1.2017.021b.zip
      BDU_v2.1.2017.022b.zip
    • By Subirats345
      Hi guys! I'm new on Hackintosh and I have a little problem (I think it's little). Yesterday I made my first hackintosh on a Xiaomi Notebook Air. All went well, but after an update (from High Sierra to 10.13.4) after the first reboot, in the bootloader doesn't appear nothing. I tried with the USB with Clover but I only can reinstall the entire system, I can not boot the system. It has a solution or I need to reinstall all again?

      Thanks a lot and sorry if the question is fool.

    • By ErmaC
      Slice is glad to present a new EFI bootloader.

      CLOVER
      Now version 2 rEFIt based.


      It is open source based on different projects: Chameleon, rEFIt, XNU, VirtualBox. The main is EDK2 latest revision.
      I also want to thank all who help Slice with the development. Credits and copyrights remain in the sources.
      https://sourceforge.net/projects/cloverefiboot/?source=directory
      There is a WIKI 
      http://clover-wiki.zetam.org/
      Main features:


      If you have a question please provide outputs from DarwinDumper (formed from Trauma tool). Thanks Trauma!
      Continued by blackosx and STLVNUB.
      Post#2 CloverGrower - create Clover by yourself Post#3 Downloads Post#4 Installation of the bootloader Post#5 How to do UEFI boot Post#6 How to use - common words Post#7 Calculator for Automatic DSDT fix Post#8 Instructions for GraphicsInjector Post#9 ATIConnector patching Post#10 Any kexts patching with some Samples Post#11 CustomEDID Post#12 Hiding unnecessary menu entries Post#13 Instruction for DSDT corrections to do DeviceInjection works Post#14 Development Post#15 Themes Post#16 About kexts injection Post#17 Instructions for P- and C-states generator Post#18 Patching DSDT to get Sleep working Post#19 CPU settings and geekbench Post#20 ACPI tables loading Post#21 DSDTmini Post#22 Custom SMBios Post#23 F.A.Q. Post#24 iCloudFix Post#25 Using mouse. Post#26 How to make orange icons to be metallic Post#27 How to make software RAID (by Magnifico) Post#28 How to modify InstallESD.dmg (by shiecldk) Post#29 Config.plist settings Post#30 Using extra kexts and skipping kernelcache Post#31 Choosing EFI drivers Post#32 Configuration files Post#33 Automatic config.plist creating Post#34 Custom DSDT patches Post#35 How to do sleep/wake working with UEFI BOOT Post#36 DeviceID substitution (FakeID) Post#37 Using Custom OS Icons Post#38 Hibernation Post#39 Floating regions Post#41 Property List Editor Post#42 Blocking Bad Kext Post#43 AAPL,slot-name Post#44 FakeCPUID for unsupported CPU Post#45 Multiple Boot Options - to write into UEFI BIOS boot menu Post#46 How to install Windows UEFI Post#47 How to speedup Clover boot Post#48 Info.plist patching Post#49 Arbitrary device injection Post#50 Non-Standard Legacy Boot Files Post#51 Reboot to Windows UEFI from Mac OSX Post#52 Deprecated Features Post#53 Using UDK2018 Post#54 Device Properties -----------------
       
      Slice:
      I edited all posts in the thread to correspond to actual Clover revision.
      Please install Clover at least 2652 and use new instructions.
×