Jump to content
xpamamadeus

Ozmosis

6,152 posts in this topic

Recommended Posts

On 8/14/2018 at 5:34 PM, taoarch said:

Hey,thx for reply!

Unfortunately,I tried,it's useless,forgot to tell u,there is apfsdriverloader in my rom,

and it can boot to 10.13.6 with apfs and almost everything works normal and smooth,

only boot to 10.14,can not turn on the HD4600,unless turn off it in bios settings!

I think it may not be caused by wx5100,

Do U use DSDT,SSDT or some kexts for HD4600?and what's ur ig-platformid?

Can u show these for me?

Thx!

 

ig-platform-id in OzmosisDefaults is:

Quote

		<key>AAPL,ig-platform-id</key>
		<integer>220332035</integer>

 

You can now use the WhateverGreen kext, if you can't boot to Mojave, and nothing magical here, in SSDT/DSDT, just use the HD4600 patch. But, if without the WX5100 card installed, it's a problem!

Share this post


Link to post
Share on other sites
Advertisement

China's d1ves has developed doz can be compatible with 1151, I already in B250, Z270, Z370 can work, at present in Asrock, Gigabyte, Asus run very well, but this doz firmware requires KEY.PO key authorization, Create Series.po file in Efi:/efi folder, brush into Doz firmware to start get Series.po, this file is authorization file, need to use SERIES.PO to convert Key.po, then put Efi:/efi, restart activation doz,Unfortunately, each PC motherboard must be a separate key, otherwise it will not work

212598558_2018-08-176_19_39.png.4d05087041d003a20c404bd7f1f06348.png1883934471_2018-08-176_20_29.thumb.png.bc374c425c24ccdfdfe1256f3b5caad3.png

key.po

series.po

Share this post


Link to post
Share on other sites

oh,it's archived,if you want to use it,sent your key to me with email or put here,i will give the key for you....

 

To be honest, compatibility is not very good, practicability is not very good, operability is not very good, personal entertainment works, difficult to ascend the hall of elegance.

 

good luck

 

:)

 

god bless you

Share this post


Link to post
Share on other sites

x_0 thats dangerous question. OpenOz is stand for OpenCore & Ozmosis (have tried OxCxOxZ, Ozopen, etc which is bad), assumed they are both had some identical keys to store the datas, and nothing more, for SEO things you know. If no, then nothing to be destroy with this app. Welcome back @STLVNUB (your nick is very hard to mention man).

Share this post


Link to post
Share on other sites
2 minutes ago, cecekpawon said:

Im badly mentioned you on the other thread @STLVNUB. I hope you enjoying much your Oz +  rEFInd (FindOz?) .. Greetz

I would enjoy it more if I could fix the kernelcache problem, what exactly did you change to get it to work? 

Share this post


Link to post
Share on other sites

Id like to help but cant with details, tired sorry. Latest workaround published by TypeThree is to disable Oz internal patches and use kernextpatcher with clover patch datas. If you know wheres the correct address to applying the patches, you may use kernextpatcher as a helper there, but seems you are trying to avoid it. Oz & Clover had some slightly different way to applying patches, but with same results.

Share this post


Link to post
Share on other sites

ozmosis xmax with kernel patches work for me with 10.13.6 on apfs

but 10.14 doesn't start

are this the correct patches?


 

    <key>Comment</key>
    <string>KbepMoja-EXT</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>6K8AAADrBeg=</data>
    <key>MatchOS</key>
    <string>10.14</string>
    <key>Replace</key>
    <data>6K8AAACQkOg=</data>



    <key>Comment</key>
    <string>KbepHSMoja-SIP</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>w0iF23RpSIsDSInf/1AoSA==</data>
    <key>MatchOS</key>
    <string>10.13,10.14</string>
    <key>Replace</key>
    <data>w0iF2+sSSIsDSInf/1AoSA==</data>

 

Share this post


Link to post
Share on other sites

Yes the values are right... I attached the original and necessary KernextPatcher.plist for you down below.

 

What happens when you try to start Mojave? Do you see a freezed Apple logo or does the system immediately restart? 

KernextPatcher.plist

Share this post


Link to post
Share on other sites

For me it works just normal... I can't say what the problem is and why Mojave refuses to boot for some people when iGPU and dedicated GPU are activated.

 

I had that problem in the beginning and the only way I could start Mojave with both GPUs, was when I had Mojave as the first boot priority, entered the BIOS and exited it again without saving (the behaviour doesn't make sence to me).

Then I reset my BIOS to defaults and ever since that day I can start Mojave completely normal with both GPUs activated.

 

Maybe somebody has a clue what this might be about...

Edited by TypeThree

Share this post


Link to post
Share on other sites

Hi

any way to stop Oz from injecting this device-properties?

 

<dict>
    <key>AFGLowPowerState</key>
    <data>AQAAAA==</data>
    <key>MaximumBootBeepVolume</key>
    <string>s</string>
    <key>PinConfigurations</key>
    <data>MEERAWARAQEQkYEBIJGgkEBAIQFQEUUB</data>
    <key>hda-gfx</key>
    <data>b25ib2FyZC0xAA==</data>
    <key>layout-id</key>
    <data>AgAAAA==</data>
    <key>platformFamily</key>
    <data>AA==</data>
</dict>

 

Share this post


Link to post
Share on other sites
16 hours ago, WinstonAce said:

Hi

any way to stop Oz from injecting this device-properties?

 


<dict>
    <key>AFGLowPowerState</key>
    <data>AQAAAA==</data>
    <key>MaximumBootBeepVolume</key>
    <string>s</string>
    <key>PinConfigurations</key>
    <data>MEERAWARAQEQkYEBIJGgkEBAIQFQEUUB</data>
    <key>hda-gfx</key>
    <data>b25ib2FyZC0xAA==</data>
    <key>layout-id</key>
    <data>AgAAAA==</data>
    <key>platformFamily</key>
    <data>AA==</data>
</dict>

 

Register these properties in DSDT

SSDT-1.aml.zip

Edited by korlione2009

Share this post


Link to post
Share on other sites
On 8/26/2018 at 5:50 AM, TypeThree said:

For me it works just normal... I can't say what the problem is and why Mojave refuses to boot for some people when iGPU and dedicated GPU are activated.

 

I had that problem in the beginning and the only way I could start Mojave with both GPUs, was when I had Mojave as the first boot priority, entered the BIOS and exited it again without saving (the behaviour doesn't make sence to me).

Then I reset my BIOS to defaults and ever since that day I can start Mojave completely normal with both GPUs activated.

 

Maybe somebody has a clue what this might be about...

This is a way to solve hd4600 which could not boot Mojave under HD4600,but not perfect for me!

First,I must set 32m&128m in bios settings.

Then,I must enter the BIOS and exit it without saving everytime.

Last,every boot or reboot,lt will panic with usb,I have patch in kernextpatcher,and in High Sierra,everything is ok!

I don't know why...

Edited by taoarch

Share this post


Link to post
Share on other sites
This is a way to solve hd4600 which could not boot Mojave under HD4600,but not perfect for me!
First,I must set 32m&128m in bios settings.
Then,I must enter the BIOS and exit it without saving everytime.
Last,every boot or reboot,lt will panic with usb,I have patch in kernextpatcher,and in High Sierra,everything is ok!
I don't know why...

I think a patch is needed here, to solve this problem. I did a request for it, on Mojave topic, but still no answer, especially when clover do the job, sadly Oz need that patch!


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
2 hours ago, ammoune78 said:


I think a patch is needed here, to solve this problem. I did a request for it, on Mojave topic, but still no answer, especially when clover do the job, sadly Oz need that patch!


Sent from my iPhone using Tapatalk

Can you show the topic for me? I can't find either!THX

Edited by taoarch

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

  • Similar Content

    • By Slice
      Since rev 4844 Vector Themes are supported and there are ready-to-use Clovy by Clovy, cesium by Slice and BGM_SVG by Blackosx.
      You may see it's structure to create own theme
      -------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
      What application in macOS can create SVG graphics?
      Inkscape is not working in macOS 10.11+. Pity.
      LibreOffice Draw works with SVG but buggy.
      Boxy SVG cost 10$ but looks good enough. It creates the best in simplicity files and have more then enough features.
      Illustrator is good but expensive.
       
      How to improve SVG file?
      Clover has restricted support for SVG. It is your job to make compatible file and as small as possible to speedup rendering.
      Some helps:
      Help:Inkscape – From invalid to valid SVG Inkscape files
      From invalid to valid SVG Adobe Illustrator files
      From invalid to valid SVG files of other editors: BKchem, ChemDraw and CorelDRAW
      Help:Illustrator – Assistance with creating and saving SVG images in Adobe Illustrator that will pass W3C validation
      User:Quibik/Cleaning up SVG files manually
      Later I will write own instructions specific to Clover abilities.
       
      How to create SVG fonts?
      You can google to find ready-to-use SVG fonts.  I found some problems with too beaty fonts: slow rendering and overflow crash. Be careful.
      You can get ttf or otf fonts and convert them into svg by using online WEB services. Not a problem to google.
      But then I want to find a way to simplify the font to reduce a size and speedup rendering.
      You can create own font by FontForge It is opensource and available for Windows, Mac and GNU+Linux. It creates otf font which you can convert to svg font.
       
      Pictures from Badruzeus
      https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=301597
    • By thomaspetersen
      Hi All
       
      I'm trying to start a Hackintosh High Sierra 10.13.5 installation:
      - MSI B350 PC Mate
      - Ryzen 5 - 2600
      - Radeon Pro 580 GPU
      - 4 x 8GB DDR4
      (Have a working clover bootloader for HS 10.13.3 - but for some reason, I can't use that setup with the 10.13.5) 
       
      Have tried different bootloader setup, with different outcomes...
      ATM. I get this error/hang - "Unknown CPU: family = 0x17, model = 0x8, Stepping = 0x2"
      Have search google, and can see that the threads ppl. are getting this, is when they look at "About this mac", I haven't yet installed the OSX.
       
      So can someone help...

      I'm running the newest Kexts: AppleALC, FakeSMC, Lilu, RealtekRTL8111, USBInjectAll and WhateverGreen.
      In Bootloader setup, i'm running: -v, -s, -f, -no_compat_check, busratio=34, PCIRootUID=1, npci=0x2000, dart=0 and nv_disable=1
      In SMBIOS i'm using the iMac18,2 and in RT i'm using BooterConfig: 0x28 and CsrActiveConfig: 0x67
      In installed drivers i'm using: AptioMemoryFix, EmuVariableUefi-64, OsxAptioFixDrv-64 (Have tried Fix2 as well)
       
      But i'm, keep getting the Unknown CPU hang/error, can someone help...
      Or do someone have a setup with the same CPU and GPU, that can show me his/her setup for Bootloader/Kexts...
    • By apianti
      Just so you all know I actually have done something. I have pushed the source to both my github and to sourceforge, please commit to the experimental branch and I will merge it into the stable branch once it is safe. Also, nothing meaningful happens yet so don't get too excited. Only the Visual studio build works right now. I haven't set up the Xcode or Makefile builds yet, I'm trying to do them now.
       
      https://github.com/apianti/Clover
      https://sourceforge.net/p/cloverefiboot/Clover
       
      IA32/X64/ARM/ARM64 testing ISO (6/7/2018): Clover-3.0-experimental.iso
    • By cvad
      Bootdisk Utility Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      BDU_v2.1.2018.023b.zip
      MakeCloverBDUReadyZip.bat.zip
      Enjoy...
       
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
      BDU_v2.1.2015.016b.zip
      BDU_v2.1.2015.018b.zip
      BDU_v2.1.2016.019b.zip
      BDU_v2.1.2016.020b.zip
      BDU_v2.1.2017.021b.zip
      BDU_v2.1.2017.022b.zip
×