Jump to content
xpamamadeus

Ozmosis

6,205 posts in this topic

Recommended Posts

@Aigors I guess you mean Pike´s post about APFS which he wrote on a pretty early beta stage of APFS Introduction am I right? As far as we know by now there is nothing special in Apple SSD Firmware about APFS at least not as Apple added Support for third Party NVME Vendors with HighSierra...

 

 

 

Right it has already been discussed but it has been discussed in a clover flavoured context and I guess we have to rethink about it in terms of OZ. If Apple is able to implement kind of a JumpStart driver into their ROM Images which takes care about loading and connecting APFS.EFI I guess it should be possible to do the same with OZ. Sure I am no Coder and do not understand the underlaying mechanisms but if it works for Macs why should it not work for us?

Share this post


Link to post
Share on other sites
Advertisement

@Aigors I guess you mean Pike´s post about APFS which he wrote on a pretty early beta stage of APFS Introduction am I right? As far as we know by now there is nothing special in Apple SSD Firmware about APFS at least not as Apple added Support for third Party NVME Vendors with HighSierra...

 

 

 

 

Right it has already been discussed but it has been discussed in a clover flavoured context and I guess we have to rethink about it in terms of OZ. If Apple is able to implement kind of a JumpStart driver into their ROM Images which takes care about loading and connecting APFS.EFI I guess it should be possible to do the same with OZ. Sure I am no Coder and do not understand the underlaying mechanisms but if it works for Macs why should it not work for us?

Griven, thank you: there's a bios from you on Hackintosh-forum.de for my board, GA Z97X UD3H. Do I have to assume that I'll be able to install High Sierra in APFS or not as per your questions about the implementation of this new file system in the Apple ROMs?

Share this post


Link to post
Share on other sites

The mentioned rom contains everything needed to install and run HighSierra :D

I asked about the implementaion of APFS because it´s not best or smartest way to just insert that heavy file into the Rom.

Share this post


Link to post
Share on other sites
Hi there,

 

Can someone help? I collected all files, but I have error in mmtool "error getting firmware information" (

Motherboard GA-H97M-D3H

"CORE_DXE" exported and compressed normally. But it does not load back(

I thought that there was not enough space, but no (

 

Help someone put ffs files in to the bios file.

 


 

Thank you!

Share this post


Link to post
Share on other sites

Tip: Use Uefitool.

 

Have this:

 

Snymok_ekrana_2017_09_30_v_10_59_00_DP.p

 

 

And I have no active buttons to "remove" and replace in the program (

 

Please help to assemble the firmware. Ideas are already over(

Share this post


Link to post
Share on other sites

@medallo

 

Replace SMC+Sensors, Ozmosis, OzmosisDefaults with current versions and add GM apfs.ffs.

 

 

In OzmosisDefaults:

 

Change FirmwareFeatures, FirmwareFeaturesMask, BiosVersion, BiosDate

 

 

Use KextToFfs to convert new OzmosisDefaults and apfs.efi to their ffs-versions:

 

Put OzmosisDefaults.plist in Ozm and apfs.efi in Efi.

 

 

attachicon.gifBildschirmfoto 2017-09-26 um 08.21.11.png

./KextToFfs.command

You will find the resulting ffs files in the Ffs folder.

 

 

Use MMTool and replace the files in the bios like this:

 

Load the bios file in MMTool and select the entry you want to replace, select the Replace tab and browse for the new file and hit replace.

 

 

attachicon.gifBildschirmfoto 2017-09-26 um 08.25.21.png

 

 

Save As different file ;) and flash it.

 

Where we can found current versions of SMC+sensors and Ozmosis?

Share this post


Link to post
Share on other sites

Here you go. The Archive contains following Files:

 

- OZ 1.03.167X-CPWN Release (the one patched for HighSierra)

- APFS.EFI patched for reduced verbose Output and taken from the Release Version of HighSierra

- FakeSMC and Sensors Rev 6.25-333 (SMC Version 2.22f16)

 

And the rest of the OZ Files taken from the XMAS Release. Be careful with the GPU Sensors they might trigger a Kernelpanik if used with a NVIDIA Pascal based GPU. The defaults in this package identify the Maschine as an iMAC14,1.

HighSierra.zip

Share this post


Link to post
Share on other sites

Here you go. The Archive contains following Files:

 

- OZ 1.03.167X-CPWN Release (the one patched for HighSierra)

- APFS.EFI patched for reduced verbose Output and taken from the Release Version of HighSierra

- FakeSMC and Sensors Rev 6.25-333 (SMC Version 2.22f16)

 

And the rest of the OZ Files taken from the XMAS Release. Be careful with the GPU Sensors they might trigger a Kernelpanik if used with a NVIDIA Pascal based GPU. The defaults in this package identify the Maschine as an iMAC14,1.

Hi Griven,

 

Could you make a Z87N-WIFI High Sierra ROM ?

 

Attached is your Modded ROM posted on hackintosh-forum forum that I use in my machine.

 

Thanks.

 

Regards.

Z87NWIFI-F6-Sierra.rom.zip

Share this post


Link to post
Share on other sites

Here you go. The Archive contains following Files:

 

- OZ 1.03.167X-CPWN Release (the one patched for HighSierra)

- APFS.EFI patched for reduced verbose Output and taken from the Release Version of HighSierra

- FakeSMC and Sensors Rev 6.25-333 (SMC Version 2.22f16)

 

And the rest of the OZ Files taken from the XMAS Release. Be careful with the GPU Sensors they might trigger a Kernelpanik if used with a NVIDIA Pascal based GPU. The defaults in this package identify the Maschine as an iMAC14,1.

Hi ..thanks griven.

but black screen and it doesn't advance.

:(

Share this post


Link to post
Share on other sites

The black screen is no OZ Issue at all. Please keep in mind that flashing a new Rom onto your board will reset all settings to factory default and in case you use a dedicated GPU you might end up with a black screen since the iGPU is reactivated and initialised as primary video output. Try to connect your screen to your iGPU instead of the dedicated one and you should be able to enter your bios setup utility and configure it properly (turn off igpu etc...)

 

@DoGuiTTo sorry but Z87N-Wifi has not enough available space to hold all necessary files so the time being there is no way to make this ROM HighSierra compatible.

Share this post


Link to post
Share on other sites

it is after setting the bios that it stays on the screen in black and does not advance.

My machine: Asus P8Z77-M, CPU:Core i5 3470, GPU EVGA Geforce 210 1024MM, SSD Kingston.

in Sierra  10.12 it works well.

Share this post


Link to post
Share on other sites

You can easily add an entry via efi shell and bcfg comand...

How does it work? Do you have tutorials or links?

Thanks

Share this post


Link to post
Share on other sites

The black screen is no OZ Issue at all. Please keep in mind that flashing a new Rom onto your board will reset all settings to factory default and in case you use a dedicated GPU you might end up with a black screen since the iGPU is reactivated and initialised as primary video output. Try to connect your screen to your iGPU instead of the dedicated one and you should be able to enter your bios setup utility and configure it properly (turn off igpu etc...)

 

@DoGuiTTo sorry but Z87N-Wifi has not enough available space to hold all necessary files so the time being there is no way to make this ROM HighSierra compatible.

 

Thanks Griven,

 

I managed replace the Osmosis.ffs patchedFakeSCM*.ffs plus the InjectorKext.ffs and DisablerKext.ffs  from your zip in the BIOS. 

 

Removed the OsmosisDefaults.ffs as I have it on /Oz

 

Is there a way to load APFS.efi and after that HighSierr, like if I put it on CLOVERx64drivers (or whatever it is called) ?

 

And HermitShellx64.efi (when needed)  ??

 

Thanks... Regards

Share this post


Link to post
Share on other sites

it is after setting the bios that it stays on the screen in black and does not advance.

My machine: Asus P8Z77-M, CPU:Core i5 3470, GPU EVGA Geforce 210 1024MM, SSD Kingston.

in Sierra  10.12 it works well.

or am I missing something to do?
or what causes this problem?

 

I'm stuck in this. thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By dgsga
      Can I propose a new subforum be created for the new OpenCorePkg OpenCore front end being created by vit9696 and others, it is a fantastic piece of work:
      https://github.com/acidanthera/OpenCorePkg
      Even at version 0.1 it runs my Mojave 10.14.4 setup very nearly flawlessly. It consists of a 10KB bootstrap BootX64.efi and a 200KB OpenCore.efi OS loader. All configuration is done using a very well documented config.plist 
       
       
    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
       
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
    • By ErmaC
      Slice is glad to present a new EFI bootloader.

      CLOVER
      Now version 2 rEFIt based.


      It is open source based on different projects: Chameleon, rEFIt, XNU, VirtualBox. The main is EDK2 latest revision.
      I also want to thank all who help Slice with the development. Credits and copyrights remain in the sources.
      https://sourceforge.net/projects/cloverefiboot/?source=directory
      There is a WIKI 
      http://clover-wiki.zetam.org/
      Main features:


      If you have a question please provide outputs from DarwinDumper (formed from Trauma tool). Thanks Trauma!
      Continued by blackosx and STLVNUB.
      Post#2 CloverGrower - create Clover by yourself Post#3 Downloads Post#4 Installation of the bootloader Post#5 How to do UEFI boot Post#6 How to use - common words Post#7 Calculator for Automatic DSDT fix Post#8 Instructions for GraphicsInjector Post#9 ATIConnector patching Post#10 Any kexts patching with some Samples Post#11 CustomEDID Post#12 Hiding unnecessary menu entries Post#13 Instruction for DSDT corrections to do DeviceInjection works Post#14 Development Post#15 Themes Post#16 About kexts injection Post#17 Instructions for P- and C-states generator Post#18 Patching DSDT to get Sleep working Post#19 CPU settings and geekbench Post#20 ACPI tables loading Post#21 DSDTmini Post#22 Custom SMBios Post#23 F.A.Q. Post#24 iCloudFix Post#25 Using mouse. Post#26 How to make orange icons to be metallic Post#27 How to make software RAID (by Magnifico) Post#28 How to modify InstallESD.dmg (by shiecldk) Post#29 Config.plist settings Post#30 Using extra kexts and skipping kernelcache Post#31 Choosing EFI drivers Post#32 Configuration files Post#33 Automatic config.plist creating Post#34 Custom DSDT patches Post#35 How to do sleep/wake working with UEFI BOOT Post#36 DeviceID substitution (FakeID) Post#37 Using Custom OS Icons Post#38 Hibernation Post#39 Floating regions Post#41 Property List Editor Post#42 Blocking Bad Kext Post#43 AAPL,slot-name Post#44 FakeCPUID for unsupported CPU Post#45 Multiple Boot Options - to write into UEFI BIOS boot menu Post#46 How to install Windows UEFI Post#47 How to speedup Clover boot Post#48 Info.plist patching Post#49 Arbitrary device injection Post#50 Non-Standard Legacy Boot Files Post#51 Reboot to Windows UEFI from Mac OSX Post#52 Deprecated Features Post#53 Using UDK2018 Post#54 Device Properties Post#55 Scalable themes Post#56 How to search Clover mistakes (bisection) -----------------
       
      Slice:
      I edited all posts in the thread to correspond to actual Clover revision.
      Please install Clover at least 2652 and use new instructions.
    • By Slice
      OK, 4988 released.
      Now, @vector sigma, what have we do to update translations?
×