Jump to content
xpamamadeus

Ozmosis

6,191 posts in this topic

Recommended Posts

didn't test it yet because still doesn't use shell as well  :blush:

Share this post


Link to post
Share on other sites
Advertisement

i'm same with you.ozmosis can boot but install faild

bcfg boot add 0 fs1:\System\Library\CoreServices\boot.efi NAME_DER_PARTITIOD

Didn't work, using the apfs2.ffs from cecekpawon did the trick.

If you think it's worth a try, I replace current pe32 image with apfs.efi

@craike ...

Thanks cecekpawon, with this one apfs2.ffs oz detect the APFS drives. You are the best!!!. :yes:

Share this post


Link to post
Share on other sites

I replace fakesmc, removed all the sensors because i have pascal gpu and got KP on Graphics sensors but now i can't get past Firmware verification error. Smbios iMac 14,2 with BIOS IM142.88Z.0118.B46.1705011513, FF 3909612855

and FFM 4280287039. Whay could I do next?

Installer Log 06-12-17.txt

Share this post


Link to post
Share on other sites

Load apfs.efi from shell also doenst work?

HEY BOSS,i chose to die,lol

post-1428044-0-72256300-1497255771_thumb.jpeg

just joke,i chose install by clover and boot by ozmosis

I replace fakesmc, removed all the sensors because i have pascal gpu and got KP on Graphics sensors but now i can't get past Firmware verification error. Smbios iMac 14,2 with BIOS IM142.88Z.0118.B46.1705011513, FF 3909612855

and FFM 4280287039. Whay could I do next?

opppps

 

Jun 12 07:47:53 iMac OSInstaller[570]: ROM Features failed to open IORegistryEntry!
Jun 12 07:47:53 iMac OSInstaller[570]: ROM does not support APFS
Jun 12 07:47:53 iMac storagekitd[571]: Bless of /System/Library/CoreServices failed with status 2

 

i see this blablabla many times,Especially this one "ROM does not support APFS"

 

you can use FF by 0x80001417, (hex imac15,1)  to fix "ROM Features failed to open IORegistryEntry!"

 

 

But it is of no damn use.

post-1428044-0-27864400-1497255720_thumb.jpg

Share this post


Link to post
Share on other sites

I had to remove GPUSensors from bios to avoid KP, i guess its due Pascal GPU inside the system.  Still not able to cleaninstall completely using Ozmosis, i receive ROM does not support APFS, firmwarecheck error.

Oz boots normally, it's automatically seen at Bootmanager as HighSierra 10.13 after flashing firmware with APFS.ffs inside it.

 

Screen_Shot_2017-06-12_at_16.52.55.png

Share this post


Link to post
Share on other sites

I juste want to notice that who have firmware error that didn't pass, should have to correct data of it's SMBios section on OzmosisDefaults! Until you get's OSInstal.Pkg blablabla is damaged then it's ok, until someone find the trick to pass this message because, when passed it, OS begin's the install process

Share this post


Link to post
Share on other sites

You can see the Firmware error in install.log

 

OSInstaller[599]: ROM Features failed to open IORegistryEntry!

 

Which means u don't have IODeviceTree:/rom@0 but something else.

Share this post


Link to post
Share on other sites

You can see the Firmware error in install.log

 

OSInstaller[599]: ROM Features failed to open IORegistryEntry!

 

Which means u don't have IODeviceTree:/rom@0 but something else.

I have rom@f0000

 

But i passed the firmware check error, this occurred one the first reboot, but when i chose to restart, after booting I have OSInstall.pkg damaged, this is my last station i'm still here!

 

 

i'm still stopped by this OSInstall.pkg!

Share this post


Link to post
Share on other sites

Got this far ...

677bd8fc74c521967608681515c46d8e.jpg

 

Good news is that I can select the APFS partition at boot.

Any idea what Firmware Features and Mask I need put into Defaults.plist.

QUO board SMBIOS iMac 13,2 (BIOS IM131.88Z.010A.B05.1210121459)

Share this post


Link to post
Share on other sites

Got this far ...

 

 

Good news is that I can select the APFS partition at boot.

Any idea what Firmware Features and Mask I need put into Defaults.plist.

QUO board SMBIOS iMac 13,2 (BIOS IM131.88Z.010A.B05.1210121459)

Try this and don't forget to update bios version and bios release date:

http://www.insanelymac.com/forum/topic/324194-pre-release-macos-high-sierra/page-9?do=findComment&comment=2436659

Share this post


Link to post
Share on other sites

HS working flawlessly in dualboot with Windows 10. Just make two HFS+ partitions by erasing disk using Paragon Hard disk Manager. Then Install HS and tick upgrade APFS, After that boot W10 UEFI and proceed with installation by formatting second HFS partition as NTFS. Install and Enjoy!

Share this post


Link to post
Share on other sites

till no go with 

 
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Version</key>
<string>1.0.1</string>
<key>Date</key>
<integer>0</integer>
<key>Defaults:4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102</key>
<dict>
<key>BiosDate</key>
<string>10/12/2012</string>
<key>BiosVersion</key>
<string>IM131.88Z.010A.B05.1210121459</string>
<key>ProductId</key>
<string>Mac-FC02E91DDD3FA6A4</string>
<key>ProductFamily</key>
<string>iMac</string>
<key>ProductName</key>
<string>iMac13,2</string>
<key>SystemSerial</key>
<string>C02LL669DNMP</string>
<key>BaseBoardSerial</key>
<string>C02LL669DNMP12345</string>
<key>FirmwareFeatures</key>
<integer>3909612855</integer>
<key>FirmwareFeaturesMask</key>
<integer>4280287039</integer>
</dict>
<key>Defaults:7C436110-AB2A-4BBB-A880-FE41995C9F82</key>
<dict>
<key>boot-args</key>
<string>-v nvda_drv=1</string>
<key>csr-active-config</key>
<integer>103</integer>
</dict>
<key>Defaults:1F8E0C02-58A9-4E34-AE22-2B63745FA101</key>
<dict>
                <key>DisableNvidiaInjection</key>
                <true/> 
<key>BootEntryTemplate</key>
<string>$label</string>
<key>DarwinDiskTemplate</key>
<string>$label $platform.$major.$minor</string>
<key>DarwinRecoveryDiskTemplate</key>
<string>$label $platform.$major.$minor</string>
</dict>
</dict>
</plist>
 
 
Jun 12 21:57:59 iMac OSInstaller[580]: ROM Features failed to open IORegistryEntry!
Jun 12 21:57:59 iMac OSInstaller[580]: ROM does not support APFS
Jun 12 21:57:59 iMac storagekitd[581]: Bless of /System/Library/CoreServices failed with status 2
Jun 12 21:57:59 iMac OSInstaller[580]: OSIInstallElement <OSIVerifyROMElement: 0x7fc0be02c630> errored out:Error Domain=com.apple.osinstall Code=512 "An error occurred while verifying firmware." UserInfo={NSLocalizedDescription=An error occurred while verifying firmware.}
 

Share this post


Link to post
Share on other sites

It seems like OZ does not inject the proper values to overcome this Issue...

 

I played around with it a couple of hours and never overcame the Firmware Check Error. I changed FakeSMC to SMC Version 2.22f16 and also made sure my Boot-Rom-Version matches the last know version but still no luck. Since Clover is able to inject prober Values I guess @bs0d is right since regardless of what you set in the defaults the error persists.

 

@cecekpawon blessing the APF Drive does the trick once blessed OZ picks it up and add a Bootentry :D

Share this post


Link to post
Share on other sites

After changing SMBIOS BIOS date to  05/01/2017 now i get this:

 

You still have to do this according to the IstallLog you've posted: I juste want to notice that who have firmware error that didn't pass, should have to correct data of it's SMBios section on OzmosisDefaults! Until you get's OSInstal.Pkg blablabla is damaged then it's ok, until someone find the trick to pass this message because, when passed it, OS begin's the install process

 

What king of Mac you're playing!

Share this post


Link to post
Share on other sites

 

till no go with 

 
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Version</key>
<string>1.0.1</string>
<key>Date</key>
<integer>0</integer>
<key>Defaults:4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102</key>
<dict>
<key>BiosDate</key>
<string>10/12/2012</string>
<key>BiosVersion</key>
<string>IM131.88Z.010A.B05.1210121459</string>
<key>ProductId</key>
<string>Mac-FC02E91DDD3FA6A4</string>
<key>ProductFamily</key>
<string>iMac</string>
<key>ProductName</key>
<string>iMac13,2</string>
<key>SystemSerial</key>
<string>C02LL669DNMP</string>
<key>BaseBoardSerial</key>
<string>C02LL669DNMP12345</string>
<key>FirmwareFeatures</key>
<integer>3909612855</integer>
<key>FirmwareFeaturesMask</key>
<integer>4280287039</integer>
</dict>
<key>Defaults:7C436110-AB2A-4BBB-A880-FE41995C9F82</key>
<dict>
<key>boot-args</key>
<string>-v nvda_drv=1</string>
<key>csr-active-config</key>
<integer>103</integer>
</dict>
<key>Defaults:1F8E0C02-58A9-4E34-AE22-2B63745FA101</key>
<dict>
                <key>DisableNvidiaInjection</key>
                <true/> 
<key>BootEntryTemplate</key>
<string>$label</string>
<key>DarwinDiskTemplate</key>
<string>$label $platform.$major.$minor</string>
<key>DarwinRecoveryDiskTemplate</key>
<string>$label $platform.$major.$minor</string>
</dict>
</dict>
</plist>
 
 
Jun 12 21:57:59 iMac OSInstaller[580]: ROM Features failed to open IORegistryEntry!
Jun 12 21:57:59 iMac OSInstaller[580]: ROM does not support APFS
Jun 12 21:57:59 iMac storagekitd[581]: Bless of /System/Library/CoreServices failed with status 2
Jun 12 21:57:59 iMac OSInstaller[580]: OSIInstallElement <OSIVerifyROMElement: 0x7fc0be02c630> errored out:Error Domain=com.apple.osinstall Code=512 "An error occurred while verifying firmware." UserInfo={NSLocalizedDescription=An error occurred while verifying firmware.}
 

 

Use it like this

 

<key>FirmwareFeatures</key>

<string>0xe907f537</string>

<key>FirmwareFeaturesMask</key>
<string>0xff1fff3f</string>
 
not as integer. Good luck :)
Edited by elviejo

Share this post


Link to post
Share on other sites

 

Use it like this

 

<key>FirmwareFeatures</key>

<string>0xe907f537</string>

<key>FirmwareFeaturesMask</key>
<string>0xff1fff3f</string>
 
not as integer. Good luck :)

 

 

did you passed the OSInstall.pkg error with this FF & FFM? Should it work with iMac15,1? Ozmosis read it as strings?  :whistle:

Share this post


Link to post
Share on other sites

did you passed the OSInstall.pkg error with this FF & FFM? Should it work with iMac15,1? Ozmosis read it as strings?  :whistle:

no bro,Ozmosis read it as strings/data/number,i test them all

 

But it is of no damn use.

post-1428044-0-27864400-1497255720_thumb

Share this post


Link to post
Share on other sites

I can't tell if it makes that big of a difference but FirmwareFeatures /-mask, Revision and so on should be integer and a hex value... You can see it if you extract the OzmosisDefaults.plist from untouched but Ozm modified UEFIs after new Ozm releases in the past. It's also stated here: http://www.insanelymac.com/forum/topic/291655-ozmosis/page-159?do=findComment&comment=2192157and here: http://www.insanelymac.com/forum/topic/291655-ozmosis/page-95?do=findComment&comment=2062449

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ErmaC
      Slice is glad to present a new EFI bootloader.

      CLOVER
      Now version 2 rEFIt based.


      It is open source based on different projects: Chameleon, rEFIt, XNU, VirtualBox. The main is EDK2 latest revision.
      I also want to thank all who help Slice with the development. Credits and copyrights remain in the sources.
      https://sourceforge.net/projects/cloverefiboot/?source=directory
      There is a WIKI 
      http://clover-wiki.zetam.org/
      Main features:


      If you have a question please provide outputs from DarwinDumper (formed from Trauma tool). Thanks Trauma!
      Continued by blackosx and STLVNUB.
      Post#2 CloverGrower - create Clover by yourself Post#3 Downloads Post#4 Installation of the bootloader Post#5 How to do UEFI boot Post#6 How to use - common words Post#7 Calculator for Automatic DSDT fix Post#8 Instructions for GraphicsInjector Post#9 ATIConnector patching Post#10 Any kexts patching with some Samples Post#11 CustomEDID Post#12 Hiding unnecessary menu entries Post#13 Instruction for DSDT corrections to do DeviceInjection works Post#14 Development Post#15 Themes Post#16 About kexts injection Post#17 Instructions for P- and C-states generator Post#18 Patching DSDT to get Sleep working Post#19 CPU settings and geekbench Post#20 ACPI tables loading Post#21 DSDTmini Post#22 Custom SMBios Post#23 F.A.Q. Post#24 iCloudFix Post#25 Using mouse. Post#26 How to make orange icons to be metallic Post#27 How to make software RAID (by Magnifico) Post#28 How to modify InstallESD.dmg (by shiecldk) Post#29 Config.plist settings Post#30 Using extra kexts and skipping kernelcache Post#31 Choosing EFI drivers Post#32 Configuration files Post#33 Automatic config.plist creating Post#34 Custom DSDT patches Post#35 How to do sleep/wake working with UEFI BOOT Post#36 DeviceID substitution (FakeID) Post#37 Using Custom OS Icons Post#38 Hibernation Post#39 Floating regions Post#41 Property List Editor Post#42 Blocking Bad Kext Post#43 AAPL,slot-name Post#44 FakeCPUID for unsupported CPU Post#45 Multiple Boot Options - to write into UEFI BIOS boot menu Post#46 How to install Windows UEFI Post#47 How to speedup Clover boot Post#48 Info.plist patching Post#49 Arbitrary device injection Post#50 Non-Standard Legacy Boot Files Post#51 Reboot to Windows UEFI from Mac OSX Post#52 Deprecated Features Post#53 Using UDK2018 Post#54 Device Properties Post#55 Scalable themes Post#56 How to search Clover mistakes (bisection) -----------------
       
      Slice:
      I edited all posts in the thread to correspond to actual Clover revision.
      Please install Clover at least 2652 and use new instructions.
    • By Slice
      OK, 4988 released.
      Now, @vector sigma, what have we do to update translations?
    • By vit9696
      OpenCorePkg / Documentation / Configuration Template / Bugtracker   Discussion and installation should be done in a separate thread! This thread is for development only!
      Current status as of April 2019: Support for UEFI and DuetPkg (legacy) booting APFS and HFS+ compatibility ACPI patcher (adding, dropping, binary patching, relocation) Apple-compatible bless implementation DeviceProperties injection DataHub and SMBIOS generation Symbolic kext and kernel patcher Direct kext injection/patching/blocking within prelinkedkernel Installation/Recovery/FileVault 2 support  Configuration in config.plist with open documentation Simple boot picker for quick launch Direct boot from dmg images  
      Known defects live here.  
      For those, who are not familiar with the history, OpenCore is a project initially born in HermitCrabs Lab that unfortunately almost died before its birth. This release is both a rebirth and a complete rewrite of OpenCore, which brings a number of new ideas, and tries to preserve the smart moves incorporated by iNDi and his team. Other than that, I wish to express my deepest words of gratitude to Acidanthera and WWHC members: your participation was and remains the key for project success, and you are simply the best.
×