Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
itsonlygeorge

1201n Keyboard/Mouse problems

5 posts in this topic

Recommended Posts

I've been running 10.6.4 on my 1201n without any problems for over a year and suddenly the trackpad and keyboard started acting up. The mouse would only work sporadically, sometimes it would come back after opening the Trackpad preference pane. I cannot get the trackpad to work at all. 

 

The keyboard only works after putting the computer to sleep. 

 

I have tried running the Kext utility and I have reinstalled OSX 10.6.4 and I still have the same problem. I don't know if it's a hardware problem with the trackpad being worn out or if there is something I can do to fix it, but I need some help! 

 

I followed the install guide up to 10.6.4 since I have had problems with stability on 10.6.8 after upgrading. I am using the 4 GB DSDT. 

 

 

Share this post


Link to post
Share on other sites

Well, i run 10.8.4 flawlessly on my OC'd 1201n. But i must confess i use a modded BIOS for AHCI support. No trackpad/keyboard issues. Follow this thread: http://www.insanelymac.com/forum/topic/264740-asus-1201n-installation-and-support/page-44

 

All the best!


P.S.: but i must warn you: it seems indeed to be a hardware issue, so perhaps it's not worthy of your effort. How old is your netbook?

Share this post


Link to post
Share on other sites

So I am looking at the ribbon cable for the track pad and the traces look rough and uneven like they were bunched up. I tried to flatten them but they look like they are a bit chewed up. I think that may be the root problem here. However, neither the left or right click buttons work either so I am worried that it is more serious. 

 

The keyboard seems to work intermittently, Sometimes it will work after boot, most times I have to put the computer to sleep first. I think it works in Safe mode without any sleep. 

 

It's a pretty old 1201n, revision 2.2 and I have had it for 2-3 years. I have upgraded the ram to 4 gb, installed an OCZ Vertex 2 SSD, and put in an Atheros Wifi card. The power adapter jack was loose at the beginning of the summer and I did reopen it to resolder the jack, and these problems started happening, first with the mouse, then with the keyboard as well. 

 

I am hoping that something is not fried or worn out... I really do like this little netbook and it has served me well. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×