Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Shvets Jan

Asus P5K. Pешение App Store "Произошла неопознанная ошибка" (AttansicL1Ethernet.kext)

2 posts in this topic

Recommended Posts

Может тема и "боян", но, думаю, на русском языке, понятным текстом - еще раз не помешает. Несколько дней шарил в интернетах кто и как решал эту проблему. В нашем случае (на P5K, с ML 10.8.4) все решается до идиотизма просто: необходимо добавить


первым ключом в org.chameleon.Boot.plist


Пошагово как я это делал:

  1. Удалил в "Системные настройки" -> "Сеть" все интерфейсы
  2. Удалил /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
  3. Добавил

    в org.chameleon.Boot.plist первым ключом, т.е. начинаться он должен так:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    	<...далее ваши ключи/значения...>
  4. Перезагрузка.

  5. В "Системные настройки" -> "Сеть" первым добавляем наш Ethernet интерфейс (настраиваем его, естесственно), после - уже все чем вы там пользуетесь.

  6. Перезагрузка.

  7. Логинимся в App Store вашим Apple ID

  8. Радуемся жизни.

В аттачах к посту - собственно сам виновник торжества AttansicL1Ethernet.kext в установщике (если до сих пор не завели сеть на вашем P5K хаке).


Всем лучей добра!


Share this post

Link to post
Share on other sites

Всему этому есть более современные аналоги/решения, но согласен, кому-нибудь и этот рецепт пригодится.

Нужно просто помнить, что LAN должен получиться en0, а WiFi - en1. Вот и весь айКлауд.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By BauerMac
      I have a bunch of issues installing High Sierra on my new build.
      As far as I can tell the biggest problem is getting the correct MacOs Installer. The ones I have tried either don´t show up in Clover (no Installer icon), or keep looping when booting.

      • I have tried downloading High Sierra via my (El Capitan) MacBook Pro - but App store won´t allow me to download more than the small 19 MB version.
      • I tried signing up to Apple´s Beta program, but no full version of High Sierra is available there either.
      • I have downloaded via some "macOS High Sierra Patcher.dmg" I found - but the installer was corrupt somehow.
      • I downloaded a .dmg file from another source - but that version seems to be completely wrong (says the Installer version is 13.0.63 (1363) but I can´t find any reference for that installer anywhere, so it´s probably fake or corrupted)
      Can anyone help me find a source of an ORIGINAL, working, FULL version of the High Sierra Installer?
      Or perhaps tell me a way to download the full version from App Store?
      Either 10.13.2 or just the first version; 10.13.0

      That would be a HUGE help!
      Thanks a lot in advance
    • By Cappen
      When I start my App Store nothing happens.. Its just gray. Tried to google my problem and looked att som YT videos but I cant find any answer. 
      I run Sierra High 10.13.1
      Tried to reboot computer but nothing new. Just wanted to say that to spare some time for some forum users..
      Regards Marcus

    • By IUTniun
      Download macOS Sierra Final from Mac App Store – Direct Link :  Download macOS Sierra 10.12 Final
      Link 2:           https://itunes.apple.com/us/app/macos-sierra/id1127487414?mt=12
      App store, sign in using your apple ID. (if you've already purchased )Mac OS  Sierra.
      Extract it to a folder, you'll get an executable file : "mas"
      Drag "mas" file to terminal window, then behind it type so it says like this: 
      <yourusername>$ /Users/@@@/Downloads/mas-cli/mas install 1127487414
      Will start downloading latest Sierra (10.12.6)
      just like  using app store.

    • By dadal75
      Come si procede quando app store propone un aggiornamento come da foto allegata?
      Come si procede quando esce una nuova versione di OSX per aggiornare tramite app store?
      Se le procedure sono simili per tutti ( ipotizzo procedura 1 per utenti clover, procedura 2 per utenti chameleon ecc..), si potrebbe creare una guida da inserire nella sezione apposita per futura memoria?
      Grazie a chi mi può aiutare!
      Risolto: è possibile eseguire tutti gli aggiornamenti dall'Apple Store ( Inclusi quelli sulla sicurezza, efi ecc..) tenendo presente che i kext eventualmente caricati in s/l/e vanno ripristinati prima del riavvio ( Fakesmc se non viene ripristinato caos il non riavvio del sistema ).
      Quindi, per chi ha clover
      sincerarsi di avere i kext nella eri/clover/kext/10.xx compreso fakesmc.kext ( non serve ripristinarli perché la partizione è nascosta al sistema e non montata quindi non modificabile )
      oppure nella directory S/L/E , dove serve ripristinarli dopo aggiornamento e prima del riavvio, riparando i permessi dell'intera cartella e ricostruendo la cache dei kext ( potete usare il Kextool.sh creato da me che trovate qui sotto in firma che fa tutto e due le cose in 2 click :-))

    • By OSX6
      So here I am, admitting to myself that I can't do this alone, posting on a forum for the first time. Hope someone can point me in the right direction. Ever since I upgraded to El Capitan (10.11) I have been plagued with this stage bug/glitch, in which every app downloaded form the App Store requires me to enter my Apple ID and Password to open said app on EVERY reboot. I'm usually greeted with this message when I try opening an app:
      "Insert app" was purchased using the App Store on another computer. To use "Insert app" on this computer, sign in using the Apple ID and password used to purchase it.

      Microsoft Office 2016, for example, doesn't remember my activation details and I have to re-enter them every time I reboot. I have had several hypotheses, NVRAM not saving (but iMessage works perfectly and values are retained), Broken Keychain (tried resetting it to no avail), etc.
      I also installed several OS X versions on my notebook to rule out possibilities. I found that none of the above happened on 10.9-10.10.5. But once I upgrade to 10.11 El Capitan, and the public beta of 10.12 Sierra, the same problem arises. So what could it be? New security features like rootless or something similar introduced since 10.11 and onward? Where could the problem be? It seems like every time I reboot it's a whole other computer. Seems like it since App Store apps and MS Office apps ask for activation.

      Im using Clover as my boot loader, r3642 to be precise. My notebook is an old Asus U50Vg, legacy BIOS.