Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
eranj

Please help me enable Intel HD 4600 QE/CI by editing DSDT

28 posts in this topic

Recommended Posts

Hi,

 

I got Gigabyte H87-D3H motherboard and Intel 4770K CPU.

I almost got everything to work, and I would like to fix the QE/CI on my Intel HD 4600.

So I extracted the DSDT, but I can't find where to put the code which will fix the HD 4600:

http://pikeralpha.wordpress.com/2013/06/16/intel-hd4600-with-full-resolution/

The code is where it says "Or, as an alternative, you add a _DSM method in the scope of Device (IGPU) in your DSDT/SSDT like so:"

I would also like to know how to configure DVI output and 128 MB of ram. I don't where and how to configure this:

http://pikeralpha.wordpress.com/2013/06/27/appleintelframebufferazul-kext/

 

I attached my DSDT.

Please help  :help:

chameleonwizard-dsdt.zip

Share this post


Link to post
Share on other sites

Hi,

 

I got Gigabyte H87-D3H motherboard and Intel 4770K CPU.

I almost got everything to work, and I would like to fix the QE/CI on my Intel HD 4600.

So I extracted the DSDT, but I can't find where to put the code which will fix the HD 4600:

http://pikeralpha.wordpress.com/2013/06/16/intel-hd4600-with-full-resolution/

The code is where it says "Or, as an alternative, you add a _DSM method in the scope of Device (IGPU) in your DSDT/SSDT like so:"

I would also like to know how to configure DVI output and 128 MB of ram. I don't where and how to configure this:

http://pikeralpha.wordpress.com/2013/06/27/appleintelframebufferazul-kext/

 

I attached my DSDT.

Please help  :help:

Which install method did you use? How did you extract your DSDT.aml?

 

Please put your complete hardware in your signature to get proper support. If you don´t do this, then try to help you is like a guess play.

 

Have fun.

Share this post


Link to post
Share on other sites

Try this......

Thank you very much!!! Will it work with any amount of RAM? I consider increasing the integrated graphics to 256/512 MB.

Which install method did you use? How did you extract your DSDT.aml?

 

Please put your complete hardware in your signature to get proper support. If you don´t do this, then try to help you is like a guess play.

 

Have fun.

I'll update with the all details soon. Thanks!

Share this post


Link to post
Share on other sites

Don't change the integrated memory. Leave it at 64mb. It has no effect and graphics performance. But will cause Kernel Panic if set wrong.

Share this post


Link to post
Share on other sites

You can try 32mb 64mb or 96mb. But there is no real advantage to doing so. I've had it all the way up to 1024mb in bios and it has absolutely no effect on performance. But remember at some point of increasing memory you WILL get a Kernel Panic on boot. Best advice I can give is leave at 64mb.  

Share this post


Link to post
Share on other sites

You can try 32mb 64mb or 96mb. But there is no real advantage to doing so. I've had it all the way up to 1024mb in bios and it has absolutely no effect on performance. But remember at some point of increasing memory you WILL get a Kernel Panic on boot. Best advice I can give is leave at 64mb.

I'll try and update. Thanks again.

Share this post


Link to post
Share on other sites
You can try 32mb 64mb or 96mb. But there is no real advantage to doing so. I've had it all the way up to 1024mb in bios and it has absolutely no effect on performance. But remember at some point of increasing memory you WILL get a Kernel Panic on boot. Best advice I can give is leave at 64mb.  
 I have a new question: If a game requires more than 64MB RAM, it won't work. right?

 

Which install method did you use? How did you extract your DSDT.aml? Please put your complete hardware in your signature to get proper support. If you don´t do this, then try to help you is like a guess play. Have fun.
I updated the info in my signature. thanks!

Share this post


Link to post
Share on other sites

Would you like to try this
Haven't tried it yet.

Edited by iFIRE
link to TMX86

Share this post


Link to post
Share on other sites

I Will try soon (tomorrow ) and post back

Thanks man. I'm not sure when I'll have the time to test it.

Share this post


Link to post
Share on other sites

Thanks man. I'm not sure when I'll have the time to test it.

 

i tried it with on intel4600

 

GraphicsEnabler=No    ==>  boot normal with shared 64 Mb  and no QE/CI.

GraphicsEnabler=Yes   ==>  hangs on bluetooth line.

 

IGPEnabler=No          ==> boot normal with shared 64 Mb  and no QE/CI.

IGPEnabler=Yes         ==> hangs on bluetooth line.

Share this post


Link to post
Share on other sites

i added 0x0c260000 in intelhd5000 kext, and my gpu is reconized but only 64MB.if set higher in bios then i get KP

Does QE/CI works in this method?

Share this post


Link to post
Share on other sites

@ eranj

 

You have forgotten or aware not told, which install method you have used, respectively which bootloader you use.

 

Have fun and no harm meant!

Share this post


Link to post
Share on other sites

@ eranj

 

You have forgotten or aware not told, which install method you have used, respectively which bootloader you use.

 

Have fun and no harm meant!

I had so much troubles with the installation (10.8 was not able to run on my Haswell build, even in VM, for the creation of the installation media... Now it has a solution) that I'm not sure which was last. It was myhack (it has a guide for mavericks on its website) or this http://www.insanelymac.com/forum/topic/289062-109-mavericks-simple-vanilla-hackintosh-install-guide/

 

Update: It was myhack

i tried it with on intel4600

 

GraphicsEnabler=No ==> boot normal with shared 64 Mb and no QE/CI.

GraphicsEnabler=Yes ==> hangs on bluetooth line.

 

IGPEnabler=No ==> boot normal with shared 64 Mb and no QE/CI.

IGPEnabler=Yes ==> hangs on bluetooth line.

You may try with Revoboot. I'm not sure how to do it: http://pikeralpha.wordpress.com/2013/06/16/intel-hd4600-with-full-resolution/

Share this post


Link to post
Share on other sites

I had so much troubles with the installation (10.8 was not able to run on my Haswell build, even in VM, for the creation of the installation media... Now it has a solution) that I'm not sure which was last. It was myhack (it has a guide for mavericks on its website) or this http://www.insanelymac.com/forum/topic/289062-109-mavericks-simple-vanilla-hackintosh-install-guide/

 

You may try with Revoboot. I'm not sure how to do it: http://pikeralpha.wordpress.com/2013/06/16/intel-hd4600-with-full-resolution/

 

 

yes me too i have no idea how to use revoboot .. i am trying to inject Device (IGPU) in SSDT but also i have no idea how lol :D

Share this post


Link to post
Share on other sites

friend igot mine wotking using latest chameleon it support haswell intel hd4600

http://www.insanelymac.com/_/osx86/intel-hd4000-and-haswell-inject-aaplig-platfor-r1005

 

with

GraphicsEnabler

Yes

IntelAzulFB

10

in org.chameleon.Boot.plist.

That's awesome, thanks! Is it possible to uae more than 96mb of RAM for the HD4600?? Let's say 128/256 MB (for games)

Share this post


Link to post
Share on other sites

That's awesome, thanks! Is it possible to uae more than 96mb of RAM for the HD4600?? Let's say 128/256 MB (for games)

The amount of video ram you indicate in the bios is only being used during boot. Once all the kexts are loaded, then the memory allocation will depend on:

 

1. Wrong kext = 32/64/96 or whatever you set in BIOS.

2. Partially compatible or fully working kexts/settings = I have seen my video Ram change from 512 to 768 (experimenting, no QE/CI for me too)

Share this post


Link to post
Share on other sites

friend igot mine wotking using latest chameleon it support haswell intel hd4600

http://www.insanelymac.com/_/osx86/intel-hd4000-and-haswell-inject-aaplig-platfor-r1005

 

with 

<key>GraphicsEnabler</key>

<string>Yes</string>

<key>IntelAzulFB</key>

<string>10</string>

in org.chameleon.Boot.plist.

 

Can I just copy paste in org.chameleon.Boot.plist.

Share this post


Link to post
Share on other sites

Can I just copy paste in org.chameleon.Boot.plist.

yes just add these in ur chameleon plist  and if doesn't work then change number 10 to between 1 ==> 15 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×