Jump to content

[FIXED] iMessages Problem ONLY! Need fix (Chameleon)


8 posts in this topic

Recommended Posts

Good evening ladies and gentlemen,


iCloud, FaceTime and AppStore works perfectly !
My problem is that iMessages not working.
I tested different solutions like delete Networking preferences and interfaces. Add my PlatformUUId into the nvram*.plist file.
I have the FileNVRAM in the module folder with the latest chameleon r2258.
Error message :
Your Apple ID "xxxxxxxxxx@gmail.com" can not be used to configure iMessage at the moment.
If it is a new Apple ID, there is no need to create another. To use this Apple ID with iMessage, contact the assistance of the iMessage app with the code below.
Client code: xxxx-xxxx-xxxx
This is the message original message in French : 
Votre identifiant Apple « xxxxxxxxxx@gmail.com » ne peut pas être utilisé pour configurer iMessage à l'heure actuelle.
S'il s'agit d'un nouvel identifiant Apple, il est inutile d'en créer un autre. Pour utiliser cet identifiant Apple avec iMessage, contactez l'assistance de l'app iMessage avec le code ci-dessous.
Code client : xxxx-xxxx-xxxx

Last information : My account work perfectly on my Macbook.


Waiting to hear from you I wish you happy holidays :)

Link to comment
Share on other sites

Hello there,


I had the same problem (iMessage won't activate and so you can't use it). To get rid of it I highly suggest you to use Chameleon Wizard and generating a random serial number in your smbios.plist file. This worked for me and since then I can use iMessage without any hassle.


Hope this works for you too.


Please note that after altering the smbios file a reboot is necessary to get into the new config.

Link to comment
Share on other sites

Hi MacFaulty and thank you for your reply,


Yes I used the Chameleon Wizard 4.2.2 and I have generated un new random serial number in my smbios 2 times now (and rebooting after each).

This not working for me.


I used the Mac Pro 4.1 in my smbios because the 4.1 hardware is similar to my hardware.

Link to comment
Share on other sites

Hi there,


Thanks for your kind reply.


It wouldn't succeed the first time on mine as well. I had to do it about 5 times and then it worked (had 5 different serials tried and then it worked). So I still suggest to try again a few times and if that doesn't work than reply back :)



Link to comment
Share on other sites

Ok and can you tell me if manufacturing site has an impact ? simply to improve my knowledge :)


My smbios :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
	<string>Apple Computer, Inc.</string>
	<string>Mac Pro</string>
	<string>Apple Computer, Inc.</string>

I go to continue changing serial until tonight   :angel_not:

Link to comment
Share on other sites


  • Create New...