Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
heyadrien

ML on HP Envy 4

43 posts in this topic

Recommended Posts

If I boot with cpus=1 -f -v I get the same text when you said a lot of errors.

 

If I add -x I get USBF...

Share this post


Link to post
Share on other sites

I feel like DSDT change nothing :/

 

I think I have to get back on Windows :(

 

No just what you said

Share this post


Link to post
Share on other sites

I think need some help from mnfesq. He has more experience with HPs.

 

Try one last time only with cpus=1 and USBBusFix=yes

Share this post


Link to post
Share on other sites

With CPUS=1 & USBBusFix=yes :

 

EBIOS read error : Device timeout

Block 0x44beb2 Sectors 0

Share this post


Link to post
Share on other sites

Ok, I'm out of ideas now. Install windows and keep a partition empty for experimenting with OS X.

Share this post


Link to post
Share on other sites

and sometimes I get that : 

 

https://www.dropbox.com/s/v5wynwv1idh56vy/Photo%2025-08-13%2022%2017%2012.jpg

 

For installing Windows, how I do ? Because the HDD is in Mac OS Extended. 

 

 

Do you have FakeSMC on the USB drive?

 

As for installing Windows, delete all partitions using the Windows installer and re-create new ones.

Share this post


Link to post
Share on other sites

No, I don't have FakeSMC on the USB.

 

Okay thank you, I will re-install Windows.

Share this post


Link to post
Share on other sites

You *must* have it on the USB!!

Unless it was installed with the system (as part of a custom installer) 

 

Edit: You're using original image so you must add fakesmc to the /Extra/Extensions on the USB.

Share this post


Link to post
Share on other sites

Finally! I installed Mountain Lion with Niresh and it works! 

 

Working : 

 

Intel Graphics 4000 (full QE/CI)

Trackpad

Sound

USB

...

 

Not working :

 

WiFi 

Brightness adjustment

Share this post


Link to post
Share on other sites

Hey Guys,

Well done to Adrien on the completion of the hackintosh

 

I see Dr. Hurt you seem to have alot of knowlege here, i have the same laptop i believe, HP Envy 4-1050ca 8gig ram and have been geeting so far as the install and boot screen to setup language etc finish off installation, but could only boot up in -x safemode, now i seem to have fallen back a few steps to trying to get back to booting after i have actually installed.

 

Could you help?

 

Both ssd 32gig and 500gig are formatted to hfs+ tried on both to install and have been succesfull on the 500gig boot but would like the ssd to boot prefable if it is faster?

 

Any help would be great!

 

Cheers

Share this post


Link to post
Share on other sites

i actually have it working, have to boot verbose through chameleon wizard each time, 2 questions: how do i get wifi working with the original card inside if possible? and hdmi out works on 720p but how do i get audio to work, it shows in audio prefs but doesnt work, cheers!

Share this post


Link to post
Share on other sites

Actually i am having some problems booting, can anyone help here i have to boot -x everytime? i could do with knowing what kexts i should really have. thank you in advance

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×