Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Cannot boot without NullCPUPowerManagement with first-gen i3 notebook!

3 posts in this topic

Recommended Posts



So i installed 10.8.4 on this Dell Inspiron n4030 with a first-gen core i3 CPU, thinking it would be a piece of cake except for the graphics. Well, in the end get the graphics running was rather easy, but the supposedly easy part, enabling native power management, it's being a pain.


Tried with a MacBookPro 6,1 definition, since these computers did use the first generation core i CPU, but no dice. Always getting a kernel panic very early on the boot. I haven't done many troubleshooting steps besides toggle SpeedStep off and on in the BIOS, since Google searches didn't return many similar cases to mine.


Any help will be much appreciated! Here's my DarwinDumper report: DarwinDumper_2.4.9_Chameleon_2.2_ML_1084.zip


All the best!

Share this post

Link to post
Share on other sites

Hi again!


Found a couple of other annoying issues in this otherwise very good experience with running 10.8.4 on this machine: 


   - The trackpad won't function with any kext i tried but latest RehabMan's branch VoodooPS2, but even using this drive the user experience is far from optimal: it's recognized as a generic mouse and won't let me do basic functions like drag a window (or file within Finder, for that matter) and sometimes will take lot of successive clicks to open a folder;


   - After waking from sleep - which is working with the SleepEnablerUniversal.kext - the backlit from the screen won't turn on, rendering the system unusable unless i reboot it - luckily when i press once the power button and then hit enter, the system shuts down by itself, not needing a hard reset.


Well, that's it. Still researching solutions.


All the best!

Share this post

Link to post
Share on other sites

Another update: AICPM and trackpad issues solved! A fellow user called qwerty12 (thank you!) reminded me of something i was overlooking: the Inspiron laptops have ALPS trackpads, not Synaptics. So i started looking for a compatible VoodooPS2 kext (qwerty12 pointed me to one that unfortunately didn't work) and i finally came across this one which did the trick: http://forum.osxlatitude.com/index.php?/topic/2545-new-touchpad-driver-for-e6520-alps/


To boot without NCPM, i used a patched AICPM kext meant for SB UEFI boards with locked MSR (don't remember from where i downloaded the kext though) and somehow it solved the KP. On the other hand, it finished breaking sleep (it was sleeping fine before, but giving me no backlight on wake, so it's not exactly a change of status, i guess).


Now i have fully working multitouch (two fingered) touchpad and (sorta) working PM. Now, to solve sleep and wake.


All the best!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.