Jump to content
gygabyte666

HP Envy 17t-j000 Quad (Haswell) + 10.8.5/10.9.5/10.10.x/10.11.x/10.12.x/10.13.x/10.14.x

1,321 posts in this topic

Recommended Posts

OK, let's start with the easiest first - audio.  Here is a voodoohda.kext that is modded to include our subwoofer as a separate audio device (I couldn't manage to combine it with the front speakers.)

 

VoodooHDA.kext.zip

 

In order to get both subwoofer and front speakers to play together, you need to create a multi-output device.  Use audio midi setup to do this. Make the volume ratio about 3:2 with front speakers louder than subwoofer. In other words, if front speaker volume is 100%, make subwoofer volume about 66%.

 

Once you have the multi-output device enabled for all purposes, you will lose the volume control (that happens on real macs as well).  I use a free app called PTHVolume.  To get this to load at boot up, go into the prefpane and copy the actual app to login items in system preferences.

 

I have a custom SSDT and you should make one yourself.  I used MaciASL to extract the SSDT.  But that did not give me full speedstepping without the correct smbios.plist.  What worked for me was MacBookPro8,3.  That may or may not be the best for you.

 

As for wifi, I don't believe you should use a combo card, particularly if you dual boot with windows. The Envy has separate slots for wifi and bluetooth.  Separate cards seem to work best, although I did try a combo card.  The biggest problem with the combo card is that the firmware for bluetooth did not load well.  There may have been progress with the kext that I used but I chose to go with a hardware fix because this is all such low-cost hardware.  For wifi, I use the Atheros 9285 pci-e half-mini card.  My bluetooth is the Broadcom 2070, also a pci-e half-mini card.

 

As for your GPU, you DON'T need a separate SSDT for it.  Since you are using Chameleon, do you have the right efi-injection?  Here's what I used to use when I ran Chameleon:

 

 

<key>device-properties</key>

<string>8800000001000000010000007c0000000200000002010c00d041030a000000000101060000027fff0400100000006d006f00640065006c0000001a000000496e74656c20484420477261706869637320343030302c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000004006601</string>

 

That's enough for now.  Let me know if you made any progress.

Share this post


Link to post
Share on other sites
Advertisement

Thanks for the kext but sadly it produced the same results I had with the latest VoodooHDA I tried. The audio is unbearable. It works yes but it stutters and crackles so much that it isn't even useful. As I mentioned before, I sort of have AppleHDA working and I think that's gonna be my best bet for an audio solution. Besides, the less 3rd party kexts I need to rely on, the better off i'll be. Just need to try out the codec/node patching soon.

 

Tried using MaciASL to regenerate a new SSDT but it doesn't seem to work for my hardware. It just kept giving me errors. :(

 

I'll have to snag my model's spec sheet from HP. They decided to give me my WiFi+Bluetooth on one pcie-half mini card, which sucked. I am not even sure I have another slot for a seperate bluetooth card. Hopefully I do, so I can just pickup both cards. Will have to look into this further later. Thanks for the suggestions for cards! I'll keep that in mind for when purchase time rolls around.

 

I figured using efi-injections were obsoleted by DSDT/SSDT patches by now for GPUs. Hmm, how did you extract yours? Obviously, yours won't work with mine since you have a 4000 and I have a 4600. Good to know though. If I can manage to extract that from mine and it works, I won't need to mess with my SSDTs.  :)

 

I plan to try out Clover again when I can. I also need to reinstall 10.8.5b for testing as well. Wish I had the time now but gotta go to work soon >_<

 

Thanks again! ^_^

Share this post


Link to post
Share on other sites

Audio - did you remove the AppleHDA.kext before installing the VoodooHDA.kext?  Did you create a multi-output device?  Was it made up of Speaker (analog) and Speaker (multi)?  The crackling may have to do with your CPU functioning properly. Does it?

 

Video - until you have Haswell support, you're going to lack video drivers.  

 

When I get a chance, I will post my Clover install options and config.plist.  I doubt it will work for you the same as for me because your hardware is so much newer than mine.  That's the price you pay for having the newest system on the block.

 

In the meantime, check this out:

 

http://www.insanelymac.com/forum/topic/290783-intel-hd-graphics-4600-haswell-working-displayport/?do=findComment&comment=1934467

Share this post


Link to post
Share on other sites

Yes, I removed AppleHDA before testing Voodoo. Doesn't make any difference if AppleHDA exists or not, it still acts the same way. It's not really a crackling either, more like a stutter, like it's skipping really badly. No options for me to create multi-output device. I had many inputs/outputs. I had Speaker (analog), Speaker (multi), HDMI, Headphones and 2 Mics. Since I have to rely on using NullCPUPM, I assume that my CPU doesn't function properly. All 8 threads are counted for but i'm pretty sure that's just because Chameleon's kernelpatcher is helping.

 

Yup! Believe me, I know. That's why I need to figure out a way to get 10.8.5b to act more stable. 10.8-10.8.4 are fine but since so much of my hardware relies on the drivers for 10.8.5b, the stability of it running with this machine is quite low.

 

Having your Clover setup as example might help. Maybe it just doesn't support my system yet, maybe my setup is way off, I just don't know. All I know is that Chameleon is the only thing working right now, which is why i've stuck with it. I'd much rather move to Clover though.

 

Thanks for the link! I've read through it before, but i'm gonna do it again and try to just add an IGPU section right into my DSDT. I'm sick of screwing around with my SSDTs and getting nowhere.

Share this post


Link to post
Share on other sites

I had many inputs/outputs. I had Speaker (analog), Speaker (multi), HDMI, Headphones and 2 Mics.

 

It appears that you may not have known how to create a multi-output device using Audio Midi Setup.  Here is a link to a tutorial:

 

http://www.sethwebster.com/2012/07/18/mac-osx-lion-output-sound-to-multiple-devices/

 

The two devices to include in the multi-output device is speaker (analog) and speaker (multi).  

 

As for stuttering, check out some of the options mentioned here:

 

http://olarila.com/forum/viewtopic.php?f=28&t=454

 

As for clover, here are the options I selected on installation:

 

post-270804-0-85253000-1377193745_thumb.png

 

And here is my config.plist:

 

config.plist.zip

 

My HP Envy did not allow me to install to EFI partition.  I installed Clover to my OS X partition using the Legacy method.

 

Let me know if you make any progress.

Share this post


Link to post
Share on other sites

Ok, I appreciate the info. I'll try it again soon and get back to you with any results. :)

 

On the same note, may I ask why you are relying on Voodoo for your audio? If you have similar hardware, you should be able to get AppleHDA working, which is typically much more stable and is official. As mentioned before, I already have that working, but something isn't configured right since my audio isn't producing sound. All my ports are detected though (minus HDMI audio) and I can adjust volume like a real Mac.

 

I checked that site before for troubleshooting the stuttering but I never found anything that helped fix it.

 

Hmm, when I find a bit more time i'll have to try out Clover again and try to incorporate some of the options you're using. It can't hurt. Thanks!

Share this post


Link to post
Share on other sites

I use Voodoo because it was easier for me to map the subwoofer.  I'm not a computer guru and it was really hard for me to learn how to generate the correct code to locate it.  Then, it was really easy to add it to the Info.plist.  I am certainly willing to learn to use Applehda.  In time, that may happen.

 

I'm thinking that until you have native power management, your may get audio stuttering.  Need to get rid of that NullCPUManagment.kext.  Try these kexts and see if it works instead:

 

Archive.zip

 

Keep at it.  If it was easy, it wouldn't be fun.

Share this post


Link to post
Share on other sites

Ok, i'm gonna make this quick because 1) my battery is dying and 2) it's late and I should be in bed. Just wanted to write down my experiment while it's fresh in my mind.

 

I went through the process again. Made sure AppleHDA was removed and reinstalled your VoodooHDA. Setup multi-output device and it went through just fine. Oddly enough, the volume slider still worked even after I had the multi-output enabled. Sadly, no change in terms of sound quality. To be sure, I tested out my USB audio card, which normally works great under OS X and sure enough, the stuttering persists using that as well. It's looking like it is my lack of CPU support afterall. That really sucks for now considering I have no method to fix it. All is not lost though because while I was using Voodoo, I used the official getdump tool to dump my audio information. I figure, even if the stuttering is there making the audio basically useless to me, it's still working audio and maybe the information from the dump will help me fix AppleHDA at a later date.

 

I also tried out your provided kexts from the archive above. Of course, I removed NullCPUPM before testing them out but it doesn't matter. It still threw a KP at CPUPM as expected. It's looking more and more like I really am going to have to wait until the 10.8.5 final is released. I'd be lying if I said I wasn't concerned about the changes (or possible lack thereof) that Apple makes to the final build. Hopefully, those changes will be in my favor.

 

Lastly, for kicks I made a post in the HD 4600 support thread here and got a few replies. Hopefully some good will come of that too. Time will tell I suppose. Post is here: http://www.insanelymac.com/forum/topic/290783-intel-hd-graphics-4600-haswell-working-displayport/?p=1940442

 

Ok, said what I needed to. Going to bed now. Assuming I don't sleep all day, perhaps there will be more testing fun tomorrow.

Share this post


Link to post
Share on other sites

Got it! Updated the first post to reflect this too but my audio is fixed!

 

I re-patched a clean AppleHDA using my codec dump info and all is well now. Audio works and most ports are correctly identified. The subwoofer and HDMI aren't currently detected and neither of them work but that's ok for now, they are both low priority fixes i'll look more into later or whenever I get around to it.

 

The stuttering still exists but the fact remains that I can actually hear audio playing now. So, I'm gonna classify the audio issue as solved and assume that the VoodooHDA kext is working properly as well since they both yield the same sound quality results.

 

I only have 2 high priority pieces left to fix and this system will be in good shape. My CPU and my GFX are all that's left before this system can really start being used. It's a good day! :)

Share this post


Link to post
Share on other sites

Guess what's working now...

 

4600HD_systprof_after.png

 

Thanks to Cobra03 for their support and for providing the needed DSDT values. First posted updated to reflect this change. ^_^

 

C'mon CPU support! That's the last piece of this system's puzzle.

Share this post


Link to post
Share on other sites

@gygabyte666

 

I see great progress. I guess it won't be long now. :) Btw, do you have any idea how to remove the hard drives in this laptop? Really wanna begin trying to get this up and running myself. Was scared as heck before. Anyway, great job!

Share this post


Link to post
Share on other sites

Hopefully not. Depends on what the 10.8.5 final looks like. CPU support could make or break this system.

 

Um...yeah, taking out the hard drive is just like any other computer. Unscrew the bottom and go to town. If you need more, the service manual will tell you everything you need and then some. Get it here: http://h10032.www1.hp.com/ctg/Manual/c03733756.pdf

 

Uh-huh. I see how it is. Waiting for me to get all the work done, so you can reap all the rewards? Shame on you. ;p

Share this post


Link to post
Share on other sites

Uh-huh. I see how it is. Waiting for me to get all the work done, so you can reap all the rewards? Shame on you. ;p

 

When it comes to OSx86, we are all leaders for some and followers for others.

Share this post


Link to post
Share on other sites

Hello, gygabyte!

 

I hope you haven't abandoned your efforts.  I also have a 15t-j000, and am willing to help you with your cause.

 

Here are the options I chose for my 15t:

i7-4700MQ

12 GB RAM

1920x1080 screen

Intel GPU + GeForce 740M

 

Thanks!

J

Share this post


Link to post
Share on other sites

I haven't given up yet. In fact, I updated the main page just last night.

 

Anyway, I have pretty much everything working with mine. Still have a lot of fine tuning to do though so it'll still be some time until I can call it complete.

Share this post


Link to post
Share on other sites

Appreciate the link mnfesq!

 

Rehabman's Voodoo kext is pretty nice. It's very similar to what I was already using, the only difference is mine was older and this combines what use to be 2 different kexts for me. Thanks again :)

Share this post


Link to post
Share on other sites

Heh, thank you! ^_^

 

It'd be pretty cool if it was true but honestly, I doubt it. IM has always had some talented people, and through the support i've recieved, i woukdn't be surprised if the title of first Haswell laptop went to someone else. I just might be the only one who documented success story. Still...it'd be pretty cool just the same. Lol

Share this post


Link to post
Share on other sites

Posted this on the first page already but i'll repost it here too. Hopefully, someone with the knowledge can see it and reply with good news for me. I mentioned this when I first started this thread, which feels like such a LONG time ago now. For those who weren't around, i'll recap:

 

Long story short, my wireless card will NEVER work with OS X. I always knew this. So, I swapped it out with one from my other machine. This was only intended to be a temporary solution until I got the system to the point where I felt like I should invest into a replacement. Anyway, that time has come and I need advice from those wiser than myself.

 

All that said, I didn't take into account the possibility of HP boning me by building my machine with only 1 half-mini card slot. So, there goes the idea to use 2 different cards (1 = wireless, 1 = bluetooth) and since my original card was a dual Bluetooth+Wireless card, I lost Bluetooth support since the switch. I'm aiming to get it back without wasting a USB port with a dongle. Can anyone kindly recommend me a new card? Obviously, I would much rather prefer this card to be a 2-in-1 Bluetooth+Wireless and it would be AWESOME if it was either natively supported, or only requires a simple DSDT edit to work with OS X. I hope one exists...Oh and please, no recommendations for a card you assume will work. It should be confirmed. I don't have the cash to waste on maybe cards. Keeping the price as cheap as possible is another MEGA plus. ;p

 

Thanks in advance! ^_^

Share this post


Link to post
Share on other sites

OK, I verified that you do only have one pci-e half mini card slot for wifi/bt.  I used one on my HP Envy 17t-3200 CTO but ultimately switched to separate cards for wifi and bt because that's how that laptop is designed.  The combo card that worked for me was the Atheros AR5B195 pci-e half mini card.  Here's a link for it on ebay:

 

http://www.ebay.com/itm/Atheros-AR5B195-AR3011-WiFi-WLAN-Bluetooth-Combo-Half-Mini-PCI-E-Card-PA3894U-/300959708175?pt=US_Internal_Network_Cards&hash=item461298b40f

 

The drawbacks I found were that it's only BT 3.0, not 4.0, the BT firmware does not load consistently (unless I boot into Windows first) and I get faster wifi transfer rates with my current Atheros wifi-only card (AR9258).  The plus is that it's sure to work.  

 

My understanding is that there has been advances to the BT kext for the AR5B195.  It used to break sleep.  I believe it is called IOath3kNull.kext.  

 

BTW - If you don't already have this, you might find it useful:

 

http://h10032.www1.hp.com/ctg/Manual/c03922401.pdf

Share this post


Link to post
Share on other sites

Thanks for the info mnfesq! I'll look into that card more when I can.

 

I think i'm gonna try to do some research into Broadcom cards too. I am currently using one and I know how they perform. Not to mention almost every Bluetooth supported with OS X uses some kind of Broadcom chip so I trust them enough to invest into. I just need to get some time to look into a 2-in-1 card and hope they offer one. Otherwise, you're suggest might be my best option. I'd like to have as little trouble with the new card as possible.

 

Excuse me if I am wrong since I didn't check out the PDF you linked to but i'm assuming the last link is for my model's service manual. If so, then yes I have already got it and looked at it extensively. They are a great source of information.

Share this post


Link to post
Share on other sites

Well, I had a decent lead on a Broadcom card but it fell through due to price. It was WAY too expensive. Back to square one. It's a shame too, I love BCM cards. I'm open to Atheros too though. Ralink is pretty much out of the question for me though, just due to the fact that many of them require separate drivers and their own utility at boot-time. If I have to I'll downgrade to using an older card (BT 3.0, etc) but I would really like to try to find something that works with BT 4.0 and 5Ghz Wifi would be fantastic. That's all optional perks though for me. If anyone has any thoughts, or suggestions please fill me in. ^_^

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tonyx86
      This guide is a work in progress and will be updated as I refine the installation.
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
       
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec SMBIOS MacModel MacMini 8,1 Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      Installation Steps: To be provided
      See attached EFI and /L/E kexts in EliteDesk.zip archive See installation methodology here See references here  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions
      (Solved and included in the attached EliteDesk.zip archive) Unable to upgrade from 10.15.4 to 10.15.5 when using IntelMausiEthernet.kext.  Solution is to switch to IntelMausi.kext (Rev 1.0.2 here). (Solved and included in the attached EliteDesk.zip archive) Some USB devices were not recognized. My SSDT-UIAC.aml was incomplete and did not specify all required USB port types (missing SSxx ports). The attached EliteDesk.zip archive includes this fix. (Reported this as a possible Clover issue - no solution yet) Clover boot loader may default to Recovery volume after a normal shutdown.  Work-around is to select your normal macOS volume.  This may only happen when Clover is configured to boot LastBootedVolume and may be "fixable" by explicitly setting a boot volume (haven't tested this). (No longer observed) At least one display blanks (sleeps) when plugging / unplugging USB device (observed in front USB 3.1 ports).  Display wakes immediately on keyboard and mouse activity, so this is a minor issue but may be indicative of another issue. (Solved - this is a BIOS setting and requires no macOS changes) Safari has problems loading insanelymac web pages after sleep / wake.  I suspect that the problem is with the embedded video on the pages.  Also observed video problem in AppStore after sleep/wake.  Console: VideoDecodersUnavailable.  Solution is to enable Intel ME in BIOS. (Solved and included in the attached EliteDesk.zip archive) Display does not fully wake after resuming from sleep (needs an extra mouse or keyboard stimulus to fully wake).  Solution is to change boot arg darkwake=0 to darkwake=2.  Other values of darkwake may work as well, but this is the first I tried and it worked. (Solved and included in the attached EliteDesk.zip archive) -disablegfxfirmware boot arg is not required with WEG.  I inadvertently left this boot arg after I encountered an endless gfx firmware update boot loop while working on my FB patching.  This boot arg is no longer necessary after completing FB patching with WEG. (Solved and included in the attached EliteDesk.zip archive): Sometimes, CMOS time is lost on shutdown or restart.  Solution is to enable Clover's Apple RTC fix in config.plist. (Solved and included in the attached EliteDesk.zip archive) headphone jack doesn't work.  Solution is to change HDEF layout-id to 28. (Solved and included in the attached EliteDesk.zip archive) System freezes on wake from sleep because of a kernel panic related to hda-gfx (my system does not have HDMI and my DP->DVI adapters do not drive monitor speakers).  Solution is to add No-hda-gfx property to HDEF as described here.  This property is recognized as a Lilu flag and prevents loading hda-gfx. (Solved and included in the attached EliteDesk.zip archive) Device (PMCR) is not defined.  Solution is a SSDT that "injects" the missing device. (Solved and included in the attached archive) eficheck is loaded (not sure why this is bad, but may be a privacy issue - see here). Solution is to add updated EFICheckDisabler kext that include Q370 chipset.  See here.  
      BIOS Version / Configuration: To be provided
      Version: 02.11.01 Rev.A Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration: To be provided
       
      UHD 630 Framebuffer Patching: To be provided
       
      Current Versions
      Catalina 10.15.4.02 Clover (UEFI) r5118 Lilu.kext 1.4.4 WhateverGreen.kext 1.3.9 AppleALC.kext 1.4.9 IntelMausi 1.0.2 (Not IntelMausiEthernet)  
      Credits To be provided
       
       




      EliteDesk800 G4 Mini - Rev 0.7.zip



    • By Donw35
      Catalina update 10.15.5 without issues, make sure you update your kexts before hand and clover 5118
      Catalina update 10.15.4 without issues, make sure you update your kexts before hand and clover 5107
      Catalina update 10.15.3 without issues, make sure you update your kexts before hand.
      Catalina update 10.15.2 without issues, make sure you update your kexts before hand.
      Catalina update 10.15.1 without issue although you may have to make sure clover boots from the right partition.
      HP 840 G2/G3, working with OS X 10.15 Catalina, for this to work you will need the SSDT-ECUSBX.aml and place that  EFI/CLOVER/ACPI/Patched. 
      Make sure you remove Remove all patches about renaming acpi of EC or H_EC, revert all ACPI renaming in ACPI DSDT.
       
      My method to install OS X on the SSD from a working real Mac via SSD to USB converter. I then install Clover and add my kexts and set the config.plist
       
      Not working
      SD Card reader
      Finger Print device
       
      Working
      Video - screen looks better in OS X then it does in Windows 10
      Display port
      VGA port
      WiFi and BlueTooth working OOO using the below hack
      Battery status with Rehabman's DSDT patch
      Brightness controls
      Sounds - using VoodooHDA
      * Microphone - cannot turn it off or mute
      Keyboard backlight - controlled though BIOS anyways
      touchpad - using VoodooPS2Controller
      USB3 - this laptop has two on board only and I haven't test them using the docking station
      USB3.1 C
      Ethernet - using IntelMausiEthernet
      Sleep - kind of, closing the lid doesn't go to sleep but goes to sleep over time.
      Web Cam, works but I covered it up.
       
       

       
      SSDT-ECUSBX.aml
      CLOVER.zip
      CLOVER_HP_840_G3_02032020.zip
    • By mavifree
      Sir 
      I am new in this, i try to make my hp laptop in hackintosh but i facing some error in clover boot manager while installing but unable to understand it. I really try hard but not able to get there, something i noticed that i facing same kind of error every time. I just watched youtube and visitied so forum like tonymac86, InsanelyMac, Noobsplanate and so on but nothing solved. So Please Please I Request All of You If you can help me to resolve my problem.
      Here Is my Laptop Specs:
      --------------------------------------------------------------------
      Laptop : HP cs2082tx
      Mobo : HP84C1
      Southbridge : Coffee Lake-U/Y PCH
      CPU : Intel Core i5 8265U @ 1.60GHz Kaby Lake- U/Y
      Ram : 8 Gb
      HDD : 256GB SSD & 1TB HDD
      Graphics : Intel UHD Graphic 620 with nvidia MX250
      ----------------------------------------------------------------------
       
      I even don't is my laptop is compatible or not, and don't have MacBook or Mac Desktop so if you can provide important driver and other stuff for installation. I really be very thankful to you.
      Please Reply me if any other information about my laptop hardware i will attached it i only have this info right now. 
       
      and i here attached my screenshot while installation error in clover.
      Sorry for my English.
       
      Please Help Me 
       



    • By josebv98
      So, ive trying to install various versions of macOSs to an old hp laptop.
      Specs: intel i7 3610qm, 8gb ram, nvidia 650m, intel HD4000
      model: hp dv6
       
      3 ago i did managed to install Niresh yosemite, even bought the right wifi adapter so i could use it on campus, but even then, i had to set cpus=1
       
      Now, ive tried several guides, tried internet vanilla install guide (which ive done successfully in 2 devices), opencore guide, opencore laptop guide
       
      Im currently having some financial problems, so i want sell my macbook to pay student loans, i really want to daily drive this laptop in mac os, but i cant get to boot the installer.
       
      Anyone here have a similiar laptop? so i could borrow the efi folder, just to get it to install, then ill change stuff
       
    • By e285ne
      Hello,
       
      could you help me with Intel UHD 620 HDMI port?
       
      HP ProBook G6 440
      Intel Core i5-8265u
      Catalina 10.15.4

      I've installed Catalina 10.15.4
      But I can't get HDMI working
      When I connect HDMI cable I got freezes and errors as in file freezes.png (attached)

      [IGFB][INFO ] Setting DP power failed (0xe00002bc), ignoring empty dongle handling (likely HDMI/TMDS case)

      I also looked into IOregistryExplorer and see that the connect type is 00400000 there for FB@1
      I tried to patch it via setup.plist but it seems that there is no change in IOregistryExplorer.
      Though the Hackintool sees the change (image attached)
      e285ne.zip
×