Jump to content
InsanelyMac Forum
gygabyte666

HP Envy 17t-j000 Quad (Haswell) + 10.8.5/10.9.5/10.10.x/10.11.x/10.12.x/10.13.x

Recommended Posts

OK, let's start with the easiest first - audio.  Here is a voodoohda.kext that is modded to include our subwoofer as a separate audio device (I couldn't manage to combine it with the front speakers.)

 

VoodooHDA.kext.zip

 

In order to get both subwoofer and front speakers to play together, you need to create a multi-output device.  Use audio midi setup to do this. Make the volume ratio about 3:2 with front speakers louder than subwoofer. In other words, if front speaker volume is 100%, make subwoofer volume about 66%.

 

Once you have the multi-output device enabled for all purposes, you will lose the volume control (that happens on real macs as well).  I use a free app called PTHVolume.  To get this to load at boot up, go into the prefpane and copy the actual app to login items in system preferences.

 

I have a custom SSDT and you should make one yourself.  I used MaciASL to extract the SSDT.  But that did not give me full speedstepping without the correct smbios.plist.  What worked for me was MacBookPro8,3.  That may or may not be the best for you.

 

As for wifi, I don't believe you should use a combo card, particularly if you dual boot with windows. The Envy has separate slots for wifi and bluetooth.  Separate cards seem to work best, although I did try a combo card.  The biggest problem with the combo card is that the firmware for bluetooth did not load well.  There may have been progress with the kext that I used but I chose to go with a hardware fix because this is all such low-cost hardware.  For wifi, I use the Atheros 9285 pci-e half-mini card.  My bluetooth is the Broadcom 2070, also a pci-e half-mini card.

 

As for your GPU, you DON'T need a separate SSDT for it.  Since you are using Chameleon, do you have the right efi-injection?  Here's what I used to use when I ran Chameleon:

 

 

<key>device-properties</key>

<string>8800000001000000010000007c0000000200000002010c00d041030a000000000101060000027fff0400100000006d006f00640065006c0000001a000000496e74656c20484420477261706869637320343030302c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000004006601</string>

 

That's enough for now.  Let me know if you made any progress.

Share this post


Link to post
Share on other sites
Advertisement

Thanks for the kext but sadly it produced the same results I had with the latest VoodooHDA I tried. The audio is unbearable. It works yes but it stutters and crackles so much that it isn't even useful. As I mentioned before, I sort of have AppleHDA working and I think that's gonna be my best bet for an audio solution. Besides, the less 3rd party kexts I need to rely on, the better off i'll be. Just need to try out the codec/node patching soon.

 

Tried using MaciASL to regenerate a new SSDT but it doesn't seem to work for my hardware. It just kept giving me errors. :(

 

I'll have to snag my model's spec sheet from HP. They decided to give me my WiFi+Bluetooth on one pcie-half mini card, which sucked. I am not even sure I have another slot for a seperate bluetooth card. Hopefully I do, so I can just pickup both cards. Will have to look into this further later. Thanks for the suggestions for cards! I'll keep that in mind for when purchase time rolls around.

 

I figured using efi-injections were obsoleted by DSDT/SSDT patches by now for GPUs. Hmm, how did you extract yours? Obviously, yours won't work with mine since you have a 4000 and I have a 4600. Good to know though. If I can manage to extract that from mine and it works, I won't need to mess with my SSDTs.  :)

 

I plan to try out Clover again when I can. I also need to reinstall 10.8.5b for testing as well. Wish I had the time now but gotta go to work soon >_<

 

Thanks again! ^_^

Share this post


Link to post
Share on other sites

Audio - did you remove the AppleHDA.kext before installing the VoodooHDA.kext?  Did you create a multi-output device?  Was it made up of Speaker (analog) and Speaker (multi)?  The crackling may have to do with your CPU functioning properly. Does it?

 

Video - until you have Haswell support, you're going to lack video drivers.  

 

When I get a chance, I will post my Clover install options and config.plist.  I doubt it will work for you the same as for me because your hardware is so much newer than mine.  That's the price you pay for having the newest system on the block.

 

In the meantime, check this out:

 

http://www.insanelymac.com/forum/topic/290783-intel-hd-graphics-4600-haswell-working-displayport/?do=findComment&comment=1934467

Share this post


Link to post
Share on other sites

Yes, I removed AppleHDA before testing Voodoo. Doesn't make any difference if AppleHDA exists or not, it still acts the same way. It's not really a crackling either, more like a stutter, like it's skipping really badly. No options for me to create multi-output device. I had many inputs/outputs. I had Speaker (analog), Speaker (multi), HDMI, Headphones and 2 Mics. Since I have to rely on using NullCPUPM, I assume that my CPU doesn't function properly. All 8 threads are counted for but i'm pretty sure that's just because Chameleon's kernelpatcher is helping.

 

Yup! Believe me, I know. That's why I need to figure out a way to get 10.8.5b to act more stable. 10.8-10.8.4 are fine but since so much of my hardware relies on the drivers for 10.8.5b, the stability of it running with this machine is quite low.

 

Having your Clover setup as example might help. Maybe it just doesn't support my system yet, maybe my setup is way off, I just don't know. All I know is that Chameleon is the only thing working right now, which is why i've stuck with it. I'd much rather move to Clover though.

 

Thanks for the link! I've read through it before, but i'm gonna do it again and try to just add an IGPU section right into my DSDT. I'm sick of screwing around with my SSDTs and getting nowhere.

Share this post


Link to post
Share on other sites

I had many inputs/outputs. I had Speaker (analog), Speaker (multi), HDMI, Headphones and 2 Mics.

 

It appears that you may not have known how to create a multi-output device using Audio Midi Setup.  Here is a link to a tutorial:

 

http://www.sethwebster.com/2012/07/18/mac-osx-lion-output-sound-to-multiple-devices/

 

The two devices to include in the multi-output device is speaker (analog) and speaker (multi).  

 

As for stuttering, check out some of the options mentioned here:

 

http://olarila.com/forum/viewtopic.php?f=28&t=454

 

As for clover, here are the options I selected on installation:

 

post-270804-0-85253000-1377193745_thumb.png

 

And here is my config.plist:

 

config.plist.zip

 

My HP Envy did not allow me to install to EFI partition.  I installed Clover to my OS X partition using the Legacy method.

 

Let me know if you make any progress.

Share this post


Link to post
Share on other sites

Ok, I appreciate the info. I'll try it again soon and get back to you with any results. :)

 

On the same note, may I ask why you are relying on Voodoo for your audio? If you have similar hardware, you should be able to get AppleHDA working, which is typically much more stable and is official. As mentioned before, I already have that working, but something isn't configured right since my audio isn't producing sound. All my ports are detected though (minus HDMI audio) and I can adjust volume like a real Mac.

 

I checked that site before for troubleshooting the stuttering but I never found anything that helped fix it.

 

Hmm, when I find a bit more time i'll have to try out Clover again and try to incorporate some of the options you're using. It can't hurt. Thanks!

Share this post


Link to post
Share on other sites

I use Voodoo because it was easier for me to map the subwoofer.  I'm not a computer guru and it was really hard for me to learn how to generate the correct code to locate it.  Then, it was really easy to add it to the Info.plist.  I am certainly willing to learn to use Applehda.  In time, that may happen.

 

I'm thinking that until you have native power management, your may get audio stuttering.  Need to get rid of that NullCPUManagment.kext.  Try these kexts and see if it works instead:

 

Archive.zip

 

Keep at it.  If it was easy, it wouldn't be fun.

Share this post


Link to post
Share on other sites

Ok, i'm gonna make this quick because 1) my battery is dying and 2) it's late and I should be in bed. Just wanted to write down my experiment while it's fresh in my mind.

 

I went through the process again. Made sure AppleHDA was removed and reinstalled your VoodooHDA. Setup multi-output device and it went through just fine. Oddly enough, the volume slider still worked even after I had the multi-output enabled. Sadly, no change in terms of sound quality. To be sure, I tested out my USB audio card, which normally works great under OS X and sure enough, the stuttering persists using that as well. It's looking like it is my lack of CPU support afterall. That really sucks for now considering I have no method to fix it. All is not lost though because while I was using Voodoo, I used the official getdump tool to dump my audio information. I figure, even if the stuttering is there making the audio basically useless to me, it's still working audio and maybe the information from the dump will help me fix AppleHDA at a later date.

 

I also tried out your provided kexts from the archive above. Of course, I removed NullCPUPM before testing them out but it doesn't matter. It still threw a KP at CPUPM as expected. It's looking more and more like I really am going to have to wait until the 10.8.5 final is released. I'd be lying if I said I wasn't concerned about the changes (or possible lack thereof) that Apple makes to the final build. Hopefully, those changes will be in my favor.

 

Lastly, for kicks I made a post in the HD 4600 support thread here and got a few replies. Hopefully some good will come of that too. Time will tell I suppose. Post is here: http://www.insanelymac.com/forum/topic/290783-intel-hd-graphics-4600-haswell-working-displayport/?p=1940442

 

Ok, said what I needed to. Going to bed now. Assuming I don't sleep all day, perhaps there will be more testing fun tomorrow.

Share this post


Link to post
Share on other sites

Got it! Updated the first post to reflect this too but my audio is fixed!

 

I re-patched a clean AppleHDA using my codec dump info and all is well now. Audio works and most ports are correctly identified. The subwoofer and HDMI aren't currently detected and neither of them work but that's ok for now, they are both low priority fixes i'll look more into later or whenever I get around to it.

 

The stuttering still exists but the fact remains that I can actually hear audio playing now. So, I'm gonna classify the audio issue as solved and assume that the VoodooHDA kext is working properly as well since they both yield the same sound quality results.

 

I only have 2 high priority pieces left to fix and this system will be in good shape. My CPU and my GFX are all that's left before this system can really start being used. It's a good day! :)

Share this post


Link to post
Share on other sites

Guess what's working now...

 

4600HD_systprof_after.png

 

Thanks to Cobra03 for their support and for providing the needed DSDT values. First posted updated to reflect this change. ^_^

 

C'mon CPU support! That's the last piece of this system's puzzle.

Share this post


Link to post
Share on other sites

@gygabyte666

 

I see great progress. I guess it won't be long now. :) Btw, do you have any idea how to remove the hard drives in this laptop? Really wanna begin trying to get this up and running myself. Was scared as heck before. Anyway, great job!

Share this post


Link to post
Share on other sites

Hopefully not. Depends on what the 10.8.5 final looks like. CPU support could make or break this system.

 

Um...yeah, taking out the hard drive is just like any other computer. Unscrew the bottom and go to town. If you need more, the service manual will tell you everything you need and then some. Get it here: http://h10032.www1.hp.com/ctg/Manual/c03733756.pdf

 

Uh-huh. I see how it is. Waiting for me to get all the work done, so you can reap all the rewards? Shame on you. ;p

Share this post


Link to post
Share on other sites

Uh-huh. I see how it is. Waiting for me to get all the work done, so you can reap all the rewards? Shame on you. ;p

 

When it comes to OSx86, we are all leaders for some and followers for others.

Share this post


Link to post
Share on other sites

Hello, gygabyte!

 

I hope you haven't abandoned your efforts.  I also have a 15t-j000, and am willing to help you with your cause.

 

Here are the options I chose for my 15t:

i7-4700MQ

12 GB RAM

1920x1080 screen

Intel GPU + GeForce 740M

 

Thanks!

J

Share this post


Link to post
Share on other sites

I haven't given up yet. In fact, I updated the main page just last night.

 

Anyway, I have pretty much everything working with mine. Still have a lot of fine tuning to do though so it'll still be some time until I can call it complete.

Share this post


Link to post
Share on other sites

Appreciate the link mnfesq!

 

Rehabman's Voodoo kext is pretty nice. It's very similar to what I was already using, the only difference is mine was older and this combines what use to be 2 different kexts for me. Thanks again :)

Share this post


Link to post
Share on other sites

Heh, thank you! ^_^

 

It'd be pretty cool if it was true but honestly, I doubt it. IM has always had some talented people, and through the support i've recieved, i woukdn't be surprised if the title of first Haswell laptop went to someone else. I just might be the only one who documented success story. Still...it'd be pretty cool just the same. Lol

Share this post


Link to post
Share on other sites

Posted this on the first page already but i'll repost it here too. Hopefully, someone with the knowledge can see it and reply with good news for me. I mentioned this when I first started this thread, which feels like such a LONG time ago now. For those who weren't around, i'll recap:

 

Long story short, my wireless card will NEVER work with OS X. I always knew this. So, I swapped it out with one from my other machine. This was only intended to be a temporary solution until I got the system to the point where I felt like I should invest into a replacement. Anyway, that time has come and I need advice from those wiser than myself.

 

All that said, I didn't take into account the possibility of HP boning me by building my machine with only 1 half-mini card slot. So, there goes the idea to use 2 different cards (1 = wireless, 1 = bluetooth) and since my original card was a dual Bluetooth+Wireless card, I lost Bluetooth support since the switch. I'm aiming to get it back without wasting a USB port with a dongle. Can anyone kindly recommend me a new card? Obviously, I would much rather prefer this card to be a 2-in-1 Bluetooth+Wireless and it would be AWESOME if it was either natively supported, or only requires a simple DSDT edit to work with OS X. I hope one exists...Oh and please, no recommendations for a card you assume will work. It should be confirmed. I don't have the cash to waste on maybe cards. Keeping the price as cheap as possible is another MEGA plus. ;p

 

Thanks in advance! ^_^

Share this post


Link to post
Share on other sites

OK, I verified that you do only have one pci-e half mini card slot for wifi/bt.  I used one on my HP Envy 17t-3200 CTO but ultimately switched to separate cards for wifi and bt because that's how that laptop is designed.  The combo card that worked for me was the Atheros AR5B195 pci-e half mini card.  Here's a link for it on ebay:

 

http://www.ebay.com/itm/Atheros-AR5B195-AR3011-WiFi-WLAN-Bluetooth-Combo-Half-Mini-PCI-E-Card-PA3894U-/300959708175?pt=US_Internal_Network_Cards&hash=item461298b40f

 

The drawbacks I found were that it's only BT 3.0, not 4.0, the BT firmware does not load consistently (unless I boot into Windows first) and I get faster wifi transfer rates with my current Atheros wifi-only card (AR9258).  The plus is that it's sure to work.  

 

My understanding is that there has been advances to the BT kext for the AR5B195.  It used to break sleep.  I believe it is called IOath3kNull.kext.  

 

BTW - If you don't already have this, you might find it useful:

 

http://h10032.www1.hp.com/ctg/Manual/c03922401.pdf

Share this post


Link to post
Share on other sites

Thanks for the info mnfesq! I'll look into that card more when I can.

 

I think i'm gonna try to do some research into Broadcom cards too. I am currently using one and I know how they perform. Not to mention almost every Bluetooth supported with OS X uses some kind of Broadcom chip so I trust them enough to invest into. I just need to get some time to look into a 2-in-1 card and hope they offer one. Otherwise, you're suggest might be my best option. I'd like to have as little trouble with the new card as possible.

 

Excuse me if I am wrong since I didn't check out the PDF you linked to but i'm assuming the last link is for my model's service manual. If so, then yes I have already got it and looked at it extensively. They are a great source of information.

Share this post


Link to post
Share on other sites

Well, I had a decent lead on a Broadcom card but it fell through due to price. It was WAY too expensive. Back to square one. It's a shame too, I love BCM cards. I'm open to Atheros too though. Ralink is pretty much out of the question for me though, just due to the fact that many of them require separate drivers and their own utility at boot-time. If I have to I'll downgrade to using an older card (BT 3.0, etc) but I would really like to try to find something that works with BT 4.0 and 5Ghz Wifi would be fantastic. That's all optional perks though for me. If anyone has any thoughts, or suggestions please fill me in. ^_^

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By Gymnae
      This guide guide is a work in progress
       
      Introduction
      The H370 chipset powers 8th generation Core-i CPUs by Intel and is actually much newer than the Z370, even though it name implies otherwise. The H370 requires new approaches compared to the Z370, since it includes newer or different components. An example would be on-die USB 3.1 and WiFi support.
      Since this guide is not a "hold-your-hand-every-step" guide, I assume you know:
      Clover installation and configuration How to create an install medium BIOS configuration and access Have heard of ACPI patching (I'm a newb at this myself)  
      What works
      Sleep (via DSDT edits and emulated NVRAM) on-board Audio (via CloverALC script) Native PM (without any kext or patch) All USB ports iGPU for both acceleration and display dGPU (I'm running an Nvidia GTX 1080)  
      Untested
      NIC --> I'm using WiFi only  
      What doesn't work
      Native NVRAM via AptioMemoryFix.efi DMVT Pre-alloc higher than 64MB (but not necessary)  
      1. Installation
      This guide heavy inspired by the work of /u/corpnewt of /r/hackintosh and his (sorta) Vanilla guide
       
      1.1 Create the install media for MacOS
      Follow this, if you are using a Mac to start off with. If you are totally new to MacOS, then please check the basic guide Creation of an installer media in windows or linux
       
      1.2 Install Clover on the install media
      Using the Clover installer, ensure you are installing to the USB medium you are using for the installer.
      Chose the following options:
      AptioMemoryFix UEFI booting only Install to ESP You have to get your hands on an apfs.efi. A google search can help, or extracting it from the Installer package. Make sure you procure a version matching the MacOS version you are about to install. Place the apfs.efi in drivers64UEFI.
       
      1.2 Adjust the config.plist for the installer
      You can use the config.plist attached as a guideline, but take a look at it before and at least adjust the SMBIOS - otherwise it won't boot.
      Attention: The attached plist contains audio patches introduced by a post-install step. If you run into problems, you might remove those. It also contains a manual slide value, which should normally not be needed, but works fine for me. It is also tuned for usage with an Nvidia Pascal dGPU as main GPU.
       
      The config you create now should serve you nicely for install and running the system.
       
      Take care of adding the following basics:
      SMBIOS: iMac18,3 - You can generate a serial number via Clover Configurator. The creation of a proper SMBIOS is covered in many guides to good extend Look at the graphics section and adjust the injection for Intel to your situation  
      Fixes

      Patches

      Devices

      Graphics

      Kernel and Kext patches
       
      1.3 kexts and friends
      Add the supplied SSDT-UAIC.aml to "patched" - it limits the injected USB Ports to the actual number and ports valid for this board.
       
      Required kexts on "Other":
      FakeSMC.kext IntelGraphicsFixup.kext Lilu.kext When having an Nvidia card: NvidiaGraphicsFixup.kext IntelMausiEthernet.kext in case you're running Ethernet USBInjectAll.kext with the HCI-300-series-injector.kext --> These two should be installed to /L/E after install  
      We are leaving sound out at the moment, this is something for post-install. Please note the absence of Shiki, I don't find it necessary. Video material I tried made use of the iGPU without shiki.
       
      1.4 Check BIOS and install
      You should be ready for install. But before you reboot, please take a look at your BIOS and set it up accordingly (copied from the aforementioned guide and adapted):
      Load Optimized Defaults Disable VT-d setting If your system has Secure Boot Mode, disable it Set OS Type to Windows 8/10 or OtherOS - I have not seen a difference Turn off internal Serial and Parallel port Turn off Network stack for boot Turn off wake-on-lan (for now) Set XHCI Handoff to Enabled Don't enable decode over 4G Depending on your GPU, set priority for boot Set internal GPU to enable Set DMVT pre-alloc to 64MB Set USB legacy to enabled Activate XMP profile 1 f your Ram has it (mine doesn't and I added the timings manually) Set ERP to enable, disable platform power management (I need to do more research if this could be enabled)  
      I've attached my current BIOS config "hack2". You can place that on a fat32 drive (the EFI partition of your install USB drive might be an idea) and see if it loads. It's made for and with the F2 BIOS.
       
      The install itself should be like other MacOS Hackintosh installs with it several reboots and ensuring to select the correct boot device in Clover.
       
      2. Post-install
       
      2.1 Install clover on target
      This is a no-brainer, but install a fresh copy of Clover on your target medium.
       
      During install select again AptioMemoryFix but also additionally
      EmuVariableUefi-64.efi Install RC scripts on target volume because otherwise NVRAM doesn't seem to work
       
      After the install, copy
      config.plist contents of "Other" content of "patched" apfs.efi from drivers64UEFI to your new clover install.
       
      2.1 Edit DSDT for slumber
      This is necessary only once on initial install and every time, you edit or upgrade the BIOS. The DSDT.aml attached to this post might work for your system or give you a file to compare to. Don't expect it to work for you, though.
      I won't go into the details of DSDT extraction and patching. There are better guides (the linked guide is a rip-off of rehabman's guide from a different forum). Please follow such a guide to extract your ACPI data.
       
      Locate and disassemble the DSDT with the newest iasl binary you can put your hands on, then open it with MacIASL in its newest version you can find (Hint: Here is a good source) You can check if the version is new enough if MacIASL doesn't throw error upon compiling a freshly extracted DSDT.aml or DSDT.dst
       
      Add rehabmans repo (as per linked guide) and apply the following patches:
      Rename _DSM to _XDSM Fix _WAK Arg0 v2 USB3 _PRW 0x6D Skylake (instant wake) Find the CNVW device and remove the _PWR function there.
       
      Compile the DSDT and place it in "patched".
       
      2.2 Install kexts to system
      As mentioned in the install section, it's better to follow rehabman's instruction and install USBinjectAll.kext to /L/E:
      sudo cp -R Release/USBInjectAll.kext /Library/Extensions sudo touch /System/Library/Extensions && sudo kextcache -u / 2.3 Enable onboard Audio
      This is where I'm not so happy currently, I'd like it to work without altering AppleHDA. But currently I find no other way.
       
      2.3.1 Install FakePCIID & FakePCIID_Intel_HDMI_Audio
      Rehabman tells us to use a kext installer to install it to /S/L/E. Chose the RELEASE folder
       
      2.3.2 Run CloverALC command
      Ensure your EFI partition is mounted before running this command
      Get the newest version of CloverALC command (audio_cloverALC-xxx.sh) and run it. Our Audio codec is RTL887 and I'm running with layout ID 1
       
      2.4 Optional steps
      If you have a dGPU, now it's the time to install its drivers and adjust the config.plist for it.
      This is out of scope of this guide. Yet, my supplied config.plist is ready to be used with Nvidia Pascal cards and using the Nvidia web driver.
       
      3. ToDo
      Move away from static DSDT patching to SSDT hotpatching --> requires my work Native NVRAM --> requires developer work Audio without AppleHDA patching --> requires developer work  
      4. Thanks to
      @MaLd0nfor helping finding the right way with the DSDT
      @RehabMan, for being a legend and helping me out patching
      @toleda, for audio patches for the 300 series
      /u/corpnewt, for his superb vanilla guide
      @wmchris for his super XPS 9550 guide and introducing me to hot-patching
      all the developers of clover and it's awesomeness
       
      SSDT-UIAC.aml
      config.plist
      DSDT.aml
      hack2
    • By fantomas1
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)  New!
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By iammask
      My laptop is Hp ab522tx(https://support.hp.com/in-en/document/c04863397)
      Product number T0Z73PA Product name HP Pavilion Notebook - 15-ab522tx Microprocessor Intel® Core™ i5-6200U with Intel® HD Graphics 520 (2.3 GHz, 3 MB cache, 2 cores) Memory, standard 8 GB DDR3L-1600 SDRAM (1 x 8 GB) Video Graphics NVIDIA GeForce 940M (4 GB DDR3L dedicated) I made bootable USB of high sierra. While installing it in verbose mode, I get a blank black screen. Mostly its graphics problem with the kext.
      please help guys.
       
    • By Twml
      I have an HP Elitebook 8460P running OSx 10.13.4 High Sierra
       
      I have an odd issue i believe is related to DSDT patch for ACPI Power battery.
      My battery icon works the battery level goes up/down and battery goes black when charging/white when not.
       
      BUT... Always has a lightning bolt in it and says "Power Source: Power Adapter" no matter if its connected or not.
       
       
      How can i get it to recognize my adapter is unplugged?
    • By oliveiro
      Hi community !
      Is anybody successful with 10.13.x and multiple GPUs on a desktop hack ?
      My main rig (see in signature) HD4600 + GTX550Ti + GTX560 is working perfectly under 10.11.6 and 10.12.6.
      Very simple to install, Intel IGPU set to active and primary in bios, inject intel and igplatformid in bootloader (enoch or clover), no nividia injection, since Fermi GPUs are natively supported. Smbios set to iMac14.2 for my Haswell CPU, and to avoid AppleGraphicsDeviceControl devices unloading.
      But from 10.13.0 to 10.13.3, system boots fine until login screen where WindowServer crashes with a "no MTLDevice" error (MeTaL device I guess). I could workaround that error by unloading nvidia devices in AppleGraphicsDeviceControl, but that kind of defeats the purpose, since only the IntelHD4600 can then be used.
      10.13.4 brings a little improvement, desktop can be reached, all 3 gpus active (AppleDisplay instances appear in IORegistryExplorer for Intel and Nvidias) but only Intel HDMI output shows desktop correctly, both nvidias (HDMI or DVI output) only show a black desktop where the mouse pointer can be moved normally. Displays can be arranged, orientation and resolution can be changed, as if everything was fine, but it is not.
      Console shows the following repeated messages :
           WindowServer (Skylight) : Unable to composite display surface due to null compositor.
           WindowServer (CoreDisplay) : [ERROR] - Attempting to get capabilities from capabilities with no devices
      Does anybody have an idea on how to avoid or workaround these errors ?
      Thanks !
      O.
      Things I've tried:
      Bios Graphic Devices order changes (breaks everything unless IGPU is primary) nvidia injection in bootloader (fails in enoch, disables secondary nvidia GPU outputs in clover) Smbios changes and/or AppleDeviceControlPolicy plist edits (simply enables or disables nvidia outputs) nvidia official or web drivers (no changes at all, even though webdrivers are properly loaded ; requires nvram emulation with enoch) enoch or clover (no difference except clover boots a bit faster - than enoch with nvram - thanks to proper UEFI boot I guess) lilu intel and/or nvidia and/or coredisplay graphicsfixups (no visible changes but graphics devices names, and thus enables or disables AGPM) use binaries from Sierra 10.12.6 for CoreDisplay and/or Skylight frameworks (never reached desktop) NVIDIAeGPUSupport (no changes)
×