Jump to content
InsanelyMac Forum
Sign in to follow this  
joe_black

[Solved] ASUS X501A ML : Boot Hanging Post-Install, Not Sure of Cause?

Recommended Posts

Been trying to install ML on my Asus X501A.

Snow Leopard works great but I want to try a clean install of ML.

ML install completed successfully but now I'm stuck here:

 

boot_hang_ml.jpg

 

I don't see any panic or indication of why it's hanging right there... Is it the "Waiting for AppleSMC"?

I'm using FakeSMC.kext from iATKOS ML2. SMBios.plist for MacbookPro 8,1

Hardware specs are in my signature. Any ideas?

Share this post


Link to post
Share on other sites
Advertisement

*** Solved ***

 

Needed to remove:

       <key>FanThrottledRPM</key>
      <integer>3500</integer>
      <key>FanMax</key>
      <array>
        <integer>6200</integer>
      </array>

From ACPI_SMC_PlatformPlugin.kext > Plugins > MacBookPro8,1.plist inside of the IOPlatformPluginFamily.kext

 

*** EDIT ***

 

Working actually very smooth now with proper kexts!

about.png

 

Will post more details as I continue to test the stability! CPU is now showing as an i7, lol (Was unknown in 10.6)  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By chriz74
      I think this guide will help people install Yosemite on Asus x301a and possibly x401a, x501a intel HM76 (probably also hm70) based laptops both Ivy and Sandy bridge.
       
      1) we need an unlocked MSR bios in order to get native cpu powermanagement, so download and flash your latest bios, restart your pc enter bios press F9 and load optimized setup.
       
      2) download fptw64, open an elevated command prompt in window, change directory to fptw64 one and dump your bios with this command:
      fptw64 -d BIOS-Backup.rom -BIOS Now download uefiPatch from coderush and patch your bios, please pay attention to what the output is, if there is some errors or something. Refer to this post. You should now have an MSR unlocked patched bios that you can flash back with the command...
       
      **** if you are not sure or don't understand what a failed bios flash can do to your pc stop and ask in the forum ****
       
      **** of course the names of the roms are of your choice so modify the commands accordingly ****
      fptw64 -f patched.rom -BIOS after flashing restart the laptop, enter bios and again press F9 to load optimized defaults, also be sure that graphics framebuffer is set to 64MB.
       
      3) create a uefi USB with Yosemite and clover, put these kexts in the clover / kexts / 10.10 directory in efi partion of usb:
       
      FakeSMC.kext 
      GenericUSBXHCI.kext
      VoodooPS2Controller  > the correct driver for me is Elan  However I think some versions of these notebooks have Alps Touchpad as the Asus support website lists both drivers.
       
      4) start pc from uefi usb (press esc at boot to show boot menu)
       
      5) in clover press F1 to show some options, dump your DSDT with F4.
       
      6) restart pc in windows, download dsdteditor  and mount EFI partition of the USB with clover 
       
      7) open the DSDT in clover / acpi / origin and apply these patches:
       
       - IRQ patch by rehabman
       - hd4000 patch (if you have an ivy bridge cpu)
       - hd3000 patch  (if you have a Sandy bridge cpu)
       - this battery patch 
      - asusNBFnkeys BrightnessKeys_Patch
      - orange icons patch
         
      compile the DSDT and see if there are errors or warnings, search and apply patches accordingly (e.g. Tx rename patch)
       
      once you have your dsdt.aml put it in efi clover / acpi/ patched
       
      8) restart pc from USB and install Yosemite, when finalizing installation put the time zone manually, tell the pc is not connected to the internet for now.
       
      9) at desktop we need some files:
       
       - dpci manager to install some kexts
       - clover and clover configurator to install clover in efi
       - ssdtpregen to generate our ssdt (for cpu)
       - RealtekRTL8111.kext
       - asusNBFnkeys.kext
       - this appleHDA kext
       - Rehabman acpibacklight kext -> this kext was causing this behavior: http://bit.ly/1LYGOKq. Brightness still works without the kext.
       - Rehabman battery kext
       - eapd codec commander (you will have to build this one with xcode)
       
      so, install clover into efi in the hard disk (look this other guide of mine for more details on options),
      generate your ssdt (install the lan driver first as this script downloads info from the internet while running).
       
      with clover configurator mount efi and put the kexts from the usb on disk.
      put the DSDT and SSDT in efi (in clover / acpi / patched on disk)
      load the attached config.plist in clover configurator, generate your own smbios (chose macbook air 5.2), export the plist to efi. Note if you are using an SSD please apply the trim kernel patch as per third method in this post: http://www.insanelymac.com/forum/topic/298507-enable-trim-on-non-apple-ssd/
       
      Now install the kexts with dpcimanager, when finished installing reboot from USB and  open uefi shell:
       
         - find your efi partition with fsx: (fs1: , fs2: whatever is yours, check with ls what is the content)
       
         - when your found yours do cd \EFI\CLOVER ; bcfg boot dump ; bcfg boot add 0 CLOVERX64.efi "OSX"
       
       - reboot, press ESC and choose boot from EFI:OSX (the option we just added).
       
      everything should work apart WIFI (you can buy a compatible half mini pcie card, I replaced mine with an Atheros  AR5B93 half mini pcie card, it works out of the box).
       
      Please note: if audio doesn't work you will have to find out the verbs of your codec and replace them in applehda kext.
       
      ----- This part is for patching HDMI audio and LVDS screen in HD4000 -----
       
      This is what I did for mine, I have an i7-3630qm with HD4000 graphics.
       
      First thing the DSDT patch for HD4000 video and audio (igpu and hdef). I have id 1660009 of HD4000 in this cpu so I put the same layout id in the DSDT patch. At this moment without patches only the external HDMI monitor will work so I put these patches in config.plist of clover:
       
      for lvds internal video to work
      AppleIntelFramebufferCapri 010000000200000030000000 to 050300000200000030000000

      for hdmi

      HDMI

      AppleIntelFramebufferCapri 030400000004000007010000 to 030400000008000006000000
       
      ---------------> for that part I followed this guide but put the patches in clover instead of patching the kext.
    • By joe_black
      (Scroll down to my reply for 10.8 install instructions)
      Installing OS X Snow Leopard on Asus X501A Notebook   Hardware that will NOT work: QE Support, Integrated WiFi, Bluetooth* *Bluetooth may work with patched kext. I have not tried.   What You Will Need: - Asus X501A/X501A1 Notebook - 2 formatted USB Flash Drives (8GB+) - iATKOS S3 v2 ISO - Actual Mac or Mac running under VM with USB support - TransMac for Windows - "ASUS X501A OSX DRIVERS.zip" kext archive - Mac-compatible USB WiFi Adapter (optional)   --- Step 1 - Acquire iATKOS S3 v2 ISO Torrent/web search for this ISO, make sure it is S3 v2. Prepare the ISO to be burned to USB.   Step 2 - Prepare USB Flash Drives Installation will require 2 formatted USB flash drives, one with at least 8GB for iATKOS.   Using TransMac for Windows, you need to right-click the icon for one of the flash drives and click "Restore For Mac". Select the iATKOS ISO file and let it burn the image to the flash drive.   Using a real Mac or Mac running under VM with USB support, you need to burn Chameleon v2.2 bootloader to your other flash drive. This is necessary if you get into boot issues with your OS X installation or issues with dualbooting. This flash drive will save you from not being able to boot. You might be able to use TransMac for this one too, but I highly recommend using a real Mac as much as possible for USB burning.   After burning your Chameleon flash drive, make sure it works before you continue! Do not attempt to install OS X without it on this notebook. Now, you should have 2 ready-to-go flash drives, one with iATKOS and one with Chameleon bootloader.   Step 3  - Installation Insert both of your flash drives into the notebook and power it on.   Keep hitting DELETE (or maybe F2) to get into the BIOS. You need to make sure these options are selected: You can also use ESCAPE and hit Enter Setup.   "CSM Support : "Enabled" "Secure Boot Control : "Disabled" "Fast Boot : "Disabled" (might not be an option) "SATA Configuration : "AHCI"  Intel Virtualization Technology should also be Enabled.   The above BIOS options are required for installation. ... Now we will restart with the saved changes and keep hitting ESCAPE to get boot options.   You need to select your Chameleon flash drive (this might be trial and error with 2 of them)   While in the Chameleon bootloader, you need to now boot up your iATKOS drive using verbose so hit F8 and type "-v" and then enter. Your iATKOS installer should start.   Click on Utilities at the top and then load Disk Utility, format your HDD with MBR and HFS+ for your OS X partition. (MBR required for dualbooting with Windows, if this is OSX only you should probably use GUID)   Under Customize, just make sure you have GraphicsEnabler and UUID. Don't install SleepEnabler or pretty much anything else. Nothing else really matters because we're going to install the kexts ourself. In this regard, you could possibly use a retail ISO but I did not try it myself.   Install will take approx. 20mins to 60mins...   Step 4 - Post-Installation   After install, reboot the machine and try booting first without the Chameleon flash drive.   Always boot with "-v" for verbose mode until we are positive everything is stable. You MIGHT get stuck on a completely black screen at this point with no errors or log information what-so-ever. If this happens, restart again and boot with your Chameleon flash drive. Under Chameleon boot the other flash drive using "mach_qoopz -v", you should NOW be able to boot OS X. If "mach_qoopz" still fails you should try "mach_kernel_org -v" and that should do the trick.   Before installing drivers you should install system definitions for MacBookPro 8,1 for Snow Leopard. This will change your SMBios.plist to trick your machine into thinking it is a real Mac and load your drivers properly.   Step 5 - Driver Installation             Using Kext Utility you can install all the .kext files in the "ASUS X501A OSX DRIVERS.zip" archive to get hardware working BUT you NEED to backup all the originals just in case. Also, for any reason the trackpad isnt working just reply here and tell me and I'll help you through that. All kexts should be installed to /System/Library/Extensions with disk permissions repaired afterwards.   If you are stuck in 1024x768 you will need to use boot flag GraphicsMode=Yes "Graphics Mode"="1366x768x32" which can be added to your boot .plist (search for a guide if you don't know how) so you don't have to type it every time.   For WiFI you will need a compatible USB adapter. Full QE will most likely not work. For full USB and webcam support you need to install the USBFamilyRollback kext for Snow Leopard. This will allow your iPod/iPhone and Webcam as well as other devices to work properly. You can now follow other guides to upgrade from 10.6.3 to 10.6.7/10.6.8 properly if you want.   The .zip for the drivers is down below in my reply.  
    • By carbo178
      Salve a tutti,
      sto provando ad installare su questo notebook con Pandora, ma non riesco ad avviare l'installazione;
      Ho scelto l'opzione Laptop 6, con SMBIOS MacBookAir 4,1
      Le caratteristiche del PC sono qui, la versione è quella con Pentium B980, grafica integrata Intel HD 4000 (almeno così dicono)
      Avviando con -v cpus=1 mi si blocca qui

      E questo è il risultato dopo che ho inserito il kext natit (stessa flag in avvio).

      Ho provato altre flags, tra cui -x, GraphicsEnabler=Yes/No e npci=0x2000 ma non ottengo risultati
      Ogni aiuto è ben accetto
      Grazie
×