Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
!Inventor

iAtkos 10.8.2. on a AMD/ATI system post-installation problem

4 posts in this topic

Recommended Posts

Hello,

 

I have run into some trouble while trying to run Mac OS X 10.8.2 on my computer and I would greatly appreciate any help.

 

I did the following:

1) Set BIOS settings to AHCI, enabled USB mouse and keyboard.

2) Downloaded iAtkos ML2 (Mountain Lion, version 10.8.2), iAtkos bootloader and AnV's AMD kernel.

3) Formatted USB disk to Mac OS Extended (Journaled) on a MacBook Pro.

4) Used Carbon Copy Cloner to copy the .dmg files to the USB.

5) Copied AnV's AMD kernel on the USB and installed the bootloader package on the USB.

6) Booted the USB and ran it using "amd_kernel -v" as a boot flag.

7) Used Disk Utility during the installation to format the HDD to Mac OS Extended (Journaled).

8) Used the default package from iAtkos, without any additional options.

9) At the end of the installation I got an error how it cannot start up from my HDD, but I was led to believe that was a normal error.

10) I rebooted, with the USB still in the computer, and selected my HDD at the boot screen.

 

This is where I run into a problem, as it keeps restarting no matter what I do, it just won't load the installed OSX. I used all kind of bootflags, -x, -f, -F, GraphicsEnabler=Yes, etc. but with no luck.

Maybe there is a problem because it cannot load the necessary AMD kernel, but I have no idea how to bootflag it, since it is still on the USB and it cannot find it by using just "amd_kernel". It restarts so quickly I don't have time to read anything on the screen.

During the installation I have selected the default iAtkos package (without any additional option), amongst which was some kind of a "Kernel patch". Since I didn't use the iAtkos kernel, maybe it is interfering? Unfortunately, I don't have my computer near me, so I will try that and any other advice as soon as I can.

 

 

My system is as following:

GigaByte GA-MA790X-DS4

AMD Phenom II X4 940 3.00 GHz

8 GB RAM

ATI Radeon 4850 HD

500 GB Seagate HDD

 

I can post the in-depth SiSoftware Sandra data and any other info if needed.

 

 

Thank you very much!

Share this post


Link to post
Share on other sites

I agree with theconnactic above!

But... I see you loaded the AMD kernel for the installer but are you sure you're loading the correct kernel post-installation?

Try typing "mach_modbin -v" as your boot flag. 

 

* EDIT *

If "mach_modbin -v" does not boot... have you tried using the amd_kernel.zip from this page:

http://www.insanelymac.com/forum/topic/281450-mountain-lion-kernel-testing-on-amd-dont-ask-help-here-use-the-help-topic/page-74?do=findComment&comment=1878822

 

Copy it to /Extra and use boot flag "amd_kernel -v"

Share this post


Link to post
Share on other sites
 I see you loaded the AMD kernel for the installer but are you sure you're loading the correct kernel post-installation?

 

 

That's exactly what I'm worried about.

But I don't know how to load the correct kernel post-install as it is located on the USB. Just typing "amd_kernel -v" doesn't work as it cannot find it.

 

Copy it to /Extra and use boot flag "amd_kernel -v"

 

By the folder "/Extra" you are referring to the folder on the USB? I put it in the root directory of the USB, so maybe I need to put it in "/Extra" instead so I can use it?

 

 

 

I will try installing 10.7.5 if this doesn't work then.

 

And thank you for the replies, guys!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×